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This class covers several workflows that answer the most common questions that Inventor software users 

have about assemblies, parts, drawings, and Content Center library. You will learn how to add parts to 

top-down assemblies; create a chamfer on a corner point having freedom in the xyz dimensions; 

automatically show bend up/down direction for a sheet metal part in the drawing based on line color; 

control the display of alternate tolerance; copy multiple Inventor drawing views as blocks in AutoCAD 

model space with the right scale; to manage the content center files when you move to a newer Inventor 

release; place a Tube & Pipe fitting in an assembly as a normal part; change the BOM Structure of a 

standard part family; and calculate the cost of a Structural Shape component based on a standard cost-

per-meter/length. 

Learni ng Objectives 
At the end of this class, you will be able to: 

¶ Add parts to top-down assemblies 

¶ Create a chamfer on a corner point having freedom in the xyz dimensions 

¶ Copy multiple Inventor drawing views as blocks in AutoCAD’s model space with the right scale 

¶ Place a tube and pipe fitting in an assembly as a normal part 

About the Speaker  

Alessandro Gasso is currently employed as Premium Support Specialist within Autodeskôs Premium 

Support Services ï Global Services department and leads the Premium Support EMEA MFG Design 

Team. 

In his past thirteen years with Autodesk he worked as Product Support Specialist for Inventor, supporting 

mainly South European Customers and Partners. 

Then, he has led for two years the EMEA Inventor Product Support Team and was the EMEA Technical 

Lead of Inventor for one year. 

Alessandro is a coauthor of the Being Inventive Inventor blog and was a speaker at the AU 2012 and 

2013. 

Prior to Autodesk he worked for seven years as Mechanical Designer for a company in the Defense 

industry, using products as AutoCAD, Mechanical Desktop and Inventor. 

Alessandro is a native from Italy; he speaks English, Italian, French, Spanish and Portuguese and holds 

a Masters in electro-mechanical engineering from the University of Naples. 

http://beinginventive.typepad.com/being-inventive/
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Section 1: Add parts to top -down assemblies  
You have created an assembly from the solid bodies of a part.  

 

 

 

 

 

In this section you find two methods for adding more parts to that assembly from other solid bodies of the 

original part you have not selected when you have created the assembly, or that you have created in the 

original part after creating the assembly. 

Method 1  
1. Open the part 

2. From the menu Manage > Layout > Make Components  

3. In the Make Component dialog select the other solid bodies 

4. In the Target assembly name field write the name of the assembly created previously 

¶ The Template and Default BOM structure field 

become inactive 

 

 

 

Method 2  
This is recommended if the assembly is located in a subfolder down in the hierarchy or, in general, if you 

don’t want to type the assembly name 

1. Open the part 

2. From the menu Manage > Layout > Make Components 

3. In the Make Component dialog select the other solid 

bodies 

4. Click on the icon on the right of the Target assembly 

location field 

5. Click NO in the following Create dialog 

6. Browse to the location where the assembly is located and select it 
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Section 2: Create a chamfer on a corner point  
In this section you find two methods for creating a chamfer on a corner point. 

The Method 1 allows you to create a chamfer where the xyz dimensions are all equals. 

The Method 2 allows you to create a chamfer where the xyz dimensions are all different. 

Method 1  
1. Open the part where you want to apply the feature 

2. From the menu 3D Model > Modify > Chamfer  

3. Use the default Distance method 

4. Select the three edges that converge in the corner point where you want to apply the 

chamfer 

5. Expand the Chamfer dialog and verify that the Setback option is selected 

6. Set the value in the Distance field > OK 

7. From the menu 3D Model > Modify > Direct Edit > Delete Geometry  

8. Select the three faces to remove 

 

 

 

 

 

 

 

After that, changing the value of the Chamfer distance, the feature updates as expected. 
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Method 2  
1. Open the part where you want to apply the feature 

2. From the menu 3D Model > Sketch > Start 3D Sketch 

3. In the Draw panel click on Include Geometry 

4. Select the three edges that converge in the corner point where you want to apply the chamfer 

5. In the same panel click on Point and create three point one on each projected edge  

6. Apply the dimensions between one of each point and the corner point 

7. Finish the sketch 

8. Menu 3D Model > Work Features > Plane 

9. Select the three points from the 3D sketch to create the Work Plane 

10. Select the Work plane as Split Tool if you want to cut 

the corner with the Split (Trim Solid) feature or as 

Surface if you want to use the Sculpt feature 

 

 

 

 

 

 

 

 

 

 

After that you can edit the three dimensions or the corresponding parameters 

independently. 

 

 

 

Section 3: Show bend up/down direction for a sheet metal part in the drawing 

based on line color   
In this section you find a method for showing automatically bend up/down direction for a sheet metal part 

in the drawing based on line color. 

1. Open the drawing 

2. Menu Manage > Styles and Standards > Styles Editor  

3. In the Styles Editor, under the Layers, locate the "Bend Centerline" layer 

4. Rename it to "+ Bend Centerline"  and change the layers color 

5. Select the layer you just renamed and click "New" towards the top center of 

the dialog box 

6. Rename this layer to "- Bend Centerline" and change its color as well 
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7. In the Styles Editor expand the Objects Defaults 

8. Locate "Sheet Metal Bend Centerlines +/-" and assign the two layers we just created. 

 

 

You can save these settings in your Sheet Metal Template. 

 

 

 

 

 

 

 

 

Section 4: Control the display of alterna te tolerance  
It is not possible to control the display of tolerances for a dual dimension independently from each other.   

That is, there is no way only turn on the tolerance for primary unit and  turn off the tolerance for the 

alternate unit or vice versa. 

 

 

 

 

However, by applying the steps below, it is possible to do that for small tolerances (< 1 inch). 

1. Open the drawing 

2. Menu Manage > Styles and 

Standards > Styles Editor 

3. Locate the active dimension style 

4. In the Tolerance tab, set the 

Precision to 0 for the Alternate Units 

5. In the Display Options, set Suppress 

Display for the Zero Tolerance 

Display 
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Section 5: Copy multiple Inven tor drawing views as blocks in AutoCAD ȭÓ model 

space 
In this section you find a method for copying multiple Inventor drawing views as blocks in AutoCAD’s 

model space with the right scale. 

1. Create an Inventor dwg with multiple views 

2. Save the dwg 

¶ This will create the blocks automatically 

3. Close the dwg 

4. Open the dwg in AutoCAD and insert the blocks 

¶ Alternatively use Design Center 

5. Manually align the blocks if necessary 

 

 

 

If the Inventor dwg contains just one view, you can use the “Insert in Model Space” command. 

You can open the Inventor dwg in AutoCAD, right click the layout tab and select “Export Layout to Model” 

This will create a new AutoCAD file with all the views turned into blocks in model space with the scale 

used in the drawing, but the new drawing is not linked to the Inventor dwg. 
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Section 6: Manage the Content  Center files when you move to a newer Inventor 

release  
By default Inventor creates sub-directories related to the version you are using (i.e.: C:\Users\<user 

name>\Documents\Inventor\Content Center Files\R2015\) in order to store the generated Content Center 

instance files. 

You have never changed this setting in the Default Content Center files field in the Application Options, 

File tab, and in all your projects, under Folder Options, the setting for the Content Center Files is Default. 

 

You have upgraded your Inventor version and set active a project created in the previous release. 

You open an existing assembly of the project and get the Resolve Link dialog related to some Content 

Center parts. 

 

 

 

 

 

 

 

In this section you find a method for moving all the Content Center files in a common "generic" folder 

without separation into yearly subdirectories. 

1. Menu Tools > Options > Application Options > File tab  

2. Set your generic path (i.e.: C:\CC Version) in the Default Content Center 

files field  

3. Close Inventor 

4. In Windows Explorer open the default Content Center file location corresponding to the oldest 

Inventor release you have used for inserting the Content Center parts (i.e.: C:\Users\<user 

name>\Documents\Inventor\Content Center Files\R2014) 

5. Copy the subfolder en-US with its content and paste it under the new 

Content Center File location (C:\CC Version) 
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¶ If you are using Inventor and / or the Content Center in another language, the name of 

the subfolder to copy is different (i.e.: de-DE for German, fr-FR for French, it-IT for Italian, 

etc.) 

6. Copy all the folders located under the en-US subfolder under the default Content 

Center file location of the next Inventor release (i.e.: C:\Users\<user 

name>\Documents\Inventor\Content Center Files\R2015\en-US) and paste them 

under C:\CC Version\en-US 

7. Accept to merge the folders with the same name and to replace the files with the 

same names with the newer versions 

 

 

 

 

 

 

 

 

 

8. Possibly, repeat steps 6 and 7 for the next Inventor versions until the latest one 

After you have applied the procedure above, you can open the legacy assemblies resolving all the links 

with the Content Center parts inserted in previous versions. 

Besides, next time you upgrade to a new Inventor version, you just need to set the location of the same 

generic directory in the Default Content Center files field in the Application Options, File tab 

Additional Notes . 

¶ If you were using custom libraries in previous versions and you want to migrate and use them in 

the latest Inventor version as well, you can follow the procedure you found in the page below and 

its related links for migrating them 

http://help.autodesk.com/cloudhelp/2015/ENU/Inventor-Install/files/GUID-CEA48D57-577A-4551-

BD71-9303AEAEC5DC.htm  

¶ If you are moving from R2012 or older to Inventor 2015, after you have 

applied the procedure above, you can update all the standard contents to 

the latest Inventor version using the “Refresh Standard Components” 

functionality of Task Scheduler  

¶ Alternatively, you can enable the option “Refresh out-of-date standard parts 

during placement” in the Application Options, Content Center tab so that the 

existing standard part file is automatically replaced with a newer version of 

the part from the library when you insert it 

http://help.autodesk.com/cloudhelp/2015/ENU/Inventor-Install/files/GUID-CEA48D57-577A-4551-BD71-9303AEAEC5DC.htm
http://help.autodesk.com/cloudhelp/2015/ENU/Inventor-Install/files/GUID-CEA48D57-577A-4551-BD71-9303AEAEC5DC.htm
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Section 7: Place a Tube & Pipe fitting in an assembly as a normal part  
You have opened a Tube & Pipe fitting from the Content 

Center using the option “As Custom” and saved the file in 

a location of your machine. 

Then, you have inserted the file you have saved in an 

assembly with the command Place Component, but the 

file is still behaving as a Tube & Pipe fitting. 

For instance, you get the tooltip that asks for selection a run. 

If you right-click while inserting the component, you get the same context menu as if you were 

placing the fitting in a Tube & Pipe subassembly. 

You cannot place the component using the iMates you have 

possibly added, you cannot demote or replace it, etc., and in 

the assembly browser the fitting icon is the same as if you 

have inserted the component directly from the Content 

Center. 

This behavior is due to the authoring information the fitting 

still contains and that, for instance, would allow you to insert and connect it to a Tube & Pipe run. 

In this section you find a method for removing the authoring info stored in the part, so that it can behave 

as a normal part at the insertion. 

1. Open the file you have created opening the fitting 

with the “As Custom” option from the location where 

you have saved it. 

2. Menu Tools > Options > VBA Editor 

3. Paste the script below in the file document and run it 

Sub RemoveTPAuthoringInfo() 

 

    Dim oProperty As Property 

 

    Set oProperty = ThisApplication.ActiveDocument.PropertySets.Item("32853F0F-3444-11d1-

9E93-0060B03C1CA6").ItemByPropId(56) 

 

    

 

    oProperty.Value = "" 

 

End Sub 

4. Return to Inventor and save the file 

After doing that, the fitting will behave as a normal part at the insertion, but still 

has some Content Center properties as you can see from the context menu, 

right-clicking the component. 
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So, if you want to remove any trace of the Content Center properties, you can repeat the steps above 

with the script you can find below. 

Sub strip_CC() 

    Dim oDoc As PartDocument 

    Set oDoc = ThisApplication.ActiveDocument 

     

    'Check to see if it is not a true content center part . otherwise bail out 

    If oDoc.ComponentDefinition.IsContentMember = False Then 

        ' Enable all commands and set the subtype to a standard part. 

        oDoc.DisabledCommandTypes = 0 

        oDoc.SubType = "{4D29B490-49B2-11D0-93C3-7E0706000000}" 

     

        ' Optionally clean up other Content Center related properties. 

        On Error Resume Next 

        oDoc.PropertySets.Item("Content Library Component Properties").Delete 

        Dim DTPropSet As PropertySet 

        Set DTPropSet = oDoc.PropertySets.Item("Design Tracking Properties") 

        DTPropSet.Item("Catalog Web Link").Value = "" 

        oDoc.Save 

    End If 

End Sub 

You can easily combine the two macros if you need to remove both authoring information and Content 

Center properties from the fitting before inserting it as normal part in your assemblies.  

 

Preliminary remark  for the next two sections : 

In order to modify the Library Families as described in the next two sections you need to add a read/write 

library to the current project using the Configure Libraries dialog box. 
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Section 8: Change the BOM Structure of a standard part family  
You want to change the BOM Structure of one or few standard part families, for instance, from Purchased 

to Phantom, because you don’t want these standard parts showing up in BOMs and Parts Lists. 

Of course, you can use the Parts List filters, but if you prefer to change the BOM Structure for a Standard 

Part Family, in this section you find below the procedure to follow for doing that. 

1. In the Content Center Editor, copy the family in a Read/Write library 

2. Open one component from the family with the “As Custom” option and save the 

file 

3. Menu Tools > Options > Document Settings 

4. In the Bill of Materials tab, change the Default BOM Structure from Purchase to 

Phantom 

5. Apply, close and save the file 

6. In the Content Center Editor, select the custom library in the Library View field 

7. Right-click the family and select Replace Family Template 

8. Click Yes in the following dialog, select and open the file 

saved in step 5 

9. Click OK in the “Publish was Successful” dialog box 
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Section 9: Calculate the cost of a Structural Shape component based on a 

standard cost-per -meter/length  
You want to calculate the cost of a Structural Shape component based on a standard cost-per-

meter/length. 

In this section you find the procedure you need to apply to each family you are going to use. 

1. In the Content Center Editor, copy the family in a Read/Write library 

2. Open one component from the family with the “As Custom” option and save the file 

3. Menu Manage > Parameters 

4. Create a new User Parameter 

¶ Name it CostPerMeter and set its unit to Unitless 

¶ Set the value according to your 

requirement 

5. Create another new User Parameter 

¶ Name it Cost and set its unit to Unitless 

¶ Set the equation for Cost to “G_L / (1 m) * CostPerMeter” 

6. Check the Export checkbox for the parameter Cost 

7. Edit the parameter Cost Property Format to not display the Unit String and Trailing 

Zeros 

8. Close and save the file 

9. In the Content Center Editor, select the custom library in the Library View field 

10. Right-click the family and select Replace Family Template selecting the file saved in 

step 8 

After that, every family member generated will have the Cost property in the Custom tab in 

iProperties that can be used in the BOM and Parts List. 

And you can easily edit the Parts List if you want to display the total cost of all the components 

with the same length. 

 

 

 

 

Summary 

We had a good look at several workflows that answer the most common questions from Inventor users 

about Assemblies, Parts, Drawings, and Content Center Library. 

For more tips and trick about these topics, refer to the Being Inventive Inventor blog, under the 

corresponding categories. 

Thank you for attending! 

http://beinginventive.typepad.com/being-inventive/

