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CI2674  Tired of seeing an AutoCAD® Civil 3D® software grading demonstration of a rectangular building pad? In this class, 

you will learn how to use the Civil 3D grading tools to build 10 common things that are great practical applications for most grading 
designs. We will look at walls, driveways, berms, swales, and many other things. We'll also look at how to combine these smaller 
designs into one large final design. 
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At the end of this class, you will be able to: 
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components 
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 Recognize the appropriate grading tools to use for the type of design that is required 

 Combine several small grading designs together into one large design 
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Introduction 
No power points or long-winded monologues here…we’re just going to jump right in and build 

some stuff.  It’s good to have a goal, however, so before we proceed let’s figure out what that is.   

We’ve all seen demonstrations of the powerful grading features of Civil 3D but most people 

seem to struggle with practical application.  In my experience it has really helped to just watch 

other people build stuff or have them explain how they’ve done it.  That gets the creative juices 

flowing and before I know it I’ve got lots of ideas of how I should tackle some other projects I’ve 

got going on. 

So that’s our goal…let’s pack in as many practical applications as we possibly can within a 90-

minute session so that what we see can spawn other ideas.  Don’t mistake the example 

exercises here for step-by-step procedures, though.  Each grading project is different and 

requires a more twisted way of applying the tools than the last.  Try your best to understand the 

concepts that are being applied and you can’t go wrong.  Concepts can be scaled and modified 

to fit a given scenario.  Step-by-step procedures cannot and are therefore much less useful. 

Fun With Feature Lines 

One - Retaining Wall 
In this exercise we are going to begin with a simple polyline which will become the top edge of 

our wall.  We’ll then offset it outward to create the polyline that will become the bottom 

edge…just plain AutoCAD so far.  The magic happens when we convert these polylines to 

feature lines then use the feature line tools to set the elevation of the top of the wall and make 

the bottom of the wall match existing ground. 

1. Open 01-Retaining Wall.dwg in your class dataset folder. 

2. Use the AutoCAD OFFSET command to offset the magenta polyline to the south 1 foot. 

3. On the Home tab of the ribbon click Feature Line > Create Feature Lines from Objects.  
Select the two magenta polylines and accept the defaults in the Create Feature Lines dialog 
box. 
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4. Use the Raise/Lower command to assign an elevation of 1015 to all vertices of the interior 
(northern) feature line. 

 Click the northern feature line 

 If the Edit Elevations panel is not visible on the ribbon, click Edit Elevations. 

 Click Raise/Lower 

 

 Type E for Elevation and press Enter 

 Type 1015 and press Enter. 

 Watch the feature line rise up to elevation 1015 in the 3D view. 

 

5. Use the Elevations from Surface command to assign elevations to the second polyline from 
the EG surface.  Answer Yes to create intermediate grade breaks. 

 Click the southern feature line 

 Click Elevations From Surface on the ribbon. 

 

 Press OK to accept EG as the target surface and to accept “Insert intermediate 
grade break points”. (this will add additional elevation points on the feature line 
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everywhere it crosses a TIN line on the surface – this will “bend” the feature line 
so that it matches the surface exactly) 

 

 Click the southern feature line and press Enter. 

 Select the southern feature line and watch it move up to match the EG surface in 
the 3D view. 

 

6. Build a surface using the two feature lines as breaklines and view the result. 

 In Prospector, right-click on Surfaces and select Create Surface. 

 

 Name the surface Retaining Wall and apply a style of Proposed Contours 
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 Under the Retaining Wall Surface, browse down to Definition and right-click on 
Breaklines.  Select Add.  Press OK to accept the default settings in the Add 
Breaklines dialog. 

 

 Select the two feature lines and press Enter.  View the surface that has been 
built. 

 

Two - Driveway Apron 
In this exercise we’ll use feature line interaction to “press” a driveway apron into a sidewalk (this 

works great for handicap accessible ramps too).  We start with a simple corridor defined to the 

edge of pavement.  The curb/gutter and sidewalk have already been constructed using feature 

lines.  This was done by exporting the edge of pavement feature line from the corridor and using 

the Stepped Offset command in the Feature Lines toolbar to construct the curb and sidewalk. 
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We’ll need to add some elevation points to our feature lines to cause the type of interaction we 

want between the feature lines.  Then we’ll draw some new feature lines that represent the 

grade breaks that form the depressed area of the apron.  Using our Reset Feature Line button 

we can get exactly the result we want. 

1. Open 02-Driveway Apron.dwg.  Zoom into the area within the green circle in the plan view. 

2. Click on the westernmost blue feature line.  On the ribbon, if the Edit Elevations panel is not 
visible, click Edit Elevations.  Then click Insert Elevation Point. 

  

3. Use the Center OSNAP to create elevation points at the centers of the two magenta circles 
on that feature line.  Press enter when prompted for the elevation to accept the default. (this 
default is the actual elevation of the feature line at that point) 

 

4. Repeat the Insert Elevation Point command for the four magenta circles on the curb flow 
line feature line. 

 

5. On the Home tab of the ribbon, click Feature Line > Create Feature Line. 
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6. Make sure the Styles option is unchecked and accept the other defaults in Create Feature 
Lines dialog.  Use the Endpoint OSNAP to snap to the vertices where elevation points were 
created to draw the four feature lines in the configuration shown below.  For each feature 
line that you draw, make sure the prompt for the second point asks for elevation.  If it does 
not, type E to use the elevation option. 

 

7. In the right view, note how the new feature lines “bend” the existing ones. 

 

8. Use a crossing to select the blue feature lines that are intersected by the new red feature 
lines. 

 

9. Launch the MOVE command and press Enter twice to move the feature lines a 
displacement of 0,0,0. 
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10. In the right view, note how the blue feature lines have returned to their original shape and 
now the green feature lines have bent to match. 

 

11. Repeat step 10 for the two interior feature lines.  Note how they return to their original 
shape and force the interior of the apron downward creating the shape we are looking for. 

 

12. On the Prospector tab, right-click on the Sidewalk surface and select Properties.  Change 
the style of the surface to 3D Display. 

 

13. On the Prospector tab, right-click on the Sidewalk surface and select Rebuild.  

 

14. Note in the right view how the surface reflects the new changes. 
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Three – Parking Lot Access 
In this exercise we’ll see how to use feature line interaction to create a parking lot access drive 

that ties to existing ground elevations at one end, and finished ground at the other. 

1. Open 03-Driveway Access.dwg 

2. Use the Create Feature Lines from Objects command to convert the access drive curb lines 
to feature lines. 

 On the Home tab of the ribbon, click Feature Lines > Create Feature Lines from 
Objects. 

 

 Select the four polylines that form the curbs on either side of the access drive. 

 Click OK to accept the defaults in the Create Feature Lines dialog box.  Notice 
how the western end of the newly created feature lines are tied to the elevations 
of the other parking lot feature lines.  This is due to the interaction between 
feature lines in the same site. 

 

3. Draw a new feature line at the front of the entrance drive along the edge of the existing 
road. 

 On the Home tab of the ribbon, click Feature Line > Create Feature Line. 

 Click OK to accept the defaults in the Create Feature Line dialog box. 
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 Snap to the end of the curb flowline feature line on either side of the access 
drive.  Press enter each time to accept the default elevation of zero.  You now 
have a feature line drawing across the mouth of the drive access. 

 

4. Project the newly created feature line to match existing ground elevations. 

 Select the new feature line, then click Elevations from Surface on the ribbon. (if 
the Edit Elevations panel of the ribbon is not visible, click Edit Elevations first) 

 

 Select the EG surface and make sure that “Insert intermediate grade break 
points” is checked. (this will make sure that the feature line is an exact match to 
the EG surface by creating additional elevation points where necessary) 
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 Click the newly created feature line.  You should see green markers appear 
where additional points are created.  You should also see the eastern ends of the 
drive access feature lines “jump up” to existing ground elevations. 

 

5. Elevations are established at the beginnings and ends of the curbs, now you must fix the 
interior elevations.  To do this, use the Set Slope/Grade Between Points command, but only 
on the flow line feature line for now. 

 Click one of the flow line feature lines for the drive access. 

 Click the Set Grade/Slope Between Points command on the ribbon. 

 

 Click one end of the feature line and press enter to accept the elevation 

 Click the other end of the feature line and press enter to accept the elevation 

 Repeat these steps for the other side of the access drive.  The flow line feature 
lines now have the correct elevations throughout. 



Ten Practically Awesome Grading Examples 

13 
 

 

6. Use the Adjacent Elevations by Reference command to set the top-of-curb feature line 
elevations. 

 Click one of the flow line feature lines, then click Adjacent Elevations by 
Reference on the ribbon. 

 

 Select the adjacent top-of-curb feature line.   

 Type 0.5 and press Enter to specify the elevation difference. 

 Repeat these steps for the curb on the other side of the access drive. 

 The drive access curb feature lines now have the correct elevations. 

 

Four - Pond Spillway 
In this exercise we will start with a pond design that is nearly complete.  All that is left is to add a 

spillway. 

The pond construction is fairly simple:  parallel feature lines at the rim at an elevation of 1000, 

feature lines at the 997 contour on both the inside and outside, and a feature line at the invert of 

the pond at 990.  The purpose of the feature line at elevation 997 is to provide the basis for a 
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grading object that ties into our existing surface at a 3:1 slope.  By moving the start of the 

grading object down and out to 997 we prevent a clash between it and our spillway feature lines. 

 

Once again we are going to take advantage of the ways that feature lines interact with each 

other.  By using several simple feature lines that establish the shape and elevations of the 

spillway, we can bend the rim feature lines downward creating the depression in the pond berm 

that will be our spillway.  Finally we’ll add these feature lines into the pond surface so that the 

spillway is part of the final model. 

1. Open the drawing 04-Spillway.dwg.  Take a moment to examine the construction of the 
pond.  Note the simple feature lines to the east of the pond that will be used to create the 
spillway. 

2. With ORTHO on and OSNAPs off, use the MOVE command to move the four spillway 
feature lines to the approximate midpoint of the southern embankment of the pond. 

 

3. In the right view, note how the spillway feature lines bend the pond feature lines downward 
to create the spillway depression. 

Grading 

Object 

Rim feature lines 

at elev 1000 

Feature lines at 

997 contour 

Feature line at 

elev 990 



Ten Practically Awesome Grading Examples 

15 
 

 

 

4. Change the style of the Pond surface to 3D Display. 

5. Add the spillway feature lines to the Pond surface as breaklines. 

 In prospector, find the surface named pond and keep expanding the tree beneath 
until you find Definition.  Right-click on Breaklines under Definition and select 
Add. 

 

 Press OK to accept the defaults on the Add Breaklines dialog and select the four 
spillway feature lines. 

 When you press Enter the surface will automatically rebuild showing the pond 
spillway in the right view. 
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6. Again using ORTHO, move the two spillway feature lines on the right side of the spillway to 
the right to widen the spillway.  Notice the change reflected in the model. 

 

7. Experiment with moving the spillway feature lines and/or changing their elevations. 

Five - Lot Grading 
In this example we’ll begin with a drawing that already contains the parcels and corridor models 

for part of a residential development.  Our goal will be to grade Lot 9, the corner lot, to provide 

for a colonial style house and create positive drainage away from the structure. 

A few key items that we have included are corridor surfaces on both Autodesk Ave (east to 

west) and University Drive (north to south), an existing ground surface, and defined parcel 

segments.  It is interesting to note that parcel segments can function exactly like feature lines in 

that they can be assigned elevations and utilized as breaklines in a surface.  We’ll take 

advantage of this capability to form the basis of our lot grading and then add a few more simple 

feature lines to actually grade Lot 9. 

1. Open 05-Lot Grading.dwg 

2. Click the back lot line, the click Elevations from Surface on the ribbon.  If the Edit Elevations 
panel is not visible, click Edit Elevations on the ribbon. 

 

3. Choose eg and press OK. 

4. Select the back lot line and watch in the 3D view to the right as the parcel line is elevated to 
match existing ground elevations.  Press Enter to exit the command. 
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5. Repeat the Elevations from Surface command using the University Drive surface for the 
parcel line forming the frontage of Lots 5-9. 

6. Repeat the Elevations from Surface command using the Autodesk Ave surface for the 
parcel line forming the frontage of Lots 1,2,3, and 9.  All of the parcel lines should now be 
elevated.  The lines along the frontage match up to the corridor elevations and the back lot 
lines match up with eg. 

 

7. Add all of the parcel lines to the Lots surface as breaklines. 

 Find the Lots surface in Prospector and keep expanding the tree below until you 
find Definition, then Breaklines.  Right-click on breaklines and select Add. 
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 Press OK to accept the defaults on the Add Breaklines dialog and select all of the 
red parcel lines. 

 Notice how the surface is built, tying into the corridor elevations along the 
frontage and into eg along the back.  There’s a little cleanup to do on the inside 
corner of the back line but we’ll save that for another day. 

 

8. Zoom into Lot 9 and use the Create Feature Line from Objects command to convert the 
yellow building footprint into a feature line. 

 Launch the Create from Objects command on the Feature Lines toolbar. 

 

 Select the yellow rectangle representing the building. 

 Press OK to accept the defaults in the dialog that appears. 

9. Use the Raise/Lower command to raise the building footprint up to elevation 1007. 

 Select the building footprint feature line, right-click, and select Raise/Lower 
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 At the command line, type E for Elevation and press Enter.. 

 Type 1007 and press Enter. 

 Note in the 3D views how the feature line now appears in the same general 
elevation as the lot. 

 

10. Use the Stepped Offset command to create another feature line around the building that 
represents a 10-foot wide area that slopes away from the building at 2%. 

 Click the building footprint feature line 

 Click Stepped Offset on the ribbon.  If the Edit Geometry panel is not visible, you 
will need to click Edit Geometry. 

 

 Enter 10 for the offset distance. 

 Click a point to the outside of the building feature line. 

 Type g for grade then -2 for the actual grade value. 

11. Add the new feature lines as breaklines in the Lots surface. 

 In Prospector, Right-click on breaklines under Surfaces => Lots => Definition and 
select Add. 
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 Press OK to accept the defaults in the Add Breaklines dialog.  Select the two 
rectangular feature lines.  Press Enter and note the changes to the surface. 

 

12. Now we’ll use the polyline to the north of the building to create a swale that directs drainage 
to the back (west side) of the lot. 

 On the Home tab of the ribbon, click Feature Line > Create Feature Lines from 
Objects. 

 

 Select the green polyline to the north of the building feature lines and press 
Enter.  Press OK to accept the defaults in the dialog that appears. 

 Click the new feature line, then click Edit Elevations on the ribbon. 
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 Type 1006 for the first elevation.  Press enter, then type “P” Enter to move the 
marker back to the first vertex. 

 

 Type G for grade then press Enter.  Type -2 and press Enter.  Type -2 and press 
Enter again.  This will set the starting elevation at 1006 and the grade of the 
entire feature line at -2.00%.  Type “x” then press Enter to exit the command. 

13. Add the new feature line to the Lots surface. 

 Right-click on Breaklines in Prospector and select Add. 

 Press OK to accept the defaults in the Add Breaklines dialog. 

 Select the feature line we’ve just been working with and press Enter. 

 Note the new swale that has been created along the north side of the building. 

 

14. Experiment with moving and/or changing the elevations of the building and swale feature 
lines and note how the surface is updated.  You may need to rebuild the surface to see 
certain changes. 
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Fun with Grading Objects 

Six - Channel 
In this exercise we will create a simple diversion channel like you might provide for erosion and 

sedimentation control.  We’ll begin with the existing ground surface and a 2D polyline 

representing the path of the channel.  We’ll use some feature line tools to “paint” this polyline on 

the ground surface.  We’ll then “bury” the new 3D feature line below the ground surface and use 

Civil 3D grading objects to find daylight.  The result will be a 3-foot deep channel cut right into 

our existing ground surface. 

1. Open 06-Channel.dwg. 

2. Use the Create from Objects command to convert the white 2D polyline to a 3D feature line. 

 On the Home tab of the ribbon, click Feature Line > Create Feature Lines from 
Objects. 

 

 Select the polyline representing the path of the channel and press Enter. 

 Press OK to accept the feature line defaults. 
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3. Use the Elevations from Surface command to “paint” the feature line on the surface. 

 Click on the newly created feature line, then click Elevations from Surface on the 
ribbon.  If the Edit Elevations panel is not visible, you will need to click Edit 
Elevations first. 

 

 Click OK to accept EG as the assigned surface. 

 Click the feature line and watch as it is projected to existing ground elevations. 

 

4. Use the Raise/Lower command to lower the feature line by 3 feet. 

 Select the red feature line, right-click, and select Raise/Lower. 

 

 At the command line, type -3 and press Enter. 

5. Use the Grading Creation Tools to project the invert of the channel back up to existing 
ground at a 3:1 slope. 

 On the Home tab of the ribbon, click Grading > Grading Creation Tools. 
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 Click on the Select a Criteria Set button on the Grading Creation Tools toolbar. 

 

 Select Basic Set and press OK. 

 

 Select the Surface @ 3-1 Slope criteria on the Grading Creation Tools toolbar. 

 

 Click the Create Grading button. 

 

 When the dialog appears, press OK and type Channel as the name of the 
grading group. 
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 Select the red feature line and a point to the north.  Press Enter to apply the 
grading to the entire length of the feature line.  Note the channel embankment 
that appears. 

 

 Carefully select the original feature line and this time select a point to the south.  
Press Enter to apply the grading to the entire length of the feature line.  Examine 
the results. 
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Seven - Berm 
This exercise will be very similar to the last except this time we’ll create a raised berm rather 

than a channel. 

1. Open 07-Berm.dwg 

2. Use the Create from Objects command to convert the white 2D polyline to a 3D feature line. 

 On the Home tab of the ribbon, click Feature Line > Create Feature Lines from 
Objects. 

 

 Select the polyline representing the path of the channel and press Enter. 

 Press OK to accept the feature line defaults. 

3. Use the Elevations from Surface command to “paint” the feature line on the surface. 

 Click on the newly created feature line, then click Elevations from Surface on the 
ribbon.  If the Edit Elevations panel is not visible, you will need to click Edit 
Elevations first. 

 

 Click OK to accept EG as the assigned surface. 

 Click the feature line and watch as it is projected to existing ground elevations. 
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4. Use the Grading Creation Tools to project upward from the feature line at a 3:1 slope to 
create a berm that is 3 feet above existing ground. 

 On the Home tab of the ribbon, click Grading > Grading Creation Tools. 

 

 Click on the Select a Criteria Set button on the Grading Creation Tools toolbar. 

 

 Select Basic Set and press OK. 

 

 Select the Relative Elevation @ Slope criteria on the Grading Creation Tools 
toolbar. 
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 Click on the Create Grading button. 

 

 Enter Berm for the name of the grading group. 

 

 Select the red feature line and a point to the south.  Press Enter to apply the 
grading to the entire length. 

 Enter 3 for the relative elevation and 3 for the slope.  Note the result. 

 

 Change the criteria to Distance @ Grade. 
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 Click on the Create Grading button and select the southern edge of the berm 
embankment. 

 

 Press Enter to apply to the entire length.  Enter 10 for the distance and -2 for the 
grade.  Examine the result. 

 

 Change the criteria to Surface @ 3-1 Slope.  Launch the Create Grading 
command once again. 

 

 When the warning dialog appears, press OK and select eg as the target surface. 

 Select the southern edge of the top of the berm. 
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 Press Enter to apply to the entire length.  Examine the result. 

 

Eight - Headwall/Wingwalls 
In this exercise we have an access road with a culvert that passes under it.  A surface has been 

built out of the access road and tie-in embankments as well as for existing ground.  Our job will 

be to cut the headwall area out of the embankment.  Our headwall will match finished ground 

elevations at the top and existing ground elevations at the bottom.  We’ll use some feature line 

functions to establish elevations at the bottom of the wall then use the Grading Creation tools to 

create the vertical face of the wall.  Finally we’ll perform a little magic with surfaces to make the 

wall part of the overall surface. 

1. Open the drawing named 08-Headwall. 

2. Convert the inner wall line of the headwall into a feature line. 

 On the Home tab of the ribbon, click Feature Line > Create Feature Lines from 
Objects. 

 

 Select the inner wall of the headwall. 
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 Press Enter and then press OK to accept the feature line defaults. 

3. Use the Elevations from Surface command to “paint” the bottom edge of the wall on to the 
existing ground surface. 

 Select the newly created feature line and click Elevations from Surface on the 
ribbon.  If the Edit Elevations panel is not visible, you will need to click Edit 
Elevations first. 

 Select eg as the target surface and press OK. 

 Select the new feature line and press Enter. 

4. Use the Grading Creation tools to project the feature line vertically to the finished ground 
surface. 

 On the Home tab of the ribbon, click Grading > Grading Creation Tools. 

 

 On the Grading Creation Tools toolbar, change the criteria to Grade to Surface. 

 

 Click on the Create Grading button. 
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 When the warning dialog appears press OK and select fg-complete as the target 
surface. 

 

 Select the green feature line.  Click Continue grading… when the warning dialog 
appears. 

  Click a point behind the back of the wall.  Press Enter to apply grading to the 
entire length. 

 Use Slope for the format and 0.01 as the slope value for both Cut and Fill (this is 
not quite vertical but plenty close enough – trying to make perfectly vertical faces 
is always a bad idea).  Examine the result in the 3D view. 

 

5. Create a surface from the grading object. 

 Locate the Headwall grading group in Prospector.  Right-click on it and select 
Properties. 
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 Click on the Information tab and check the box under Automatic Surface Creation 

 Press OK twice to return to the drawing. 

6. Create a new surface that is a combination of FG and the headwall surface. 

 On the Home tab of the ribbon, click Surfaces > Create Surface. 

 Enter FG Complete as the name and click OK. 

 On Prospector, expand Surfaces > FG Complete > Definition.  Right-click Edits 
and select Paste Surface. 

 

 Select FG and press Enter. 

 Repeat the previous step using the Headwall surface. 
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7. On Prospector, right-click the surface named FG and select Surface Properties.  On the 
Information tab, change the style to _No Display. 

 

8. Use a boundary to clean up the surface within the wall area. 

 Turn on the layer Boundary 

 Find the Boundaries node under the FG Complete surface.  Right-click on it and 
select Add. 

 

 Change the boundary Type to Hide and check the box next to Non-destructive 
breaklines. 

 

 Select the green polyline that has been provided for the boundary. 
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 Examine the result. 

 

Nine - Complex Site 
This exercise will be the grand finale where we’ll apply many of the previous concepts to build 

our most complex model.  Although very simple compared to most site grading designs, this site 

has some basic elements that are fairly common.   

The most important concept we’ll apply in this exercise is the two-step process of modeling a 

generic version of our site grading, and then projecting the actual shape of our site on to that 

model.  This approach can be used time and time again for even the most complex sites. 

We’ll start the exercise with one surface, “eg”, and some simple AutoCAD polylines.  We’ll begin 

by creating the generic version of our grading by setting a few elevations around the perimeter 

of the building and using the Grading Creation Tools to project outward and downward at a 2% 

slope.  With our generic grading established, we’ll then project the curb lines of our site on to 

that surface using the all-powerful Elevations from Surface command.  Using some handy 

feature line tools we’ll create low points at the catch basins to promote drainage, then use 

surface smoothing to “warp” the irregular grading that we’ve generated.  Finally we’ll apply the 

Grading Creation Tools to tie the perimeter of the parking lot back to existing grade. 
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Here goes… 

1. Open the drawing named 09-Site Plan. 

2. Convert the magenta building polyline to a feature line. 

 On the Home tab of the ribbon, click Feature Line > Create Feature Lines from 
Objects. 

 

 Select the magenta polyline and press Enter 

 

 Press OK to accept the defaults in the Create Feature Lines dialog 

3. Edit the elevations of the building feature line. 

 Click the newly created feature line, then click Elevation Editor on the ribbon.  If 
the Edit Elevations panel is not visible, you will need to click Edit Elevations first. 
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 Select the building feature line.  Edit the elevations to match the image below. 

 

4. Use the Grading Creation Tools to model the 2% slopes away from the building. 

 On the Home tab of the ribbon, click Grading > Grading Creation Tools. 

 

 Click the Set the Grading Layer button on the Grading Creation Tools toolbar. 

 

 Navigate through the ensuing dialogs to set the layer to General Grading 

 Verify that the criteria is set to Grade to Distance 
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 Click on the Create Grading button 

 

 Verify that the current grading group is General Grading and click OK. 

 Select the building feature line and a point to the outside.  Press Enter to apply 
grading to the entire feature line. 

 Specify 300 for the distance.  Then type G for grade and enter -2 for the grade. 

 Note the model of the building and 2% slopes shown in the 3D view.  (If things 
don’t look right you can open Waypoint1-09-Site Plan.dwg and continue from 
there) 

 

5. Freeze the layer General Grading 

6. Set the view named Fine Grading current. 

 From the View tab of the ribbon, click Fine Grading in the list of named views. 

 

7. Set a new site and grading group for the fine grading objects. 

 Click on the Set Grading Group button on the Grading Creation Tools toolbar (if it 
is not visible, launch it by selecting Grading Creation Tools from the Grading 
menu). 
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 Choose Fine Grading for both the Site and Grading Group 

 

8. Convert all of the visible polylines to feature lines using the Create from Objects command.  
Make sure to place the new feature lines in the Fine Grading site. 

 On the Home tab of the ribbon, click Feature Line > Create Feature Lines from 
Objects. 

 Select the polylines and press Enter (don’t forget the small cyan polyline at the 
northwest corner of the site). 

 Select Fine Grading as the site in the Create Feature Lines dialog and press OK. 

 

9. Use the Elevations from Surface command to set the elevations of all of the feature lines to 
match the General Grading surface. 

 Click one of the feature lines, then click Elevations from Surface on the ribbon. 

 Select the General Grading surface and click OK. 

 Click Multiple on the command line. 

 Select all of the feature lines.(If things don’t look right you can open WayPoint2-
09-Site Plan.dwg and continue from there) 

10. Add the new feature lines to the Fine Grading surface as breaklines. 
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 Find the Fine Grading surface in prospector and browse downward until you find 
the Breaklines node.  Right-click on breaklines and select Add. 

 Press OK to accept the defaults in the Add Breaklines dialog. 

 Select all of the visible feature lines and press Enter. 

11. Click on the Layer Previous button to restore layers to their previous state (you can also 
type LAYERP at the command line to launch this command). 

 

12. Use the REGEN command to refresh the screen.  You should now see design contours. (If 
things don’t look right you can open WayPoint3-09-Site Plan.dwg and continue from there) 

 

13. Add low points for drainage. 
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 Turn on the layer new-storm.  Note the locations of the catch basins. 

 Select the feature line representing the perimeter of the parking lot.  On the 
ribbon, click Insert High/Low Elevation Point. 

 

 When prompted for a start point click the point at the center of circle A. 

 

 Pick the second point at the center of circle B. 

 

 Specify -1 for both grade ahead and grade back. 

 Note the depression that is created and shown by the contours in that area (the 
contours look a little rough but we’ll fix that later). 

 Repeat these steps for circles CD and EF. (If things don’t look right you can open 
WayPoint4-09-Site Plan.dwg and continue from there) 



Ten Practically Awesome Grading Examples 

42 
 

 

14. Infill the parking lot area. 

 On the Home tab of the ribbon, click Grading > Grading Creation Tools. 

 Click on the Set Grading Group button. 

 Verify that the site and grading group are set to Fine Grading and press OK. 

 Expand the button and select Create Infill. 

 

 Click a point in the parking lot area and press Enter. 

15. Apply smoothing to the surface. 
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 Right-click on Edits under the Definition node of the Fine Grading surface and 
select Smooth Surface. 

 

 Click to the right of Select Output region…a button will appear.  Click on the 
button and type S for Surface. 

 

 Change the Grid X and Y spacing to 10 and press OK.  Note how the 
appearance of the contours has changed. (If things don’t look right you can open 
WayPoint5-09-Site Plan.dwg and continue from there) 
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16. Use the Grading Creation Tools to tie in the slopes. 

 If the Grading Creation Tools toolbar is not visible launch it by clicking Grading > 
Grading Creation Tools on the Home tab of the ribbon.. 

 Click on the Set Grading Group button. 

 Verify that the site and grading group are set to Fine Grading and press OK. 

 Change the criteria to Grade to Surface. 

 Click on the Create Grading button. 

 If a warning dialog appears press OK and verify that the target surface is eg. 

 Select the red perimeter feature line and pick a point to the outside.  Click 
Continue grading…when the warning dialog appears.  Press Enter to apply 
grading to the entire length. 

 For Cut, use a format of Slope and a slope of 2 and for Fill, use a format of Slope 
and a slope of 3.  Press Enter to exit the command and examine the result. 
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17. Hide the surface in the building area using a hide boundary. 

 Right-click on Boundaries under the Definition node of the Fine Grading surface 
and select Add. 

 

 Change the boundary type to Hide and check the box next to Non-destructive 
breakline. 

 Select the yellow building rectangle (you will need to use selection cycling to 
select it). 

 Note that contours no longer pass through the building area. 
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18. Getter a better look in the Object Viewer. 

 Select one of the yellow design contours, right-click, and select Object Viewer. 

 

 Examine the surface using the object viewer interface. 

 

 

Ten - Raised Parking Lot Island 
We’ll pick up from the last exercise and do one more trick.  We have several curbed islands 

within our parking lot that have not been represented in the Fine Grading surface.  To address 

this we’ll use the outline of the island to create a feature line and use the Elevations from 

Surface command to “paint” this outline on the pavement.  Then using the Stepped Offset 

command we’ll model the top of the curb.  The two feature lines will then be used to create a 

surface which will be combined with the Fine Grading surface. 

1. Open 10-Parking Lot Island.dwg.  Note the contour line that passes through the raised 
island. 

 

2. Use the Create from Objects command to convert the green polyline to a feature line. 
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3. Use the Elevations from Surface command to set the elevations of the feature line to match 
the surface Fine Grading. 

4. Used the Stepped Offset command to create a new feature line that is 0.1 feet inward and 
0.5 feet above the original island perimeter. 

5. Create a new surface from the island feature lines. 

 Select the two feature lines, then click Add to Surface as Breakline on the ribbon. 

 

 In the Select Surface dialog box, click the plus sign icon. 

 

 In the Create Surface dialog box, enter Island1 for the name and set the style to 
_No Display.  Click OK twice. 

 

 In the Add Breaklines dialog box, set the Mid-ordinate distance to 0.1 and click 
OK. 
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6. Create a new surface and paste Fine Grading and Island1 into it to create the full design. 

 Set the style of Fine Grading to _No Display. 

 Create a new surface named Fine Grading with Islands.  Set the style of this new 
surface to Contours 1’ and 5’ (Design). 

 Paste the Fine Grading surface into the Fine Grading with Islands surface 

 Paste the Island1 Surface into the Fine Grading with Islands surface. 

 

 

7. View the island area in Object Viewer to admire your work. 

 

8. Grade in more islands if time permits. 
 

 

 


