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Would you like to take hours, or even days, out of your typical schematic design
process on every new project? Maximize the power of AutoCAD Electrical software in your
organization by implementing a streamlined workflow using selected standard tools. In this class, we
show you how to use the intelligence of a completed AutoCAD Electrical project and some subtle,
yet powerful tools integral to AutoCAD Electrical, to take a new project from 0 to 90% complete in a
matter of minutes. By using the power of several project-wide editing tools, we transform a
completed project into a unique new project where you can cruise through the mundane changes
and direct your focus to what is substantially different.

Learning Objectives
At the end of this class, you will be able to:


Copy a completed project to create a unique new project



Update project descriptions and other title block data across the entire drawing set



Reformat component tags and wire numbers for the whole project



Update descriptions and location codes for components and PLC modules in Microsoft® Excel®
software

About the Speaker
Eric France is a Solutions Consultant for the Manufacturing Solutions Division of IMAGINiT
Technologies. He has worked in their Denver office since 1998 and has had the privilege of
helping hundreds of Manufacturers maximize their software investment. His Manufacturing
experience goes back to his childhood, when he would help his father at his machine shop in
upstate New York.
His first exposure to CAD, in various forms, was in the late '80's. He has been using AutoCAD
since 1992. He is proud to say his first encounter with AutoCAD Electrical was when it was still
VIA WD. His career has allowed him the opportunity to learn, internalize, and promote the suite
of Manufacturing tools provided by Autodesk from their release, as well as many
complimentary products from third-party vendors.
With the notable exception of a 3 year paid vacation hauling Abrams tanks around Europe for
the US Army... Computers, Manufacturing, and CAD have been a staple of his existence for
over 25 years.
EFrance@Rand.com
@IMAGINiT_EricF
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Copy a completed project to create a unique new project
First things first, we need to start with an existing AutoCAD® Electrical project. We would prefer
to start with a project that already has a lot of the circuitry and other electrical information we
need defined in it. That could be one that is very similar to the new one we will be creating or it
could be our company’s “all options selected” master project. Either way, the higher percentage
of time we spend focused on creating just what is different, the more efficient we are in
completing this project. So we’ve selected our best project and set it as the Active Project in
AutoCAD® Electrical, now what?
Copy Project
We make sure we’ve closed all files related to the project we are about to copy and we’ve
opened a non-related drawing. Then, we select the Project tab and pick the Copy command
from the Project Tools panel.
Step 1
We pick the Copy Active Project button to identify which project we will use as a template for
our new project. Once that is selected, we pick OK to continue.

Step 2
Next, we identify a name and location for our new project. Most likely this will be an existing
directory out on the network that contains the information that was used to get this new project
to the point where we are ready to start creating drawings. Regardless, select a folder location
and give our new project a name. To keep things simple, we will call ours “New Project”. Once
that is identified, we pick Save to continue.

2

Short Circuit Your Schematics: Maximize Autodesk® AutoCAD® Electrical in Your Organization

Step 3
Next, we identify the drawings from the template project that we need for our “New Project”.
Unless you have ruled out certain drawings that are unneeded in our new project, you will likely
want all of them. The easiest way to select all the drawings in the project is to pick the Do All
button. If you don’t need them all, you can use the Process and Un-select buttons to control
which drawings will be copied. Having selected the drawings we need, we pick OK to continue.

Step 4
This step is typically a pass-through step, meaning we typically accept the defaults. If we use
the same Project-Related Files for all projects, there won’t be any files available to select in the
template project folder. This is because they will be in the network support path. If we use
different Project-Related Files for most projects, we will usually want copies of the ones selected
by default. Having selected the Project-Related Files we need, we pick OK to continue.
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Step 5
The final step is where we rename the drawing files for use with this new project. If the
drawings will all use the same prefix, ex. the project number, we can use the Find/Replace
button to rename the files in bulk. If we need more flexibility in how the drawings get renamed,
we can use the Edit button to adjust the names one at a time. Having renamed all the drawings
to the new names we need, we pick OK to continue.

Activating Our “New Project”
Once we’ve completed all the steps for copying the project, AutoCAD® Electrical will process
our request, create the new files, activate our “New Project”, and open the first drawing listed in
our project list automatically. We are now ready to adjust our project information and update
our title blocks.

Update project descriptions and other title block data across the entire
drawing set
If we expand our “New Project” in the Project Manager, we can see that everything came across
from the previous project, including the manager folder structure. However, as this is our “New
Project”, we need to make the stored project and drawing information unique to this project and
update our drawings with that new information.
Updating Project Descriptions
By right-clicking on the “New Project” heading in the Project Manager, we can then pick
Descriptions… to access the Descriptions dialog containing the common information that
pertains to all the drawings in the project.
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You should also use a .wdl file to convert the Line1, Line2, … labels to familiar field labels so
users know on which line to enter the appropriate information.
Updating Drawing Descriptions
If the descriptions for the individual drawings need to be adjusted and updated in individual title
blocks, we can do this by editing the Drawing Descriptions. This can be accomplished by rightclicking on a drawing in the project list, selecting Properties, then Drawing Properties… and
editing Description 1, Description 2, and Description 3.

Once we have made the edits to our project and drawing descriptions, it’s time to push those
edits out to our title blocks.
Batch Updating Title Blocks across the Project
There are two primary ways to initiate the Update Title Block command. We can either rightclick on the “New Project” heading in the Project Manager and pick Update Title Block…, or we
can pick Update Title Block from the Other Tools panel on the Project tab. Regardless of which
way we choose to initiate the Update Title Block dialog, once we are there we need to select the
information that we want updated in the title blocks of our project. Then, we pick OK Projectwide to apply our “New Project” updates to all drawings in the entire project.
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In many cases, the formatting of the information in the drawings themselves will not change
from project to project, especially if these projects are being created for use internally to a
company standard. However, if the formatting does need to change, we have a tool for that…
Enter the Project-Wide Update/Retag tool.

Reformat component tags and wire numbers for the whole project
In cases where the drawing formatting needs to change, either by customer request or for a
special project, the Project-Wide Update/Retag tool can help us make quick work of it.
Project-Wide Updates or Retagging
To kick off our project-wide updates and retagging, we can pick the Project-Wide Update/Retag
button in the middle of the toolbar at the top of the Project Browser. Alternatively, we can pick
the Update/Retag button on the Project Tools panel on the Project tab. With the Project-Wide
Update or Retag dialog displayed, we select the formatting changes we need to make for this
project.
In the top right corner of the dialog, we can select type of formatting updates to apply to the
components in our project, as well as their cross-references and the wire and signal arrows that
connect them. Below them, we can make adjustments to the line references on our ladders and
control how they change from sheet to sheet. On the right half of the dialog, we can adjust
sheet and drawing numbering. We can also dig deeper into Other Configuration Settings and
override the formatting for the components, cross-references, and wire numbers. We can even
initiate a Title Block Update right from within the dialog. When we have made all our selections
and we are ready to push the changes down to the drawings, pick OK to apply them to our
project drawing set.

Updating and retagging a project’s worth of drawings in a matter of minutes allows us to focus
our time on the unique aspects of the project. Our final task before doing so is to utilize
Excel®’s powerful data sorting and editing capabilities to integrate the discrete component
information changes quickly into our project set.
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Update descriptions and location codes for components and PLC modules in
Microsoft® Excel® software
Let’s face it. In most electrical schematic drawings, there is a lot of descriptive information
about the components; what they are, what they do, where they are located. Therefore, when
an old project is copied for use as the basis of a new project, one of the biggest differences is
the naming of the component tags, descriptions, and locations. So, even if the circuitry is all the
same, there is still a large amount of editing required to uniquely identify the components.
An oft-overlooked capability of AutoCAD® Electrical is a pair of tools that allow us to leverage
the powerful sorting and editing tools in Excel®. It’s really just one tool to get the data out of our
drawings and another to get the edited data back in. What is really significant is the magic that
happens while the data is editable in the spreadsheet. Let’s look at the tool for getting the data
out to Excel® first.
Export to Spreadsheet
First, we need to make our way over to the Import/Export Data tab. Since we need to get our
data out to Excel®, we pick To Spreadsheet on the Export panel. The dialog that appears asks
us to specify the category of data we want to edit in Excel®. While we can be very selective
about the category of data that is output, in this case it is probably best to select General (all *
below) and pick OK. We choose this option because it outputs each of the categories that have
an * next to them to their own worksheet in the spreadsheet workbook. By doing that, we can
quickly edit the most common categories of data by selecting the different tabs of a single
spreadsheet. We then need to specify the General Data Export settings and pick OK to control
the scope and format of the export.
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Next, we use Select Drawings to Process again to select all the drawings in the project with
another Do All and OK. Finally, we identify the name (use the project name) and location
(typically the project files folder) for the output file to be saved to and pick Save. With that, the
software extracts the data we have requested to the output file and we are ready to make our
edits in Excel®.
Editing in Excel®
Using Windows Explorer, we navigate to where we saved the output file and open it in Excel®.
** A word of caution here **
For whatever reason, after using Export to Spreadsheet, the output file consistently opens up on
the second tab on the right side of the columns. Because of this, the first step to editing the
data is typically selecting on the first tab “COMP” and scrolling the spreadsheet to cell A1.
Two of our most useful tools in Excel® are Sort in the middle of the Data tab and Find & Select
on the far right side of the Home tab. By leveraging these two tools, we can organize the output
data in a variety of ways. Doing so, allows us to easily add the data needed for the new project.
Sort
When we pick Sort on the Data tab, we use the headers of the columns as our sort criterion by
checking the “My data has headers” checkbox. We then “Sort by” the column whose data we
need to change and pick OK.

Replace
Next, we can use the Replace… tool under Find & Select to “Find what:” data from the old
project we need to “Replace with:” the data for the new project. By using the Replace All option,
we quickly adjust the cells on the “COMP” tab to the new project data. Leaving the Find and
Replace dialog open as we move to each tab and rerun the same Replace All option allows us
to make the same replacements on the other tabs very quickly.
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We continue to make our edits in Excel® until all of the data we can change has been updated.
Then, we Save and Close the spreadsheet and switch back to our project in AutoCAD®
Electrical.
NOTE: There are five columns with the headers in parenthesis, ex. (REF). These columns
should not be edited as they contain data that AutoCAD Electrical uses to maintain the mapping
between the data in Excel and where it goes in the drawing files.
Import from Spreadsheet
Now that all the edits have been made to the data that we need for our “New Project”, we can
pull that data back into our drawings using the second tool. Since we are getting our data back
from Excel®, we pick From Spreadsheet on the Import panel. In the Update Drawing from
Spreadsheet File dialog, we select the edited .xls file and pick Open. In the Update Drawings
per Spreadsheet Data dialog, we typically accept the defaults and pick OK.

A final Do All and OK in the Select Drawings to Process dialog to select all the drawings in the
project allows AutoCAD® Electrical to begin the process of updating the data in our “New
Project” automatically. Soon, all the drawings have been updated and we can now focus on
what is unique about the design of our “New Project” drawing set.

Before Editing in Excel®

After Editing in Excel®
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Class Summary
In this class, you learned how to:


Copy a completed project to create a unique new project



Update project descriptions and other title block data across the entire drawing set



Reformat component tags and wire numbers for the whole project



Update descriptions and location codes for components and PLC modules in Microsoft® Excel®
software

Using these tools effectively will allow you to leverage the intelligence contained in an existing
AutoCAD® Electrical project, as a means to maximize the efficiencies of that intelligence and
the ease with which it can be changed, to assist in reducing the time to complete your next
project.
Thank you for your time and attention.
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