A Better Structural Workflow: Integrated Design, Analysis, and Detailing

Aaron Vorwerk, AIA, EIT, LEED AP BD+C
Subject Matter Expert, Buildings

Ian Coats
Technical Specialist, Structural BIM
Today’s Speakers

Aaron Vorwerk

Aaron Vorwerk is a registered architect, civil/structural engineer-in-training (EIT), LEED AP BD+C, and AEC industry technologist. He advises customers across North America on AEC project lifecycle strategy and workflows. Aaron holds graduate degrees in architecture and engineering (M.Arch, MSCE, BSCE) and has 25 years’ worth of widespread experience in the AEC industry.

Ian Coats

Ian Coats has enjoyed a construction-oriented career spanning over 20 years with experience of civil / structural projects, including steel detailing and fabrication with a strong emphasis on BIM and related technologies. An accomplished speaker, thought leader and mentor, he is working to drive construction industry efficiencies through manufacturing style processes.
Agenda, Part 1

- Tools and Workflows
- Connecting Design to Analysis with Revit
- Finite Element Analysis (FEA) in RSA
- E1: The Round-trip Experience
- Extending Revit
Tools and Workflows
What, Where, and Why
# The Autodesk Structural Toolbox

<table>
<thead>
<tr>
<th>Design</th>
<th>Fabrication</th>
<th>Construction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conceptual Design</td>
<td>Fabrication Model</td>
<td>Installation</td>
</tr>
<tr>
<td>Structural Design</td>
<td>Shop Drawings</td>
<td></td>
</tr>
<tr>
<td>Coordination &amp; Simulation</td>
<td>Prefab &amp; Production</td>
<td></td>
</tr>
<tr>
<td>Code Checking</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Robot Structural Analysis Professional**

**Dynamo**

**Revit**

**Advance Steel**

**BIM 360 Design, BIM 360 Docs, Navisworks, BIM 360 Glue**

**BIM 360 Build, BIM 360 Plan**

**Partner Add-ins**
Steel Design and Detailing

- Construct Model
  - Revit, Advance Steel
- Perform Analysis
  - Robot Structural Analysis Pro
- Detail Steel Connections
  - Advance Steel, Revit
- Generate Shop Drawings
  - Advance Steel
Concrete Design and Detailing

- Construct Model
  - Revit
- Add Reinforcement
  - Revit (+optional add-ins)
- Perform Analysis
  - Robot Structural Analysis Pro
- Create Assemblies
  - Revit (+optional add-ins)
- Generate Shop Drawings
  - Revit (+optional add-ins)
Connecting Design to Analysis
Revit Structural Analytical Model
Connecting Design to Analysis

The Analytical Model

• Revit takes its ‘best guess’ at an analytical model during design
• The analytical model can be independently adjusted
• Revit checks for connectivity and ensures elements are supported
Finite Element Analysis in RSA
Key Features
Robot Structural Analysis Pro

Collaboration
- Supports efficient BIM workflows
- Interoperability with Revit, Inventor, etc.

Speed
- Auto-meshing (FEA)
- Robust nonlinear and dynamic algorithms
- Over 70 design codes

Versatility
- Flexible, open API
- Covers a broad range of structures
- Localization
Typical Customers

Spans Multiple Industries

- Structural Engineers
- Multidisciplinary Engineering Teams
- Building Product Manufacturers and Fabricators
- Large Industrial Machinery Providers
- Oil and Gas / Mining Firms
Concrete, Steel, and Timber

Design Versatility

• Reinforced Concrete Design Module
• Steel Design Module
• Timber Design Module
Modeling Flexibility

Shells, Solids, and More

- 2D and 3D Frames and Trusses
- Plates, Shells and Grillages
- Plane Stress and Deformation Structures
- Axisymmetric and Volumetric Structures
- Composite Beams
Advanced Analysis

Flexible and Capable

- Advanced Supports and Release Characteristics, e.g. Damping, Nonlinearities
- Advanced Loadings, e.g. Thermal, Notional, etc.
- Automatic Generation of Finite Elements (FE) Mesh
- Powerful Numeric Solvers
Advanced Analysis

Linear and Non-linear

• Compression / Tension Elements
• Cable Elements
• Non-linear Constraints and Hinges
• Material Plasticity
• 2\textsuperscript{nd}-order Effects (Non-linear)
• 3\textsuperscript{rd}-order Effects (P-delta)
Advanced Analysis

Dynamic Analysis

- Modal, Seismic, and Spectral
- Harmonic and FRF
- Linear and Non-linear Time History
- Elasto-plastic
- Pushover
- Footfall
Advanced Analysis

Wind Loads Simulation

- Simulates the wind flow around a structure
- Generates wind loads on all surfaces automatically
- Adjustable wind profile and velocity factor
- Graphic representation of the virtual wind tunnel
Extensibility

Open, Flexible API

- Custom Macro Creation
- Extraction of Analysis Results
- Generate Parametric Structures

Results Connect

Dynamo
Customer Examples
Integration

Round-tripping for Analysis

• Analytical Geometry (Bars, Surfaces)
• Section (Bars)
• Thickness (Surfaces)
• Gamma Angle (Bars)
• Material (Bars, Surfaces)
• Releases (Bars)
• Analytical Links (Bars)
E1: The Round-trip Experience
Revit and RSA
1. Open 01 - Start.rvt and locate the Analyze tab > Structural Analysis panel.
2. Select Robot Structural Analysis > Robot Structural Analysis Link.
3. Leave default options and select OK. RSA will open and begin importing the Revit model data.
4. Click Yes to the pop-up dialog to view the Events Report.
5. If load symbols are not displayed, go to View tab > Display > Loads and toggle Load symbols off and on again, clicking Apply each time.
6. Select OK to exit that dialog.
7. Element visibility may also be controlled using the toolbar at the bottom left edge of the drawing window. Use this toolbar to toggle the display of Section shapes.
8. Select the analytical floor at Level 2.
9. In the Properties Inspector at the left side of the screen, change the Calculation model for this floor from Shell to Deck slab (one-way).
10. Repeat for the floor at Level 3.
11. Select **Loads** tab > **Automatic Combinations** to open the Load Case Code Combinations dialog.
12. Select **Full automatic combinations**, then click **More** to view the combinations in more detail.
13. Select **Generate** to build out the load combinations list.
14. Click the **Options of FE Mesh Generation** icon to open this toolbar, then choose **Meshing Options** (select **Yes** to the pop-up message).

15. Select **Complex mesh generation (Delaunay)** and set the **Element size** to 2 feet. Select **OK**.

16. Select **Generation of calculation model** to create the FE mesh.

17. Select **Mesh Freeze** to store this mesh; then close the toolbar.
E1: Perform Analysis

18. Time for analysis! If you’ve gotten lost along the way, open 02 - Analysis.rtd to catch up.

19. Go to Analysis tab > Analysis Types to open this menu. Observe additional capabilities under the New and Parameters buttons.

20. Select Calculations to run the analysis. Close when complete. A green light at the bottom of the screen indicates that current results are available.
21. Select **Results** tab > **Maps** to open this dialog.
22. Select the \( z \) direction for **Displacements** – \( u,w \) and select **Apply**.
23. Note the color mapping in RSA is similar to the results previously explored in Revit.
24. Deselect the \( z \) checkbox and select **Apply** again to remove the map.
25. For this step, let’s change our RSA layout. Locate the **Layouts** toolbar and change from **Geometry** to **Steel > Steel/Aluminum Design**.

26. Proceed to the **Groups** tab of the **Definitions** dialog. Click **New** to create a new code group and enter members **104 to 123** in the **Member list**.

27. Select **Save**.
E1: Perform Design

28. Proceed to the **Calculations** dialog and select the **Code group design** option. Enter 1 or use the **List** button to find and select group 1.

29. Select **Optimization** and check the **Weight** option. Select OK to close this dialog. If you’re behind, open **03 - Design.rtd** to catch up.

30. Select **Calculations** to perform code group design for the selected settings.
31. The **Code Group Design** module highlights the optimal section for the group (W 8x24 here). Click on the icon next to this section to view results; select **OK** to return.

32. In the **Code Group Design** dialog, select **Change all** to resize the sections. **Close** the dialog and **Cancel** saving the calculation results.
33. Return to Revit. As before, select **Robot Structural Analysis > Robot Structural Analysis Link**.

34. Choose **Update model** and click **OK**. You can also choose **Update from the intermediate file** and select **04 - Update.smxx**. Ignore the events report.

35. Open the **{3D}** view, hide the top floor slab, and select an interior beam to confirm its new size.
You Did It!

(That was the BIG one!)
### Revit 2017, 17.1, 17.2

#### Architecture/platform enhancements
- Depth cueing
- Improved railing hosts and UI usability
- Autodesk® FormIt® 360 Converter
- Autodesk® Insight 360 integration
- Global parameter enhancements
- Improved software performance
- Autodesk® Raytracer rendering engine
- Text Editor and layout engine
- Calculate in annotation tags
- Dynamo updates and player
- Tangency locks
- Schedule improvements
- LED light fixtures content
- Sketch on level
- Stairs parameters tooltips
- Import 3D shapes (Rhino®/SAT files)
- Work in a perspective view
- Corruption data loss prevention
- High-resolution monitor support
- Autodesk® Collaboration for Revit® sync progress notification

#### Structural engineering enhancements
- Open Model detailed progress for Collaboration for Revit
- Export hatch pattern background colors to DWG/DXF
- Export material colors to DWG/DXF and DGN
- Reinforcement connectors
- Variable rebar distribution
- Graphical rebar constraints management
- Bent fabric sheets reinforcement
- Structural connectivity
- Autodesk® Steel Connections for Revit®
- Split columns and framing elements
- New Steel profiles catalogues
- Improved structural foundations
- AISC connection code checking for steel connections
- New steel shapes content

#### MEP design & fabrication enhancements
- Design to Fabrication
- Optimize lengths
- Short segment optimization
- Route and Fill
- Trim and Extend
- Quick Connect
- Change type
- Slope control
- Fabrication model documentation
- Hanger improvements
- Electrical apparent load calculation options
- Design computation improvements
- Scalability improvements
- Resize connected parts
- Change service
- Exclude FAB parts from Autofill tools
- Add or modify a damper
- Split fabrication elements
- Hanger support rod enhancement
- AWWA valves and pumps content
- Space Naming tool integration
Revit 2018, 18.1, 18.2, 18.3

Architecture/platform enhancements
• Multistory Stairs
• Railings
• Coordination Model
• Schedule Groups and Links/Add Parameters to Groups and Links
• Global Parameters
• Geo-referencing
• 3D Shapes
• Documentation enhancements
• New content for architects
• Schedule management in Project Browser
• Dynamo Player inputs
• Visual Materials API
• Section Box Controls
• Project Browser Expand Collapse
• Fill Pattern Enhancements
• Location of the Last Family Loaded
• Column Width spacing in Type Properties dialog
• Initiate collaboration
• Scope boxes sort alphanumerically

Structural engineering enhancements
• New steel connection types
• Steel connections for user defined framing families
• Priority of elements in steel connections
• Enhanced interoperability between Revit and Advance Steel
• Rebar placement in free form concrete objects
• Improved varying rebar distribution
• Graphical rebar constraints in 3D Views
• Rebar placement in imported concrete elements
• Free form rebar distribution for curved civil structures
• Additional steel content
• Autodesk Structural Precast Extension for Revit
• New Precast content
• Rebar content update for France and Germany

MEP design & fabrication enhancements
• Closed Loop Hydronic Analysis
• Analytical Connections
• Outdoor Air on Space and Buildings Types
• Custom Space and Building Types
• Circuit Pathway
• Multipoint routing for Fabrication
• Sloped Pipe part by part modeling for Fabrication
• Sloped pipe in Multipoint Routing
• Dynamic Holes
• Fabrication Reports and Worksheets
• API for Centerline Length on Fabrication Parts
• API for creating a MAJ file
• P&ID Modeler for Revit
• Direction Arrows on Duct and Pipe Connectors
• MEP Fabrication Change Service
• MEP Fabrication Change Size
• MEP Fabrication Solid Fill
• Pipe sizing improvements
Revit 2019, 19.1, 19.2

Automate
- Precast automation for lattice girder slabs
- API for precast automation

Modernize
- Tabbed views
- Improved docking and tiling
- Multi-monitor support
- Levels in 3D views
- Material appearances
- Improved work with perspective views
- Scope box improvements
- Improved work with perspective views
- Section view align and snapping
- Resizable dialog boxes

Optimize
- New engine in Autodesk Rendering
- Move Objects Small Distances

Strengthen
- OR in filters
- Background fill patterns
- Vertical text alignment improvements
- Views usability improvements
- File version in Open dialog

Inform
- Parallel Pump Set
- Complex piping networks

Connect
- Improvements for IFC support
- Revit Home
- Site Collaboration
- IFC links with Desktop Connector (BIM 360)
- Cloud Models for Revit
- Publish Cloud Models on Revit Home
- Cloud Model Upgrade
- Site Collaboration Enhancements
- Extended CAM Export
- Unitechnik 7.0 CAM Export

Create
- Dimensions for curved objects in section views
- Split railings
- Detailed Steel Design
- Standard and Custom Connections
- Documentation with steel details
- Free form rebar shape matching
- New content
- Free form rebar aligned distribution
- Move and rotate surface pattern on the top of a wall
- Import solid background patterns from CAD
- Zoom In Schedules
- High Resolution Texture Support
- Place Multiple Instances of Images
- Enhanced Custom Fabric Sheets Creation
- New Precast hollow-core slabs (HCS) families
- Fabrication Modeling Enhancements
- Modify Top/Bottom Elevation
Revit 2020, 20.1

Connect
- PDF Into Revit
- Publish Cloud Model on Revit Home
- Cloud Models for Revit Update
- Support for Sketchup 2018 and 2019 Import and Link
- Revit Extension for Fabrication Exports
- BIM 360 Design Sync Activity Indicator

Create
- Elliptical Walls
- Improved Rebar Copy & Move Logic
- Multi Rebar Annotation to Concrete Faces
- Multi Rebar Annotation for Free Form Rebar
- Rebar in Model-in-place Stairs
- Steel Connections Propagation
- Steel Connections Grouping
- Tags & Dimensions of Steel Elements
- Electrical Homerun Wiring Improvements
- New Rebar-to-Rebar Constraint Types
- Intuitive Rebar Constraints Visualization and Editing
- Rebar Constraints Editing Performance Improvements
- Precast Automation for Double Walls

Optimize
- Path of Travel and Enhancements
- Improved OR in View Filters
- Material Appearance Improvement
- Material User Interface Improvements
- Image and PDF improvements
- Tag, Schedule and View Filter for Elevation
- Track and Edit Scope Box Parameter in View List
- Copy and Paste Legends Across Sheets
- Create Parts from Imported Geometry
- InfoCenter Reduction
- Dynamo 2.1 Ships with 2020
- Steel Connections for Dynamo
- Enhanced Performance for Detailed Steel Models
- Additional Parameters for Steel Components
- Electrical panel feed through lugs connection
- Change Service Improvements
- MEP Systems Analysis Features and Framework
- Row Striping in Schedule View
- Attach Walls Dialogue Enhancement
- Expose Survey Point and Project Base Point for Linked Models
Taking Structures Further
Agenda, Part 2

- E2: From Design to Detailing
- E3: Complete the Detailing
- E4: Create and Update Deliverables

Conclusion

Q&A
E2: From Design to Detailing
Revit to Advance Steel
1. Open **05 - Part 2 Start.rvt**.
2. Go to **Add-Ins** then select **Advance Steel Extension > Export**.
3. Select the **Advance Export**.
4. Save the file onto the desktop as **06 - Part 2 Start.smlx**.
5. Switch to Advance Steel and open a new drawing.
Some nomenclature in Revit is noted differently than Advance Steel. Use the Material Conversion Dialog to convert these; this creates an entry in the Advance Steel database that is remembered.

<table>
<thead>
<tr>
<th>Revit</th>
<th>Advance Steel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concrete – Cast-in-place Conc</td>
<td>Concrete</td>
</tr>
<tr>
<td>Metal – Steel – ASTM A992</td>
<td>A992</td>
</tr>
<tr>
<td>HSS6x6x6x0.500</td>
<td>HSS6X6X1/2</td>
</tr>
</tbody>
</table>
6. On the **Export & Import** tab, choose **Revit Import**.
7. Select **06 - Part 2 Start.smlx**.
8. Confirm any required mappings.
9. Go to **Zoom Extents** to see the entire model.
10. Change the **Visual Style** to **X-Ray** and set the **Opacity** to 25%.
11. Right-click on the 3\(^{rd}\) floor slab and choose **Isolate > Hide Objects**.
12. Repeat to hide the 4\(^{th}\) Floor Slab.
13. Right-click on any Beam and select **Advance Properties**.
14. Change its **Section** to **W10x22**.
15. Examine other properties and attributes.
16. Save as or load **07 - Part 2 Imported.dwg**.
17. Synchronize other changes from Revit since the last import by going to **Revit > Synchronize**.
18. Load **08 - Part 2 Revised.smlx**.
19. Scroll to the bottom of the list to identify any beams to be added (shown in green).
20. Check the box then click **Apply All Actions** to incorporate the changes into the model without affecting any change made since the last import.
21. Notice how a new beam appears that had been added in Revit separately.
E3: Complete the Detailing
Advance Steel
E3: Edit Existing Connection

1. Save the model as **08 - Part 2 Revised.dwg** or load it from datasets.
2. Identify the Clip Angle Connection Shown
3. Right-click on the Clip Angle and select 'Advance Joint Properties'.
4. Change the Back Mark to 2½“ (Horizontal Bolts Tab).
5. Save to the library.
E3: Add Connections

6. Add a **Shear Plate Connection** by finding it the **Connection Vault**. Find the **Shear Plate** connection.
7. Click the **Column** first. Then right-click to progress, then click the **Beam** to be connected, then right-click to end the command.
8. A Parametric Dialog should also appear. Go to **Joint Design** then click **Check**.
9. Click **Report** to see the Calculation.
10. Create a Unique Connection from **Connection Vault Connections** by adding a **Stiffener** to the Column.

11. Select the **Column**, then right-click, then select the lower edge of the beam bottom flange.

12. Change the **Plate Thickness** to **3/16”** to match the beam flange thickness and set the **Plate Alignment** to ‘**bottom’**.

13. Add a Custom **Cap Plate** next by setting the **UCS** to the Top of the column.

14. Use the **Plate by 2 Points** tool on the Objects Page of the Home tab to define the plate size.

15. Snap to diagonally opposite points.
16. Change the plate thickness to 3/16”.
17. Add a **Galvanizing Drain Hole** using the **Bolts** Command.
18. Switch the **Bolt Type to Hole** on the Objects Tab, Switch Page.
19. Then **Select Rectangular, 2 Points** from the Connection Objects Page.
20. Select the plate, then the diagonally opposite 2 points.
21. Change the **hole diameter** to 3/16” then set the **Intermediate Distance X** to 1/2” and **Intermediate Distance Y** as 7”.

E3: Custom Connection (Holes)
22. Finally, add a **Point Weld** to create the Assembly.

23. Select the **Column** first, then the **Plate** then locate the point weld at the center of the connection.

24. Check that the Plate is Shop welded by using the 'Display Objects Connected In Shop' command on the Selection Toolbar.

25. Objects that show highlighted in red will appear on the shop drawing for the assembly selected.
E4: Create & Update Deliverables
Advance Steel
1. Open 09 - Part 2 Connected.dwg to catch up.
2. Select Numbering from the Home tab.
3. Check Process Single Parts and Process Assemblies, then click OK.
4. Using the traditional method, numbers are marked as Prefix#Internalxx until elements are assigned to drawings.
5. Go to Drawing Processes and select ‘All Assemblies with Parts Each (ANSI B to ANSI E)’.
6. Press OK to accept the settings on the next dialog.
Method Comparison

Traditional Detailing
• Less Paper Printed
• More Suited to Manual Drafting

Modern Manufacturing
• Simpler Drawings
• More Suited to Electronic Delivery
E4: Viewing Drawings

7. Wait for processing to finish then open the Document Manager from the Home tab and Update all the labels by right clicking on Update Required.

8. Close Document Manager and return to the column with the custom cap plate in the mode.

9. Select it, then right-click on it and choose Show Assembly Detail to open its Assembly Drawing.

10. Clean up the drawing by moving Views (green bordered areas) or managing dimension placement using their grips.
11. Close the drawings and go back to the model.
12. Open 10 - Part 2 Drawings.dwg to catch up.
13. Change the thickness of the Column Stiffener to 1/4” by editing its Advance Joint Properties.
14. Go back to the Document Manager and right-click on the Column Drawing that shows as ‘Update Required’ - Note: The drawing number may differ.
15. Right-click on the Assembly Drawing and Select Update Revision.
16. Click Add and enter an Author and Description.
17. Click OK and OK again in the next dialog. The new drawing will now show the revision suffix and red clouds will highlight where changes were applied.
Conclusions
Delivering Value
Authoring and Coordination
Analysis
Prefabrciation
Q&A
A Better Structural Workflow