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Learning Objectives





Discover the benefits of specialized AutoLISP editors over plain text editors
Learn how to create and format LSP files with the Visual LISP editor and VS Code
Learn how to debug using the tools of the Visual LISP editor and VS Code
Learn how to manage and secure source code with AutoLISP projects

Description
Whether you are new to AutoLISP programming or not, the right editor can make a big
difference. There are many different editors that can be used to edit AutoLISP (LSP) files, some
are plain text editors with no specialized features while others are specially designed to
understand the syntax of the AutoLISP programming language. There are two specialized
editors that Autodesk currently supports for AutoLISP development: Visual LISP® Integrated
Development Environment (IDE) and Microsoft Visual Studio (VS) Code. Both editors offer
several tools for editing, formatting, and debugging AutoLISP files. During this session, you will
learn about the many features that the VLIDE and VS Code editors offer to improve the writing
and managing of LSP files. If you are already a user of the VLIDE, you will learn how to use VS
Code to work with AutoLISP files.

Speaker(s)
Lee Ambrosius is a Principal Learning Experience Designer at Autodesk, Inc., for the
AutoCAD® and AutoCAD LT products on Windows and Mac. He works primarily on the
customization, developer, and CAD administration documentation along with the user
documentation. Lee has presented at Autodesk University for about 15 years on a range of
topics, from general AutoCAD customization to programming with the ObjectARX technology.
He has authored several AutoCAD-related books, with his most recent project being AutoCAD
Platform Customization: User Interface, AutoLISP, VBA, and Beyond. When Lee isn't writing,
you can find him roaming various AutoCAD community forums, posting articles on his or the
AutoCAD blog, or tweeting information regarding the AutoCAD product.
Twitter: @leeambrosius
Email: lee.ambrosius@autodesk.com
Blog:
http://hyperpics.blogs.com
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Introduction

The AutoCAD program is an extensive 2D drafting and 3D modeling program that has grown in
functionality since it was first introduced almost 40 years ago back in 1982. AutoCAD is a
platform at its core, which means that AutoCAD is highly extensible through customization and
automation. While AutoLISP wasn’t part of AutoCAD’s very early days, it wasn’t long before it
become one of the program’s essential features and one of the cornerstones of AutoCAD being
a platform.
AutoLISP was introduced in 1986 with AutoCAD 2.18 and it powered several AutoCAD features
after its introduction. Although AutoLISP is never or rarely used in new AutoCAD feature work
anymore, it is still used by many of the programs that make up the Express Tools and tens of
thousands (maybe hundreds of thousands or millions) of programs created by AutoCAD users
to automate everyday drafting workflows.
AutoLISP is an interpreted programming language, so programs created with the programming
language don’t need to be created or compiled with a specific software before being loaded into
AutoCAD. Because there wasn’t a specific software requirement to develop AutoLISP programs
in the early days, it wasn’t uncommon to find developers using a DOS text editor like Edlin or
something as basic as Notepad on Windows or TextEdit on Mac OS.
Even though Autodesk never felt the need to create a custom editor for AutoLISP development,
third-party developers did notice a gap in the market that several popular editors filled, such as
LispPad by Tony Tanzillo, LispLink by CAE-Link Corporation and Vital LISP by WSSW. I
personally started with Notepad, then moved to LispPad which offered a variety of features that
made AutoLISP development much easier, such as parenthesis balancing and color syntax for
elements in code statements.
Autodesk eventually purchased Vital LISP in the later 1990s and make it available for AutoCAD
R14 before renaming it to Visual LISP and including it with AutoCAD 2000. The inclusion of
Visual LISP with AutoCAD, did cause many third-party developers to slow and eventually end
development of their own AutoLISP editors but some remained popular for many years.
After the inclusion of Visual LISP, until the release of AutoCAD 2021, Autodesk hadn’t put much
effort into the AutoLISP development environment. With AutoCAD 2021, Autodesk announced
the retirement of Visual LISP as the aging code base was too difficult to update to properly
support Unicode and Mac OS. In 2020, Autodesk shipped the first release of the AutoCAD
AutoLISP Extension for Visual Studio (VS) Code in parallel with the release of AutoCAD 2021based products.
The AutoCAD AutoLISP Extension, unlike Visual LISP, is supported on both Windows and Mac
OS. With the AutoLISP development environment being separated from the AutoCAD program,
new features can be released more frequently for the extension. This has already been
demonstrated with an updated version of the AutoCAD AutoLISP Extension being released
shortly after AutoCAD 2021 shipped containing several user requested enhancements.
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As part of this session, I will be discussing the following editors and how they can be used to
develop and debug AutoLISP programs:
Editor

Supported releases

Notepad

All releases of AutoCAD on Windows

TextEdit

All releases of AutoCAD on Mac OS

Visual LISP

AutoCAD 2000 and later on Windows

AutoLISP Extension for VS Code

AutoCAD 2021 on Windows or Mac OS
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Things You Should Know

Before you get started, you should be familiar with the following items.


Where to find the dataset for this session



Setting up the folder used in the exercises found in this handout



What is the VLISP command and LISPSYS system variable

Where Can I Find the Handout and Additional Files for this Session?
The files for this session are available from the Autodesk University website, these files included
code samples, the PowerPoint, and some additional files.
These steps explain how to download and extract the contents of this session’s dataset:
1. Browse to this session’s page on the Autodesk University website.
Go to https://www.autodesk.com/autodesk-university/conference/overview and search
on the session ID SD468505.
2. In the search results, click the entry for this session.
3. On the session’s page, click Downloads and then click Presentation and Additional
Materials.
4. Once downloaded, extract the Additional Materials to:
C:\Dataset\SD468505
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Setup the Folder Used by the Exercises
The exercises throughout this handout expect you to have created an AutoLISP Files folder
under the Documents folder of your operating system (OS). You can choose to store the LSP
files created as part of these exercises in a different folder, just remember to use your folder
instead of the AutoLISP Files folder.
The following steps explain how to create a folder named AutoLISP Files:
Windows
1. Do one of the following:


(Windows 8.1) On the Windows Start screen, type explorer and click File Explorer.



(Windows 10) Right-click over the Windows Start menu button and choose File
Explorer.

2. In File Explorer, click in the Address bar, type Documents and press Enter.

Page 4

3. Click Home tab > New panel > New Folder.

4. In the in-place editor, type AutoLISP Files for the name of the new folder and press
Enter.
Mac OS
1. In Finder, on the Mac OS menu bar, click Go menu > Documents.

2. In the Documents window, click the Perform Tasks with the Selected Items menu.

3. From the drop-down menu, choose New Folder.
4. In the in-place editor, type AutoLISP Files for the name of the new folder and press
Enter.

VLISP Command and LISPSYS System Variable
The VLISP command is used to open the default AutoLISP development environment based on
the current value of the LISPSYS system variable. When the LISPSYS system variable is set to
0, Visual LISP is used to edit and debug LSP files, while VS Code is used when LISPSYS is set
to 1 or 2. The difference between the values of 1 and 2 is the support for ASCII or Unicode LSP
files. After changing the value of the LISPSYS system variable, the AutoCAD program must be
restarted to load the proper AutoLISP engine.
Note: This command and system variable are available on Windows only.
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Notepad and TextEdit; Basic Editors

If you are new to AutoLISP development, starting with a familiar editor can be the best
approach. Even though Notepad on Windows and TextEdit on Mac OS might not be feature
rich, they do allow you to focus on learning the basics of AutoLISP programming and less on
learning a new software application at the same time. As a seasoned AutoLISP developer, I still
find myself launching Notepad when I need to write a simple AutoLISP program.
I suggest moving to learning either Visual LISP or the VS Code with the AutoCAD AutoLISP
Extension installed after you have a basic understanding of AutoLISP programming and how to
work with AutoLISP (LSP) files in AutoCAD. While those two editors will make it easier to
develop AutoLISP programs, there are key concepts that you need to understand when working
with LSP files in the AutoCAD program.
In this section, I focus on how to use Notepad and TextEdit as editors to work with LSP files
along with several other core concepts needed to load LSP files into AutoCAD. For those that
have been working with AutoLISP files for a while, most of the information in this section will be
a refresher, but you might pick up a few things along the way.

Create AutoLISP (LSP) Files
AutoLISP (LSP) files are used to store AutoLISP statements so they can be loaded into and
executed within an AutoCAD session, repeatedly. LSP files are plain-ASCII or Unicode text files
that can be created with Notepad or TextEdit, but how to create an LSP file might not be
obvious.
Note: Starting with AutoCAD 2021, LSP files can be saved in the Unicode file format. When a
LSP file is saved as a Unicode file format, it can’t be loaded into AutoCAD 2020 and earlier.
After an LSP file is opened in the editor, you can use the tools available to edit the AutoLISP
statements you type in the editor window. Both Notepad and TextEdit allow you to


Find/replace text strings



Move and duplicate text strings with the Clipboard



Control the font size of the editor window

That’s pretty much the core of the features that are beneficial for writing LSP files, but these can
be great editors to start with as they have a very small learning curve.
The following steps explain how to create an LSP file and add some AutoLISP statements:
Windows
1. Do one of the following:


(Windows 8.1) On the Windows Start screen, type note and click Notepad.



(Windows 10) From the Windows Start menu, click Windows Accessories >
Notepad.

2. In Notepad, click File menu > Save As.
3. In the Save As dialog box, browse to the Documents > AutoLISP Files folder or the
folder in which you want to store the LSP file.
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Note: I explained how to create the AutoLISP Files folder earlier in the Setup the Folder
Used by the Exercises section.
4. In the File Name text box, type helloworld.lsp.
5. Click the Save As Type drop-down list and select All Files (*.*).
6. Click the Encoding drop-down list and choose ANSI. Click Save.
7. In the editor area, enter the following
(defun c:helloworld ( / msg)
(setq msg "Hello World!")
(alert msg)
)
(prompt "\nAutoLISP sample file loaded.")
(princ)
8. Click File menu > Save.
Mac OS
1. In Finder, on the Mac OS menu bar, click Go menu > Applications.
2. In the Applications window, double-click TextEdit.
3. Close the default document
4. In TextEdit, on the Mac OS menu bar, click TextEdit menu > Preferences.
5. In the Preferences dialog box, do the following:
a. Under Format, check Plain Text.
b. Under Options, clear Check Spelling as You Type and Correct Spelling
Automatically.
6. Click Close.
7. On the Mac OS menu bar, click File menu > New and then click File menu > Save.
8. In the Untitled dialog box, browse to the Documents > AutoLISP Files folder or the folder
in which you want to store the LSP file.
I explained how to create the AutoLISP Files folder earlier in the Setup the Folder Used
by the Exercises section.
9. In the Save As text box, type helloworld.lsp.
10. Clear the If No Extension is Provided, Use “.TXT” checkbox.
11. Click Save.
12. If prompted to use the .lsp file extension, click Use .LSP.
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13. In the editor area, enter the following
(defun c:helloworld ( / msg)
(setq msg "Hello World!")
(alert msg)
)
(prompt "\nAutoLISP sample file loaded.")
(princ)
14. On the Mac OS menu bar, click File menu > Save.

Load an LSP File into AutoCAD
After you have created an LSP file, or maybe you found one online you want to use, you will
need to load the file into AutoCAD before you can use any of the defined AutoLISP functions.
The Load/Unload Applications dialog box is one of the common ways to load an LSP file.
Note: If you want to load an LSP file each time AutoCAD starts up, you can add the file to the
Startup Suite in the dialog box.
The following steps explain how to load an LSP file:
1. Launch AutoCAD on Windows or Mac OS.
2. Do one of the following:


In AutoCAD for Windows, on the ribbon, click Manage tab > Applications panel >
Load Application.



In AutoCAD for Mac OS, on the Mac OS menu bar, click Tools > Load
Application.

3. In the Load/Unload Applications dialog box, browse to the Documents > AutoLISP Files
folder or the folder in which you stored the helloworld.lsp file.

4.

Click Load.
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5. If the File Loading – Security Concern dialog box is displayed, click Load Once.
6. Click Close (or Open on Mac OS) to return to the application window.
The following message should appear in the Command window.
AutoLISP sample file loaded.
7. At the Command prompt, enter helloworld.
A message box is displayed with the text string “Hello World!”.
8. Click OK to dismiss the message box.

Include Support Paths and Trusted Locations for AutoLISP Files in AutoCAD
Starting with AutoCAD 2016, there has been an increased effort to secure and protect the
AutoCAD program from malware and malicious code. One of these security enhancements was
the inclusion of trusted locations. Trusted locations are folders from which AutoCAD can safely
load LSP and other executable files.
If an LSP file is load from an untrusted location, AutoCAD will ask you if it is safe to load the file.
AutoCAD will also inform you if an LSP file being loaded from a trusted location hasn’t been
digitally signed, and if it is okay to continue loading the file as an additional layer of security.
Note: It is recommended to digitally sign the LSP files you create before sharing them with
others, this will let someone know if the LSP file was altered after it was signed indicating it isn’t
safe to load the file. You can learn more about digitally signing a LSP file in the AutoCAD
Developer Documentation help at https://help.autodesk.com/view/OARX/2021/ENU/.
The following steps explain how to add a folder to the support paths and trusted locations in the
AutoCAD program:
Windows
1. In AutoCAD, click the Application menu > Options.
2. In the Options dialog box, Files tab, select the Support File Search Path node.

3. On the right side, click Add and then click Browse.
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4. Do one of the following:


AutoCAD 2021: In the Browse for Folder dialog box, browse to the Documents >
AutoLISP Files folder. Select the AutoLISP Files folder and click Open.



AutoCAD 2020 and earlier: In the Browse for Folder dialog box, browse to the
Documents > AutoLISP Files folder. Select the AutoLISP Files folder and click
Open.

5. On the Files tab, select the Trusted Locations node.

6. On the right side, click Add and then click Browse.
7. In the Browse for Folder dialog box, browse to the Documents > AutoLISP Files folder.
Select the AutoLISP Files folder and click Open.
8. In the Trusted File Search Path – Security Concern dialog box, click Continue.
Note: Normally, you want to make sure a trusted location is marked as read-only to
protect your LSP and executable files from being altered.
9. Click OK to apply the changes made.
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Mac OS
1. In AutoCAD, on the Mac OS menu bar, click AutoCAD <release> > Preferences.
2. In the Options dialog box, Files tab, select the Support File Search Path node.

3. On the bottom, click (+) Add.
4. In the Browse for Folder dialog box, browse to the Documents > AutoLISP Files folder.
Select the AutoLISP Files folder and click Open.
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5. On the Files tab, select the Trusted Locations node.

6. On the bottom, click (+) Add.
7. In the Browse for Folder dialog box, browse to the Documents > AutoLISP Files folder.
Select the AutoLISP Files folder and click Open.
8. Click OK to apply the changes made.

Open AutoLISP (LSP) Files
Once you have created an LSP, you will most likely need to modify the AutoLISP statements
stored in the file at some point.
The following steps explain how to open an LSP file in Notepad on Windows or TextEdit on Mac
OS:
Windows
1. Do one of the following:


(Windows 8.1) On the Windows Start screen, type note and click Notepad.



(Windows 10) From the Windows Start menu, click Windows Accessories >
Notepad.

2. In Notepad, click File menu > Open.
3. In the Open dialog box, click the Save As Type drop-down list and choose All Files (*.*).
4. Browse to and select the LSP file you want to open. Click Open.
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Mac OS
1. In Finder, on the Mac OS menu bar, click Go menu > Applications.
2. In the Applications window, double-click TextEdit.
3. In TextEdit, on the Mac OS menu bar, click File menu > Open.
4. Browse to and select the LSP file you want to open. Click Open.

4

Visual LISP Integrated Development Environment

Notepad is a good editor to use when first getting started with AutoLISP programming, but as
your programs grow, so will your needs for a specialized editor with debugging tools. Visual
LISP is the AutoLISP development environment that ships with AutoCAD 2000 and later.
Note: Visual LISP is only available in AutoCAD for Windows. If you use AutoCAD for Mac OS,
proceed to the AutoLISP Extension for Visual Studio (VS) Code section.
Visual LISP is designated as obsolete with AutoCAD 2021. While Visual LISP is still available in
AutoCAD 2021, it is best to start using the AutoCAD AutoLISP Extension with VS Code moving
forward. The LISPSYS system variable controls which AutoLISP environment the AutoCAD
program uses. Set LISPSYS to 0 to use Visual LISP as your default AutoLISP environment.
Visual LISP allows you to:


Create and edit AutoLISP source (LSP) and Dialog-Control Language (DCL) files



View AutoLISP statements with syntax highlighting



Format and check AutoLISP statements in an LSP file



Load and debug AutoLISP statements and preview DCL files



Manage LSP files with AutoLISP project (PRJ) files



Compile and protect LSP files into FAS or VLX files
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Launch Visual LISP
Unlike Notepad, Visual LISP is accessible from within the AutoCAD program.
The following steps explain how to launch Visual LISP:
1. Start AutoCAD.
2. In AutoCAD, on the ribbon, click Manage tab > Applications panel > Visual LISP Editor
or enter vlisp at the Command prompt.
3. If you are using AutoCAD 2021, follow one of these steps if the Visual LISP Editor
doesn’t open right away:


If the AutoLISP – Default Environment Not Set message box is displayed, click
AutoCAD Visual LISP and then restart AutoCAD.



If Visual Studio Code is launched, switch back to AutoCAD and enter lispsys at
the Command prompt. Then enter a new value of 0. Restart AutoCAD and
launch the VLISP command again.
Note: The LISPSYS system variable controls which AutoLISP environment is
launched with the VLISP command and when executing AutoLISP programs. For
additional information on the LISPSYS system variable, see VLISP Command
and LISPSYS System Variable.

Create and Open AutoLISP (LSP) Files
Visual LISP allows you to edit LSP, DCL, and several other file types. When you create or open
a file, Visual LISP enables or disables certain tools based on the extension of the file in the
active editor window. LSP is the default file type when a file hasn’t been saved or when a file
without an extension is opened.
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The following steps explain how to create a new LSP file:
1. In Visual LISP, on the menu bar, click File menu > New File.

2. On the menu bar, click File > Save As.
3. In the Save-as dialog box, browse to the Documents > AutoLISP Files folder or the
folder in which you want to store your LSP files.

4. In the File name text box, type vl-samples and click Save.
The default file format should be Lisp Source Files, which will add the .lsp file extension
to the end of the filename you enter.
To open an LSP file, follow these steps:
1. On the menu bar, click File menu > Open File.

2. In the Open File to Edit/View dialog box, browse to the Documents > AutoLISP Files
folder or the folder in which you stored your LSP file.
3. Select vl-samples.lsp or another LSP file to edit and click Open.
If you want to open a different type of file in Visual LISP, click the Files of Type dropdown list and choose the type of file you want to filter on.
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Tip: You can use Reopen on the File menu of Visual LISP to open an LSP file you
worked on previously.

Edit AutoLISP Statements
Once you have created or opened an LSP file in Visual LISP, you can take advantage of several
different tools that make writing AutoLISP programs easier. Visual LISP supports common
editing tools such as find and replace along with the Clipboard like Notepad, but it also offers
specialized tools that assist in writing AutoLISP programs.
Here are some of the tools that simplify the writing of AutoLISP programs with Visual LISP:


Syntax highlighting



Complete word by match or Apropos



List available functions with the Apropos window



Toggle statements as comments



Select elements and statements between parentheses



Save code statements to and insert code statements from an LSP file

Syntax Highlighting
As you type in Visual LISP, characters will appear in different colors based on their meaning.
For example, an open or closing parenthesis appears in red while a valid name of a function
appears in blue, by default.
The following is a list of the font and background colors applied to statements in the editor
window:


String



Symbol/function/variable names



Integer number



Real number



Comment



()

Here is an example of what AutoLISP statements look like in the Visual LISP editor window:
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If you find some of the colors applied to the elements of AutoLISP statements and comments
hard to view, you can change the default colors used.
To change the color of an element, do the following:
1. In Visual LISP, click Tools menu > Window Attributes > Configure Current.

2. In the Window Attributes dialog box, choose an element to change from the Elements
drop-down list.

3. Pick a foreground color from the top row and a background color from the bottom row for
the selected element.
4. Optionally, choose another element and specify the color values for its foreground and
background color.
5. Click OK to accept the change.
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Complete Word
Visual LISP allows you to enter the first few characters of a function or variable name, and then
autocomplete the name by matching a name in the active editor window or one defined in the
active drawing. Using autocomplete can minimize typing and reduce the mistyping of function
names.
The following explains how to match the name of a function with Apropos:
1. Create or open an LSP file if you don’t already have one open.
2. In the editor window, type (co and press Shift+Ctrl+Spacebar.

3. In the list that appears, click COMMAND.

4. Press the Spacebar once and type "._circle" "3,5" 6) to finish the statement.

Tip: If you normally type function names in all lowercase letters, you can have autocomplete
return the function name in lowercase instead of uppercase. To return the function name in
lowercase when using autocomplete, click View menu > Apropos Window. In the Apropos
Window, check Lowercase symbols and click OK.
To match a variable or function name in the active editor window, type the first few characters of
the name and press Ctrl+Spacebar to show the most recently typed word that matches. Press
Ctrl+Spacebar repeatedly to cycle through all matches.

List Functions in Apropos Window
Whether you are new to AutoLISP programming or not, at some point in time you will forget the
exact spelling of a function’s name. The Apropos window makes it easy to scroll through a list of
available functions defined by name in the current drawing. You already used a variant of this
functionality with autocomplete in the previous section.
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The following explains how to get the name of a function with the Apropos window:
1. On the menu bar, click View menu > Apropos Window or click Apropos on the View
toolbar.

2. In the Apropos Window, click in the function match field and type last.

You know there is a function that allows you to get the last entity added to a drawing and
its name contains “last”, but you don’t remember its exact name. You think it is
LASTENT, but that isn’t a valid function name. So searching on part of a function name
can help narrow down the list.
3. Click OK to display the results of the search.
4. In the Apropos Results window, select ENTLAST.
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5. Right-click the item and choose Copy to Clipboard to copy the name of the function to
the Clipboard.

If you are unsure about how to use the function, select the function and then click
the Apropos Results window or right-click over the function and choose Help.

in

6. Close or move the Apropos Results window as desired.
7. Click in an editor window where you want to insert the function name, type an open
parenthesis, and then right-click and choose Paste. Then complete the statement with
any required values and add a closing parenthesis.

Toggle Comments
Comments are used to add information to an LSP file that shouldn’t be executed, such as when
a program was last updated, what certain statements are used for, and disable statements while
debugging. A single semi-colon is used to indicate the start of a comment. When a semi-colon is
added, everything on the same line and to the right of the semi-colon is ignored unless an in-line
comment is defined.
Here are examples of different comment styles you might find and use in an LSP file:
Line comment

; This function is used to create a new layer

Block comment

;;; Program created by Lee Ambrosius
;;; Last updated on: 8/22/2020

Comment after a statement

(command "._circle" PAUSE 3) ; Create circle w/ radius of 3
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In-line comment

;| Program created by Lee Ambrosius
Last updated on: 8/22/2020 |;

Note: A line comment can start with more than one semi-colon. When adding a comment using
the tools in Visual LISP, the selected lines are prefixed with three semi-colons.
You can mark selected lines as comments manually by adding a semi-colon to the left of the
text, or you can use the following tools to mark/unmark one or more selected lines as
comments:


Mark selected lines as comments: Click Edit menu > Extra Commands > Comment
Block or click Comment Block on the Tools toolbar.



Unmark selected lines as comments: Click Edit menu > Extra Commands >
Uncomment Block or click Uncomment Block on the Tools toolbar.

Select between Parentheses
There will be times when you will want to select all elements or statements between an open
and its matching closing parenthesis. Instead of manually locating either the matching open or
closing parenthesis, Visual LISP provides tools to select all elements and statements either
backwards or forwards from a parenthesis.
To select the elements or statements between an open or closing parenthesis, do one of the
following:


Select closest closing parenthesis to matching open parenthesis: Click adjacent to
a closing parenthesis, and then click Edit menu > Parentheses Matching > Select
Backwards.



Select closest open parenthesis to matching closing parenthesis: Click adjacent to
an open parenthesis, and then click Edit menu > Parentheses Matching > Select
Forwards.

Tip: Along with selecting elements and statements between two parentheses, you can also just
find the matching parenthesis. See the Check AutoLISP Statements section for more
information.

Save and Insert Code Statements
Visual LISP allows you to save selected AutoLISP statements in the active editor window to an
LSP file which can then later be inserted into another LSP file. This can be useful for a
standardized set of comments, a custom error handler, or even statements that are used to load
your utility functions.
The following explains how to save selected AutoLISP functions to a LSP file:
1. In Visual LISP, select the statements you want to save to a LSP file.
2. On the menu bar, click Edit menu > Extra Commands > Save Block As.
3. In the File to Write Block to dialog box, browse to the Documents > AutoLISP Files folder
or another folder which you want to write the LSP file.
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4. Enter a name in the File Name text box.
I suggest prefixing the filename with snippet- and then the intent of the statements. For
example, snippet-load_common_utilities.lsp might be a name to use for a code
snippet that is used to load utility LSP files.
5. Click the Save As Type drop-down list and choose Lisp Source File
6. Click Save.
Once the LSP file has been saved, you can insert it in the active editor window. The following
explains how to insert an LSP file into the active editor window:
1. In Visual LISP, click in the active editor window where you want the statements from the
LSP file to be inserted.
2. On the menu bar, click Edit menu > Extra Commands > Insert File.
3. In the File to Insert dialog box, browse to the Documents > AutoLISP Files folder or
where you saved the LSP file.
4. Click the Files of Type drop-down list and choose Lisp Source Files.
5. Select the LSP file to insert and click Open.
The statements in the LSP file are inserted at the location of the cursor.

Format AutoLISP Statements
Unlike some programming languages, AutoLISP doesn’t require special characters to continue
statements on multiple lines nor does it require the use of whitespace except between function
names and arguments. Whitespace in an LSP file is often in the form of spaces or tabs to indent
nested AutoLISP statements and align arguments and comments. The inclusion of whitespace
can make your programs easier to read and scan for missing parentheses.
Unlike Notepad, Visual LISP understands the AutoLISP programming language and contains
several tools and aids to help format the statements in the active editor window. Here are some
of the editor specific tools that Visual LISP offers to make formatting your LSP files:


Auto indentation of nested statements as you type



Format selected or all statements in the active editor window

After you type an AutoLISP statement and press Enter, Visual LISP automatically indents the
next line if the previous AutoLISP statement isn’t properly closed. By properly being closed, I
mean there are more open parenthesis than closing parenthesis in the file. The number of
spaces for the indentation varies, from two spaces to as many as it takes to align the cursor with
the first open parenthesis that is encountered when searching backwards.
Automatic indenting is nice for new statements as they are typed, but that doesn’t help to format
statements in an LSP file that weren’t previously formatted, or statements that were
copied/pasted from one file to another. Visual LISP allows you to quickly format select or all
statements in the active editor window, making it seem like the AutoLISP statements were
initially typed using Visual LISP.
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The following explains how to format selected statements or all statements in the active editor
window:


Format selected statements: Select the statements you want to format, and then click
Tools menu > Format Code in Selection or click Format Selection on the Tools toolbar.



Format all statements: Set focus to the window that contains the statements you want
to format, and then click Tools menu > Format Code in Editor or click Format Edit
Window on the Tools toolbar.

The following image shows the before and after of formatting AutoLISP statements with the
Format Code in Selection tool.

Tip: You can control some of the formatting settings of AutoLISP statements in the Format
Options dialog box. See the Customize the VL IDE section for more information.

Check AutoLISP Statements
Visual LISP gives you some real-time feedback about problems with your AutoLISP statements
through syntax highlighting and auto-indenting. For example, if you are missing a double
quotation mark to define a string value, a magenta coloring will be applied to more than just the
string value. Also, if you are missing a closing-parenthesis, when you go to try the next line, you
might see Visual LISP indent the next line unexpectedly.
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While those are examples of real-time check of AutoLISP statements as they are typed, Visual
LISP also provides a way to check the syntax of selected or all AutoLISP statements in the
active editor window.
The following explains how to check the syntax of selected or all statements in the active editor
window:


Check selected statements: Select the statements you want to check, and then click
Tools menu > Check Selection or click Check Selection on the Tools toolbar.



Check all statements: Set focus to the window that contains the statements you want
to check, and then click Tools menu > Check Text in Editor or click Check Edit Window
on the Tools toolbar.

If an error with the syntax is found, a message about the type of error found will be displayed in
the Build Output window. Double-click the error message to try and highlight where the error
was found in the syntax of your AutoLISP statements.
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Tip: It shouldn’t take very long to complete the check of an LSP file. If the message ; Check
done. doesn’t get displayed in the Build Output window, multiple errors might have been
encountered that are causing problems with the checker to finish. Try to select several
statements and then check those, if those are successfully checked, then select and check
more statements until you find the improperly formatted statement.

Load AutoLISP Files
After you have written and checked your AutoLISP programs for syntax errors, and before you
can debug your programs, you will need to load your programs into AutoCAD. Visual LISP
allows you to load/execute:


Selected statements in AutoCAD



All statements in the active editor window into AutoCAD



A single statement in the Visual LISP Console window

The following explains how to load selected or all statements in the active editor window into
AutoCAD:


Load selection: Select the statements you want to load, and then click Tools menu >
Load Selection or click Load Selection on the Tools toolbar.



Load active edit window: Set focus to the window that contains the statements you
want to load, and then click Tools menu > Load Text in Editor or click Load Active Edit
Window on the Tools toolbar.

The Visual LISP Console window is like the AutoCAD Command prompt, it can be used to
execute AutoLISP statements and query variables. The following demonstrates how to execute
AutoLISP statements in the Visual LISP Console:
1. In Visual LISP, click View menu > LISP Console.
2. In the Visual LISP Console window, at the prompt that starts with _$, enter the AutoLISP
statement you want to execute or the variable you want to query.

Note: When using the Visual LISP console you don’t need to prefix a variable with an !
(exclamation mark) to return its current value like you do when querying a variable’s
value at the AutoCAD Command prompt.
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Debug AutoLISP Files
Debugging is the process of loading your programs into an environment, in this case the
AutoCAD program, and then evaluating them as they execute. The debug tools are where the
true value is when using an editor that is designed for AutoLISP programming. While
debugging, Visual LISP allows you to interrupt execution on a specific line, at a specific
statement, or when an error occurs. While execution is interrupted, you can step through each
statement as it is being executed and watch the return value of the statement being evaluated
along with the current value of any previously defined variables.
Visual LISP offers the following features that you can use to debug your custom programs:


Breakpoints – Interrupt the execution of a custom program and allow you to step
through and evaluate variables and expressions.



Break on Error – Interrupt the execution of a custom program when an error occurs.



Animate – Shows the execution of a custom program one statement at a time. The first
statement is highlighted and then executed with a short pause, the next statement is
highlighted and executed followed by a short pause, and so on until all statements have
been executed.



Watches – Evaluates a statement or variable in the current context.



Trace – Displays the current state of a function while the execution of a custom program
is interrupted.



Inspect – Browse, examine, and modify values.

Note: Some of the code shown/demonstrated in this section can be found in the recurse.lsp file
of the dataset for this session.

Breakpoints
Breakpoints allow you to interrupt the execution of a custom program based on a user-defined
location. While a program is interrupted, you can evaluate the values assigned to variables and
the return value of statements being executed in the current context.
Many of the tools that are used when execution is interrupted by breakpoints can be found on
either the Debug menu or toolbar.



Step Into – Steps into a nested statement or to the next statement.



Step Over – Evaluates the statements between an open and closing parenthesis.
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Step Out – Evaluates all statements between the current statements being evaluated to
the end of the function.



Continue – Resumes normal execution and runs to the end of the function or next
breakpoint/error.



Quit – Ends the current break loop and returns you to the previous break loop, which
might not be the Top-Level break loop.



Reset – Ends all current break loops and returns you to the Top-Level break loop.



Toggle Breakpoint – Adds or removes a breakpoint based on the current location of the
cursor.



Add Watch – Adds a new watch based on the selected statement in the active editor
window to the Watches window.



Last Break – Highlights the expression where the last error occurred.

The following explains the process of using breakpoints:
1. In Visual LISP, open an LSP file.
2. In the active editor window, select the parenthesis where you want to set a breakpoint.
Right-click and choose Toggle Breakpoint.

3. Load the AutoLISP statements in the active editor window into AutoCAD and execute
the function as you normally would from the AutoCAD user interface.
4. Visual LISP highlights the location where execution has been interrupted.

5. Use the Step tools on the Debug menu or toolbar to step through the code.
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6. On the Debug menu or toolbar, click Continue to resume normal execution or Reset to
stop execution.
In Visual LISP, on the menu bar, click View > Breakpoints Window to display the Breakpoints
dialog box. The Breakpoints dialog box allows you to remove or navigate to a set breakpoint.

Break on Error
Interrupts execution when an error occurs and the Break on Error option on the Debug menu is
enabled. When interrupted, you can evaluate the values assigned to the variables in the current
context of the program and see which line the error occurred on by using the Last Break
Source/Last Break option on the Debug menu or toolbar. You can also use the Error Trace
window to get some information on the error encountered as well; click View > Error Trace.

Animate
Slows down the execution of a custom program so you can watch it execute in real-time. Before
you execute your custom program, click Debug > Animate to enable animated debugging mode
and then execute your program like you normally would. Execution starts and then pauses for a
specified increment between the execution of each statement. The increment in which execution
is paused is controlled by the Animation Delay setting in the General Options dialog box.

Page 28

Use the following steps to change the animation delay:
1. On the menu bar, click Tools > Environment Options > General Options.
2. In the General Options dialog box, Diagnostic tab, type a new incremental value
(milliseconds) in the Animation Delay text box. Click OK.

Trace Stack and Trace Stack Window
The trace stack is a temporary record of the functions that are being executed in the current
context while the execution of a program is suspended or after a recent error. The stack is
cleared before a function is invoked from either the AutoCAD Command prompt or the Visual
LISP Console window. As nested functions are called, an element is added to the trace stack
and can be viewed using the Trace Stack window.
The Trace Stack window can be displayed by clicking View > Trace Stack.
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The following explains how to use the Trace Stack window:
1. In Visual LISP, open an LSP file.
You can find the recurse.lsp file in the dataset for this session.
2. In the active editor window, select the parenthesis that you want to set a breakpoint at.
Right-click and choose Toggle Breakpoint.

3. On the Debug toolbar, click Load Active Edit Window.
The LSP file is loaded into AutoCAD.
4. Start the execution function with the breakpoint.
5. On the menu bar, click View > Trace Stack (or click Trace

on the View toolbar).

The Trace window is opened.

6. Use the Step tools on the Debug menu or toolbar to step through the code.

Page 30

7. On the Trace Stack window, click Refresh

to see the current elements on the stack.

8. Right-click an element and click one of the options to get more information about it.

9. On the Debug menu or toolbar, click Continue

to resume normal execution.
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Watches and the Watch Window
Watches allow you to see the value assigned to a variable or returned by a statement in the
current context. It can be helpful to see variable values in real-time as you step through an
interrupted program to try and identify potential problems. The Watch window can be displayed
by clicking View > Watch Window on the menu bar or Watch Window

on the View toolbar.

The following explains how to use the Watches window:
1. In Visual LISP, open an LSP file.
You can find the recurse.lsp file in the dataset for this session.
2. In the active editor window, highlight the variable or statement that you want to watch.
Right-click the highlighted text and choose Add Watch.

3. In the active editor window, set one or more breakpoints; one before and one after the
variable you are watching.
4. Load the LSP file into AutoCAD and execute the function with the breakpoints.
5. Use the Step tools on the Debug menu or toolbar to step through the code.
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6. On the Watch window, review the values currently assigned to the variables or returned
by the expressions.

7. Continue stepping through the code.
8. On the Debug menu or toolbar, click Continue

to resume normal execution.

Right-click over an entry in the Watch window to remove it or get more information about the
value assigned to a variable or returned by a statement.

Inspect and the Inspect Window
Inspecting is the process of accessing additional information about a symbol, value, or
statement. You can inspect values in a Frame Binding window that can be accessed from the
Trace Stack window or an entry in the Watch window.

You can inspect a symbol, value, or expression by doing one of the following:


On the View menu or toolbar, click Inspect
. In the Inspect dialog box, enter the
symbol, value, or expression you want to inspect.



On the Trace Stack or Watch window, right-click an element and click Inspect.

Customize the VL IDE
Visual LISP offers settings that can be used to control the behavior of its editing, formatting, and
debugging tools. Some of these settings were mentioned in earlier sections, but the following
lists those and additional settings that can be changed to affect various features in Visual LISP:


Syntax highlighting and general editor indenting: Click Tools menu > Window
Attributes > Configure Current



Editor font style and size: Click Tools menu > Window Attributes > Font
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Editor and debug settings: Click Tools menu > Environment Options > General
Options



Auto-indenting and code formatting settings: Click Tools menu > Environment
Options > Visual LISP Format Options



Printing and page setup settings: Click Tools menu > Environment Options > Paget
Setup Options

5

AutoLISP Extension for Visual Studio (VS) Code

When Visual LISP was first introduced, it was a robust environment for AutoLISP development.
However, as time passed, it started to lose a few steps along the way when compared to more
modern development environments. Rather than starting with the aging code base of Visual
LISP, Autodesk decided to deprecate Visual LISP and start building an extension for AutoLISP
on top of Visual Studio Code also known as VS Code.
Note: While Visual LISP is still available in AutoCAD 2021, it has been designated as obsolete
and will be removed in a future release. The LISPSYS system variable controls which AutoLISP
environment to use in the AutoCAD program. Set LISPSYS to 2 to use VS Code as your default
AutoLISP programming environment. LISPSYS can also be set to 1 to use VS Code, the
difference is that 1 enables “legacy” ASCII LSP file format and 2 enables Unicode support. Set
LISPSYS to 1 if you need to support multiple AutoCAD releases.
VS Code is a modern development environment that can be extended through extensions
created by Microsoft, third-party developers, and the development community. Extensions add
new tools and language support to VS Code. The Autodesk developed extension for AutoLISP
programming is AutoCAD AutoLISP Extension. The extension can be downloaded and installed
through the Marketplace in VS Code. Both VS Code and the AutoCAD AutoLISP Extension are
supported by AutoCAD 2021 on Windows and Mac OS.
Note: The AutoCAD AutoLISP Extension can be used to write and manage AutoLISP programs
for any AutoCAD release, but the ability to debug AutoLISP programs is limited to AutoCAD
2021 (and future releases).
The AutoCAD AutoLISP Extension for VS Code allows you to:


Create and edit AutoLISP source (LSP) and Dialog-Control Language (DCL) files



View AutoLISP statements with syntax highlighting



Format AutoLISP statements in an LSP file



Load and debug AutoLISP statements in AutoCAD



Manage LSP files with AutoLISP project (PRJ) files



Compile and protect LSP files into FAS or VLX files, AutoCAD Command prompt only
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Here is an AutoLISP source (LSP) file loaded in Visual Studio Code with the AutoCAD AutoLISP
Extension loaded:

Install Visual Studio (VS) Code
Unlike Visual LISP, VS Code isn’t installed with AutoCAD. VS Code is a programming
environment that can be downloaded from Microsoft’s website for free.
The following steps explain how to download and install VS Code:
1. Launch your Web browser and navigate to https://code.visualstudio.com/.
2. On the Visual Studio Code page, click Download and choose the download specific to
your operating system (OS); Windows or Mac OS.
3. After the installer has been downloaded, start the installer, and follow the on-screen
instructions.

Launch Visual Studio (VS) Code
Even though VS Code is a separate program from AutoCAD, once installed, VS Code can be
launched from inside or outside of the AutoCAD program. When you try to launch VS Code from
inside AutoCAD, AutoCAD checks to make sure VS Code is installed along with the AutoCAD
AutoLISP Extension.
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Note: When you launch VS Code outside of AutoCAD, you will have to manually install the
AutoCAD AutoLISP Extension from the VS Code Marketplace.
Note: On Windows, VS Code can be launched from inside and outside of AutoCAD. If you are
using AutoCAD for Mac OS, VS Code can only be started from outside of AutoCAD.

Launch VS Code from Inside of AutoCAD (Windows only)
The following steps explain how to launch VS Code, after it has been installed, from inside
AutoCAD:
1. Launch AutoCAD.
2. In AutoCAD, on the ribbon, click Manage tab > Applications panel > Visual LISP Editor
or enter vlisp at the Command prompt.


If the AutoLISP – Default Environment Not Set dialog box is displayed, click
Microsoft Visual Studio Code and the AutoCAD AutoLISP Extension.



If VS Code isn’t installed, the AutoLISP – Visual Studio Code Environment
Incomplete message box is displayed which allows you to install VS Code and
the AutoCAD AutoLISP Extension.
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Download and install Microsoft Visual Studio Code, and then restart the VLISP
command again.


If VS Code is installed, but not the AutoCAD AutoLISP Extension, it will be
installed automatically for you before launching VS Code.



If Visual LISP is launched, switch back to AutoCAD and enter lispsys at the
Command prompt. Then enter a new value of 2. Restart AutoCAD and launch
the VLISP command again and start with Step 2 again.
Note: The LISPSYS system variable controls which AutoLISP environment is
launched with the VLISP command and when executing AutoLISP programs. For
additional information on the LISPSYS system variable, see VLISP Command
and LISPSYS System Variable.

3. If the Visual Studio Code message box appears, which requests permission to “Allow an
extension to open this URI?”, click Open.

You can choose not to display the message box again by checking the “Don’t ask again
for this extension.” before you click Open.
4. Click OK to acknowledge the information message box on how to start debugging.

Note: While you can launch Visual Studio Code from inside AutoCAD with the VLISP command,
it can also be launched from the Windows Start menu. The only difference is that the messages
shown in Steps 3 and 4 are not displayed. See the next section on launching VS Code from
outside of AutoCAD.
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Launch VS Code from Outside of AutoCAD
The following steps explain how to launch VS Code, after it has been installed, from outside of
AutoCAD:


(Windows 8.1) On the Windows Start screen, type code and click Visual Studio Code.



(Windows 10) From the Windows Start menu, click Visual Studio Code > Visual Studio
Code.



(Mac OS) In Finder, click Go > Applications and then click Visual Studio Code in the
Applications window.

Note: If you launch VS Code outside of AutoCAD, you will need to install the AutoCAD
AutoLISP Extension manually. See the next section on how to install the AutoCAD AutoLISP
Extension from the Marketplace in VS Code.

Install the AutoCAD AutoLISP Extension for Visual Studio (VS) Code
VS Code itself doesn’t know what an AutoLISP source (LSP) file is, but the AutoCAD AutoLISP
Extension does. The AutoCAD AutoLISP Extension can be installed from the Visual Studio
Code Marketplace.
The following steps explain how to install the AutoCAD AutoLISP Extension from the Visual
Studio Code Marketplace:
1. Launch Visual Studio Code.
2. In VS Code, on the Activity Bar, click Extensions (or menu bar, View menu >
Extensions).

3. On the EXTENSIONS pane, in the Search Extensions in Marketplace text box, type
autocad autolisp.
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4. In the Search Results, click Install under AutoCAD AutoLISP Extension.

After a few moments, the extension will be installed. You shouldn’t need to restart VS
Code but if prompted, restart the program.

Quick Tour of VS Code
There are a few things you should know about the VS Code user interface (UI) before you get
started. This is just a quick overview, for more information on the VS Code UI, see the VS Code
website (https://code.visualstudio.com/docs).



Activity Bar – Tabbed interface that allows you to access a variety of the main activities
you can perform with AutoLISP files.



Side Bar – Views or panes that are available based on the context of the current activity.
Tip: Views and panes can be dragged to the Panels area if you want a pane to be
accessible outside the content of the current activity displayed on the Activity Bar.
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Editor Windows – Each file that is open is represented as a tab. The current file is
displayed in the main editor area.
Tip: This area can be split to show more than one editor window at a time. Simply drag a
tab along the top that represents an open file and drop it along one of the edges of the
current editor window. A preview will be displayed showing you how the editor window
will be split. Drop the tab and the window splits.



Minimap – Small visual representation of the lines in the current editor window versus
all the lines loaded in the current editor window.



Status Bar – Information about the current file being edited along with an indicator if you
are currently in Edit or Debug mode.



Panel – General windows that aren’t context sensitive like the views or panes displayed
on the side bar.

Create and Open AutoLISP (LSP) Files
VS Code allows you to create and edit not only AutoLISP source files, but many other types of
files. When you go to create a new file of any type in VS Code, you will need to make sure to
supply a file extension. File extensions are how VS Code makes sure the correct extensions are
enabled for each editor window.
The following steps explain how to create a new LSP file:
1. In VS Code, on the Activity Bar, click Explorer.

2. On the menu bar, click File menu > New File.

This creates a generic text file in a new editor window and displays it in the Open Editors
area of the EXPLORER view.
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3. On the menu bar, click File menu > Save As.

4. In the Save As dialog box, browse to the Documents > AutoLISP Files folder or the
folder in which you want to store your LSP files.
5. In the File name text box, type vs-samples.

6. Click the Save As Type drop-down list and choose AutoLISP (*.lsp; *.mnl) and click
Save.
The file extension .lsp should be appended to the file name you entered.
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To open an LSP file, follow these steps:
1. In VS Code, on the menu bar, click File menu > Open File (or File menu > Open on Mac
OS).
2. In the Open File dialog box, browse to the Documents > AutoLISP Files folder or the
folder in which you stored your LSP files.

3. Select the vs-samples.lsp file, or another LSP file to edit, and click Open.
Tip: You can open LSP files you previously worked on by clicking File menu > Open
Recent.

Work with AutoLISP (LSP) Files in a Folder
While VS Code allows you to work with individual LSP files, it is more efficient to work with LSP
files from the folder level.
The following steps explain how to create a new LSP file:
1. In VS Code, on the Activity Bar, click Explorer.
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2. On the menu bar, click File menu > Open Folder (or File menu > Open on Mac OS).

3. In the Open Folder dialog box, browse to the Documents > AutoLISP Files folder or the
folder in which you want to store your LSP files.
4. Click Select Folder.
All the files in the selected folder are displayed in the EXPLORER view.

5. Click a LSP file in the folder to open it for edit.

Edit AutoLISP Statements
Once you have created or opened an LSP file in VS Code, you can take advantage of the
various tools that will make editing AutoLISP programs easier. Like other editors, such as
Notepad and Visual LISP, VS Code supports general editing tools such as find and replace, and
Clipboard. In addition to the general editing tools, VS Code with the addition of the AutoCAD
AutoLISP Extension provide several specialized tools to make completing AutoLISP statements
easier.
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Here are some of the tools that simplify the editing of AutoLISP programs with VS Code:


Syntax highlighting



Smart brackets



Intellisense which allows you to autocomplete function and variable names



Toggle statements as comments



Select elements and statements between parentheses



Insert code snippets

Syntax Highlighting
As you type in VS Code, characters will appear in different colors based on their meaning. For
example, an open or closing parenthesis appears in white (or black) while standard functions
appear in blue, by default. The default colors will vary based on the current color theme which I
explain later in this section.
The following is a list of the font and background colors applied to statements in the editor
window when the color theme of VS Code is set to Default Light:


String



Function name



Integer or real number



Variable or custom function name



Comment



()

Here is an example of the colors displayed for AutoLISP statements in an editor window:

If you find that the default colors are hard to distinguish or don’t like the dark theme you can
change the color theme that VS Code applies to the application and editor window. The current
theme does impact the syntax highlighting of statements in the current editor window.
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The following explains how to change the color theme of VS Code:
1. In VS Code, click File menu > Preferences > Color Theme (or Code menu > Preferences
> Color Theme on Mac OS).
2. From the Select Theme dialog box, click the theme you want to apply.
Tip: You can preview each theme before you apply it by pressing the Up and Down
Arrow keys. Press Enter to accept the highlighted theme.
Note: While it is possible to change the color of each element type for a color theme, it isn’t as
easy as opening a dialog box and picking a new color for an element like Visual LISP offers. If
you want to modify the color of a specific element, take a look at modifying themes in the VS
Code documentation (https://code.visualstudio.com/docs/getstarted/themes). Another option is
to search the VS Code Marketplace on the keyword theme and see if there is a theme that
better fits your needs (or personality).

Smart Brackets
AutoLISP statements require a balanced pairing of parentheses (one open and one closing
parenthesis) to be valid. When an open parenthesis is typed in VS Code, a closing parenthesis
is automatically added in front of the cursor. This eliminates an extra keystroke, but more
importantly it helps you avoid missing a parenthesis and introducing an unbalanced statement.
Tip: The same concept also applies to quotation mark pairs to represent a string and in-line
comments that you might manually type. When you enter the sequence of ;|, VS Code will
automatically add |; in front of the cursor to make sure the closing sequence for an in-line
comment is not forgotten.

Intellisense
As you type in the active editor window, VS Code will display a list of members that match the
characters you have typed. This functionality is known as Intellisense, and it helps you complete
your code faster and with less errors. The members in the Intellisense list are:


Names of standard AutoLISP functions



Text matches in the active editor window, such as user-defined variables and functions



Code snippets that are user defined or part of the AutoCAD AutoLISP Extension

Note: Icons are used to distinguish between different member types in the Intellisense list.
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The following explains how to use Intellisense:
1. Create or open an LSP file if you don’t already have one open.
2. In the editor window, type (.
Notice the balancing closing parenthesis is automatically added because of the Smart
Brackets feature.
3. In between the parentheses, type setq circ-rad 6.
The completed statement should look like:

4. Press End and then Enter to move to the next line in the editor window.
5. On the new line, type (co.
Intellisense displays a list of members that start with or contain the letters “co”.

6. Do one of the following:


If the command function is highlighted, press Tab.



If the command function isn’t highlight, press the Down Arrow key until the
function name is highlighted and then press Tab.

The statement should currently look like:

7. Press the Spacebar once and type "._ci.
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8. Highlight _circle and press Tab or click _circle with the mouse to autocomplete the circle
command.

The statement should currently look like:

9. Press the Right Arrow key once and then press the Spacebar once.
10. Type "3,5" circ-rad.
The completed statement should look like:

Toggle Comments
Comments are used to add information to an LSP file that shouldn’t be executed, but provide
information about the program, such as when it was last updated, what certain statements are
used for, and to disable statements while debugging. A single semi-colon is used to indicate the
start of a comment, and everything to the right of the semi-colon is ignored that is on the same
line unless an in-line comment is defined.
Here are examples of comments you might find or use in an LSP file:
Line comment

; This function is used to create a new layer

Comment after a statement

(command "._circle" PAUSE 3) ; Create circle w/ radius of 3

Block comment

;| Program created by Lee Ambrosius
Last updated on: 8/22/2020 |;

Note: A block comment is also known as an in-line comment.
You can mark lines as comments manually by adding a semi-colon to the left of the line, or you
can use the following tools to mark/unmark one or more selected lines as comments:


Mark/unmark selected lines as line comments: Click Edit menu > Toggle Line
Comment



Mark/unmark selected lines as a block comment: Click Edit menu > Toggle Block
Comment
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Select between Parentheses
Sometimes you will need to select all elements and statements between balanced parentheses.
VS Code provides two different tools, Expand Selection and Shrink Selection, that allow you to
select all elements and statements either backwards or forwards from a parenthesis until you
reach the balancing parenthesis.
To select the elements or statements between an open or closing parenthesis, do one of the
following:


Match open parenthesis to its balancing closing parenthesis: Click in front of the
open parenthesis, and then press the key combination Shift+Alt+Right Arrow (or
Ctrl+Shift+Cmd+Right Arrow on Mac OS) until the parentheses are selected.



Match closing parenthesis to its balancing open parenthesis: Click behind a closing
parenthesis, and then press the key combination Shift+Alt+Left Arrow (or
Ctrl+Shift+Cmd+Left Arrow on Mac OS) until the parentheses are selected.

Tip: There is a VS Code extension that you can install to improve the selection of elements and
statements between parentheses called “Bracket Pair Colorizer 2”. This extension also applies a
different color to parentheses based on their nested level. I mention this and a few other helpful
extensions under the Install Other Helpful Extensions later in this handout.

Create and Insert Code Snippets
VS Code supports the ability to define what are known as code snippets. Code snippets are
defined as a single or block of AutoLISP statements with a unique name. You might define a
code snippet for a standardized comment block, string values you might commonly use in your
programs, or statement structures you use frequently. Placeholders can be added to a code
snippet. A placeholder is a field that can be filled in during the insertion of the code snippet or
control where the cursor should be positioned after the code snippet has been inserted. The
AutoCAD AutoLISP Extension contains several code snippets to simplify the development of
AutoLISP programs.
The following explains how to insert a code snippet into an LSP file:
1. Create or open an LSP file if you don’t already have one open.
2. In the editor window, type ifp and then press Tab.
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The inserted code snippet should currently look like:

3. In the first placeholder, testexpr, type < 2 3 and press Tab.

4. In the second placeholder, thenexpr, type alert "3 is greater than 2" and press Tab.
The code block should now look like:

In addition to the code snippets that come with the AutoCAD AutoLISP Extension, you can
define your own code snippets in either the autolisp.json or snippets.json file. These two files
can be found under:
Windows


%USERPROFILE%\AppData\Roaming\Code\User\snippets\autolisp.json



%USERPROFILE%\.vscode\extensions\autodesk.autolispext-n.n.n\snippets\
snippets.json

Mac OS


~/Library/Application Support/Code/User/snippets/autolisp.json



~/.vscode/extensions/autodesk.autolispext-n.n.n/snippets/snippets.json

Note: The snippets.json file is specific to each version of the AutoCAD AutoLISP Extension
installed. If the extension is updated, you will need to manually copy/migrate your code snippets
to the latest version of the extension to continue using them. Substitute n.n.n in the
autodesk.autolispext-n.n.n folder with the version of the AutoCAD AutoLISP Extension installed.
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Code snippets are defined using JSON format which stands for JavaScript Object Notation.
JSON files are typically made up of two different elements: objects and arrays. Objects are
defined as name/value pairs and are stored in curly {} brackets. Objects are then stored in
arrays which contain one or more objects separated by commas in square [] brackets.
The following is an example of a custom code snippet for a personalized comment block named
“My Comment Template” and an Intellisense entry of mycomment-template:
"My Comment Template": {
"prefix": "mycomment-template",
"body": [
";| Program created by ${1:Your Name Here}",
"
Last updated on: ${2:Date Here} |;",
"$0"
]
}
You can learn more about the syntax and structure of a code snippet in the VS Code
documentation (https://code.visualstudio.com/docs/editor/userdefinedsnippets).
The following explains how to create a Hello World code snippet:
1. In VS Code, on the menu bar, click File menu > Preferences > User Snippets (or click
Code menu > Preferences > User Snippets on Mac OS).

2. In the User Snippets dialog box, click autolisp.json (AutoLISP).

3. Click to the left of the last closing curly } bracket in the file
4. Press Enter a few times and then click in one of the new blank lines you created.
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5. Type the following:
"Hello World Function": {
"prefix": "helloworld",
"body": [
"(defun c:helloworld (/)",
"
(alert \"Hello World!\")",
")",
"$0"
]
}
Note: If there are any previously defined code snippets in the file, make sure there is a
comma after the close curly } bracket before the code snippet you added.

6. On the menu bar, click File menu > Save.
7. In the editor window of the LSP file, click where you would like to insert the code snippet.
8. Type hello and press Tab.
The code statements defined in the body of the code snippet are inserted and the cursor
is moved to the location indicated by $0 in the code snippet.
(defun c:helloworld (/)
(alert "Hello World!")
)
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Format AutoLISP Statements
AutoLISP statements require some basic formatting to execute properly, such as a space
between function names and argument values, but otherwise they don’t require any other
specific formatting. Even though AutoLISP statements don’t require indenting or the alignment
of statements to execute properly, adding those types of whitespace to your programs does
make them easier to read and scan for improper syntax.
The AutoCAD AutoLISP Extension provides tools that allow you to format AutoLISP statements
in the active editor window. Here are some of the editor specific tools that can be used to format
your LSP files:


Auto indentation of nested statements as you type



Smart brackets and alignment



Format selected or all statements in the active editor window

After you type an AutoLISP statement and press Enter, VS Code automatically indents the next
line if the previous AutoLISP statement was left open. Being left open means there are one or
more closing parentheses that are not in the file yet or are in front of the cursor. The number of
spaces for the indentation varies, from two spaces to as many as it takes to align the cursor with
the first open parenthesis that is encountered when searching backwards.
Automatic indenting is nice for new statements as they are typed but doesn’t help to format
statements that weren’t before being copied/pasted from another file. VS Code allows you to
quickly format select or all statements in the active editor window, making it seem like they were
typed directly into VS Code.
The following explains how to format selected or all statements in the active editor window:


Format selected statements: Select the statements you want to format, and then rightclick in the active editor window and choose Format Selection.



Format all statements: Set focus to the window that contains the statements you want
to format, and then right-click in the active editor window and choose Format Document.

The following image shows the before and after of formatting AutoLISP statements with the
Format Selection tool.
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Tip: You have some control over the settings related to formatting AutoLISP statements. See
the Change Extension Settings section later in this handout.

Configure the AutoLISP Extension to Connect to AutoCAD
Before you can load or debug LSP files from VS Code into AutoCAD, you need to first inform
VS Code how to connect to the AutoCAD program. The connection between VS Code and
AutoCAD is established using a debug configuration. The AutoCAD AutoLISP Extension
supports two different debug configurations: attach and launch.
The following explains the difference between the two debug configurations:


AutoLISP Debug Attach (attachlisp) – Used to connect to a running instance of the
AutoCAD program before VS Code enters Debug mode



AutoLISP Debug Launch (launchlisp) – Used to launch a new instance of AutoCAD
before VS Code enters Debug mode

Tip: Of the two, the Attach debug configuration is more efficient to use as you don’t have to wait
for AutoCAD to restart each time you want to debug your AutoLISP programs.
The following explains how to configure the Debug Attach and Debug Launch configurations:
1. In VS Code, on the menu bar, click File menu > Preferences > Settings (or click Code
menu > Preferences > Settings on Mac OS).

2. In the Settings window, User tab, click Extensions.
3. With Extensions expanded, click AutoCAD® AutoLISP Configuration.
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4. Under AutoCAD® AutoLISP Configuration, change the following setting values:
Windows


Debug: Attach Process = acad



Debug: Launch Program = C:\Program Files\Autodesk\AutoCAD
2021\acad.exe

Mac OS


Debug: Attach Process = AutoCAD



Debug: Launch Program = /Applications/Autodesk/AutoCAD 2021/AutoCAD
2021.app/Contents/MacOS/AutoCAD

5. Close the Settings window.

Load AutoLISP (LSP) Files
After you have written your AutoLISP program and setup the debug configurations for the
AutoCAD AutoLISP Extension, you can now load your AutoLISP program into AutoCAD. VS
Code allows you to load/execute:


All statements in the active editor window into AutoCAD



A single statement in the VS Code Debug Console window
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Load All Statements in an LSP File into AutoCAD
The following explains how to load an LSP file in the active editor window into AutoCAD:
Attach Debug Configuration
1. Launch AutoCAD 2021.
2. In VS Code, set the editor window active which contains the LSP file you want to load.
3. On the menu bar, click Run menu > Start Debugging.

4. In the Debug Configuration dialog box, choose AutoLISP Debug: Attach.

5. In the Process dialog box, choose the AutoCAD application process.

Debug mode should now be active, and the LSP file in the active editor window loaded
into AutoCAD.
6. If you want to load another LSP file from VS Code, open the file and set that window
active. Right-click in the newly activated editor window and choose Load File in
AutoCAD.
7. Switch to AutoCAD and execute you AutoLISP functions or commands as normal.
8. Switch back to VS Code.
9. In VS Code, on the Debug toolbar, click Disconnect to end Debug mode. AutoCAD
remains open.
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Tip: If you make changes to a LSP file while using the attach debug configuration, click Restart
on the Debug toolbar to detach, then reattach to AutoCAD before reloading the LSP file.
Launch Debug Configuration
1. In VS Code, set the editor window active which contains the LSP file you want to load.
2. On the menu bar, click Run menu > Start Debugging.

3. In the Debug Configuration dialog box, click AutoLISP Debug: Launch.

Debug mode should now be active, and the LSP file in the active editor window loaded
into AutoCAD.
4. If you want to load another LSP file from VS Code, open the file and set that window
active. Right-click in the newly activated editor window and choose Load File in
AutoCAD.
5. Switch to AutoCAD and execute you AutoLISP functions or commands as normal.
6. Switch back to VS Code.
7. In the Debug toolbar, click Stop to end Debug mode and close AutoCAD.

Tip: If you make changes to a LSP file while using the launch debug configuration, click Restart
on the Debug toolbar to close and relaunch the AutoCAD program. After AutoCAD is
relaunched, VS Code re-attaches to AutoCAD before loading the LSP file again.
In addition to the Debug toolbar appearing, the status bar also changes from its default color of
Blue to Orange to indicate Debug mode is active.
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Tip: If you switch drawings while VS Code is attached to AutoCAD, whether you used the attach
or launch debug configurations, right-click in the LSP you want to load and choose Use Load
File in AutoCAD.

Load Select Statements from an LSP File into AutoCAD
The Debug Console window in VS Code provides access to the AutoLISP engine while Debug
mode is active. From this window, you can execute AutoLISP statements and query variables.
The following explains how to execute a single AutoLISP statement in the Debug Console
window of VS Code:
1. In VS Code, if you are not in Debug mode already, on the menu bar, click Run menu >
Start Debugging. Connect to AutoCAD using either debug configuration.
2. In the panel along the bottom, click Debug Console.
If not displayed, click View menu > Debug Console.

3. In the Debug Console window, at the prompt, enter the AutoLISP statement you want to
execute or the variable you want to query.
Note: You don’t need to proceed a variable with an ! (exclamation mark) to return its
current value like you do when querying a variable’s value at the AutoCAD Command
prompt.
Tip: Instead of manually entering a variable name or statement into the Debug Console
window prompt, select a variable name or statement from the active editor window, rightclick and then choose Evaluate in Debug Console.

Debug AutoLISP Files
Debugging is the process of loading your programs into an environment, in this case the
AutoCAD program, and then stepping through them as they execute. The debug tools in VS
Code is where you realize the power of using an editor that is designed for AutoLISP
programming. While debugging, VS Code allows you to interrupt execution at a specific
statement or when an error occurs. While execution is interrupted, you can step through each
statement as it is being executed and watch the return value of a statement along with the
current value of local and global variables.
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VS Code offers the following features that you can use to debug your AutoLISP programs:


Break on Error – Interrupts the execution of a custom program when an error occurs.



Breakpoints – Interrupts the execution of a custom program at a specific statement in a
program, allowing you to step through and evaluate variables and statements.



Variables – Evaluates the values of local variables and the last statement.



Watches – Evaluates functions and variables in the current execution context.



Call Stack – Displays the call stack and switching stack frame up to the point where
execution is currently interrupted.

Note: Some of the code shown/demonstrated in this section can be found in the recurse.lsp file
of the dataset for this session.

Break on Error
Interrupts execution when an error occurs in your AutoLISP program, whether a breakpoint is
set or not. This feature is automatically enabled, you don’t need to do anything to take
advantage of this feature. When execution is interrupted, the line in which the error occurred is
highlighted, you can then evaluate currently assign variable values to try and identify the
problem.

Breakpoints
Breakpoints are used to identify where execution should be interrupted when a LSP file is being
loaded or after a custom function defined in a LSP file loaded through VS Code has been called.
When a program is interrupted, you can


Step through and evaluate statements one at a time



Evaluate the current value assigned to local and global variables and the return value of
statements
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You use the tools on the Debug toolbar, while Debug mode is active in VS Code, to advance
execution statement-by-statement and restart or exit Debug mode.



Pause – Not supported for the AutoCAD AutoLISP Extension. Temporarily interrupts the
execution of a program that might be taking a while to complete, which might be the
result of an infinite loop or large dataset.



Continue – Resumes normal execution and runs to the end of the function or next
breakpoint/error.



Step Over – Evaluates the elements between an open and closing parenthesis.



Step Into – Steps into a nested statement or advances execution to the next statement.



Step Out – Evaluates all expressions between the current statements being evaluated
to the end of the function.



Restart – Relaunches or re-attaches VS Code to AutoCAD and then loads/reloads the
LSP file in the active editor window.



Disconnect/Stop – Ends debugging and exits Debug mode.

The following explains the process of using breakpoints:
1. In VS Code, if you are in Debug mode, on the Debug toolbar, click Disconnect or Stop.
2. Set the editor window active which contains the LSP file you want to debug.
3. In the left margin of the editor window, to the left of the line number, click the faded red
circle when it appears to add a Breakpoint.

Clicking a breakpoint again will remove it.
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All set breakpoints appear in the BREAKPOINTS section of the Run view.

Note: You can right-click over a breakpoint and choose Disable Breakpoint. This keeps
the breakpoint in place, but execution isn’t interrupted when it is encountered.
4. Once one or more breakpoints have been added, on the menu bar, click Run menu >
Start Debugging. Connect to AutoCAD using either debug configuration.
5. Execute the function in which the breakpoint was set, in the VS Code Debug Console
window or at the Command prompt in AutoCAD.
6. If needed, switch focus back to VS Code
VS Code highlights the location where execution has been interrupted.

7. On the Debug toolbar or Run menu, use the Step tools to step through each statement
one at a time.
8. On the Debug toolbar or Run menu, click Continue to resume normal execution or
Stop/Disconnect or Stop Debugging to stop execution.
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Tip: In VS Code, on the menu bar, click Run menu > Disable All Breakpoints or Remove All
Breakpoints to disable or remove all breakpoints in the active editor window. This can be more
efficient than disabling or removing each breakpoint one at a time. Click Run menu > Enable All
Breakpoints to enable all previously disabled breakpoints.

Local Variables
While in Debug mode, you can view local variables set within a user-defined function created by
the debug or defun-q functions while execution is interrupted. In this case, a local variable is a
variable defined not just in the function but those listed in the variables argument of the debug
or defun-q functions. Each local variable defined is displayed under Locals on the
VARIABLES section of the Run view as they are set during execution. Once the variables go
out of scope, they are automatically removed from Locals.

Note: You can right-click over a variable entry under Local to copy the name or current value of
a variable to the Clipboard or add it as a watch under the WATCH section.
Tip: You can expand Last Value to view the return value of the last statement evaluated.

Watches and WATCH section
Variables and their current values change as your programs execute. Whether the value is
supplied by the user or comes from an external source such as a file or an AutoCAD drawing,
the point in which variable’s value changes can lead to something unexpectedly happening. VS
Code provides several ways to evaluate the current value of a variable, watches and the
WATCH section on the Run view is the main method.
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The WATCH section allows you to see the current value assigned to a variable and the return
value of AutoLISP statements. The ability to watch variable and statement values is available
when in Debug Mode and the program is interrupted by a breakpoint.

The following explains how to add watches to and use the WATCH section:
1. In VS Code, set the editor window current which contains the LSP file to debug.
2. Add one or more breakpoints before the variables and statements you want to evaluate
under the WATCH section.
See the Breakpoints section earlier this handout under AutoLISP Extension for Visual
Studio (VS) Code.
3. On the menu bar, click Run menu > Start Debugging. Connect to AutoCAD using either
debug configuration.
4. Execute the function in which the breakpoint was set, in the VS Code Debug Console
window or at the Command prompt in AutoCAD.
VS Code highlights the location where execution has been interrupted.
5. If needed, switch focus back to VS Code and click Run on the Activity Bar.
You should see the WATCH section in the middle of the Run view.
6. In the active editor window, highlight the variable or statement you want to watch.
7. Right-click the highlighted text and choose Add to Watch.
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The variable or statement is added to the WATCH section.

Note: Select a watch under the WATCH section and right-click to edit or remove it.
8. On the Debug toolbar, click Step Into or Step Over to step through the code.

As each statement is executed, the variables and statements in the WATCH section are
update accordingly.

9. In the WATCH section, review the values currently assigned to the variables or returned
by the statements.
10. Continue stepping through the code.
11. On the Debug menu or toolbar, click Continue to resume normal execution.
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While in Debug Mode, you can position the cursor over a variable to view its current value
without needing to add it to the WATCH section.

Tip: Panes, such as WATCH or VARIABLES, can be pulled from the Run view, and docked in
the Panels area below the editor windows. This can be useful when watching variables that are
assigned long string or list values which would normally get truncated otherwise in the VS Code
UI.
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Call Stack
As programs are executed, the order in which those programs are executed is maintained on
what is known as the call stack. Using the call stack, you can see which functions have been
called while debugging along with being able to see which variables are local to a specific
function and the current state of execution for the statement being evaluated; before and after
execution. The call stack is displayed in the CALL STACK section on the Run view.

The following demonstrates how to use the call stack:
1. In VS Code, create a new LSP file or open the vs-samples.lsp file created earlier.
2. In the LSP file, enter the following:
(defun main ( / )
(secondary 2)
)
(defun secondary (int / msg)
(setq msg (strcat "\nInteger value: " (itoa int)))
(prompt msg)
)
3. Add breakpoints as show in the following image.
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4. On the menu bar, click Run menu > Start Debugging. Connect to AutoCAD using either
debug configuration.
5. Switch back to VS Code.
6. In the Debug Console window, at the prompt, enter (main).

Execution starts and is interrupted by the breakpoint on the (secondary 2) statement.

7. If the Run view isn’t active, on the Activity Bar, click Run.
8. On the Run view, in the CALL STACK section, you should see MAIN listed which is the
function started from the Debug Console window.
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9. On the Debug toolbar, click Continue to resume normal execution.

SECONDARY should now be listed in the call stack.

10. On the Debug toolbar, click Continue.
SECONDARY is now removed from the call stack since execution has returned to the
main function.
11. On the Debug toolbar, click Disconnect/Stop to end execution.

Change Extension Settings
Earlier I explained how to specify the settings related to the debug configurations used to
connect VS Code to AutoCAD, the AutoCAD AutoLISP Extension provides several other
settings that you can change. These additional settings are related to how AutoLISP statements
are formatted as they are typed or when you use the format tools.
The following explains the settings available for controlling the format of AutoLISP statements:


Close Parenthesis Style – Closing parenthesis is indented to align with the matching
open parenthesis when a statement continues onto a new line, else it is placed on the
same line as the open parenthesis.



Long List Format Style – Each or multiple parameters of a function are placed on
separate lines.



Maximum Line Characters – Maximum number of characters that should be displayed
on each line. Minimum value is 60 characters.



Narrow Style Indent – Number of spaces to use for the indentation of Narrow
Formatting Style which affects nested statements. Valid range is 1 to 6.
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The following explains how to change the format settings of the AutoCAD AutoLISP Extension:
1. In VS Code, on the menu bar, click File menu > Preferences > Settings (or click Code
menu > Preferences > Settings on Mac OS).

2. In the Settings window, User tab, click Extensions.
3. With Extensions expanded, click AutoCAD® AutoLISP Configuration.

4. Under AutoCAD® AutoLISP Configuration, scroll the right column and change the
setting values as desired.

Page 68

5. Close the Settings window.
If you want to change the appearance of the editor window, click File menu > Preferences >
Settings (or Code menu > Preferences > Settings on Mac OS). Then in the Settings window,
expand Text Editor and change the values as desired. Here are some of the common settings
you might want to change:


Font: Controls the font family, size, and weight of the text in the editor window.



Formatting: Controls whether the document is formatted on save or when text is pasted
into an editor window.



Minimap: Controls the appearance and size of the minimap for the editor window.



Files: Controls settings for file association overrides by extension, Autosave, and default
language.
Note: Default language allows you to associate the AutoCAD AutoLISP Extension to
files that have not been saved with a file extension yet. If you are using VS Code
primarily or only for editing LSP files, you can add autolisp to the Default Language
setting. Then when you create a new file it will automatically be recognized as a LSP file
and load AutoCAD AutoLISP Extension.
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Install Other Helpful Extensions
One of the biggest benefits of using VS Code as a development environment is the flexibility it
offers through the ability of adding additional tools through extensions. There are many thirdparty extensions that you might want to install that complement the AutoCAD AutoLISP
Extension.
Here are some of the extensions I have installed and recommend:
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Bracket Pair Colorizer 2 by CoenraadS – Applies different colors to matching
parentheses, making it easier to visually see where the open and closing parenthesis of
a statement are located.



Quick and Simple Text Selection by David Bankier – Improved selection of elements
and statements between open and closing parenthesis and quotation marks.
Ctrl+Shift+M can be used to select the elements between and the balancing
parentheses of a statement which is more efficient than the default Expand/Shrink
selection methods of VS Code.



vscode-position by jtr – Shows the character position of the cursor in the status bar.

Manage and Compile AutoLISP Source with Project (PRJ) Files

AutoLISP source (LSP) files can be managed just like other file types using folders on your local
or network drives; even if you choose to use a source code management system, such as
GitHub. As an alternative to opening individual LSP files in Visual LISP or VS Code to edit and
debug them, or working with a folder in VS Code, you can choose to manage your LSP files with
the AutoLISP Project Manager.
Another thing to consider before sharing your LSP files with others is to make sure they are
backed up and compiled into FAS or VLX files. FAS and VLX files help protect your source code
from alterations.
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Manage LSP Files with a Project (PRJ) File
While managing your LSP files using folders is straightforward, it is not the most efficient
approach. Both Visual LISP and the AutoCAD AutoLISP Extension for VS Code support what
AutoLISP Project files. AutoLISP Project files have a .prj file extension. PRJ files are completely
optional, but they do make editing and compiling LSP files easier if you decide to protect your
source code.
The following steps explain how to create an AutoLISP Project and add LSP files to the project:
Visual LISP (Windows only)
1. In Visual LISP, on the menu bar, click Project menu > New Project.
2. In the New Project dialog box, browse to the Documents > AutoLISP Files folder or the
folder where you want to store the project file.
3. In the File Name text box, enter vl-project and then click Save.
4. In the Project Properties dialog box, in the files list, located below the Look In section,
select each of the LSP files you want to add and click Add [>].

Select an LSP file in the project, rightmost list box, and click Remove [<] to remove the
LSP file from the project.
Note: If you want, you can select an LSP file and manage its order within the project by
clicking the Top, Up, Down, and Bottom buttons.
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5. Click OK to create the new project.
The AutoLISP Project window appears.

From the AutoLISP Project window, you can


Add an LSP file – Right-click over the window and choose Add File. Add the LSP file
using the Project properties dialog box.



Remove an LSP file – Right-click over the LSP file you want to remove from the project
and choose Remove File. In the message box that appears, click Yes.



Open an LSP file for edit – Double-click the LSP file you want to edit in the project, or
right-click over the file and choose Edit.



Load all LSP files into AutoCAD – Click Load Source Files on the window’s toolbar.



Load an LSP file into AutoCAD – Right-click over the LSP file in the window and
choose Load Source.



Edit the properties of a project – Click Project Properties on the window’s toolbar.



Save the project as – Right-click over the window and choose Save Project As. In the
Save Project As dialog box, enter a new file name and click Save.

When you are done with a project, you can close it by clicking Project menu > Close Project or
right-clicking in the AutoLISP Project window and choosing Close Project. The Open Project
item on the Project menu can be used to reopen a project.
AutoLISP Extension for VS Code
1. In VS Code, with the latest version of the AutoLISP Extension installed, click AutoLISP
Project Manager on the Activity Bar.
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2. On the AutoLISP Project Manager, in the PROJECT pane, click Create a New Project.

3. In the Save As dialog box, browse to the Documents > AutoLISP Files folder or the
folder where you want to store the project file.
4. In the File name text box, enter vs-project and then click Create.
5. In the PROJECT pane, click Add File to Project.

6. In the Open dialog box, browse to and select the LSP files to add to the project. Click
Add to Project.
The LSP files appear under the open project in the PROJECT pane.

From the PROJECT pane, you can


Add an LSP file – Right-click over the open AutoLISP project’s name and choose Add
File to Project or click Add File to Project on the PROJECT pane. Select the LSP file and
click Add to Project.



Remove an LSP file – Right-click over the LSP file you want to remove from the project
and choose Remove File from Project. In the message box that appears, click Yes.
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Open an LSP file for edit – Click the LSP file you want to edit from the project.



Save a project – Right-click over the open AutoLISP project’s name and choose Save
Project.



Save all open and changed LSP files – Right-click over the open AutoLISP project’s
name and choose Save All.



Refresh project – Refreshes the current project and the files shown in the PROJECT
pane.

The open project is automatically closed when you exit/quit VS Code. When you want to work
with an existing project, click Open an Existing Project in the PROJECT pane. If a project is
already open when you go to open another project, the current project is closed, and the
selected project is opened.

Find and Replace Text Across LSP Files in a Project
When developing AutoLISP programs, you will frequently want to find code statements for reuse in a new program or even replace old code statements with something newer across many
AutoLISP Source (LSP) files. AutoLISP Projects (PRJ) files not only make it easy to access and
edit your LSP files, but they also allow you to find and replace code statements across your LSP
files that are in the project currently open.
The following explains how to find and/or replace text in the LSP files of an open project:
Visual LISP (Windows only) – Find in Project Only; No replace feature available
1. In Visual LISP, open an AutoLISP Project (PRJ) file.
a. Click Project menu > Open Project.
b. In the Enter Project Name dialog box, click Browse.
c. In the Open Project dialog box, browse to the Documents > AutoLISP Files folder
or the folder where stored the vl-project.prj or another project file.
d. Select the PRJ file to open and click Open.
2. Click Search menu > Find.
3. In the Find dialog box, under the Search section, click Project.
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4. If you have more than one project open, click the Project drop-down list and choose the
project to search.
5. In the Find What text box, type a function, variable, or value for which to search.
6. Optionally, make changes to the other find options.
7. Click Find.
The results are shown in the <Find Output> window.

8. Review the results.
You can double-click on the results to open the LSP file in the editor and see the text in
the context of the file.
AutoLISP Extension for VS Code – Find and Replace in Project
1. In VS Code, open an AutoLISP Project (PRJ) file.
a. On the Activity Bar, click AutoLISP Project Manager.
b. On the AutoLISP Project Manager, in the PROJECT pane, click Open an Existing
Project.
c. In the Open dialog box, browse to the Documents > AutoLISP Files folder or the
folder where stored the vs-project.prj or another project file.
d. Select the PRJ file to open and click Open Project.
2. On the AutoLISP Project Manager, in the FIND & REPLACE pane, click either


Find in Project – Find a text string within the LSP files



Replace in Project – Find and replace a text string within the LSP files
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Note: There is no way to undo the Replace in Project operation, so make sure
you want to apply the change to all files before using the feature. You might want
to create a copy of your files before starting.
3. Do one of the following:


In the Find in Project dialog box, type the text string to find and press Enter.



In the Replace in Project dialog box, type the text string to find and press Enter.
Then in the second Replace in Project dialog box, type the text string to replace
with and press Enter.

Tip: You can use the options at the top of the Find in Project and Replace in
Project dialog boxes to match case, match whole word, and use Regular
Expressions.
The results of the Find in Project or Replace in Project are shown in the FIND &
REPLACE pane.

4. Review the results.
You can click on the results to open the LSP file in the editor and see the text in the
context of the file.
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Compile LSP Files
LSP files can easily be read and edited using a text editor as you have seen and for many
companies that is fine. However, if you want to protect the logic and source code that make up
your custom AutoLISP programs you can compile the LSP files into FAS and VLX files. FAS
and VLX files can be loaded into AutoCAD but cannot be read by a text editor.
Note: You can only compile LSP files in AutoCAD for Windows, not AutoCAD for Mac OS.
Warning!: Make sure to not lose your LSP files as there is no way to get it back from a FAS or
VLX file.
While you can compile individual LSP files, adding your LSP files to an AutoLISP project (PRJ)
file is the most efficient approach. You can use the PRJ file to manage and then later compile
your LSP files. When you use a PRJ file to compile your programs, individual FAS files for each
LSP file are created and all FAS files are compiled into a single VLX file.
The following steps explain how to compile the LSP files in an AutoLISP project (PRJ) file:
1. Do one of the following:


Visual LISP – In Visual LISP, click File menu > Make Application > New
Application Wizard.



AutoLISP Extension for VS Code – In AutoCAD, at the Command prompt,
enter makelispapp. Type w to use the Wizard option and press Enter.

2. In the Application Wizard, on the Wizard Mode page, click Simple and the Next.
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3. On the Application Directory page, click Browse.

4. Browse to and select the Documents > AutoLISP Files folder or the location you want to
output the compiled files. Click OK to accept the selected folder.
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5. On the Application Directory page, click in the Application Name text box and enter
compiled-lsps (or your desired name for the application). Click Next.

6. On the LISP Files to Include page, click the Files of Type drop-down list and choose
Visual LISP Project File. Click Add.

You could also choose Lisp Source File from the drop-down list and add your LSP files
to files list box to be compiled. If you want to create a VLX file for each LSP file, you will
need to add one LSP file and compile it.
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7. In the Add Visual LISP Project Files dialog box, browse to and select your PRJ file. Click
Open to add the project to the list of files to be compiled.

The file should be under the Documents > AutoLISP Files folder or the location you
choose earlier in the Manage LSP Files with a Project (PRJ) File section.
8. Click Next.
9. On the Review Selections / Build Application, make sure Build Application is checked
and click Finish.
The FAS files are compiled 1-to-1 for each LSP file in the PRJ file, while the VLX file
contains all the FAS files compiled into a single file. You can load the FAS files or VLX
file into AutoCAD just like you would a LSP file, then execute the functions and
commands as you normally would.

7

Which Editor to Choose?

Out of the three editors I mention in this handout, my answer to that question is VS Code with
the AutoCAD AutoLISP Extension.
Here are my reasons for that answer...
While Notepad can get the job done, it lacks many tools that can simplify AutoLISP
development.
So, the choice in the end comes down to Visual LISP or VS Code.
If you are using AutoCAD 2020 or earlier, Visual LISP is the better choice as it allows you to edit
and debug LSP files in a common environment since VS Code only supports debugging in
AutoCAD 2021. If you are using AutoCAD for Mac, Visual LISP is not available, and you are
limited to VS Code.
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Even though Visual LISP is available in AutoCAD 2021, it is marked as a deprecated feature
and will be removed in a future release. With the deprecation of Visual LISP in AutoCAD 2021,
you might not want to spend too much time learning to use it if you haven’t used Visual LISP in
the past. However, if you are using Visual LISP today, you should begin to transition to using VS
Code.
Since VS Code is where Autodesk is investing future resources, I recommend you choose and
start using VS Code with the AutoCAD AutoLISP Extension. VS Code is also supported on both
Windows and Mac for AutoCAD.

Transition from Visual LISP to VS Code
If you are a user of Visual LISP and want to make the transition to VS Code, you can use the
Visual LISP IDE to Visual Studio Code Feature Access Comparison topic in the AutoLISP
Reference Guide to help with the transition. The tables in that topic list how to start a tool in
Visual LISP and then how to start the equivalent tool in VS Code.
The following table provides a comparison of the features between Visual LISP and VS Code
with the AutoCAD AutoLISP Extension installed:
Feature

Visual LISP

Unicode support

AutoLISP Extension
for VS Code
X

Autocomplete function/variable name

X

Code snippets

/, Save Block As and X, snippets file
Insert File

Auto-indentation while typing

X

Smart brackets

X

X
X

Find and replace in current editor window

X

X

Find and replace in current AutoLISP
Project (PRJ) file

X

X

Toggle comment

X

X

Color-code syntax

X

X

Format AutoLISP statements

X

X

Check Syntax

X

Browse drawing database

X
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Load selected statements

X

/, partially with the
Debug Console

Load current editor window

X

X

Console window

X

X

Debug AutoLISP Source (LSP) files

X

X

Breakpoints

X

X

Watch variables

X

X

Watch last evaluation

X

X

Inspect value

X

Animate debugging

X

Trace stack

X

X

AutoLISP Project (PRJ) files

X

X

Compile LSP files into FAS/VLX files

X, in editor

X, MAKELISPAPP
command in AutoCAD

Preview DCL files

X

Modern/extensible interface
Deprecated/obsolete

8

X
To be removed in a
future release

Deploy AutoLISP Files

No matter which editor you choose to help edit and debug your custom programs, the process
of getting your custom programs loaded onto another workstation is the same. Moving your
custom programs out of the development environment, most likely your workstation, to where a
user will be able to load them is known as deployment. Deployments can be as simple as
copying a set of files from one workstation to another, but they can also be a bit more involved,
which might require manipulation of the AutoCAD program or even the operating system.
The following questions can help to determine some of your deployment needs:


Where will the custom programs be stored and loaded from, a local or network drive?



Who will be using the custom programs, internal or external users?



What is the expertise level of the users that will need to load the custom programs?
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Custom programs can be deployed by:


Manually copying custom program and resource files to a local or network drive –
This method can be used to deploy programs internally and externally to users but may
result in some support questions related to setting up the files and AutoCAD. The plug-in
bundles feature that AutoCAD supports can help to simplify the deployment of your files.



Automate the copying of custom program and resource files from a network
location to a local drive with a Group Policy or script/batch file – This method is
often used when deploying programs internally to many users in a company. Cloud
storage services such as Box, DropBox, and Google Drive can be good alternatives
when you want to share files with remote employees.



Create an installer that handles the copying of files to a computer – This method is
often used when deploying programs to external companies and can be the most
effective way to deploy programs, but it does impact how quickly changes can be
deployed. There are many different programs on the market that can be used to create
an installer, most have a cost associated with them. I have personally used InstallShield
(http://www.flexerasoftware.com/producer/products/software-installation/installshieldsoftware-installer/) which starts at $699 for Express and up for the higher-end products,
and Setup Projects available in Visual Studio Professional and higher.

Tip: The MS-DOS XCOPY command and RoboCopy utility can make it easy to synchronize
files on a local drive with those stored on a remote/network drive. RoboCopy should be
available in Windows 7 and later from a Windows Command prompt, but if you want a graphical
interface you can download the companion utility Robocopy GUI
(https://technet.microsoft.com/en-us/library/2006.11.utilityspotlight.aspx).
After your custom program and resource files have been deployed to a local or network drive,
the custom program files can then be loaded into an AutoCAD-based product. The following
outlines the methods that can be used to load a program into an AutoCAD-based product
(simplest to more complex):


APPLOAD command (Load/Unload Application dialog box) – Requires the user to
load the custom program files each time they are needed.



Startup Suite of the APPLOAD command – Requires the user to add each custom
program file to the Startup Suite, but only needs to be done once. Then the files are
loaded automatically each time a drawing is opened or created.



acad.lsp or acaddoc.lsp program files – Files must be created and placed in a
support file search path and trusted location. Then the files must be manually edited to
include the necessary LOAD statements to load your custom program files.



Custom CUI/CUIx file – Add the LSP files to be loaded under the LSP Files node of a
CUI/CUIx file, and then load that CUI/CUIx. This is done with the Customize User
Interface (CUI) Editor (CUI command).



MNL file with the same name as a custom CUIx file – AutoCAD looks for and loads a
MNL file that has the same name as a CUI/CUIx file that gets loaded; for example,
mytools.cuix and mytools.mnl.
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Plug-in bundle – Used to configure the AutoCAD drawing environment and load
AutoLISP programs when a drawing is opened or created. Along with loading program
files, you can partially load a CUIx file as well.

Note: You can centralize the loading of multiple AutoLISP programs by defining a single
AutoLISP program file that a user can load, this single program file loads all other AutoLISP files
with the use of the LOAD function or loads the files on-demand when a command in a file is
used. The AutoLISP AUTOLOAD function is used to load an AutoLISP program file on-demand
when a command is used the first time during a drawing. In addition to the AUTOLOAD function,
a plug-in bundle can also be used to automatically load an AutoLISP program file when a
command is used the first time.
While having users manually load program files can make deployment tasks easier for you, it
can be very problematic for them and lead to a support nightmare if something goes wrong. No
matter if you have your users manually load the program files or if the files are automatically
loaded, you need to consider the following questions:


How will the user specify the necessary support file search paths and trusted locations to
load and use your custom program and resource files?



Should the source code contained in your custom program files be protected?



Should the custom program files be digitally signed?

Plug-in bundles make it easy to deploy AutoLISP programs as you just need to distribute a
folder structure and the files contained in them. The folder structure organizes and contains all
the program and resource files needed, along with the information required to configure the
AutoCAD drawing environment.
You can learn more about digital signatures and plug-in bundles in the AutoCAD Online help
system (https://help.autodesk.com/view/OARX/2021/ENU/) and my AU 2016 session named
“Deploy and Support AutoLISP Programs Like a Pro” (https://www.autodesk.com/autodeskuniversity/class/Deploy-and-Support-AutoLISP-Programs-Pro-2016).

9

Where to Get More Information

When starting to work with a new tool, you will most likely have questions of which you will want
answers. The following is a list of resources that you can use to get answers to the questions
you might have:


AutoLISP Help – The AutoLISP Developer’s and Reference Guides topics are part of
the AutoCAD Online Help system. The AutoLISP Developer’s Guide has information on
how to get started with the AutoLISP programming language in general along with
information on using Visual LISP and the AutoCAD AutoLISP Extension for VS Code.
The AutoLISP Reference Guide is where you will want to go if you have questions on a
specific AutoLISP function, such as what kind of value the function returns or what are
the expected arguments for a function. You can access these guides online at:
https://help.autodesk.com/view/OARX/2021/ENU/



Autodesk Developer’s Network – If you are serious about developing applications for
AutoCAD and specialized toolsets, you might want to consider becoming a registered
Autodesk Developer. You don’t need to be a member of ADN, to use the AutoLISP
programming language. Individuals that develop applications for sale, might decide to
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become an ADN member. For information on registering as an Autodesk Developer, see
https://www.autodesk.com/adn


Autodesk Discussion Forums – The Autodesk forums provide peer-to-peer networking
and interactions with Autodesk moderators. Here, you can ask a question about anything
AutoCAD related and get a response from a fellow user or Autodesk employee.
To access the AutoLISP forums, go to https://forums.autodesk.com/t5/visual-lispautolisp-and-general/bd-p/130



AUGI Forums – The AUGI forums provide peer-to-peer networking where you can ask
questions about virtually anything in AutoCAD or Autodesk software related and get a
response from a fellow user. Visit AUGI at https://www.augi.com/



Industry Events and Classes – Industry events such as Midwest University and
Autodesk University are great places to learn about features or workflows in an
Autodesk product. Along with industry events, you might also be able to find classes at
your local technical college or an Autodesk Authorized Training Center (ATC).



Internet – There are tutorials and information scattered across the Internet that cover
the basics of AutoLISP. Use your favorite search engine, such as Google or Bing, to find
this information.



Books – There are many books out there that cover AutoLISP programming, I have
written one along with many others in the industry over the years. Search an online book
reseller, such as Amazon (amazon.com) or Barnes & Noble (bn.com), for books that
cover AutoLISP programming.
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