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FAB463426 

Revit to Inventor - BIM exchange for custom fabrication hands-on Lab  

Paul Munford, Autodesk 

Description 

This lab will provide an opportunity for customers to get hands-on with the new 'Revit AnyCAD' 

functionality in Inventor 2021. 

We will cover some of the theory of why BIM is important to building product manufacturers and 

custom fabricators and level-set on our existing BIM exchange tools. We will then work our way 

through a four-part example use case for referencing Revit data. 

We will cover some basic clean-up of the model in Revit. Test what we can do with the data in 

Inventor. 

Marvel as changes made to the Revit model update inside of Inventor, and round trip the 

Inventor model back into Revit. 

This class will suit Inventor users who are confident using the Inventor UI to design and build 

their models. 

This class will be specifically focused on Inventor users who wish to participate in BIM Project 

and who would like to test the new 'Revit AnyCAD' functionality in Inventor 2021. 

Supporting documents 

'Don't forget to download the dataset and watch the video of the presentation on AU Online. 

https://www.autodesk.com/autodesk-university/au-online?query=paul+munford 

  

Learning Objectives 

¶ Learn how to create a simplified view in Revit, in preparation for referencing the 

Revit Project into Inventor. 

¶ Learn how to reference a Revit Project File into Inventor to design in context  

¶ Test the ability to update the Revit file, and consume the update inside Inventor 

¶ Round trip the Inventor file back into Revit. 

https://www.autodesk.com/autodesk-university/au-online?query=paul+munford
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Paul Munford 

Paul Munford is a laugher, dreamer, raconteur, CAD geek and 

Technical Marketing Manager for Autodesk in the UK. 

Paul's background in manufacturing items for the construction 

industry gives him a foot in digital prototyping and a foot in Building 

Information Modeling (BIM). 

Paul was a speaker at Autodesk University for the first time in 2012, 

and he says it's the most fun anyone can have with 250 other people 

in the room. 

@PaulCADmunford 

 

What is BIM? 

'BIM' or Building Information Modelling is the process of collaborating on a digital, 3D database 

of information about a building design. 

A 'BIM' is the Building Information Model itself. 

A BIM is created using a BIM authoring tool such as Autodesk Revit, and is compiled from a 

number of separate 3D model/databases, each created by a different specialist - for example an 

Architectural BIM, a Structural BIM and a Mechanical BIM. 

At each design stage, the BIMs can be coordinated, so that the overall design has no 

contradictions before being released to the broader project team. 

The coordinated BIM is a 3D model that represents a database of information about the design. 

Schedules, drawings and even simulations or renderings are all 'views' of the same database. 

The design BIM can be passed on to the General Contractor, who can continue to update the 

BIM by incorporating 3D models from trade subcontractors and specialists. 

Eventually, the 'As Built' BIM can be passed on to the building owner, who can use the BIM 

database for asset management throughout the building's lifecycle.  

BIM for Custom Fabricators 

In this class, we will take the role of a custom fabricator on a BIM project. We have been 

supplied with a Revit BIM to help us work in context with the Architect's design. 

Our deliverable will be a 3D model that can be returned to the General contractor and Architect 

for design coordination and aesthetic approval.  

https://twitter.com/PaulCADMunford
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About this lab 

At Autodesk University, a óLabô style class is an opportunity to get hands-on with Autodesk 

software. The Lab instructor takes you through the exercises, and there are óLab Assistantsô to 

help you if you get stuck. 

Due to the coronavirus pandemic, AU is entirely virtual this year. This means that youôll have to 

work a little harder to get the best out of this lab. Youôll need to install the software yourself, 

download the handout and dataset, and follow the instructions with minimal help from me and 

without Lab assistants. 

Iôve tried to make the instructions for each exercise as straight forward and easy to follow as 

possible. I welcome your feedback on how I can improve this for you. 

Please watch the video of the presentation that goes with this class. I will demonstrate each 

exercise for you, and then you can use the step-by-step instructions in this handout to try the 

workflow out for yourself. 

I have supplied a dataset with files for each exercise. If you donôt get the result you were 

expecting during an exercise, donôt worry ï just close the file you are working on and open the 

file from the folder for the next exercise.  

Your feedback 

If you have any feedback on this class, the format, the dataset, the handout, or the presentation, 

please feel free to contact me: Paul.Munford@Autodesk.com 

To show your appreciation, please use the 

óRecommendô button on the Autodesk university 

online webpage for this class. 

Your questions 

You can ask questions via the óCommentsô box 

on the Autodesk University Online web page for 

this class.  

During the week of AU2020, I will monitor your 

questions and answer as many as I can. 

You will also be able to join us for a LIVE 

Q&A session on Thursday 19th November at 

08:30 PST 16:30 GMT 

  

mailto:Paul.Munford@Autodesk.com
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Prerequisites 

To follow the instructions in the class, you will need: 

¶ The Handout 

¶ The Dataset 

¶ Autodesk Inventor 2021 Installed on your computer 

¶ Autodesk Revit 2021 Installed on the same computer. 

It is expected that you will be familiar with basic concepts in Inventor and Revit, such as opening 

files, navigating within the file structure, and navigating in 3D space. 

 

Installing Inventor and Revit 2021 

If your subscription includes Autodesk Inventor 

and/or Revit 2021, you can install them via the 

Autodesk Desktop app or via your Autodesk 

Account. 

You can log into your Autodesk account using 

your Autodesk ID and password here: 

https://manage.autodesk.com/home/ 

 

Downloading a trial of Inventor 2021 

You can download a free 30 day trial of Autodesk 

Inventor using this link: 

https://www.autodesk.co.uk/products/inventor/free-trial 

If youôve never used Autodesk Inventor before, please visit the trial center for ógetting startedô 

tutorials: 

https://www.autodesk.com/campaigns/inventor-trial-center 

Or take a look at the in-product Tutorial Gallery 

 

Figure 1The Autodesk Desktop App 

https://manage.autodesk.com/home/
https://www.autodesk.co.uk/products/inventor/free-trial
https://www.autodesk.com/campaigns/inventor-trial-center
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Downloading a trial of Revit 2021 

You can download a free 30 day trial of Autodesk Inventor using this link: 

https://www.autodesk.co.uk/products/revit/free-trial 

If youôve never used Autodesk Revit before, please visit this link for ógetting startedô tutorials: 

https://knowledge.autodesk.com/support/revit-products/getting-

started/caas/CloudHelp/cloudhelp/2020/ENU/Revit-GetStarted/files/GUID-C3DEF8F6-A9C0-

496E-A554-8147B12A4EDA-htm.html 

A note on versioning 

The functionality we are learning about in this Lab did not exist prior to Inventor 2021. The 

workflow described in this class will not work with older versions of Inventor. 

Inventor 2021 can reference Revit files from previous versions of Revit (older than 2021); 

however ï you will notice a performance hit. In the background, Inventor is updating the Revit 

file from the previous version to Revit 2021. 

To avoid this performance hit, we recommend updating the Revit project to Revit 2021 in Revit, 

before you reference it into Inventor 2021. 

The Video 

The video of the presentation that goes with this class will give context on why the workflow is 

helpful to Custom fabricators working on BIM projects, along with a recording of the 

demonstration for each exercise. 

Please watch each demo in its entirety before pausing the video and trying the workflow for 

yourself. 

You can use the instructions in the handout to help you follow along with the exercise, or rewind 

the video and follow along. 

The Handout 

If you are reading this ï you have the handout - Thank you! 

The handout will take you through each exercise step ï by step, including the file and folder 

path to the example files you will be using. 

The instructions in the handout follow the demo of the exercise we will see in the video of the 

presentation. 

Tip: I have included extra detail and references to further information in the handout that I didnôt 

have time for in the presentation. 

  

https://www.autodesk.co.uk/products/revit/free-trial
https://knowledge.autodesk.com/support/revit-products/getting-started/caas/CloudHelp/cloudhelp/2020/ENU/Revit-GetStarted/files/GUID-C3DEF8F6-A9C0-496E-A554-8147B12A4EDA-htm.html
https://knowledge.autodesk.com/support/revit-products/getting-started/caas/CloudHelp/cloudhelp/2020/ENU/Revit-GetStarted/files/GUID-C3DEF8F6-A9C0-496E-A554-8147B12A4EDA-htm.html
https://knowledge.autodesk.com/support/revit-products/getting-started/caas/CloudHelp/cloudhelp/2020/ENU/Revit-GetStarted/files/GUID-C3DEF8F6-A9C0-496E-A554-8147B12A4EDA-htm.html
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The Dataset 

The dataset is a zipped file containing all the files you need for the exercises. 

The files for each exercise are self-contained. If you donôt get the result you were expecting at 

the end of an exercise ï donôt worry. Just close the file that you are working on and open the 

example file from the folder for the next exercise. 

Please download the dataset and extract the zipped files directly on to your C: Drive. 

We recommend saving the class files in this folder location óC:\Datasets\FAB463426ô. 

You can download the dataset from the Autodesk University online page for this class, or youôll 

also find it here: http://cadso.co/FAB463426_DOWNLOAD 

The Demos 

Each exercise is demonstrated in the video of the presentation for this class. Please watch each 

demonstration in full before you start the exercise.  

You can use the instructions in the handout to help you follow along with the exercise, or rewind 

the video and follow along. 

  

http://cadso.co/FAB463426_DOWNLOAD
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Exercises 

Setup ï Before we beginé 

Before we begin, please check that you have the following: 

Ã Inventor 2021 installed 

Ã Revit 2021 Installed 

Ã Dataset downloaded and extracted C:\Datasets\FAB463426 

Ã Handout  

Ã Video of the presentation 

Please start Inventor and set the project file to point at the class dataset. 

With Inventor 2021 open, go to: 

1. Get started (Tab) > Launch (Panel) > Projects (Button) 

2. In the óProjectsô dialog, click on óBrowseéô  

3. In the óchoose project file dialogô browse to C:\Datasets\FAB463426 

(or wherever you saved and extracted the dataset for this class) 

4. Select the project file óFAB463426.ipjô with a left mouse button click, and click the 

óOpenô button. 

5. In the óProjectsô dialog, check that óFAB463426.ipjô has a ócheckô mark next to it (V) 

6. Click on the óDoneô button. 
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Exercise 01- In Revit, creating a simplified View. 

When we bring a Revit project file into Inventor, we donôt want to bring in EVERYTHING! The 

referenced Revit model would be large and unwieldy and would slow down Inventor. 

To reduce the size of the referenced Revit model file in Inventor, we can reference in a saved 

view of the Revit model, which has been filtered to just the information we are interested in. 

In this exercise we will learn how to create a view of the Revit model, which only shows the 

detail we are interested in.In this exercise, we will learn how to create a view of the Revit model, 

which only shows the detail we are interested in. 

In this Exercise, we will: 

¶ Open the data set for this exercise 

¶ Browse the Revit project structure 

¶ Copy and rename an existing 3D View 

¶ Filter the view 

¶ Use a Section box to crop the view 

Open the data set for this exercise 

1. From the Revit home page, look for óMODELSô and click óOpen.ô 

2. Navigate to: 

C:\Datasets\FAB463426\01 Creating a simplified view in Revit\ 

3. LMB select óAS-AK-00-ZZ-M3-A-00001.rvtô (Revit Project File) and click 

on the óOpenô button. 

Tip: With the Revit óOpen dialogô open, navigate to óFAB463426-AU020-Datasetô 

folder. 
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Now Right mouse button click over the óplacesô bar and choose óAdd current folder.ô This will 

create a short cut to the 

class dataset folder in 

your places bar.  

 

 

 

 

 

 

 

 

Browse the Revit project structure 

1. In Revit, look for the óProject Browser.ô 

2. Next to the óViews (all)ô node, click on the cross (+) symbol to expand the node. 

3. Next to the ó3D Viewsô node, click on the cross (+) symbol to expand the node. 

4. Look for the view called óDefault 3D View.ô 

5. This view should be the current view. 

Tip: Youôll know óDefault 3D Viewô is current if the view name is in Bold text. The view name 

will also be shown at the tab of the current graphics window. 

Copy and rename an existing 3D View 

1. Right-click on the óDefault 3D Viewô node and select: 

óDuplicate view> Duplicate.ô 

2. A new view will be created called óDefault 3D View Copy 1ô, and Revit will set it as the 

current view. 

3. Right-click on the óDefault 3D Viewô node and select: 

óRenameô 

4. Rename óDefault 3D View Copy 1ô to ó3D Circular Balcony.ô 

Tip: To change views, double the Left mouse button click on óDefault 3D Viewô to make it 

current. Double LMB click on ó3D Circular Balconyô to make it current again for the next 

exercise. 



 

12 | P a g e  

 

 

 

Filter the view 

To hide individual elements in a Revit view, hover over the element and use the tab key to cycle 

between overlapping elements. 

When you have the element highlighted that you want to remove, Right mouse button click and 

choose: 

óHide in View > Elementsô 
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Tip: Use óHide in View > Categoryô, to hide all elements that belong to the same category, such 

as all walls or all windows. 

Tip: To select all instances of an element, select an element, then RMB click and choose 

óSelect all instances > Visible in Viewô to select all instances of the same element. With the 

selection set active, you can now RMB click and choose óHide in View > Elementsô to hide all 

instances of an element. 

Tip: You can hold down the CTRL and left mouse button click to select multiple elements from 

different categories. 
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A quicker way is to select everything and then use a filter to select only the elements we donôt 

want to see. 

If necessary, use the scroll wheel on your mouse to zoom out until you can see the whole Revit 

model. 

Tip: Hold down the scroll wheel on your mouse to Pan. Hold down the SHIFT key on your 

keyboard, plus hold down the scroll wheel on your mouse to orbit. 

1. In the graphics window, Left mouse button click and drag from the top left of the window, 

to the bottom right of the window; you should now have the entire Revit model selected. 

 

2. Navigate to: 

Modify | Multiselect (Tab) > Selection (Panel) > Filter (Button) 
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3. Click on the filter button. 

4. In the Filter dialog, notice that all Revit 

categories are represented. 

5. Click the óCheck noneô button. 

 

 

 

 

 

 

 

 

 

 

 

6. Now select the categories we wish to hide: 

V Room separation 

V Doors 

V Furniture 

V Levels 

V Lighting Fixtures 

V Model Groups 

V Slab Edges 

V Specialty Equipment 

 

7. Click the OK button. 
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8. Only the items that belong to the categories we selected are highlighted. 

 

9. Right mouse button anywhere in the graphics window and choose: 

óHide in View > Elementsô 

 

10. The elements we donôt wish to see in Inventor are hidden.  

Only the items we are interested in are visible. 
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Use a Section box to crop the view 

We can also focus on the detail we are interested in by using a Section box. A Section box will 

crop the Revit model to just the area we are interested in. 

Tip: Before you start the next section, make sure that you donôt have anything selected by 

pressing the óEscape(esc)ô key a couple of times. 

1. In the Properties browser, under óExtents,ô check óSection box.ô 

2. A wireframe box will appear around the extents of the Revit model. 

3. Left mouse button click on the section box to activate it ï Triangular handles will appear 

at the center of each face. 
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4. Use the triangular handles to crop the view of the model to show just the area around 

the circular handrail. 

 

5. Save your version of this file using: 

File > Save as > Project 

And then close this Revit file. 

 

Or go to: 

File > Close 

To close the file without saving and use the file Iôve prepared for you for the next 

exercise. 

Tip: Use the view cube to orient the view 

until you are parallel with the sides of the 

section box. 

To switch to an orthographic view, hover 

over the Viewcube and look for the options 

button (It looks like a rectangular bar, with a 

triangle underneath it). 

From the options, select óOrthographicô. 

When you are done, you can switch back to 

perspective mode the same way. 














































