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Learning Objectives





Create both 1D and 2D HEC-RAS geometry models using Civil 3D terrain and pipe
networks.
Analyze hydraulic flow patterns, velocities, shear stresses, and flow inundation limits on the
Civil 3D surface
Extract data from HEC-RAS (both 1D and 2D) to create hydraulic work maps suitable for
review agencies
Use new HEC-RAS technologies to expedite floodplain modeling, mapping, and production
needs

Description
Intended for intermediate to advanced AutoCAD Civil 3D users, this class is designed to show land development
professionals workflows for brokering data between AutoCAD Civil 3D software and Hydrologic Engineering Center’s
River Analysis System (HEC-RAS) for the creation of detailed floodplain analysis.
Using terrain data from both LiDAR and grading objects, this class will demonstrate how 1D and 2D hydraulic
floodplain simulations can be quickly created from AutoCAD Civil 3D designs. With DEM terrain aggregation and
geometric editing functionalities recently added in the newest releases of HEC-RAS version 5.0.7 from the U.S. Army
Corps of Engineers, this class will focus on techniques and nuances for setting up your HEC-RAS model and getting
simulated results back into AutoCAD Civil 3D for the creation of detailed work maps. Utilizing only AutoCAD Civil 3D
and open-source programs, this class will demonstrate how to successfully integrate HEC-RAS simulations with
AutoCAD Civil 3D.

Speaker
Andy Carter, PE received his BS in civil engineering from the University of Texas in Austin. Mr.
Carter is recognized as an expert in hydrologic and hydraulic design and analysis necessary to
support land development activities. His experience has concentrated on evaluating and
designing drainage facilities necessary to protect infrastructure from flooding and erosion. At
national conferences, Mr. Carter has demonstrated software and techniques he personally
developed for the reclamation of land encumbered by floodplains. He has consulted the National
Weather Service regarding data transmission protocols of hydrologic data.
He was selected as winner of the Autodesk Excellence in Infrastructure Award in 2015. Andy is
an AutoCAD Civil 3D Certified Professional and was invited to evaluate the functionality of the
2014 release of AutoCAD Civil 3D at Autodesk’s headquarters.
Andy.Carter@landdevconsulting.com & civileng127@hotmail.com
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NOTE: This class handout provides a sequence of the workflow (pics and clicks) presented at the AU2019 class. It is
intended to serve as desktop reference for replicating these procedures on your own future projects.
This goal of this tutorial is to create a detailed floodplain analysis of a proposed Civil3D design that consists of (1) a new
roadway, (2) a culvert under this roadway and (3) fill that encroaches into the limits of the floodplain.
This tutorial starts with these assumptions:
 Existing topography has been acquired and an existing surface has been created in Civil3D
 A proposed roadway corridor and corresponding Civil3D surface has been created
 Proposed culverts have been drawn as Civil3D Pipe Networks.
 Grading for the proposed encroaching fill is has been created as a Civil3D surface
This tutorial will focus on floodplain analysis utilizing HEC-RAS version 5.0.7.
https://www.hec.usace.army.mil/software/hec-ras/download.aspx It includes1D analysis and 2D analysis workflows.

Step 1a: Export Terrain Data from Civil3D
Open the resource drawing provided titled “01_Floodplain_BaseData.dwg”.
[This is an AutoCAD 2018 drawing set to the Central Texas Zone – US Survey Feet Zone]
1a.1) This drawing contains three (3) surfaces. Each one will be exported as
separate Digital Elevation Model (DEM) as a GeoTiff format. To export the
terrain, right click on “ExistingGround” and select the “Export to DEM…”
option. In the “Export Surface to DEM” dialog, select a grid spacing of 3.0 ft.
Save the file as “02_ExistingGround_3ft.tif”

1a.2) Repeat this export for the other two (2) surfaces.
Proposed_LotFill // Grid Spacing = 2.0 ft // Dem file name = “02_Proposed_LotFill_ 2ft.tif”
Proposed_Road // Grid Spacing = 0.5 ft // Dem file name = “02_Proposed_Road_05ft.tif”
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Step 1b: Create a Stream Centerline and Cross Section Shapefiles
To create a one dimensional (1D) hydraulic model in HEC-RAS, ESRI shapefiles of the stream centerline
and hydraulic channel cross sections are necessary.
In the “01_Floodplain_BaseData.dwg”, draw a polyline that represents the stream centerline.
*** Important – This must be drawn from Upstream to Downstream ***
1b.1) Once a stream centerline polyline is created, type in “MAPEXPORT” in the
AutoCAD command line. Select the “ESRI Shapefile (*.shp) option. Name the file
“02_StreamCL_LN.shp”

Select the “line” object type. With the “select manually” option, click the select button and
then select the drafted stream polyline. Select the “OK” button to create the shapefile.

1b.2) Draw hydraulic cross sections using AutoCAD polylines. Make sure that one of
the sections is drawn along the center of the proposed road. Also, sections approximately
10 feet from the upstream and downstream face of the proposed culvert are requested.
For guidance, a frozen layer named “XS” is provided in the refence drawing for typical
cross section layout.
*** Important –
(1) Cross Sections must be drawn from Left to Right looking downstream
(2) Lines must cross the stream centerline once and only once
(3) cross sections should not cross each other
Using the “MAPEXPORT” command in the AutoCAD, select the “ESRI Shapefile
(*.shp) option. Select all the cross sections and create “02_XS_LN.shp”
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Step 2: Creating a HEC-RAS Project

2.1)

Open HEC-RAS and select File and then “New Project…” Save the project as “AU_2019_CartersBranch”

2.2)

From the main HEC-RAS window, select the
“RAS Mapper” icon.

2.3)

In “RAS Mapper”, under “Tools” select the “Set Projection for
Project…”
In the RAS Mapper Options, browse to find the folder where you saved
the 02_StreamCL_LN.shp created in step 1b.1.

Select the file name “02_StreamCL_LN.prj” This is a projection file that is telling RAS Mapper that the
project will utilize the NAD_1983_StatePlane_Texas_Central_FIPS_4203_Feet projection for this model.

Warning! A HEC-RAS project
has an extension of .PRJ.
An ESRI shapefile has a
projection of .PRJ. These
are not the same type of
files, so on future projects
make sure there is a clear
understanding as to what
type of PRJ is being
selected.
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Step 3: Creating a Composite Terrain in RAS Mapper
RAS Mapper is a great tool for compositing multiple DEM’s of varying resolution (grid size) and spatial
projections. RAS Mapper creates a surface file that is a .HDF file (Hierarchical Data Format).
3.1)

Create a new Terrain File. Right click on “Terrains” and select “Create a New RAS Terrain”
In the New Terrain Layer, select the “+” to
add the three (3) DEM files exported in
step 1a.

Order the terrain data so
that the proposed surfaces
are on the top of the stack
using the Arrow buttons.
*** Important – RAS
Mapper builds a surface
from the bottom up.

The correct terrain stack has
the two (2) Proposed DEM’s
above the Existing DEM.
Once the DEM order is
correct, select the File Icon,
and save the Terrain HDF as
“Proposed Surface”.

Select the “Create” button to complete the Terrain creation.
A successfully created
surface should look like
this:
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Step 4: Adding Google Earth Imagery
4.1) In RAS Mapper, right click on “Map Layers” and select “Add
Web Imagery Layer…”
In the GDALWMS window, select the “Google Satellite” option and
select OK.
Check the “Map Layers” box in the RAS Mapper to turn the aerial
imagery on and off.

Step 5: Create a HEC-RAS Geometry File in RAS Mapper
5.1) In RAS Mapper, right click on “Geometries” and select “Add
New Geometry”. Name the new Geometry file “Proposed1D”

5.2) In the “Proposed1D” geometry, right-click on “Rivers” and select
“Edit Geometry (BETA)”. Once in edit mode, a pencil icon will
appear next to Rivers. Note that the selected active editable layer is
shown in magenta.
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5.3) In Edit mode, right click on “Rivers” and select “Layer
Properties”. Select the “Features” tab and then the “Import
Features” button.
Navigate to and select the “02_StreamCL_LN.shp”created in step
1b.1.

Change the River name from “River 1”
to “CartersBranch” and the reach to
“Main”.

5.4) Now the cross sections will be brought in. With the edit mode still
active, right-click on “Cross Sections” and select “Layer Properties”.
As in step 5.3, select the “Features” tab, and then the “Import
Features” button. Navigate to and select the “02_XS_LN.shp” created
in step 1b.2.

5.5) Right click on the “Proposed1D” geometry file and select the “Stop
Editing” option.
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Step 6: HEC-RAS (1D) model Setup
To complete a 1D hydraulic simulation, there are a few items that need attention.
 Manning’s channel roughness values need to be assigned
 Modeling of a bridge deck and culvert is necessary
 Create a steady state flow file with reach boundary conditions
 Create and Execute steady flow plan
6.1) Close RAS Mapper and return to the main HEC-RAS
window. Select the geometric data editor button.
In the geometric data window, select “File” and “Open”.

Select the “Proposed1D” geometry created in Step 5.
6.2) In the Geometric data window, select Tables and then “Manning’s n or k values (Horizontally varied)…”

Highlight all the cells in the three
columns labeled “n #1, n #2 and n
#3”. Once Highlighted, select the
“Set Values…” button.
Enter in a value of 0.060 to set the
Manning’s values.

Select “OK” to close the Edit
Manning’s window.
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6.3) In step 1b.2, it was noted that a cross section was placed along the center of the
proposed road. This section will now be removed, and a bridge deck will be added in its place.
In this tutorial the section along the center of the road is cross section 863.
Locate the cross section in the
middle of the road through the
Cross Section editor in the
Geometric data editor. In the
“Cross Section Data” window,
select the “River Sta.” that is the
station down the middle of the
road. For this tutorial, it is
station 8+63.
Highlight all the “Station” and “Elevation” data from the table and copy it
to the clipboard utilizing Ctrl+C.
Once the table is copied to the clipboard, delete this cross section by
selecting “Options” and then “Delete Cross Section”. Select “Yes” to
allow reach lengths to be adjusted automatically.

To add a bridge deck, select the “Brdg/Culv” button in the
Geometric data editor. Then select “Options” and “Add a
Bridge and/or Culvert …” in the Bridge Culvert Data
window.
Enter the new river station of the bridge at station of the removed cross
section (863).

In the Bridge Culvert Data, select the “Deck
/Roadway” button. Set the “Distance” as 10 feet
and the “Width” as 40 feet. Paste (Ctrl+V) the cross
section geometry into the “Station” and “high chord”
for both the upstream and downstream portions.
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Add the culverts utilizing the
“Culvert” button in the Bridge
Culvert Data window. Enter in the
culvert data per the graphic provided.
Once entered, select “OK” on the
Culvert Data editor and “File” then
“Exit” on the Bridge Culvert Data
editor.
Save the Geometry data and close the Geometric
Data window.

NOTE: This completes the creation of the Proposed1D geometry model. For a FEMA compliant
model, there would need to be adjustments to the Expansion/Contraction coefficients around the
culvert and the placement of ineffective flow areas.

6.4) Create a steady state flow file. Select the “Edit / enter steady flow
data” button on the main HEC-RAS window.
In the steady flow window, select “File” and then “Save Flow Data
AS…”. Save the flow file as “Proposed1D-Flows”

In the steady flow window, select “Options” and then
“Edit Profile Names”. Rename the first profile from
“PF 1” to “100yr” and select the “OK” button.

In the Steady Flow Data window, set the 100Yr flow value to
2500.
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In the Steady Flow Data window, select the
“Reach Boundary Conditions…” button. In
the Steady Flow Boundary Conditions form
select the “Normal Depth” button and enter a
value of 0.005 in the field. Select OK and OK
to return to the Steady Flow Data form.

Save the flow file. In the steady flow window, select “File” and “Exit Flow
Data Editor”.

6.5) Create and execute a Steady State Plan. Select the “Perform a
Steady Flow Simulation” icon from the main HEC-RAS window.

In the Steady Flow Analysis window,
select “File” and then “Save Plan
As…”.
Save the plan as “Proposed1DPlan”. For the short plan identifier,
enter “Prop1D”

Select the “Compute” button on the Steady Flow Analysis
form to run a 1D hydraulic analysis.
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Step 7: View and Export 1D Results from RAS Mapper

7.1) Open RAS Mapper from the HEC-RAS main window.

Tree down the Results option and select
the “Depth (100Yr)” check box.
NOTE: The results are stored in an
.HDF file that HEC-RAS creates.
Through RAS Mapper, shapefiles and
GeoTiff’s are exported that can
be ingested downstream in GIS and
AutoCAD for the creation of
workmaps

7.2) Export the Stream Centerline as a shapefile.
Under the Results option, tree down Geometry
and check the Rivers option. Right click on
Rivers and select “Export Layer” and “Save
Features to Shapefile”
Save the file as
“07_StreamCL_LN_Export.shp”.
Repeat this for the cross sections by selecting then right-clicking on Cross Sections option under
Results -> Prop1D -> Geometry -> Cross Sections in RAS Mapper. Save this file as “07_XS_LN_Export.shp”

7.3) Create a shapefile for the limits of the calculated floodplain.
Under results, right click on the “Prop1D” header and select the
“Add New results Map Layer”.
This will open a “Results Map Parameters” window from which
both .SHP and .TIF files can be exported.
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To create a floodplain limits shapefile, select the “Inundation Boundary” option under Map Type, and “100Yr”
under the steady profile. Then select the “Add Map” button.

The requested layer is added to RAS
Mapper but not yet computed. Right click
the “Inundation Boundary (100Yr
Value_0)” layer and select
“Compute/Update Stored Map (Map
not created”.

Once computed, to export this
layer as a .SHP, right-click on the
layer and select “Export Layer”
and then “Save Features to
Shapefile”
Save the file as
“07_Floodplain_100YR_AR.shp”
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Step 8: Create a Hydraulic Workmap from the 1D HEC-RAS analysis
8.1) Open the drawing in tutorial resources titled “08_Workmap_1D.dwg”. This drawing has the existing and
proposed surfaces utilized in Step 1a. It also has a surface that is a composite of the existing ground and proposed
ground titled “Composite_FG”. Note that like the file in Step 1, this file references the Centr
al Texas– US Survey Feet Zone
In the AutoCAD command line, use the MAPIMPORT command to bring in the Stream centerline, cross section
and inundation limits created in Step 7. Make sure the “Files of Type:” is ESRI Shapefile. Select the three created
files and select “OK”.

Check the Import Polygons as closed polylines box. Select OK to bring in the linework.
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8.2) In Civil3D, create an alignment from the imported stream centerline
shapefile. From the Home tab in the ribbon, select “Alignment” and then
“Create Alignment from Object”
Select the imported stream centerline, and accept the current alignment
direction.
Name the Alignment “StreamCL” and select the style name
“AU_2019_StreamCenterline”

8.3) All the imported cross sections should be polylines, however if the cross section
has only two vertices then AutoCAD makes is a line on the MAPIMPORT. Convert all
the cross sections to polylines.
Enter PEDIT on the command line for the. Type M for the multiple option. Select all
the imported cross sections.
Select Y to convert all objects to polylines.

8.4) Turn all the cross section polylines into Sample Lines. From the Home tab on
the ribbon, select the “Sample Lines” option. Select the “StreamCL” as the base
alignment.
In the Create Sample Line Group window, name the group “XS”. Set the sample
line style to “AU_2019_XS_Line” and the Sample line label style to
“AU_2019_SectionLine_STA_0.12”

In the Sample Line Tools window, select
the “Select existing polylines” option.
Select all the cross section polylines and
convert them into sample lines.
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8.5) The floodplains lines that are exported from RAS Mapper typically have a larger number of vertices that make
hatching difficult and bog down AutoCAD. A routine called MAPCLEAN can be used to simplify the lines.
In the AutoCAD command line,
type in MAPCLEAN. Use the
“Select manually:” option and
click on the selection icon.
Select the floodplain polylines and
then the NEXT button on the “Drawing Cleanup” window.
In the Drawing Cleanup – Select
Actions window, add the
“Simplify Objects” from to the
Selected actions. Enter a
tolerance of 0.5 and click the
“Next” button.
Ensuring the Cleanup Method is
set to “Modify original objects”,
click the finish button to
complete the MAPCLEAN.

8.6) A georeferenced aerial image can be exported from RAS Mapper. This is quick and easy way to get
an aerial into the hydraulic work map. Back in RAS Mapper, check the “Map Layers” box to turn on the
Google Satellite image.
Zoom to the limits of the area where an image extraction is desired.
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Right click on the “Google
Satellite” and select “Export
Layer” and then “Export
current image to TIF”.
Save the file as
“08_GoogleAerial.tif”

Back in Civil3D, to bring the georeferenced aerial into AutoCAD type MAPIINSERT into the
command line. Select the 08_GoogleAerial.tif file just created. Select OK on the Image correlation.
Execute a DRAWORDER command in the command line and move the aerial to the back.
Together, these data in AutoCAD provide a solid construct for the beginnings of a hydraulic work map.
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Step 9: Create a 2D HEC-RAS Geometry file
With the composite terrain data already loaded in step 3, a 2-D HEC-RAS geometry file will be created.

9.1) Create a new HEC-RAS Geometry file. In RAS Mapper, rightclick on Geometries and select “Add New Geometry”
Save the new New geometry
Data as “Proposed2D”

9.2) Create the 2D computational grid mesh. In RAS Mapper,
tree down the “2D Flow Areas”. For the Proposed2D Geometry,
right-click on Perimeters and select the “EDIT Geometry
(BETA)” option.
Select the Add New Feature Icon.

In RAS Mapper, draw a polygonal area for
the grid mesh like the graphic provided.
Name the new Perimeter “2Darea”
Right-click on the polygon and select the
“Perimeters” layer and select the “Edit
2D Area Properties”
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Set the point spacing to 30 ft for the DX and 30ft for
the DY.
Note that by default, all cells in the grid mesh have a
Manning’s ‘n’ of 0.060.
Click the “Generate Computation Points” button
and then the “Compute Property Tables” button.
Finally, click the “Close” button.
Right-click on the “Proposed2D” geometry and select
“Stop Editing”. Select “Yes” when asked to save
edits.

9.3) Add the proposed road deck to the HEC-RAS Geometry file. In the
main HEC-RAS window, select the Geometry Editor button.
In the Geometric Data window, select File->Open Geometry Data and
select the Proposed2D file.
Select the SA/2D
Area Conn tool.

In RAS Mapper, draw a line down the center of the road way from
left-to-right looking downstream. This line must be within the grid
mesh. Once complete, name the Connection “Road1”.
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The drawn connection will seek to conform to the calculated grid mesh. Select (left click) on Road1 and select the
“Enforce Internal Connection as Breakline in 2D Flow Area”. This will adjust the 2D grid mesh to conform to
the road.

Select (left-click) on the Road 1 connection and select the
“Edit Connection…” option. This will open the
Connection Data Editor. Click the “Terrain Profile…”
button.

In the Centerline Terrain Profile window, select the Table
Tab. Highlight all the table data and copy (Cntl+C) these
data to the clipboard.
In Microsoft Excel, paste (Cntl+V) in these data. Add 0.05 feet
to the Elevation data. Copy (Cntl+C) the revised data out of
Excel.
Back on the “Connection Data Editor” window, select the
“Wier/Embankment” Button. Paste (Cntl+V) the paired
data into the Station Elevation table in the Storage-Area
Connection Weir Data window. Set the weir width to 40
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9.4) Add the proposed culverts to the 2D grid. In 2D HEC-RAS culverts are hosted on a Connection area [like
Road1 that was just created]. HEC-RAS does have a tool where it will attempt to place the culvert. It requires an
ESRI shapefile of the centerline of the pipes. These lines must be drawn from upstream to downstream .
Back in Civil3D, draw polylines down the center of
each culvert from upstream to downstream.
Enter MAPEXPORT in the command line. Select the four (4)
lines drawn down the center of the culverts and save them as a
line shapefile named “09_CulvertCL_LN”

Back in the
Geometric Data window
of HEC-RAS, select GIS
Tool -> Culvert
Centerlines -> Import
Barrel Centerlines …
Select Yes to import the
data. Select the
09_CulvertCL_LN.shp
file.
In the Geometric Data editor of HEC-RAS, select the “SA/2D Area Conn” editor
button. In the Connection Data Editor window, select the “Culvert” button.
Each culvert is created as a separate culvert group. For each of the four culvert groups
enter in the following information.
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Note that there are four culvert groups
named “import #0, import #1, import #2
and import #3”.

For each of these culverts, set the US Sta and DS Sta of the Barrel
Centerline equal to the GIS Sta. This will need to be done on all
four culverts.

The completed roadway and culvert in the 2D model should look as follows:

In the HEC-RAS Geometric Data editor, save the Proposed2D geometry file by selecting File -> Save Geometry
Data
9.5) Add boundary condition lines on the 2D grid mesh at
the upstream end of the two (2) creeks and at the
downstream end of the merged creeks.
For this tutorial, three (3) boundary conditions lines named
“Inflow_A”, “Inflow_B” and “Outflow” will be created
along the boundary of the grid mesh at the locations shown
on the image to the right.
NOTE: For a 2D analysis, boundary conditions are
limits on the boundary or within the grid mesh
where water is either “poured” into the terrain
or allowed to flow out of the mesh.
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In the Geometric Editor, click the “SA/2D
Area BC Lines” button.

Draw a line outside the grid mesh in the vicinity of the Inflow_A white line shown on the previous page.
Enter the name for the new SA_2D Flow Area Boundary as Inflow_A.

Create the Inflow_B and the Outflow boundary condition
lines in a similar manner.
n the HEC-RAS Geometric Data editor, save the
Proposed2D geometry file by selecting File -> Save
Geometry Data
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Step 10: Create and Run a 2D HEC-RAS Simulation
10.1) Create an unsteady flow file. In the main HECRAS window, select the unsteady flow button.
In the Unsteady Flow Data window, select the
File -> Save Unsteady Flow Data.
Save the Unsteady Flow File as “Proposed2D-Flows”.

In the Unsteady Flow Data window, select the
boundary condition to the right of BCLine: Inflow_B
and click the Flow Hydrograph button.
In the Flow Hydrograph window, select the “Read
from DSS before DSS simulation” option. Click the
“Select DSS file and Path” button.
In the Pick DSS Path window, select the file icon.
Navigate to the file name “10_Proposed_100yr.dss”
provided in the tutorial supporting files.

Select and double click the row
titled “Inflow_B” in Part B with
“01Jan2020” in Part D. Select the
OK button.
Back in the Flow Hydrograph
window, set the “EG Slope for
distributing flow along BC Line:”
to 0.005. Select the “OK” button to
close the Flow Hydrograph button.
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Back in the Unsteady Flow Data window, repeat the process to add a Flow Hydrograph to the BCLine: Inflow_A.
With the provided DSS file, select the Inflow_A flow from 01JAN2020.

Make sure to set the “EG Slope for distributing flow along BC Line:” to 0.005.
NOTE: A hydrologic program called HEC-HMS generates flow hydrographs in a DSS format.
files are being used in this tutorial.

These

Back in the Unsteady Flow Data
window, select the Normal Depth
button for the BCLine:Outflow row.
In the Normal Depth Downstream
Boundary window, set the Friction
Slope to 0.005.

Save the Unsteady Flow Data file and close the Unsteady Flow Data window.
10.2) Create an unsteady plan file. In the main
HEC-RAS window, select the unsteady plan
button.
In the Unsteady Flow Analysis window, select File -> Save As. Save the file as
Proposed2D-Plan. Set the short ID as Proposed2D.
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In the Unsteady Flow Analysis window, select File -> Save As. Save the file as
Proposed2D-Plan. Set the short ID as Proposed2D.

Under “Programs to Run” check all the boxes except
the Sediment Option.
Set the Start Date: to 01JAN2020 and the Start Time:
to 04:00
Set the Ending Date: to 01 JAN2020 and the End
Time: to 17:00
Set the Computational Interval to 15 Seconds.
Set the Mapping Output Interval to 5 minutes.
Set the Hydrograph Output Interval to 5 minutes.
Set the Detailed Output Interval to 5 minutes.
Select the “Compute” button.
Estimated time for this simulation is about 2 to 3
minutes.

Step 11: View and Extract Data from the 2D Simulation

11.1) Open RAS Mapper from the HEC-RAS main window.
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11.2) Review the results of the depth analysis. In
RAS Mapper, under the Results option, tree down
and select the Proposed2D and then Depth
option. Note that when viewed, the Max option is
set the default value.

11.3) At the top of the HEC-RAS window, a slider is available to step through the requested 5 minute mapping
outputs. Slide this slider until the 01 JAN 2020 12:35 time step.

Once this time step is selected, select the particle tracing button at the top
of the RAS Mapper Window.

11.4) Create a shapefile for the limits of the maximum calculated floodplain. Under results, right-click on the
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“Proposed2D” header and select the “Add New results Map
Layer”.
This will open a “Results Map Parameters” window from which both
.SHP and .TIF files can be exported.
In the Results Map Parameter window, select the Inundation
Boundary map type, and Maximum as the Unsteady Profile. Click
the “Add Map” button.

In RAS Mapper, right-click on Inundation
Boundary (Max Value 0) as select the
“Compute/Update Stored Map (Map not
created)” option.

Once computed, right-click on Inundation

Boundary (Max Value 0) as select the Export Layer and then Save Features to Shapefile.

Save the new file as “11_Floodplain_2D_AR.shp”
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11.5) Create a Geotif the represents the maximum water surface elevation. Under results, right-click on the
“Proposed2D” header and select the “Add New results Map Layer”. In the Results Map Parameter window,
select the Water Surface Elevation map type, Maximum as the Unsteady Profile and Raster based on Terrain: as
the Map Output option. Click the “Add Map” button.

In RAS Mapper, right-click on WSE (Max) as select the “Compute/Update Stored Map (Map not created)”
option.
NOTE: In addition to water surface elevation, it is typical to export grid data for Velocity,
Depth and Shear Stress grids for proposed design analysis in Civil3D

11.6) Locate the GeoTIFF(s) created by RAS Mapper for the maximum water surface elevation (WSE). Unlike the
Inundation Boundary shapefile, the GeoTIFFs created by RAS Mapper are a bit more difficult to locate.
Back on the main HEC-RAS window, select the file folder icon

This will open the folder where the HEC-RAS project and all supporting data is stored.
Double click the Proposed2D folder.
In this folder will three (3) Max WSE geotiffs. As the
ProposedSurface (see task 3) is a composite of three
DEMs, three grids were created.
Note this file location as it will be used in the next
step.
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Step 12: Cleaning HEC-RAS TIFFs
In Civil3D a surface can be created from a DEM such as
the Geotiffs exported from HEC-RAS. In the Civil3D
prospector, right-click on surfaces and select the
“Create Surface From DEM…” option.
Navigate to the WSE(Max).02_ExistingGround_3ft.tif file created in the
previous step. Civil3D will not read this file and will throw an error that
states “Unable to read file” in the command line.
In order to create a surface from the exported DEMs, those DEM files need to be digitally whitewashed through a
GIS program. This can be done in programs such as ArcGIS or QGIS.
For this tutorial SAGA (System for Automated Geoscientific Analyses) will be utilized. This program can be
downloaded at http://www.saga-gis.org
12.1) Locate the GeoTIFF(s) created by RAS Mapper for the maximum water surface elevation (WSE). See step
11.6 above. For this tutorial, the file is in:
….\HECRAS\Proposed2D

and is called

WSE (Max).02_ExistingGround_3ft.tif

12.2) Open SAGA. Note that this tutorial utilizes version 2.1.0. Other versions may differ for workflow.
Ensuring that the “Modules” tab is selected at the
bottom of the Manager window, find the
“Import/Export – GDAL/OGR” tool and
double click on the “GDAL: Import Raster”

12.3) In the “GDAL: Import Raster” window, select the ellipsis “…” to the right of the file field and navigate to the
WSE (Max).02_ExistingGround_3ft.tif file.

Once the file is selected, click OK on the “GDAL: Import Raster” window.
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12.4) Export the imported Raster as a GeoTiff. Select the “Import/Export –
GDAL/OGR” tool and double click on the “GDAL: Export Raster to GeoTiff”
In the “GDAL: export Raster to GeoTIFF” window, select the only grid system
available.

Select the ellipsis “…” to the right of Grids(s).
Select the grid on the left side
and click the “>” to add to the
right side. Click the “Okay”
button.

Back on the “GDAL: Export raster GeoTIFF” window, select the ellipsis “…” to the right of the file field.

Save the file in the /HECRAS/Proposed2D folder and name the file
“12_WSE_ExistingGround_SAGA_3ft”
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Step 13: Importing Cleaned TIFFs to Civil3D
Back in Civil3D, the cleaned water surface GeoTIFF will be imported in as a DEM surface.

13.1) In the “Toolspace”, right click on “Surfaces” and select the
“Create Surfaces from DEM” option.
Navigate to a select the “12_WSE_ExistingGround_SAGA_3ft.tif” created in step 12.

Once the surface is imported, right-click on that
surface and select the “Surface Properties…”.

Select the Surface Style named
“AU_2019_WSEL”.
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NOTE: For this project, the projection has a base unit of US Survey FEET. The GeoTIFF metadata also has a
base unit of US Survey FEET. When a surface is created from a DEM, it appears that Civil3D erroneously
assumes that a DEM with a unit of feet is International FEET.
As the tutorial project is working with a state plane reference system, this causes the imported DEM grid to be shifted
both south and west of where it should actually land.
One U.S. survey foot is equal to 1.000002 International Feet.
For this tutorial, Civil3D places the surfaces the surface with an error that is scaled from the origin of the stateplane
system.
As the location of the project is at X: 3,100,000 and Y: 10,100,000 the error is about 6 feet east and 20 feet north.

If the project is in meters then this shift will
not appear. Note that this error appears to
only appear when DEMs are IMPORTED
into Civil3D and the units are in US Survey
Feet.

13.2) Correct the DEM shift error by moving the surface 6 feet east and 20 feet north.
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About LandDev Consulting, LLC
LandDev, is an infrastructure engineering firm located in Austin, Texas. They are recognized as a leader in their use of
Civil3D as they employ BIM to improve multi-disciplinary design collaboration.
With a BIM workflow, LandDev Consulting has proven that Autodesk’s tools can empower small engineering firms to
create detailed hydraulic analysis within the constraints of a small project’s budget. LandDev is always interested in
partnering with like-minded clients and firms to create successful projects.
Discover their story at: https://www.landdevconsulting.com
Contact us at: andy.carter@landdevconsulting.com
P: (512) 872-6696

HEC-RAS – Civil3D Compendium
This concludes the Civil3D tutorial for Autodesk University 2019. In addition to the Civil3D tutorial, this document
serves a compendium for additional workflows that may be helpful for creating HEC-RAS analyses.
The following workflows are attached to this reference.
1)
2)
3)
4)

Terrain disappearing in HEC-RAS Geometry editor
Extract Pipe data from Civil3D for HEC-RAS.
Create a Civil3D water surface and corresponding floodplain delineation of 1D model with VBA routine.
Creating a DEM ground surface from LiDAR point cloud files.
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Compendium Item #1 - Terrain Disappearing in HEC-RAS
Geometry Editor
Sometimes the terrain that can be seen in RAS Mapper can’t be viewed in the Geometric Data Editor. This is
a tip provided at http://www.surfacewater.biz/disappearance/
Credit: Krey Price - Surface Water Solutions

Sometimes even when you’ve got your associations and view options set correctly, the terrain that you can readily see in
RAS Mapper will be missing in the Geometric Data Editor. To get the terrain to be visible in the Geometric Editor, try
the following steps.

1.

Save geometry and close the geometry editor window

2.

Close RAS Mapper

3.

Save the HEC-RAS project

4.

Open RAS Mapper

5.

Open the geometry editor (leaving RAS Mapper open)

6.

Zoom or pan in the geometry editor (use CTRL left-click to pan)
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Compendium Item #2 - Civil3D Pipe to HEC-RAS (VBA)
Getting HEC-RAS pipe data from Civil3D. LandDev Consulting has developed a simple VBA routine that
runs inside of Civil3D that helps extract pipe information for modeling culverts in HEC-RAS.

Step 1: Load the VBA Routine
To execute a VBA routine inside of Civil3D and AutoCAD, the Microsoft VBA Module must be separately downloaded
and installed. Prior to running this routine, install the VBA into AutoCAD. A link is provided below.
https://knowledge.autodesk.com/support/autocad/downloads/caas/downloads/content/download-the-microsoftvba-module-for-autocad.html

7.

In the AutoCAD command line, type in VBALOAD

8.

Locate the provided file titled
“PipeToHECRAS_2D.dvb”

9.

On the security pop-up, select “Enable
Macros”

10.

In the AutoCAD command line, type in VBARUN

11.

Select the available option, a click Run

12.

The routines main window
will pop up. Click the
“Select Alignment” button
and then pick the alignment
that represents the road
centerline in HEC-RAS.
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13.

Click the Select Pipe button, and select a pipe that intersects the road alignment.

14.

The window will populate data that can then be entered into HEC-RAS culvert structures.

NOTE: This routine assumes that pipes are created from upstream to downstream in compliance with HEC-RAS
requirements. Culverts with the same span and rise will assume that the structure is a pipe. Confirm with the Part
Name and adjust to Box Culvert if necessary.
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Compendium Item #3 - HEC-RAS to Civil3D Surfaces (VBA)
This routine allows Civil3D users the ability to quickly determine the water surface elevation for a 1D HECRAS floodplain. The routine imports the water surface elevation (WSE) and creates a Civil3D surface.
Additionally, this routine

For this program to run, both HEC-RAS and Civil3D must be installed on the machine prior to VBA
execution.
Execution notes:




This routine only executes on the ‘active’ plan in the HEC-RAS project. (the last executed analysis)
This routine only processes the first Reach and the first River of this plan.
The create Civil3D Floodplain tool works only on TIN surfaces (DEM surfaces will not work)

Step 1: Load the VBA Routine
To execute a VBA routine inside of Civil3D and AutoCAD, the Microsoft VBA Module must be separately downloaded
and installed. Prior to running this routine, install the VBA into AutoCAD. A link is provided below.
https://knowledge.autodesk.com/support/autocad/downloads/caas/downloads/content/download-the-microsoftvba-module-for-autocad.html

1.

In the AutoCAD command line, type in VBALOAD

2.

Locate the provided file titled
“HECRAS_to_CAD.dvb”

3.

On the security pop-up, select “Enable Macros”

4.

In the AutoCAD command line, type in VBARUN

5.

Select the available option, a click Run

6.

The routines main window will pop up. Click the “Browse…” button and locate a HEC-RAS
Project (prj) file.
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7.

If properly loaded, the HEC-RAS project information should populate. In the ‘Step 2’ portion
of the window, select the flood profile an click the “Create Civil3D Water Surface” button.

8.

To create a floodplain delineation, in step 3 select a base surface on which the floodplain
will be delineated and select the water surface elevation (WSE) on which the delineation will
be performed. Once selected, click the “Create Civil3D Floodplain [TIN Volume Surface]”
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9.

Select “Quit” to close the VBA window.

This routine will create new
surface styles and new surfaces
within the Civil3D drawings.
Results typically look like this:

NOTE: A WSEL (water surface elevation) surface is very useful within Civil3D as it allows for feature lines and
corridors to be established relative to this surface. For example, for reclamation efforts, a feature line is assigned to the
WSEL surface and adjusted 2 feet up to allow for freeboard. With this adjusted feature grading can commence for
reclamation activities.

NOTE: This routine, unlike RAS Mapper, performs a floodplain delineation that is a TIN versus TIN delineation. For
analysis with vertical structures, such as retaining walls, this frequently provide a more accurate floodplain delineation.
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Compendium Item #4 - LiDAR LAS to DEM
This item provides a sequence of the workflow (pics and clicks) for creating a useable existing ground (EG)
digital elevation model (DEM) from LiDAR LAS files for use in Civil3D.

Step 1: Loading the LAS file(s) in SAGA and creating a ground DEM
SAGA (system for automated geoscientific Analyses) is a robust and free set of tools utilized for the rapid processing
and production of GIS datasets. Specifically for this writeup, we will use the point cloud and DEM tool sets to create a
geotiff DEM of the existing ground for use in Civil3D.

1.

Open SAGA GIS. Ensure that the “Modules” tab is active on the “Manger” window.

2.

Select the Import/Export – LAS -> Import LAS Files

Make sure that the “classification” box is checked, as this will be used later to filter down to
the ground points. You can select multiple files if needed. Select the “Okay” button to
begin processing.
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3.

OPTIONAL: If you have multiple tiles, you will have to merge them. Select the Shapes –
Point Clouds -> Merge Point Clouds. Select the first tile as the “Main Point Cloud” and the
others using the “Additional Point Clouds” ellipses. Let SAGA place the merged point clouds
in a new file.

4.

Now we must filter the point clouds down to those classified as ground only. This will
remove the trees, building, etc…. Select the Shapes – Point Clouds -> Point Cloud
Reclassifier / Subset Extractor. Select the merged point cloud and select “classification” for
the attribute. Mode of operation is “Extract Subset” and the “old value” should be set to 2.
This is the value for ground points.

5.

Convert the point cloud into a grid. An advisable resolution that is a compromise between
file size and surface accuracy is a 3ft grid. This will supply a computed average elevation at a
3 ft post spacing.
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Select the Shapes – Point Clouds -> Point Cloud to grid. Select the merged-subsetclassification point cloud. Output should be “only z”. Aggregation should be “mean value”
and the cellsize is advised to be “3”.

6.

This next routine will be used to interpolate the values in the grid where there are gaps.
Select the Grid Tools -> Close Gaps
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Select the available extent for the grid system (there is likely only one) as the grid system. Select the
merged_subset_classification(Z) grid. Leave all other values alone. Click Okay to begin process. The
algorithim will run multiple passes as it fills in the holes.
7.

Next, the surface will be smoothed out to remove bumpiness that is common with raw
LiDAR data. The goal of this step is to create a terrain DEM that will generate less noisy
contours. Select the Grid -Filter -> Mesh Denoise

Select the spatial extents of the grid (there is likely only one). Select the
merged_subset_classification(Z) grid. Set the Threshold as “0”. Set the Iterations for
Normal Updating as “20” and the Iterations for vertex updating at “200”. This step may
make several minutes to process.
8.

OPTIONAL: You may want to clip the data down prior to exporting to Civil3D. Our tool of
choice is the Grid – Tools -> Cutting [interactive].

Select the “Data” tab of the Manager and double click the _merged_subset_classification [Z]
[Denoised] grid. This will open the created grid.
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To clip the grid, execute the Grid – Tools -> Cutting [interactive] tool in the Module
tab of the Manager. Select the grid system and the appropriate grid to clip.
(merged_subset_classification[Z][Denoised]). As you are now in the interactive tool,
pick the selection arrow from the icons at the top.
D
r
a
g
in the mapview and select the area of interest.
This will open a Cutting interface for the newly created
clipped grid.

Select “Okay” to create the new grid. Double click on the Grid – Tools -> Cutting [interactive]
tool and say “Yes” to stop the execution of the clipping module.
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Select the “Data” tab of the Manager. Note that there is a new grid that has been created.

9.

Export the Denoised grid as a Geotiff. Select the Import/Export – GDAL/OGR.

Select the spatial extent. Select the _merged_classification[Z](Denoised) grid for export.
Save the file where appropriate.

Page 45

Heavily Inundated: Using Civil 3D
Data for Floodplain Analysis in
HEC-RAS

Step 2: Import the DEM into Civil3D.
10.

Open a new Civil3D drawing. Open the
“Toolspace” and right click on the “Surfaces”
option. Select the “Create Surfaces from
DEM”

NOTE: If the Civil3D the projection has a base unit of
US Survey FEET the imported DEM may have
problems. When a surface is created from a DEM, it
appears that Civil3D erroneously assumes that a
DEM with a unit of feet is International FEET.
One U.S. survey foot is equal to 1.000002 International
Feet. Here is an example of DEM import error.
Assume that the location of the project is at
X: 3,100,000 and
Y: 10,100,000.
The imported terrain is about 6.2 feet to the west and
20.2 feet south of the actual location.
If the project is in meters then this shift will not appear.
Note that this error appears to only appear when DEMs
are IMPORTED into Civil3D and the units are in US
Survey Feet.

Apply an existing ground style to the surface. Congrats, you have created a LiDAR surface for use in
Civil3D!
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