Learning Objectives

- Learn how to handle the analytical model in Revit.
- Learn how to use the collaboration with Robot Structural Analysis from a Revit analytical model to analysis results.
- Learn how to integrate structural analysis results in Revit steel connection workflows.
- Learn how to collaborate with Advance Steel and create the fabrication documents (NC, DXF, and detailed drawings).

Description

This class will cover the workflow between Revit software, Robot Structural Analysis software, and Advance Steel software, from the design to the fabrication of a steel structure. In this class, you will learn how to handle the analytical model in Revit, use the collaboration with Robot Structural Analysis to obtain the analysis result, and then use those analysis results to create and verify Steel Connections inside the Code Checking module. After we create the fabrication model in Revit, you will use the collaboration with Advance Steel to create the final fabrication documents: NC, DXF, and detailed drawings.

Speaker(s)

Mihai has been working in the construction industry for over 13 years, going through several branches of the industry, from working in the production of aluminum windows, construction cost estimations, junior project planner, construction work supervision and quality assurance engineer in the software industry. Joined Autodesk in 2013, through the acquisition of Graitec, he is currently working as a Sr.QA Analyst for one of the teams that develops Revit and Advance Steel features. He is specialized in structural modeling and detailing.

Catalin is a former Autodesk customer, currently Autodesk employee, working in construction field for over 19 years, going through several branches of the industry, from junior unskilled worker to formwork specialist, storekeeper, project coordinator, project manager, CAD designer, structural designer. Joined Autodesk since 2014 as Quality Analyst. Currently, Product Owner for one of the teams that develops Revit and Advance Steel structural features. He is specialized in structural modeling and detailing.
### Table of contents

From Design to Fabrication: Using Revit, Robot Structural Analysis, and Advance Steel .......................... 1
Learning Objectives ........................................................................................................................................ 1
Description .................................................................................................................................................... 1
Speaker(s) .................................................................................................................................................... 1
Table of contents ......................................................................................................................................... 2
Introduction .................................................................................................................................................. 3
How to handle the analytical model in Revit .............................................................................................. 5
  - Exercise 1: Adding Start\End Releases .................................................................................................. 5
  - Exercise 2: Adding Boundary Conditions .......................................................................................... 13
  - Exercise 3: Adding Loads, Load Cases and Load Combinations ...................................................... 16
Collaborate with Robot Structural Analysis to bring the analysis results in Revit ................................. 29
  - Exercise 4: Analyze the structure in Robot and visualize the analysis results in Revit ..................... 29
Integrate structural analysis results in Revit steel connection workflows .............................................. 36
  - Exercise 5: Verify if a steel connection withstands the efforts from a specific Load Combination ... 36
  - Exercise 6: Propagate steel connections inside the project ............................................................... 48
Collaborate with Advance Steel and create the fabrication documents (NC, DXF, and detailed drawings) .............................................................. 61
  - Exercise 7: Set up the export Settings and transfer the model to Advance Steel ......................... 61
  - Exercise 8: Number the model, create detail drawings, NC and DXF files ................................... 66
Introduction

**Used Softwares:**
- Revit 2021, build 21.0.0.383 20200220_1100(x64)
- Robot Structural Analysis 2021, build 34.0.0.7777
- Advance Steel 2021, build 25.0.611.0
- Advance Steel Extension for Revit 2021, build 39

**Exercise models:**
At the beginning of each exercise section you will find the name of the model that you need to open from the Dataset folder.

**VideoSteps:**
To follow the exercise steps easily you can open the link placed at the start of each exercise. The steps where prerecorded using Screencast, the mouse clicks and key actions are displayed on the recording.

**Links to other resources:**
At the end of each exercise section you will find links to other resources that could help you automate the process further or go deeper into the subject that was presented.

In this class we will follow a workflow that uses the softwares in the following sequence:
1. Revit 2021
2. Robot Structural Analysis 2021
3. Revit 2021
4. Advance Steel 2021

For Design to Fabrication purposes there is also another workflow available, by using the softwares in the following sequence:
1. Revit 2021
2. Robot Structural Analysis 2021
3. Advance Steel 2021
The Robot Structural Analysis model can be transferred directly to Advance Steel, in order to create the fabrication documentation. This workflow will not be covered in this course.

The model that we will use consists of a warehouse with an adjacent structure. The model is in imperial units, all steel sections and structural materials are from the AISC standard.
How to handle the analytical model in Revit

Exercise 1: Adding Start\End Releases

Model: Wharehouse-Imperial-1.rvt
Video\Steps: https://autode.sk/30f0pER

In this exercise you will add Start\End Releases to each analytical bar, inside the analytical model. This is important because you will specify the degrees of freedom at each bar end.

Columns, Rafters, Main Beams – need to be set with Fixed Releases
Purlins, Vertical Bracings, Horizontal Bracings – need to be set with Pinned Releases.

1. Open Wharehouse-Imperial-1.rvt

2. In 3D view, open the Visibility /Grapphics Overrides dialog and enable the Analytical Model Categories\Show analytical model categories in this view, click Apply and than OK.
3. In 3D view select the Column from A-7 grid intersection, right click and select Select all Instances in Entire Project.
4. From the drop down menu, select the **Analytical Columns**.

5. In the Properties menu, go to the **Base Release** and **Top Release** and select the **Fixed** option.
6. Repeat steps 3-6 for: **Columns** on Grid D:

7. Repeat steps 3-6 for: **Rafters**:
8. Repeat steps 3-6 for:

Main Beams:

9. Repeat steps 3-6 for the Purlins on the main Warehouse, but select the Pinned option in the Start and End Release fields.
10. Repeat steps 3-6 for the Purlins, on the adjacent part of the building, and select the Pinned option in the Start and End Release fields.
11. Open the **Analytical Model** view and from the view cube select the **Front view**. Using a selection from Bottom-Right to Top-Left, select the **Vertical Braces** from the right side of the view. Select the **Pinned** option in the Start and End Release fields.

12. Repeat step 11 for the **Vertical Braces** on the left side of the building.
13. From the view cube select the Top View and then Rotate 90 degrees the view. Hold Ctrl key and select the 6 Horizontal Braces from the bottom of the view. Select the Pinned option in the Start and End Release fields.

14. Repeat step 13 for the Horizontal Braces from the other side of the view.

15. Go to 3D view, Save and Close the project.
Exercise 2: Adding Boundary Conditions

Model: Wharehouse-Imperial-2.rvt
Video\Steps: https://autode.sk/34j0dFV

In this exercise you will add **Boundary Conditions** at the bottom of all the Columns inside the model. This step is important because you have to specify the support conditions of the structure.

1. Open *Wharehouse-Imperial-2.rvt*
2. Open the **Analytical Model** view and from the **Analyze** tab, select the **Boundary Conditions** icon.

3. Select the **Point** type and in the Properties menu select the **Fixed** state. Click **Apply**.
4. Inside the canvas, click on each bottom Column Analytical Node from Grids A and C. After you finish selecting each node, click Esc. In the end, the model should look like this.

5. From the Structural Plans, open the Base view, open the Visibility/Graphics Overrides dialog and enable the Analytical Model Categories|Show analytical model categories in this view. Make visible the Analytical Nodes category and then click Apply and OK.
6. Zoom in on Grid D. From Analyze tab, select the **Boundary Conditions** icon and then the **Point** type. Set the state to **Fixed**. Inside the canvas, **click** on each Column Analytical Node from Grid D. After you finish selecting each node, **click Esc**.

7. In the same **Base** view, open the **Visibility/Grapphics Overrides** dialog and disable the **Analytical Model Categories\Show analytical model categories in this view** option. **Click Apply** and **OK**.

8. Open the **Analytical Model** view. The model should look like in the below picture. You should have 21 Fixed Boundary Conditions under all the columns in the project.

9. Go to **3D view**, **Save** and **Close** the project.
Exercise 3: Adding Loads, Load Cases and Load Combinations

Model: Wharehouse-Imperial-3.rvt
Video\Steps: https://autode.sk/2HLRaph

In this exercise you will add Load Cases, Loads and Load Combinations to your project in order to assess possible deformations and stresses in your design.

1. Open Wharehouse-Imperial-3.rvt
2. Open the Analytical Model view and from the Analyze tab, click on the Load Cases icon.

For the purpose of making this exercise simpler and manageable in the given time, we will delete several Load Cases that you will not use.

3. Inside the Load Cases dialog, select 8 SEIS1 and then click on Delete.
4. In the warning message that appears, click on YES.

5. Select 7 TEMP1 and then click on Delete.
6. Select 6 ACC1 and click on Delete.
7. Select 2 LL1 and click on Delete.
8. Select 4 LR1 and Rename the load case to MEP. From the Category drop down dialog, select the Dead Loads type.

9. Select 3 SNOW1 and Rename the load case to SNOW.
10. Select 2 WIND1 and Rename the load case to WIND Y.
11. Select 1 DL and Rename the load case to DL. Click on OK. After these steps, the dialog should look like below:
12. Click on **OK** to save the configuration and close the Load Cases dialog.

13. From the **Analyze** tab, click on the **Loads** icon.

14. Select the **Hosted Line Load** option.
15. In the Properties menu, select the WIND Y Load Case, set the value for Fz 1 to 0.000 kip/ft and place a value of -0.200 kip/ft in Fy 1 field. Click on Apply.

16. Inside the canvas, orbit the model to have a better view on Analytical Columns from Grid D. Click on each Analytical Column from Grid D, in order to place this linear uniform Load. After you are finished, press Esc.
17. From the **Analyze** tab, click on the **Loads** icon and then select **Line Load** command.

18. In the Properties dialog, check that the same values from step 15 are present.

19. From the **Placement Plane** drop-down menu, select the **Grid C** option.
20. Inside the canvas, zoom in on the **Analytical Columns** from **Grid C** and place the linear load between the **midpoint node** and the **top node** of the column. Please see below picture for a visual description. After you are finished with all the **Analytical Columns** from **Grid C**, press **Esc**.

After placing this linear load on all the **Analytical Columns** from **Grid C**, the model should look like in the below picture.
21. From the **Analyze** tab, click on the **Loads** icon and then select **Hosted Line Load** command. In the Properties menu, change the value for *Fy 1* to **-0.100 kip/ft**.

22. Inside the canvas, zoom in and orbit the model to have a better view of **Analytical Columns** from Grid A. Click on each **Analytical Column** from Grid A. After you finish, press **Esc**. The model should look like in the below picture.
23. From the **View Cube**, click on the **Right view**. Select all the **Linear Loads** that were placed until now and then select the **Hide Elements** option.

24. From the **Analyze** tab, select the **Loads** icon and then click on the **Hosted Line Load** command. In the Properties menu, select the **MEP Load Case**, change the value for **Fy1** to **0.000 kip/ft** and place a value of **-0.100 kip/ft** for **Fz 1**. Click **Apply** and select each **Rafter** and **Main Beam** from the canvas. After you finish the selection, press **Esc**.
25. From the **View Cube**, click on the **Right view**. Select all the **Linear Loads** that were placed until now and then select the **Hide Elements** option.

26. From the **Analyze** tab, select the **Loads** icon and then click on the **Hosted Line Load** command. In the Properties menu, select the **SNOW** Load Case and place a value of **-0.050 kip/ft** for **Fz 1**. Click **Apply** and select each **Purlin** from the canvas. After you finish the selection, press **Esc**.
27. From the **Temporary Hide/Isolate** menu, select **Reset Temporary Hide/Isolate** option.

28. From the **Analyze** tab, select the **Load Combinations** icon.
29. In the **Load Combinations** menu create 4 load combinations using the **Add** button. Set their **Name**, **Type** and **State** as in the below picture.

![Load Combinations Menu](image1)

30. Select the 1st Load Combination **1 1.0D+1.0S** and from the **Edit Selected Formula** category press on the **Add** button, twice. In the first **Case** select **DL** and the second one **SNOW**.

![Edit Selected Formula](image2)
31. Select the 2nd Load Combination \(2 \times 1.0D + 1.25W\) and from the Edit Selected Formula category press on the Add button, twice. In the first Case select DL and the second one WIND Y. In the Factor fields, change the value to 1.25000 for the WIND Y case.

32. Select the 3rd Load Combination \(3 \times 1.0D + 1.25MEP\) and from the Edit Selected Formula category press on the Add button, twice. In the first Case select DL and the second one MEP. In the Factor fields, change the value to 1.25000 for the MEP case.
33. Select the 4th Load Combination **4 Envelope** and from the **Edit Selected Formula** category press on the **Add** button, 3 times. In the Case or Combination drop down menus, select the 3 load combinations created before: **1.0D+1.0S; 1.0D+1.25W; 1.0D+1.25MEP.** After this, press on **OK** to save and close the dialog.

34. Go to **3D** view, **disable** the **Analytical Model** and then **Save** and **Close** the project.

**Robot Structural Analysis** has the ability to generate Load Combinations based on specific design codes. For more information please visit the below link, from the Help Document.

Collaborate with Robot Structural Analysis to bring the analysis results in Revit

Exercise 4: Analyze the structure in Robot and visualize the analysis results in Revit.

**Model:** Wharehouse-Imperial-4.rvt  
**Video\Steps:** [https://autode.sk/34bUIJo](https://autode.sk/34bUIJo)

In this exercise you will learn how to transfer the Revit model to Robot Structural Analysis, analyze the structure, transfer the analysis results back in Revit and then visualize them on the whole structure or by selection.

1. Open *Wharehouse-Imperial-4.rvt*
2. Open the *Analytical Model* view, select the *Analyze* tab and from the *Robot Structural Analysis* drop down menu, click on the *Robot Structural Analysis Link*.

3. In the dialog that opens, click on the *Send options* button.
4. Verify that for the **Specify the case that contains self-weight** option, **DL** case is selected. Press **OK** to save and close the dialog.

5. Set the **Direction of integration with Autodesk Robot Structural Analysis** to **Send model** and the **Type of integration** to **Direct integration**. Press **OK** to sent the model to Robot.

6. Robot Structural Analysis software will open and the model from Revit will be imported. When the transfer process finishes, the Revit model will be brought on top and an information dialog will be displayed. Press **No** in the dialog that pops-up.
7. In Robot Structural Analysis press on the **Calculations** command.

8. After the calculations are done, the **Calculations Messages** dialog will pop-up. Press on **Close** button.

9. From the Taskbar, click on the Revit icon, to bring in front the Revit model. From the **Analyze** tab, click on the **Robot Structural Analysis** drop down menu and then select **Robot Structural Analysis Link**.
10. In the dialog that opens, select the Update model and results and Direct integration options. Press OK to import the analysis results from Robot.

11. In the dialog that opens, un-select the Required reinforcement results package option.

12. In the dialog that pops-up, press No.
13. In the Analytical Model view, open the Visibility/Graphics Overrides menu, select the Analytical Model Categories and un-select the Structural Loads category. Press Apply and then OK.

14. From the Analyze tab, click on the Results explorer button.
15. In the Results for Analytical model dialog, select the Load Case: 1.0D+1.0S and for the Results for members select the Moments My option. Press Apply. The model will be populated with the Moment diagrams on the strong axis of the beams for the 1Dead+1Snow Load Combination.

16. Uncheck the Moments My option and press Apply. The diagrams will disappear from the model.
17. In the canvas, select a Rafter and a Column, then select the Moments My option and press Apply. The Moment diagrams will be displayed only for the selected elements.

Note: Tension and Compression is displayed for Forces Fx.
Note: Shear force is displayed for Forces Fz (strong axis) and Forces Fy (weak axis).
Note: Moment is displayed for Moment My.
Note: Diagrams can be displayed on the whole model or only on the selected elements, if elements are selected prior of the click on the Apply button.
Note: Diagrams can be displayed for all the Load Cases and Load Combinations defined inside the model.

18. Save and Close the project

Robot Structural Analysis has the ability to design steel or timber linear elements. For more information on this subjects please visit the links below.


Integrate structural analysis results in Revit steel connection workflows

Exercise 5: Verify if a steel connection withstands the efforts from a specific Load Combination

**Model:** Wharehouse-Imperial-5.rvt  
**Video/Steps:** [https://autode.sk/3cJev6p](https://autode.sk/3cJev6p)

In this exercise you will determine what is the maximum Moment between the Rafters and Columns, find the associated Shear Force and Axia Force and design a Moment End Plate connection between the 2 members, using the Code Checking module inside Revit.

1. Open *Wharehouse-Imperial-5.rvt*
2. Open the *Analytical Model* view, select the *Analyze* tab and open the *Results explorer* menu.

3. In the *Results explorer* menu, select *Load case: Envelope, Results for members \ Moments \ Moments My \ MAX*. Press *Apply* and search for the maximum Moment on Y axis, at the end of a Rafter beam.
Note: The maximum moment is on the Rafter end, at the intersection between Grid A and Grid 6. The value is 82.74 kip-ft.

4. Un-check the Moments My \ MAX option from Results explorer and press Apply. Select the Rafter and Column at the intersection of Grid A and Grid 6, select the Load Case: 1D+1.25MEP and the Moments My option and the click Apply. The maximum moment is from this Load Case: 1D+1.25MEP

5. Un-check the Moments My option and select the Forces \ Forces Fx option. Click on Apply to show the diagram.
6. Un-check the Forces Fx option and check the Forces Fz option. Click on Apply to show the diagram.

Note: the associated Axial Force is 9.73 kip.

7. Un-check the Forces Fz option, click Apply, close the Result Explorer menu and open the 3D View.

8. Zoom in the 3D View, select the Column and Rafter from the intersection of Grid A and Grid 6.

Note: the associated Shear Force is 7.95 kip.
9. On the **Modify tab** click on the **Selection Box** command. After the 2 elements are isolated, orbit around them to view the intersection.

10. On the **Steel tab**, click on the **Connection Settings** button.

11. In the **Structural Connection Settings Dialog**, press on **All** button and then **Add**. Click **OK** to save and close the menu.
12. In the Steel tab click on the Connection command.

13. In the Family Types drop down menu, filter the selection after Moment End Plate, select the Moment end plate connection and then select the Rafter and Column from the canvas. Press Enter for the connection to be created.
14. Using **Tab key**, select the **Plate** element from inside the Steel Connection. In the Properties menu, change the Structural Material to **Steel ASTM A992**, click OK to save and close the Material Browser menu. Press Esc to unselect everything.

15. Select the **Steel Connection** and press on the **Edit Type** button.
16. In the **Type Properties** dialog, click **Edit**. In the **Plate layout** tab, increase the **Plate thickness** to 3/4”.

![Diagram of Type Properties dialog]

17. In the **Vertical Bolts** tab, change all the default values to the ones from the below picture: **Group 1** – 3; **Lines** – 3; **Start dist** – 3”; **Interm. Dist**. 6”; **Group 2** – 0; **Outside Bolts** – both; **Top Lines** – 1; **Start dist** – 2”; **Bottom Lines** -1; **Start dist** – 2”.

![Diagram of Vertical Bolts tab]
18. Press OK, then Apply and OK again.
19. Select the Column and in the Properties menu, increase the Top Offset to 6”. Press Apply.

20. Select the Moment End Plate connection, check the Override by Instance option and click on the Detailed Parameters Edit button.
21. In the Code Checking tab, un-check the Automatic values option, check the Use load combinations option and click on the Forces button.

22. In the Forces menu, add a new Case with the following values:
   - M = 82.74 kip-ft
   - P = 9.73 kip
   - V = 7.95 kip
   Click OK to save and close the dialog.
23. Click on **Check** button.

![Check button](image)

24. Click on **Report** button. A HTML file is opened detailing each verification that was done for that steel connection. The connection fails at the **End plate resistance at bending verification**.

![Report button](image)

25. Go back in Revit, close the **Steel Connection Detailed Parameters** menu, uncheck the **Override by Instance** option and press **Apply**.

![Revit window](image)
26. After the Steel Connection geometry is calculated and the Background Process finishes, press on the **Edit Type** button. Inside the **Type Properties** menu click on the **Edit** button.

27. In the **Plate layout** tab, increase the **Plate thickness** to 1”. Press **OK**, then **Apply** and **OK** to save and close the dialog.
28. Select the Moment End Plate connection, check the Override by Instance option and click on the Detailed Parameters Edit button.

![Moment End Plate Connection](image)

29. In the Properties \ Code Checking tab, press the Check button. The steel connection withstands the applied forces. Click on Report to see the details.

![Code Checking](image)

30. Go back in Revit, close the Steel Connection Detailed Parameters menu.
31. Save and Close the project
Steel Connection Code Checking modules are available in Advance Steel, Revit and also Robot Structural Analysis software. For more resources please follow the links below.


Exercise 6: Propagate steel connections inside the project
Model: Wharehouse-Imperial-6.rvt
Video\Steps: https://autode.sk/2GlYx60

In this exercise you will create a Base Plate Connection at the bottom of a column, a Double purlin splice plate connection between two purlins and a rafter and then you will populate the model with these connections using the Propagate command.

1. Open Wharehouse-Imperial-6.rvt
2. In 3D View, zoom in on the bottom end of the Column from the intersection of Grid A and Grid 6.
3. In the Steel tab click on the Connection command.
4. In the **Family Types** drop down menu, filter the selection after **Base plate**, select the **Base plate connection** and then select the **Column** from the canvas. Press **Enter** for the connection to be created.

5. Select the **Base plate connection** and press on the **Edit Type** button.
6. In the **Type Properties** dialog, click **Edit** button.

7. Inside the **Edit Connection Type** menu, in the **Base plate layout** tab, increase the **1. Plate thickness** to **2"**.
8. In the **Base plate dimensions** tab, increase the **1. Projection 1** to 6”.

9. In the **Anchor and holes** tab, select from the drop-down menu for **Anchor type** the value **US J-Round Anchors**, from the **Anchor diameter** drop-down select the value **1 1/4” inch** and from the **Anchor Length** drop-down select the **3’** value.
10. In the Anchors parallel web tab, for 2. Intermediate distance place a value of 16”.

11. In the Anchors parallel flange tab, for 2. Intermediate distance place a value of 23”. 
12. Click **OK**, then **Apply** and **OK** to save and close the dialog.

13. Hold the mouse cursor over the **Base plate** connection and press on **Tab** key until the **Plate element** is highlighted. Select the **Plate element** and change the **Structural Material**, from the **Properties** menu, to **Steel ASTM A992**
14. Zoom out to see the whole model. Select the **Base plate** connection, right click and from the **contextual menu**, select the **Propagate Connection** command. This command will propagate the connection type on all the Columns with the same section and geometrical position, inside the model.

15. Select the **Moment End Plate** connection, that was created between the **Rafter** and **Column** at the intersection of **Grid A** and **Grid 6**, right click and from the **contextual menu** select the **Propagate Connection** command.
16. Set the view to Right from the View Cube. Zoom in on the Columns from Grid A, select the columns from this grid using a bottom right – top left selection and in the Properties menu set a value of 6” for the Top Offset.

17. Repeat step 16 for the columns on the other side of the Warehouse building, on Grid C.
18. **Orbit** around the model to **view the Rafter and 2 Purlins** from the intersection of **Grid A** and **Grid 6**. From the **Steel tab** select the **Connection** command and then filter the available types for **Double purlin splice plate connection**.

19. Select the **Double purlin splice plate connection**, hold the Ctrl button, **select the Rafter and 2 Purlins** and then press Enter.
20. Select the **Double purlin splice plate connection** and click on the **Edit Type** button.

21. In the **Type Properties** dialog, click **Edit** button.
22. In the **Bolt dimensions** tab, increase the **1. Purlin gap** to 1”, the **5. Start distance** to 4” and the **7. Intermediate distance** to 4”.

23. In the **Rib stiffener** tab, increase the **3. Width** to 6”, the **6. Chamfer width** to 2” and the **7. Chamfer height** to 2”.
24. Click **OK**, then **Apply** and **OK** to save and close the dialog.

25. **Hover the mouse** over the Plate element and press **Tab key** until the Plate element is highlighted. **Select** the Plate element and change the Structural Material to **Steel ASTM A992**.
26. Repeat step 25 for the other Plate element inside the Steel connection.

27. Zoom out to see the model, select the Double purlin splice plate connection, right click and from the contextual menu select the Propagate Connection command.

28. Save and Close the project
Collaborate with Advance Steel and create the fabrication documents (NC, DXF, and detailed drawings).

Exercise 7: Set up the export Settings and transfer the model to Advance Steel

Model: Wharehouse-Imperial-7.rvt
Video\Steps: https://autode.sk/34hb5Us

In this exercise you will learn how to set up the export settings in Advance Steel Extension for Revit add-on and transfer the model to Advance Steel software in order to create the fabrication data.

1. Open Wharehouse-Imperial-7.rvt
2. In the Add-Ins tab, open the drop-down menu from Advance Steel Extension and click on the Settings button.

3. Inside the Settings menu, using the Edit Path and Add Path commands add the following 2 locations, that contain the US Imperial families:

   - C:\ProgramData\Autodesk\RVT 2021\Libraries\English-Imperial\Structural Framing\Steel\AISC 14.1
   - C:\ProgramData\Autodesk\RVT 2021\Libraries\English-Imperial\Structural Columns\Steel\AISC 14.1
4. Check the **Export grids** and **Ignore beam cutbacks and extensions on export** options. Click on **OK**.

5. In the **Add-Ins** tab, open the drop-down menu from **Advance Steel Extension** and click on the **Export** button.
6. In the dialog that pops-up click on **OK**.

7. Save the export file with the **Wharehouse-Imperial-7.smlx** name, in the **Exercise 7** folder, in the same location on the harddrive from where you opened the Revit model for this exercise. Click on **Save**.
8. Open **Advance Steel 2021**, select the **United States** content from the drop down menu and click on the **Check** mark.

![Country Settings and Configurations](image)

9. From the drop-down menu select the **ASTemplate.dwt**.

![Selecting ASTemplate.dwt](image)

10. From the **Export & Import** tab, select the **Import Revit** command.
11. In the dialog that opens, select the **Wharehouse-Imperial-7.smlx** file that was created in step 7. Click **Open**.

12. **Save** the model inside **Exercise 7** folder with the **Wharehouse-Imperial-7.dwg** file name.
Exercise 8: Number the model, create detail drawings, NC and DXF files

Model: Wharehouse-Imperial-8.dwg

Video/Steps: https://autode.sk/3jxCvfj

In this exercise you will learn how to automatically number the model using the “With Drawing Number” option, create detail drawings (Single Part and Assembly), explode drawings to DWG, plot drawings to PDF, create NC files and DXF files.

1. Open *Wharehouse-Imperial-8.dwg*
2. Go to *Output* tab and select the *Numbering* command.

3. In the Numbering menu, for *Single part*, set the *Counter* to *Number* and un-check the *Start with first counter* option. For *Assembly*, check the *Process assemblies* option, set the *Counter* to *Number* and un-check the *Start with first counter* option.
4. From the **Special** tab, check the **Exclude concrete objects** option. Click **Apply** and then **OK** to number the model.

5. After the numbering is done, a dialog will open displaying the Preliminary Parts, Single Parts, and Main Parts inside the model. If a line from the table is selected, the identical elements will be marked in red, in the model. **Close** the menu.
6. From the Output tab click on the Drawing Processes button.

7. Open the 2-Singleparts-All category and click on the All Sp PageFull ANSI-C drawing process.
8. In the dialog that opens, click **OK**.

9. Open the **5 – Assemblies – Selected** category, select the **Rafter** and **Column** from the intersection of **Grid A** and **Grid 6**, and then click on the **Selected Assemblies Each ANSI-D** drawing process.
10. In the dialog that opens, click **OK**.

11. **Close the Drawing Processes** dialog.
12. From **Output** tab, open the **Document Manager** menu.

13. The detail drawings are stored in **Details \ Up to date** category. To open the detail drawings you need to select them and then click on **Open drawing** button. The selection can be individual or multiple, by holding the **Ctrl** key.
14. Open **Document Manager**, select all the **detail drawings** and click on **Add to batch plot**.
15. The detail drawings will be copied to a new category called **Batch plot**. Right click on **Batch plot** and select **Choose a plotter**.

16. In the **Plot Devices**, select **PDF** and click **OK**.
17. **Right click** on **Batch plot** and select **Print**.

**Note:** The detail drawings will be printed to PDF files and will be saved next to the DWG model.
18. Open Document Manager, select all the detail drawings and click on Add to explode.

19. The detail drawings will be copied to a new category called Batch explode. Right click on Batch explode and select Set-up the explode options.
20. In the **Detail Explode** menu you can choose the version of the dwg files that will be created and also choose the Layer, Color and LineType to which element will be exported. Leave the options with the default values and click **OK**.

![Detail Explode menu]

21. **Right click** on **Batch explode** and select **Explode the documents now**.

![Batch explode dialog box]
Note: The detail drawings will be exploded to pure Autocad DWG files and will be saved next to the DWG model, in a folder called DetailsExploded.

22. In Document Manager click on OK to close it.
23. In the **Output** tab, click on **NC** command.

24. Open **Document Manager**, the NC files will be stored in **DStV-NC** category. Click **OK** to close the dialog.

**Note:** On the harddrive, the NC files will be stored next to the DWG model, in a folder called **DSTV\NC**.
25. In the **Output** tab, click on **DXF (All Objects)** command.

26. Open **Document Manager**, the DXF files will be stored in **DXF for all objects** category. Click **OK** to close the dialog.

**Note:** on the harddrive, the DXF files will be stored next to the DWG model, in a folder called **DSTV \ NC**, next to the NC files previously created.