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Learning Objectives
•
•
•
•

Become familiar with Generative Design in Revit
Learn how to create workspace layout using various Generative Design studies
Learn how to push and pull custom data to and from a Revit project into a
generative workflow
Learn how Dynamo for Revit can be used to implement generative-design
workflows

Description
As more people return to the workplace, design decisions take on new significance. From the
safe arrangement of desks, the width and spacing of aisles, to the density of seating—better
data informs better decision making. Dynamo and Generative Design in Autodesk® Revit® bring
the art and science of informed decision making to design exploration. In this class, we will walk
through the creation of four different approaches to workspace layout using various Generative
Design studies in Revit, including everything from 'out of the box' sample studies to 'built from
scratch' Dynamo scripts that have been exported for use in generative design. This class will
show you how to customize Generative Design workflows in Dynamo for Revit.

Speakers
Tomasz is a structural engineer. He has over 17 years of experience in the software industry,
including extensive knowledge of structural solutions in the Autodesk portfolio. He holds a
Master of Science degree in Structural Engineering from the Cracow University of Technology,
Poland. He is very passionate about computational and generative design. He is a BIM
enthusiast and a Revit API and Dynamo coder. Follow him on Twitter: @TomekF.
Aaron is a registered architect (AIA, NCARB), engineer-in-training (EIT), and sustainability
professional (LEED AP BD+C) with graduate degrees in civil/structural engineering and
architecture (BSCE, MSCE, M.Arch). He has practiced in architecture and engineering, led two
design firms through BIM transitions, and spent twelve years in technical sales—educating and
advising design firms, contractors, and owners on how to improve the tools and techniques they
use to accomplish their work. Aaron presently leads a global team of technical marketing
managers in the development of compelling storytelling assets for the building industry.
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Motivation
At Autodesk, we spend a lot of time thinking about the future -- in terms of the things we make,
how we make them, and how we work.
What’s happening right now in the world is both disrupting and accelerating many of the trends
we’ve been tracking. COVID-19, and the social upheavals occurring in the U.S. and much of the
world, has uncovered gaps in the way the world works: what we make, where we make it, how
we make it, and our understanding of who benefits.
The post-COVID-19 world will look different—politically, economically, and in terms of the built
environment—than the pre-COVID world. We need to work together to forge not a new normal,
but a new better…to create spaces and processes that are better for all of us as we re-enter the
world. This is an opportunity to re-think the AEC ecosystem.
From education to remote work to socializing with our friends and family in a way that keeps
everyone safe, we’re all acting as innovators now—and in ways we never imagined.
We will need to rethink the PEOPLE and PROCESS that define our industry.
Over the past few months, we’ve been talking to customers and health experts about current
challenge and the constantly changing landscape. Four main themes have continued to come
up:
1. The need to accelerate remote and hybrid work;
2. The need for space planning to retrofit indoor and outdoor spaces;
3. The need to solve for congestion points where people move through space, such as at
building entrances or through transit hubs; and
4. The need to improve indoor air quality.
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Space Planning
We’ve all heard the headlines. It’s the end of the open office floor plan. It’s the end of the
gummy bear jar. The need to maintain a safe distance of 6 feet between employees means that
commercial offices will need to be retrofitted, at least temporarily. From the safe arrangement of
desks, the width and spacing of aisles, to the density of seating – better data informs better
decision making.
AEC firms are actively thinking about what this looks like.

Dynamo and Generative Design in Autodesk Revit can automate the iteration of workspace
layouts to help determine what will work best in your client’s space.
With Generative Design in Revit, you can build safe distancing standards into your workplace
design studies. Use it to better visualize design data, understand trade-offs, and weigh different
room layout options without the manual work of re-arranging and re-orienting desks and interior
elements.
You can use Revit Generative Design to:
•
•
•
•

Optimize room capacity according to safe distancing guidelines
Generate, explore, and refine multiple layout options in a short amount of time—
visualizing and supporting design decisions with data
Create custom logic with Dynamo to address specific design requirements or needs
Populate preferred design concepts directly into the Revit model
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The tool can be applied to other project types as well, such as redesigning the layout of a
restaurant, a grocery store, or a hospital.
Think of this handout as your training guide. Inside, you will learn how to use Generative Design
in Revit to perform workspace layout. Through a total of five hands-on exercises with stepby-step instruction, you will generate alternatives for the placement of desks in office
environments. These exercises will increase in complexity as we go along, starting with “out-ofthe-box” Revit samples and working towards “built-from-scratch” studies in Dynamo for Revit.
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Exercise 1: Desk Layout using the Workspace Layout Sample Study
In this exercise, you want to determine the best arrangement of desks in a large room using
Generative Design in Revit. You plan to use the Workspace Layout study, which generates
layout alternatives in rows—suitable for an office space or classroom. Your goals are to
maximize the number of desks, maximize views to the outside, and minimize the distance from
each desk to the nearest exit.
1. Open the Datasets/Workspace Layout.rvt file.
2. On the Manage tab, click Create Study.

The Create Study dialog lists available study types. These are the examples provided by
Autodesk. Using Dynamo, more study types can be added to help solve your
organization’s unique design problems.
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3. Select the Workspace Layout sample study.
4. Enter a unique name in the Study Name field.
5. The Method you select determines the logic that is used to generate design alternatives,
or outcomes. In this example, you have specific goals, so you will use Optimize. The
settings in the dialog change based on the method you choose.

When creating a study using the Optimize method, you can choose from the following
goals:
•
•
•

Maximize the number of desks in the room (i.e. desk count).
Maximize the average score for the quality of views to outside from each desk (i.e.
views to outside).
Minimize the average distance to exits.

6. Select a room for the study. Go to the 03 – Floor view. Select the room 321 Open Office.
(Note: In Revit rooms can be selected only in a plan view.)

7. Select an instance of the desk family to be used in the layout. For this exercise, you will
select the Desk family (a standard family available out of the box) sitting in the adjacent
room 320 Media Review.
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8. For Choose Variables, you will choose the items whose values can change when
generating outcomes. For this exercise, ensure both are selected.

9. For Set Goals, you will select the goals that are important for this study as follows:

10. In addition to defining variables and goals, you can set constraints on the outcomes. In
this case, you will leave the default values unchanged.
11. For Generation Settings, use the settings pictured below. These settings affect how the
Optimize algorithm works. Check the Issues section and be sure to resolve any issues
before starting the study.
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12. Click Generate. The Explore Outcomes dialog will appear, and your study will begin
generating.
13. When the study is done, a green checkmark displays next to the study name. Outcomes
display in the center pane, showing the design alternatives resulting from the study.

14. Click the

icon to collapse studies list.

15. Each thumbnail is a live 3D view, so a limited number of outcomes are displayed at one
time. Use the controls to view the outcomes as a list, sort them, or display additional
pages of outcomes.
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16. Select an outcome, and make sure the Details and Charts options are turned on at the
top right corner. The outcome details appear in the righthand pane. The image is a 3D
view that you can manipulate. The outputs indicate resulting values for this outcome,
and the inputs show the values used to generate it. Click the arrows at the bottom right
to view other outcomes in detail.

Page 9

17. You can also use the chart to filter outcomes. Click and drag over one or more columns
to see outcomes that meet the criteria.

18. Click Clear filters to display all outcomes again.
19. To review and analyze outcomes in another way, change the chart view to a scatterplot.
Use the options here to change the criteria used for the X and Y axes, and to format the
display of outcome values.

20. Click a plot on the chart to select that outcome and view its details.
21. Once you have decided on a particular outcome that you want to integrate into the
model, select that outcome and click Create Revit Elements to add these elements to
Revit.
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22. The resulting desk layout in the 03 - Floor plan view appears as expected.

Open the 3D view Office Building. Here, you notice that the desks are oriented
backwards (i.e. back-to-front) from the desired result.
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23. Fortunately, this rotation issue is easily solved; simply select all desks and press the
Space bar twice.
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Exercise 2a: Standing Desk Layout using Customized Workspace Layout
Study
In the next exercise, you will consider the layout of a larger open office space, room 302 Office.
This time, you will use a standing desk family. Using Dynamo, you will customize your
generative design studies to overcome unexpected behavior and achieve desirable results.

One of the many challenges facing employers as they begin to repopulate their offices is the
need to maintain a safe physical distance between employees. Using Generative Design in
Revit, you will consider this basic problem: How might you configure an open office environment
with safety in mind?
Your goal is to ensure that your employees maintain a minimum distance of 6 feet from each
other.
As for constraints:
• You need to accommodate 32 employees at standing desks;
• Glass panels may be attached to the desks to enable back-to-back placement; and
• Ideally, you would like to be able to use the two operable partitions currently installed in
the open office space.
With these inputs, you decide to use the Workspace Layout study to lay out the desks.
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1. In Revit, load the family Furniture_System-Standing_Desk-Rectangular_w_Partition.rfa
from the Datasets folder. This is a nested family containing two out-of-the-box families:
Furniture_System-Standing_Desk-Rectangular.rfa and Furniture_System-PartitionPrivacy_Panel.rfa.

2. Place an instance of this family in 329 Corridor so that it will be selectable in the next
step.
3. Create a new Workspace Layout study:
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4. Make sure everything is set up as shown, and then click the Generate button.
5. You should see the following outcomes appear; take a moment to review them:

6. Select the outcome shown (52 desks, 45-degree rotation) and click Create Revit
Elements.
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7. You receive a message stating that the elements were successfully created, but they do
not appear in the 03 - Floor plan view.
8. Open the Site plan view, and you will find the desks. Note that two problems have
arisen: (1) the desks are floating in the air, and (2) the desk layout does not match the
outcome that you selected.

9. Select one of the generated standing desks. As you can see, the desk has been placed
on the correct level (03 - Floor) but the Elevation from Level parameter is 24’ 0” instead
of 0’.

The Desk family worked well in the previous exercise, as the Elevation from Level
parameter in that family is not editable and always remains 0’. The family used in this
exercise behaves differently, as this parameter is editable.

Page 16

10. Select the standing desk family and click Edit Family. In the Family Editor, Ref. Level
view, you can see how the family is defined, particularly with respect to its origin.

Note: the Furniture_System-Standing_Desk-Rectangular_w_Partition.rfa family has its origin
defined differently than the Desk family. However, you will not need to modify the family to get
desks laid out properly. This will be done with Dynamo.
11. Close the family without saving changes, return to the project, and remove all standing
desks that were previously generated. Close the Explore Outcomes dialog.
12. Now, you can quickly fix the issues you have just come across by making some
adjustments to the Workspace Layout study definition.
Note: All Generative Design studies are defined in Dynamo. From Dynamo, you can
make more study types for use with Generative Design in Revit, or you can adjust the
existing ones. Editing and/or adding studies is typically performed by someone who is
familiar with Dynamo for Revit.
When you install and launch Revit, the sample graphs are stored in the following location
on your local computer: C:\Users\<username>\Documents\AEC Generative Design.
Launch Dynamo for Revit (Manage tab > Visual Programming panel > Dynamo) and
open the C:\Users\<username>\Documents\AEC Generative Design\Workspace
Layout.dyn file.
13. This script uses custom nodes from several packages. Dynamo finds any required
packages in the refreshed Workspace References viewer and automatically notifies you
if any are missing. The viewer lists the packages used in your graph, along with their
version and status:
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14. If you do not see the Workspace References viewer click View > Show Workspace
References.

15. Select each missing package

and click Install Specified Version…

…proceeding until all missing packages have been installed:
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16. Zoom into the Place Desk Instances section.

17. This script needs to be adjusted to obtain the right value of the Elevation from Level
parameter for generated elements. The updated script will check to see whether the
selected instance of the system furniture family has the Elevation from Level parameter
defined. If the parameter exists and is editable, then the script will retrieve a value of the
Elevation from Level parameter from the selected instance and assign that value to
newly created instances.
If you are comfortable in Dynamo, add the nodes below to accomplish this task. If you
want to save time, skip ahead to step 18. If you have no experience with Dynamo, skip
to step 28.
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18. If you are a novice with Dynamo or wish to save time, please follow the simplified
instructions below. If you have no experience in Dynamo, skip to step 28.
In lieu of creating the nodes in step (17) yourself, you may import a custom node called
ElevationFromLevel. Copy the ElevationFromLevel.dyf file from the Datasets folder to
C:\Users\<username>\AppData\Roaming\Dynamo\Dynamo Revit\2.5\definitions. After
restarting Dynamo, you will find this node under the GenerativeDesign > Custom
category:

As its inputs, this node takes the selected element (desk) and newly created Revit
elements and returns new elements with the updated Elevation from Level parameter
value. Connect this node accordingly.

19. Once you have completed your modifications to the sample study in Dynamo for Revit
via steps (17) or (18), you will need to export the updated study for use in in Generative
Design in Revit. First, use File > Save As to save the graph with the new name
Workspace Layout - Standing Desk.dyn.
20. In Dynamo, select Generative Design > Export for Generative Design. Note: When you
export a graph, any previous graphs with the same name are overwritten.
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21. If the dialog displays "First run the graph," click Run. This allows Dynamo to validate the
graph before exporting it.

22. If the dialog lists any issues, you will need to resolve them before proceeding. You might
need to set nodes as inputs or outputs, for example, or fix name conflicts. In this case,
you have missing input selections:

Note: If you encounter errors in steps 21-22, you may wish to skip ahead to step 28 to
save some time.
23. Close the Export for Generative Design dialog and select inputs in Revit (i.e. desk and
room):

24. Run Export for Generative Design again and click Run.
25. In the export dialog, fill out the Description and add an Image in the fields provided (you
may want to use the standing-desk-w-partition.png file from the Dataset folder). This
information will appear in the Create Study dialog in Revit.
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26. Select Clear cached data at the bottom of the dialog.
Note: If you select Keep cached data, any data in the study that is specific to the Revit
model you have been using with the graph will be retained. When someone creates a
study, it uses this data unless they specifically change it. If you select Clear cached data,
any data in the study that is specific to the Revit model you have been using with the
graph will be removed. When someone creates a study, they are prompted to select new
data in their current model.
27. Click Export.
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The graph is exported to the folder indicated in the dialog, along with any dependencies
needed to run it. Any graph residing in that folder will appear as a study type in the
Create Study dialog.
The Dependencies folder contains the following:
• info.json: the study type description that appears in the Create Study dialog
• study_type.png: the thumbnail image that appears in the Create Study dialog
• packages: a folder containing the Dynamo packages used by the graph
• definitions: a folder containing any exported custom nodes
Note: If other team members want to use the new study type, send them the exported
DYN file and its Dependencies folder. Ask them to place the files in the following location
on their computers: C:\Users\<username>\Documents\AEC Generative Design. While
you can share study types with team members, generated outcomes cannot be shared
with others.
28. If you opted to skip steps 17-27, or if you ran into difficulties, you may simply copy the
Workspace Layout - Standing Desk.dyn file and Workspace Layout - Standing
Desk.Dependencies folder from the Datasets folder to the location specified above (i.e.
C:\Users\<username>\Documents\AEC Generative Design).
29. Close Dynamo for Revit and click Create Study. You will see the new study that you
have just created:

30. Repeat steps 3-7 using this new study and the same settings as before. All desks are
now placed at the right level. However, they are still not laid out as expected. You will fix
that in the next few steps*.
*If you previously opted to skip steps 17-27 and followed the instructions in step 28,
please skip ahead again to step 40.
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31. Reopen the Workspace Layout - Standing Desk.dyn in Dynamo for Revit.
32. Zoom into the Translate Desk Origins to Revit Placement Points section:

33. Review the Dynamo notes in this section. As you have already seen, the
Furniture_System-Standing_Desk-Rectangular_w_Partition.rfa family has its origin
located in the middle of the desk. You will need to make a few script modifications to
take into consideration how the family is defined.
34. Create a new Code Block:
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35. Connect its inputs as follows:

36. Next, move the Code Block to the Translate Desk Origins to Revit Placement Points
group and connect outputs as follows:

37. Click File > Save.
38. Repeat steps 20-27 to export the study.
39. Optionally, if you need to catch up, you may copy all files from the Workspace Layout Standing Desk.zip file to C:\Users\<username>\Documents\AEC Generative Design.
40. Repeat steps 3-7 once again. You will see that the desks are laid out as indicated in the
Outcomes dialog:
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And they are aligned appropriately to each other:

In this exercise, you found a result that accommodates up to 52 employees positioned at a
45-degree angle in the space. This outcome meets your goal to maintain a 6’ minimum
spacing between employees (laterally, as the glass panels enable back-to-back desk
placement).

However, the angled layout might not be ideal for egress, and both operable partitions are
obstructed. Perhaps another type of layout should be considered.
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Exercise 2b: Standing Desk Layout using Customized Grid Object
Placement Study
In the next exercise, you will try a new approach using the Grid Object Placement study to lay
out desks in the large open office space longitudinally (i.e. along its length).

1. To begin, load the family Furniture_System-Standing_4_DesksRectangular_w_Partition.rfa from the Datasets folder into the Workspace Layout.rvt
project. This family comprises a set of four desks.

2. Place an instance of this family in room 329 Corridor so that it will be selectable in the
next step.
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3. On the Manage tab, click Create Study. Select the Grid Object Placement sample study.

This sample study can be used with Generative Design in Revit to generate alternatives
for placing objects in a room using a rectangular grid.
4. Review the settings that are available for this study type:

Notice that this study has variables in metric units, while your project uses imperial units.
Additionally, the study measures distances between objects from their insertion points,
and the ranges provided are relatively small (i.e. 1 to 3, 0.5 to 2). These are important
considerations. In fact, if you were to proceed with the default study parameters, you
would find it impossible to lay out your desks without clashing. This is a situation where
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adjustments to the sample study need to be performed to achieve meaningful results. In
the next few steps, you will update the variable ranges and their units.
5. Close the Define Study dialog box.
6. Open the Grid Object Placement.dyn script in Dynamo for Revit (refer back to step 12 in
Exercise 2a for the script folder location). Note: if you wish to skip the Dynamo portion of
this exercise, please skip ahead to step 15.
7. Zoom into the following pink sections:

8. Update the nodes (names and values) as follows:
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9. Next, bypass the section where the unit conversion takes place:

Once this is done, you can keep the Project Units and the Unit Conversion section in
your script or delete them, as they will no longer be needed.

10. Use File > Save As to save the script with the new name Grid Object Placement Imperial.dyn.
11. Select your inputs (i.e. the 4-desk family and room 302 Office).
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12. Use Generative Design > Export for Generative Design and click Run.

13. In the export dialog, fill out the Description field, e.g. “Places elements in a rectangular
grid pattern inside a room (imperial version)” and add an image such as the one found in
the Dependencies folder (C:\Users\<username>\Documents\AEC Generative
Design\Grid Object Placement.Dependencies\Grid Object Placement.png). This
information will be displayed in the Create Study dialog in Revit.
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14. Select Clear cached data at the bottom of the dialog and click Export.

15. If you opted to skip steps 6-14, you may simply copy the Grid Object Placement Imperial.dyn file and the Grid Object Placement - Imperial.Dependencies folder from the
Datasets folder to the location specified above (C:\Users\<username>\Documents\AEC
Generative Design).
16. Close Dynamo for Revit and click Create Study. You will see the new study that you
have just created (or loaded):

17. Create a new Grid Object Placement - Imperial study. This time choose the Like This
method. This method will make Generative Design apply slight adjustments to your
current input configuration, enabling you to explore variations of a design that you
already like.

18. Select room 302 Office and the 4-desk family, together with the following variables and
Generation Settings:
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19. Click Generate.
20. Filter the results as shown:

Page 33

21. Select one of the outcomes yielding 14 groups of desks (see above) and click Create
Revit Elements.

This time, you have found room for up to 56 employees! But you are concerned that this layout
may be uncomfortable, with half of the employees facing away from the windows. And one of
the partitions is still obstructed. We have not yet found an optimal solution.
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Exercise 2c: Standing Desk Layout using New Generative Design Study
In the previous example, you modified the Grid Object Placement study slightly to lay out desks
with acceptable spacing. But you want to rotate the desks so that every user can see out the
windows. And you want to provide more flexibility, e.g. more options to control how desks are
laid out.
In this exercise, you will learn how to:
• Build your own Generative Design study from scratch.
• Change the way distances between desks are measured. The spacing between desks in
both directions will be measured between edges of desks instead of their insertion
points.
• Add an option to control the distance between desks and walls in both X and Y
directions independently.

Every Generative Design study definition needs to contain:

In this exercise case, variable parameters will include the following:
• Distance from desks to wall – X direction
• Distance from desks to wall – Y direction
• Distance between desks – X direction
• Distance between desks – Y direction
And design goals will include:
• Number of desks
• Spacing – X direction
• Spacing – Y direction
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1. Begin by loading the family Furniture_System-Standing_DeskRectangular_w_Partition_V.rfa from the Datasets folder into the Workspace Layout.rvt
project. This family is very similar to the family you used in Exercise 2a, except that it is
rotated 90 degrees to facilitate a transverse layout. Place an instance of this family in
room 329 Corridor so that it will be selectable later.

2. Open the Grid Object Placement study in Dynamo. You will see a color-coded legend (a
set of notes) for groups:

3. In your script, you will use the same convention. Copy the legend to an empty Dynamo
file or remove all Dynamo nodes except the legend.
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4. Use File > Save As to save the file with the new name Grid Desk Placement - 2c.dyn.
You do not need to save it into C:\Users\<username>\Documents\AEC Generative
Design folder; the file can be saved anywhere on your hard drive.
5. Define selection nodes for a family instance to distribute along a grid and an input node
for a room selection. Use the Select Family Instance and Select Room Element nodes,
found under GenerativeDesign > Selection.

6. Define variables using Number Slider nodes, as shown below. To set up a Dynamo
graph for use with generative design tools, right-click on each node used to drive the
graph and ensure that the 'Is Input' option is ticked.

Renaming these nodes helps to distinguish these inputs in the Create Study dialog.
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7. Select an instance of the desk family to be used in the layout and room 302 Office for
testing while you continue developing the script.
8. Add the following nodes and run the script.

Note: Using Generative Design in Revit can be a very powerful approach to quickly
explore multiple design options. To ensure your studies are executed efficiently, learn to
use the Data.Remember and Data.Gate nodes to control the data imported from Revit
and leveraged in the generative design workflow. These nodes are important because
generative design is an iterative process; making each iteration dependent on Revit
would add unnecessary computational burden.
9. Add the Remember Bounding Box group.

This set of nodes retrieves the bounding box from the selected desk and remembers its
width and length.
Note: The Data.Remember node is designed to capture the output of any node and
cache the results in the .dyn file when the graph is saved. It can hold both non-geometric
data (such as strings and numbers) and geometric data (such as solids, points, and
surfaces) in a serialized format. This means that if, for example, you want to retain
values in certain parameters or the underlying geometry of a wall or door, this node can
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handle both types of data. Currently, the node is limited to these data types. If you
attempt to pass other data through this node, e.g. a collection of Revit Elements,
Generative Design will return an error saying, 'cannot store data of type'.
10. Remember the selected room level name.

11. Retrieve and remember the room perimeter.
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12. Now, we are ready to define the logic to calculate an area in the room that can be filled
by desks. It will be an area that considers the minimum required distance from desks to
walls in both directions. First, obtain the 4 corner points of the room.

13. Then get the 4 perimeter curves of the room.
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14. Offset the perimeter curves towards the inside of the rectangular area. As offset values
use the Minimum distance from desks to wall parameters.

15. Find the intersections of the shifted curves and create a new surface. This is the area
that can be occupied by desks based on the input variables: 1 = selected room, 2 =
minimum distance from desks to walls in the X direction, 3 = minimum distance from
desks to walls in the Y direction.

You have just implemented the ability to control distances between desks and walls in X
and Y directions independently.

Page 41

16. Now you will need to calculate the insertion points of desks based on spacings between
them. The spacing between desks in both directions will be measured between the
edges of the desks instead of their insertion points. Connect these variables to the Code
Block as shown to have them handy.
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17. Calculate the insertion points using a Python script, as shown…
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…and be sure to use cross product lacing in the Surface.PointAtParameter node:
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18. Create the following Code Block to calculate X and Y spacings between desks.

19. Define Outputs using the Watch nodes. To define outputs for use with the generative
design tools, right-click on the Watch nodes and select the 'Is Output' option. Currently,
all outputs must be Watch nodes with a 'Number' data type.
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Your script is almost complete; you have just a couple of tasks remaining. You will need
to create elements in Revit and implement a logic that will be used for visualization
purposes.
20. Add the following nodes to create Revit elements.

Note: The Data.Gate node controls the flow of data after the node. It activates the
Create Revit Elements button on the Explore Outcomes dialog. You use the Data.Gate
node to control when a branch of the graph runs. This branch creates Revit elements—
i.e. it adds the desks to a room for your grid layout.
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21. Finally, you will create the visualization. Connect the relevant nodes as shown to
visualize and color-code elements.

22. Once both inputs and outputs have been set up correctly and your graph is saved, it can
be exported for use with the generative design toolset. In Dynamo, navigate to the
toolbar and select Generative Design > Export for Generative Design.
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23. Click Export.

24. To launch Generative Design, navigate to the Dynamo menu and select Generative
Design > Create Study.
25. Once the Create Study dialog has launched, select a study that you have just exported
from Dynamo.

Page 48

26. Set up the following options in the Define Study dialog box.
Note: You will not need to select a room and a family instance, as you selected Keep
cached data in steps 22-23 above. Any data in the study that is specific to the Revit
model you have been using with the graph will be retained.

27. Click Generate.
28. When the generation is done, close the Explore Outcomes dialog and Dynamo.
29. Relaunch Dynamo for Revit and navigate to the Dynamo menu and select Generative
Design > Explore Outcomes.
30. Filter the results as shown:
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31. Click Open in Dynamo.
32. When you see the Warning dialog (it may be hidden under the Explore Outcomes
dialog), click Yes.

Notice that the input variables in the script have been updated based on inputs of the
selected outcome.
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33. Export the study for Generative Design again. Select the Clear cached data option this
time.
34. Close Dynamo.
35. On the Manage tab, click Create Study, and create a new Grid Desk Placement - 2c
study.
36. Set up the study and click Generate. Notice that you need to make selections in the
model.
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37. Select the following outcome and click Create Revit Elements.

Now you are getting somewhere! In this exercise, you generated a layout that
accommodates 33 employees in groups of three, and both operable partitions are
functional. This outcome achieves your goals of maintaining 6’ of separation between
employees without installing glass panels, and every employee has a view to the
outside.
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However, you still have two concerns. Your employees are still lining up directly behind
one another, and you would prefer to have an even greater distance between them
before removing the glass panels. Also, you would like a better circulation path between
the employees’ desk positions and the exits.
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Exercise 2d: Standing Desk Layout using Customized Stepped Grid Object
Placement Study
To address the remaining concerns of Exercise 2c, you will test one last approach. This time,
you will use the Stepped Grid Object Placement study to arrange the desks with the same
orientation as before.
1. Begin by loading the family Furniture_System-Standing_2_DesksRectangular_w_Partition_V.rfa from the Datasets folder into the Workspace Layout.rvt
project. This family is very similar to the family you used in Exercise 2c, except that it
has two desks. This family has two additional parameters (Left Desk and Right Desk)
that will help you better manage how this furniture system is set up. Place an instance
of this family in (or near) 329 Corridor so that it will be selectable later.
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2. On the Manage tab, click Create Study. Select the Stepped Grid Object Placement
sample study.

3. Review the settings available for this study type:
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Notice that this study has variables in metric units, while your project uses imperial units.
Additionally, the study measures distances between objects from their insertion points,
and the ranges provided are relatively small (i.e. 1 to 3, 0.5 to 2). These are important
considerations. You faced similar issues in Exercise 2b.
This is a situation where adjustments to the sample study need to be performed to
achieve meaningful results. In the next few steps, you will update the variable ranges
and their units.
4. Repeat steps 5-9 from Exercise 2b, ensuring you have set up the variables as follows:

5. Use File > Save As to save the script with the new name Grid Desks Placement –
2d.dyn.
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6. Repeat steps 11-14 from Exercise 2b (but using the 2-desk family you loaded a few
moments ago).

7. If you opted to skip steps 4-6 in this exercise, you may simply copy the Grid Desks
Placement – 2d.dyn file and the Grid Desks Placement – 2d.Dependencies folder from
the Datasets folder to C:\Users\<username>\Documents\AEC Generative Design.
8. Close Dynamo for Revit and click Create Study. You will see the new study that you
have just created (or loaded):
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9. Create a new Grid Desk Placement – 2d study. Choose the Like This method. This
method will make Generative Design apply slight adjustments to your current input
configuration, enabling you to explore variations of a design that you already like.

10. Select room 302 Office and the 2-desk family instance, together with the following
variables and Generation Settings:

11. Click Generate.
12. Filter the results as shown:
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13. Select one of the outcomes yielding 17 groups of desks (see above) and click Create
Revit Elements.
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14. Using the Left Desk and Right Desk parameters, exclude desks that conflict with
columns:

You have found an optimal solution for your 32 employees in groups of two. This layout
ensures maximum spacing between employees, and both operable partitions in the
office space are functional.
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Congratulations! Without manually moving a single desk, you have discovered the optimal open
office layout to safely accommodate your employees using Generative Design in Revit. Best of
all, these customized studies are ready to be utilized on all your office layouts.

Remember—this is designed to be a hands-on course with 5 exercises that will teach you how
to use Generative Design in Autodesk Revit to perform workspace layout. As a supplement to
our AU recording, you’ll find the class content under “Generative Design in Revit and Dynamo
for Workspace Layout” on the Autodesk Knowledge Network (AKN).
The following materials are included:
•
•
•

Training Guide
Datasets
Step-by-step Instructional Videos

Thank you for joining us!
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