
 

 

Page 1 

AS197666-L 

Attention to Detail: Creating Construction Documents 
in Revit – Hands on Lab 
Matt Dillon 

Applied Software Technology, Inc. 

 

 

 

Description 

A good model is important in a Building Information Modeling (BIM) workflow, and equally 
important is generating a good set of construction documents, complete with detail drawings. 
After mastering basic modeling in Revit software, many users hit the wall and struggle with this 
vital aspect of project delivery. This hands-on lab will teach you how to bridge the gap between 
modeling and detailing, taking full advantage of the 3D model and adding 2D embellishments 
combined with display modification to create your construction details. 

Speaker 

With a background as a registered architect, Matt Dillon has over 30 years of experience in 
Autodesk Architectural applications and is an Autodesk Certified Instructor at an Autodesk 
Authorized Training Center. In addition to assisting customers implement Building Information 
Modeling (BIM) and Revit Platform products, Dillon has also consulted with Autodesk, Inc., 
development staff in product design and usability for AutoCAD Architecture software. A 
published author, Dillon was one of the recipients of Autodesk's Distinguished Speaker Award in 
2010, and he has been a highly rated instructor at Autodesk University since he first began 
presenting in 2000. 

 

Learning Objectives 

• Determine what to model and what not to model 

• Modify detail view properties to facilitate effective communication of detail 
geometry 

• Modify model geometry to make it useable for construction documents 

• Use detail components, line work and keynotes to finish out the detail 
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Introduction 

Much attention is paid in any demonstration or class having to do with Revit on the modeling 
process. To be sure, this is important; without a model you don’t have a project, after all. But 
equally important is the ability to generate construction documents that go beyond the model. 
Unfortunately, many firms choose to forego using the detailing and drafting tools in Revit and 
generate their details in AutoCAD instead. This is a bad idea for at least two reasons: 

• Generating details in AutoCAD separates the detailing process from the Revit workflow, 
increasing the opportunity for errors and omissions. 

• Generating details in DWG format and then importing/linking those details into the Revit 
project so they can be plotted on sheets can affect the project file in adverse ways – file 
size can grow disproportionately to the size of the DWG files being imported, 
performance suffers, and the project file can become unstable. In general, it is not a 
good idea to have a lot of DWG files, if any, in a Revit project. 

Admittedly, the drafting and detailing process in Revit is markedly different than AutoCAD’s and 
that is probably one of the main reasons that firms tend to adopt it last if at all. However, once 
the tools have been mastered most users report that they are creating details faster and more 
accurately than they used to in AutoCAD. No matter how cumbersome the detailing tools may 
seem to be at first, remember that when you create a hybrid model-based/2D detail, you are 
typically leveraging existing model geometry – your detail is half done before you even begin. 
Additionally, when done properly and at the right time in the project, change management is 
greatly enhanced. It just takes a little investment in learning the new tools and processes. 

Level of Detail 

One of the most common mistakes new users of Revit make is to “over-model” – to put too 
much detail in the model. This can cause the model to become inordinately large very quickly 
and can cause you to spend lots of time on minutiae with little or no payback. It is important to 
realize when it is not appropriate to model an object and to simply show certain objects in a 
detail as 2D geometry instead. 

As a general rule of thumb, consider using the scale of your typical overall floor plans as the first 
“litmus test” as to whether or not you are going to model something. In a commercial project for 
example, your floor plan scale is probably around 1/8”=1’-0” (assuming you’re working on a 
project in Imperial Units). If something would not normally be seen at that scale you should think 
twice before modeling it. That doesn’t necessarily mean that you shouldn’t model it, but you 
need to weigh the consequences and effort required to model the object against the benefits 
and payback. If it is something that would take a long time to model and would only be seen in 
one or two views then it might be better to show it using 2D detailing tools instead. 
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The Revit Detailing Process 

Creating a hybrid 3D/2D detail (that is, a detail that is based partly on the project’s model 
geometry and partly on 2D detail components and line work) can be broken down into four main 
phases or steps: 

• Turn off unwanted geometry. This does not mean incorrect geometry. In this step you 
merely use Visibility/Graphics Overrides and other view properties to turn off or crop out 
parts of the model or project that you don’t want to see in the detail. 

• Suppress or change the display of incorrect model geometry. There usually things 
in a model that, when viewed at a larger scale, are incorrect. In this step you use 2D 
detailing tools such as Masking Regions and Cut Profiles to either suppress them 
entirely or to modify the way they display themselves in the current view. It is important 
to note that you are not editing the model, even though it may look that way. You are 
merely changing the way it displays in the view. 

• Add 2D geometry to complete the detail graphics. Once the model geometry has 
been stripped down to just those items that are correct, the rest of the detail can be 
added using 2D Detail Lines, Detail Components and Filled Regions. 

• Annotate and dimension the detail. 

The following hands-on lab will walk you through the process of creating a construction detail in 
Revit from start to finish. 

Task 1 – Create the Detail Callouts 

The first step in the creation of a detail is to create a Callout View. Callouts can be used in Plan, 
Section or Elevation views, and once created are the same Family of View as the parent in 
which they were created. However, anytime you create a Callout, you have an additional View 
Type to choose from: “Detail”. If your Callout is truly a detail and not an enlarged plan, for 
example, you should choose the “Detail” View Type when creating it so that it will be organized 
in the Project Browser with other details. 

1. Open the file Details_1.rvt from the lab dataset folder. It should open in the Level 1 floor 
plan view. 

2. Double-click the callout bubble on the vertical section to navigate to the Section 1 
building section view. 

We will create two callout views – one for the parapet condition and one for a typical floor/wall 
connection. 

3. From the View tab of the ribbon, choose the Callout tool. In the properties palette, 
change the type to “Detail”. 
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4. Place the callout boundary and tag as shown in the following image. You can edit the 
callout boundary and tag position by selecting the callout boundary after it is initially 
placed and editing the grips. 

 

5. Create the second callout view as shown below, again, making sure it is set to the 
“Detail” view type. 

 

6. In the project browser, rename the Detail 0 detail view to “Parapet Detail” and the Detail 
1 detail view to “Floor/Wall Connection Detail”. 

7. Navigate to the two detail views and set their Scales to 1 ½”=1’-0” and the Detail Level to 
“Fine”. 
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Note: If you need to change the shape of the Callout Boundary, you can do so by selecting 
the boundary, then selecting the Edit Boundary tool on the Modify tab of the ribbon. This will 
edit both the Callout Boundary as well as the actual Crop Boundary of the view itself. 

Task 2 – Modify the View Properties 

The next task is to clean up the overall view, suppressing elements that are irrelevant to the 
detail and that may cause confusion. 

Note: If you need to get caught up, you can open the file Details_2.rvt from the lab datasets 
folder.   

1. Navigate to the Parapet Detail detail view. 

2. Use Visibility/Graphics Overrides and turn off the “Levels” category in the Annotation 
tab of the “Visibility/Graphics Overrides” dialog box. 

Next, we need to suppress part of the parapet cap that is showing beyond the cut line of the 
section. We don’t want to turn off the entire “Sweep” sub-category of walls – that would remove 
the parapet cap entirely from the detail. Instead we need to modify the far clip settings for the 
view. Currently the clip depth is the same as the parent view, which is a building section. 

3. In the properties palette, change the far clip settings to “Independent”, then set the far 
clip offset to 6” as shown in the following image. 

 

4. Navigate to the Floor/Wall Connection Detail detail view and use the same process to 
turn off the “Levels” category and set the far clip offset to 6”. 



 

 

Page 6 

 

Task 3 – Modify the Model Geometry for the Detail 

Next, we need to suppress or modify some of the model geometry that, at this scale, is 
incorrect. There are several “warts” in the Floor/Wall Connection Detail detail view that need 
to be corrected. 

• The floor slab includes a Layer for a 14K1 bar joist. In this example it was decided not to 
model the bar joists and the structural engineer is not using Revit, so there is no 
structural model to use instead. Again, the decision to model or not is one that you will 
have to weigh carefully in some cases. In this case, it may have been better to model the 
basic structure of the building to make the detailing process easier, however for this 
class we will use detail components to show the structural framing where required. We 
will need to suppress the bar joist layer in the floor slab and replace it with a 2D detail 
component. 

• The metal stud and GWB layers in the wall are broken by the floor, but in reality the stud 
needs to extend to the bottom of the bar joist or deck, and the GWB should extend just a 
little above the ceiling. 

• The boundary between the brick and air gap layers in the wall should not pass behind 
the soldier course. Instead it should “jog” over to the back of the soldier course, 
removing the thin sliver of brick hatching behind it. 

To fix these issues, we’ll use the Cut Profile tool on the View tab of the ribbon. Again, it is 
important to remember that while it may appear that we are editing the model, we are merely 
changing the way that the faces (the layers in the wall and floor) present themselves in this 
view. It is a 2D, view-specific effect. 

Note: If you need to get caught up, you can open the file Details_3.rvt from the lab datasets 
folder. 

1. From the View tab of the ribbon, select the Cut Profile tool. In the options bar, make 
sure that “Face” is selected. Pick the layer in the floor that represents the 14K1 bar joist 
(see the image below) and draw a vertical line from the top edge to the bottom edge just 
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outside of the view’s crop boundary as shown. Make sure the blue arrow points to the 
right – you can select it to flip it. Finish the sketch by clicking the green check mark in the 
ribbon. The bar joist layer should no longer be visible. 

 

The bar joist layer has not been deleted. It has merely been partly suppressed in this view. If 
you were to drag the right edge of the crop boundary to the right a bit you would see it. You can 
also select the sketch line of the cut profile and modify it or even delete it to bring the layer back 
to full visibility. 

2. Select the Cut Profile tool from the ribbon again and this time, choose “Boundary 
between faces” on the options bar. Select the boundary line between the air gap in the 
wall and the brick layer. Sketch the cut profile line as shown in the following image. Note 
that the sketch is done in two steps. First, sketch the lines loosely, then use the Align 
tool on the Modify tab of the ribbon to align and constrain (lock) the sketch lines to the 
soldier course. Click the green check mark to finish the sketch when done. 
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3. On your own, modify the cut profile of the GWB so that it extends to just a few inches 
above the ceiling as shown below. The exact distance is not important. 

 

Task 4 – Embellish the Detail with 2D Geometry and Annotation 

Once the model components have been modified to appear more correct for the current level of 
detail, we can begin to add geometry to represent those objects that we chose not to model. 
This can be done using a combination of detail components, detail lines and filled regions. All 
these items are view specific– they exist only in the view that they are created on. 

First, we will add the bar joist and structural framing Detail Components. 

Note: If you need to get caught up, you can open the file Details_4.rvt from the lab datasets 
folder. 

1. From the Annotate tab of the ribbon, select the Component tool, then click Load 
Family from the Modify ribbon tab. Navigate to the “Detail Items” folder, then “Division 
05 – Metals”, then “051200-Structural Steel Framing”. Select the AISC Wide Flange 
Shapes-Section.rfa file and click Open. In the type catalog that appears next, choose the 
“W10x30” type and click OK. Place the beam detail component in the detail as shown in 
the following image. The exact position is not important at this time. 
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Note: It is important that you choose the “Detail Items” folder and not the “Structural 
Framing” folder. Items in “Structural Framing” are 3D model components. We would have 
used families from this folder if we had decided to model the structural framing instead of 
simply represent it in the details. 

2. Use the same process to insert a bar joist. In the “052100-Steel Joist Framing” folder 
select the K-Series Bar Joist-Side.rfa file. Choose the “14K1” bar joist type and place it 
similarly to the one in the following image. 
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3. Select the bar joist, and from the Modify tab of the ribbon, use the Mirror tool with 
“Copy” unchecked in the options bar to flip the bar joist around to the correct orientation 
and move it to the position shown below. 

 

4. Align and lock the center of the beam to the column grid, and the top of the beam to the 
bottom of the bearing plate of the joist as shown below. 

 

5. Align the reference plain in the bar joist that is at the grip locations shown in the following 
image to the left edge of the beam and constrain it. (The grips will not be visible, 
however you will see the ghost image of the reference plane when you move the cursor 
across it and you will be able to select it). 

 



 

 

Page 11 

6. Use the Cut Profile tool to adjust the stud as shown below. 

 

7. On your own, try to add the Detail Components for the 2’x2’ acoustical tile ceiling as 
shown below (the notes are shown for clarification purposes only – don’t add them to the 
detail). Refer to the following page for a few tips on completing this step. 

 

Some tips to assist you: 

• All of the detail components you will need for this portion of the detail are located in the 
“Div 09-Finishes” folder under “095000-Ceilings”. You can load them all at the same time 
by using the <CTRL> key to select multiple families. 

• As we did with the bar joist and the beam, place all the components in the general 
location first, then use the Align tool to move them into final position. Start by mirroring 
the wall angle, then aligning it with the edge of the GWB component of the wall and the 
bottom of the ceiling element from the model. 
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• Once the wall angle has been placed, you can turn off the “Ceilings” category in the view 
before placing the rest of the detail components. 

• Use the Align tool with constraints to place the rest of the components, except for the 
suspension wire. You will need to move and rotate it into position, using the grips to 
make it longer. 

• Once all the Detail Components are placed, you may need to adjust the position of the 
right edge of the crop boundary to get the same extents as those shown in the previous 
image. 

There are three additional major embellishments that need to be made: 

• The brick needs to show mortar joints. While it’s obviously not effective to model each 
and every brick, the coursing needs to be shown in the detail. 

• The floor deck is not correct at this scale. For the detail it should be shown with the 
actual ribs that make up the deck. While Revit has the ability to include a “Structural 
Deck” layer in a floor or slab that can show the ribs automatically, the line weights for 
these are frequently much too heavy and cannot be modified. 

• We need to show insulation in the exterior walls. 

To accomplish the mortar joints and the deck, we will use repeating details. These consist of 
standard detail components assigned to a repeating detail type. 

Note: If you need to get caught up, you can open the file Details_5.rvt from the lab datasets 
folder. 

8. From the Insert tab of the ribbon, select Load Family. From the lab dataset folder, load 
the Standard Mortar Joint.rfa and Deck - 15NR18.rfa  families. 

9. From the Annotate tab of the ribbon, select the Repeating Detail Component tool from 
the Component drop down menu as shown in the following image. Click the Edit Type 
button in the properties palette and duplicate the current repeating detail type, renaming 
the new type to “Brick Mortar Joints”. Set the “Detail” value to “Standard Mortar Joint”, 
“Layout” to “Fixed Distance”, make sure “Inside” is checked on, set “Spacing” to 0’-3” 
and check that the “Detail Rotation” is set to “None”. Click OK to finish creating the 
repeating detail type and place the mortar joints above and below the soldier course as 
shown in the following image. When placing the repeating details if you need to flip the 
orientation you can press the <SPACE> bar while you are picking the starting and 
ending points of the pattern. 
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10. Repeat the process above to create the deck repeating detail component using the 
settings shown below, then add it to the floor as shown. Note that the “Detail Rotation” 
value is set to 90º Clockwise. 

 

From the Annotate tab of the ribbon, click the Insulation tool. In the options bar, set the Width 
to 6” and use the alignment drop down to change the orientation from “center” to “near side” to 
“far side” as required to draw the insulation as shown in the following image. Note that you can 
dynamically change the alignment as you create the insulation. 
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The detail geometry is substantially complete. While some of the line work line weights might 
need to be adjusted a bit, that level of development is probably best saved for later in the 
project. At this point it is time to add annotation. For purposes of this exercise we’ll focus on 
Revit’s keynoting capabilities. 

Note: If you need to get caught up, you can open the file Details_6.rvt from the lab datasets 
folder. 

11. From the Annotate tab of the ribbon, click Keynoting Settings from the Keynotes drop 
down menu. Make sure your settings match the figure below and click OK. 

 

For purposes of this exercise, we will start with the default settings for revit keynoting. Most 
important among these settings is the “Keynote Table File Location” – the keynotes are actually 
defined in this file, which is a simple ASCII text file. You can either customize the existing file to 
suit your needs or build a new one completely from scratch. Information explaining how to do 
that is included in the supplemental documentation for this lab. Note also in these settings that 
we are starting out with the “Numbering Method” set to “By Keynote”, which means that keynote 
numbers will be the same for a given element or material regardless of which sheet or detail 
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they fall in. In the terminology of the U.S. National CAD Standard, these are referred to as 
“Reference Keynotes”. 

12. From the Annotate tab of the ribbon, click the Element Keynote tool from the Keynote 
drop down menu. Change the keynote Type in the type selector to “Keynote Number”, 
then select the exterior brick wall and place the tag to the right. When the “Keynotes” 
dialog appears expand “Division 04 Masonry”, then  “04 21 00 Clay Unit Masonry”, then 
choose “04 21 00.A1 Standard Brick – 3/8” Joint” and click OK.  \ 

Note: If the Keynote disappears, you can select the crop boundary and drag the Annotation 
Crop boundary out to accommodate the note. 

 

The “Keynotes” dialog appeared because there had not been a keynote assigned to the wall 
type previously. By selecting the keynote from the dialog, we actually edited the wall type and 
assigned the keynote to it. Future selections of walls of this particular type with the Element 
Keynote tool will result in the keynote automatically being assigned. If you intend to use Revit’s 
keynoting feature on a regular basis, you should get in the habit of pre-assigning keynotes to 
your type and material definitions whenever it makes sense to do so. 

13. Place the rest of the element keynotes shown in the following image. When the floor is 
selected, choose the keynote “03 31 00.I3  3” Cast-in-Place Concrete Slab w/ Metal 
Decking”. 
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14. From the Annotate tab of the ribbon, click the Material Keynote tool in the Keynote 
drop down menu. Select the gypsum wall board layer in the wall and place the note. 
When the “Keynotes” dialog box comes up, choose “Division 09 Finishes” then “09 29 00 
Gypsum Board” for the keynote to apply. 

 

As with element types, keynotes can be assigned to material definitions. when you place a 
material keynote on a material, if there is no keynote assigned to it already, you will be sent to 
the “Keynotes” dialog. When you choose the keynote, it is assigned to the material definition. 

15. Use the same tool to apply a keynote to the rigid insulation on the outside of the stud. 
When the “Keynotes” dialog appears, select “Division 7 Thermal Insulation”, then “07 21 
00 Thermal Insulation” and finally “07 21 00.B2 1” Rigid Insulation” as the keynote. 

16. From the Annotate tab of the ribbon, click the User Keynote tool in the Keynote drop 
down menu. Place the keynote leader arrow on top of the batt insulation. When the 
“Keynote” dialog appears choose “Division 7 Thermal Insulation”, then “07 21 00 
Thermal Insulation” and finally “07 21 00.A2 R13 Batt Insulation” as the keynote. 
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When you place a user keynote, any keynote that is already assigned to an element or material 
is ignored and can be overridden. The resulting choice is not applied to the element type or 
material definition.  

Before moving to the last part of the lab exercises, we need to add just a few keynotes to the 
parapet detail that was created earlier, even though it has not been completed yet. 

17. Navigate to the Parapet Detail Detail View. Add an element keynote to the wall and 
material keynotes to the gypsum board and the rigid Insulation layers of the wall as 
shown below. 

 

Next we will create a keynote legend and experiment with how keynotes and keynote legends 
behave when placed on Sheets. 
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Note: If you need to get caught up, you can open the file Details_7.rvt from the lab datasets 
folder. 

18. From the View tab of the ribbon click the Keynote Legend tool from the Legends drop 
down menu. Click OK to accept the default name of “Keynote Legend”. In the “Keynote 
Legend Properties” dialog on the “Filter” tab, check on “Filter by sheet” as shown below 
and click OK. 

 

Note: Legend views can be placed on multiple sheets. The “Filter by sheet” option for 
keynote legends means that only the keynotes that are actually displayed on the details on 
a given sheet will be shown in the copy of the keynote legend that is on that sheet. 

19. Create two new sheets using the E1 30 x 42 Horizontal Titleblock and name them “A-
501 – Details” and “A-502 Details”. 

20. Navigate to the A-501 – Details Sheet and drag the Floor/Wall Connection Detail and 
Parapet Detail Detail Views onto the sheet, then drag the Keynote Legend Legend 
View onto the sheet. 
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All the Keynotes used in both Detail Views should be represented in the Keynote Legend. 

21. Delete the Parapet Detail Detail View from the sheet.  

22. Navigate to the A-502 – Details Sheet and drag the Parapet Detail Detail View and the 
Keynote Legend Legend View onto the sheet. 
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On this sheet the keynote legend should only show the keynotes that are used in the parapet 
detail. 

Revit also allows you to use “Sheet Keynotes”, where the keynote numbering is unique to each 
sheet. In other words, the same keynote can be numbered differently on each sheet. 

23. From the Annotate tab of the ribbon, click Keynoting Settings from the Keynote drop-
down menu. Set the “Numbering Method” to “Sheet” and click OK. 

 

The keynote numbers in the viewports and on the keynote legends should change to single-digit 
numbers. Compare the keynote legends on the two sheets. In particular, note the numbers for 
the gypsum board and the 1” rigid insulation notes. They should be different on the two sheets. 

You can also use the keynote feature in Revit to simply automate your annotation without using 
the keynote numbers or legends. 

24. Navigate to the Floor/Wall Connection Detail Detail View.   

25. Select any one of the keynote tags, right-click and select Select All Instances -> In 
Entire Project from the menu as shown in the image on the following page. In the 
properties palette change the keynote tag type to “Keynote Text”. 

All the keynote numbers should now be replaced with the actual keynote text. 
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At this point the detail is not quite complete by some standards. It may be desirable to modify 
some of the line weights using the Modify Linework tool, which is found on the Modify ribbon 
tab.  

 

Summary 

In this short lab we have covered a lot of ground. Hopefully you now have a better idea of how 
to determine what elements of your project you should model and what elements can be more 
efficiently represented with 2D components in a detail view. Critical to the detailing process in 
Revit is knowing how to modify the view properties and how to use cut profiles to modify the 
way model elements represent themselves in the view. Once you have the detail pared down to 
“bare bones”, build it back up with 2D detail line work, components, etc., then add your 
annotation: dimensions, text notes and/or keynotes. Finally, you can embellish the lineweights 
where necessary using the Modify Linework tool. 

Try these tools on your next project. With a little practice you’ll become more comfortable with 
this workflow and you won’t want to go back to AutoCAD to generate your details – you’ll rather 
keep it all inside Revit, where it belongs! 


