A Better Structural Workflow: Integrated Design, Analysis, and Detailing
Aaron Vorwerk and Ian Coats
Autodesk

Exercise Guide
Please reference this document during our hands-on exercises. It has been formatted to position adjacent to your Revit/RSA/Advance Steel application window.
Exercise 1: Code group design for steel members using Revit and RSA

In this exercise, we’ll start by sending our model from Revit to RSA. We’ll then prepare and perform analysis on the structural model in RSA. We’ll review the results of the analysis and perform code group design on a selected set of members. Finally, we’ll send the model back to Revit and confirm that the round-trip was executed successfully.

**Exercise 1: Send the Revit model to RSA**

1. Open *01-Start.rvt* and locate the Analyze tab > Structural Analysis panel.
2. Select Robot Structural Analysis > Robot Structural Analysis Link.
3. Leave default options and select OK. RSA will open and begin importing the Revit model data.
4. Click Yes to the pop-up dialog to view the Events Report; close the report after viewing.
Exercise 1 (continued): Configure the model display in RSA

5. If load symbols are not displayed, go to View tab > Display > Loads and toggle Load symbols off and on again, clicking Apply each time.

6. Select OK to exit that dialog.

7. Element visibility may also be controlled using the toolbar at the bottom left edge of the drawing window, similar to the View Control toolbar in Revit. Use this toolbar to toggle the display of Section shapes.
Exercise 1 (continued): Adjust analytical geometry

8. Select the analytical floor at Level 2.

9. In the Properties Inspector (similar to the Properties Palette in Revit) at the left side of the screen, change the Calculation model for this floor from Shell to Deck slab (one-way).

10. Repeat for the floor at Level 3.
Exercise 1 (continued): Generate load case combinations

11. Select **Loads** tab > **Automatic Combinations** to open the Load Case Code Combinations dialog.

12. Select **Full automatic combinations**, then click **More** to view the combinations in more detail.

13. Select **Generate** to build out the load combinations list per ASCE 7-16.
Exercise 1 (continued): Create finite element mesh

14. Click the **Options of FE Mesh Generation** icon to open this toolbar, then choose **Meshing Options** (select **Yes** to the pop-up message to select all panel elements).

15. Select **Complex mesh generation (Delaunay)** and set the **Element size** to 2 feet. Select **OK**.

16. Select **Generation of calculation model** to create the FE mesh.

17. Select **Mesh Freeze** to store this mesh; then close the toolbar.
18. Time for analysis! If you’ve gotten lost along the way, open 02 - Analysis.rtd to catch up.

19. Go to Analysis tab > Analysis Types to open this menu. Observe additional capabilities under the New and Parameters buttons.

20. Select Calculations to run the analysis. Once completed, a green light with the message “Results (FEM): available” appears at the bottom of the screen.
21. Select **Results** tab > **Maps** to open this dialog.

22. Select the \( z \) direction for **Displacements** \(-u, w\) and select **Apply**.

23. Note the color mapping in RSA. The interior beams of the top deck indicate the largest displacements; we’ll make them the focus of this exercise.

24. Deselect the \( z \) checkbox and select **Apply** again to remove the map. Close the Maps menu.
Exercise 1 (continued): Configure code group for design

25. For this step, let’s change our RSA layout. Locate the Layouts toolbar and change from Geometry to Steel/Aluminum Design.

26. Proceed to the Groups tab of the Definitions dialog. Click New to create a new code group and enter members 104 to 123 (the interior beams from the top deck) in the Member list. Note: RSA offers many selection methods, but we are directly entering known bar numbers in this example.

27. Select Save.
Exercise 1 (continued): Perform code group design with optimization

28. Proceed to the Calculations dialog and select the Code group design option. Enter 1 or use the List button to find and select group 1 using the “up” arrow icons.

29. Select Optimization and check the Weight option. Select OK to close this dialog. If you’re behind, open 03 - Design.rtd to catch up.

30. Select Calculations to perform code group design for the selected settings.
Exercise 1 (continued): Select optimal sections

31. The **Code Group Design** module highlights the optimal section for the group (W 8x24 here). Click on the icon next to this section to view results; select **OK** to return.

32. In the **Code Group Design** dialog, select **Change all** to resize the sections. **Close** the dialog and **Cancel** saving the calculation results.
Exercise 1 (continued): Update the Revit model

33. Use Alt-Tab to switch back to Revit. As before, select **Robot Structural Analysis > Robot Structural Analysis Link**.

34. This time, choose **Update model** and click **OK**. Ignore the events report. *(Alternatively, instead of direct integration, you can choose **Update from the intermediate file** and select **04 - Update.smxx**.)*

35. Open the default **{3D}** view, hide the top floor slab (by selecting it and typing **HH**), and select one of the interior beams to confirm its new size in the Properties Palette.

*Congratulations…that was the BIG one!*
Exercise 2: Design to Detailing in Advance Steel

In this exercise, we’ll send the Revit model to Advance Steel for further work. We will set up the Advance Steel project, change a member section size, and then perform a synchronization to update the Advance Steel project with the latest changes from Revit.

Exercise 2: Send the Revit model to Advance Steel

1. Open 05 - Part 2 Start.rvt.

2. Go to Add-Ins then Select Advance Steel Extension > Export.
3. Select the Advance Export.

4. Save the file onto the desktop as 06 - Part 2 Start.smlx.
5. Switch to Advance Steel and Open a New Drawing.

6. Go to Export & Import tab, then choose Revit Import.

7. Select the 06 - Part 2 Start.smlx file from the desktop.

8. Confirm any mappings required from the drop-down dialog box.

9. **Zoom Extents** to see the entire model.
10. Change the **Visual Style** to *X-Ray* and set the **Opacity** to 25%.

![Visual Style Selection](image1.png)

11. Right-click on the 3rd Floor Slab and choose **Isolate > Hide Objects**.

![3rd Floor Slab Selection](image2.png)

12. Repeat to hide the 4th Floor Slab too.
13. Right-click on any beam and select **Advance Properties**.
Exercise 2 (continued): Element Properties

14. Change its **Section** to **W10x22**.

15. Examine other properties and attributes.
Exercise 2 (continued): Synchronize Changes

16. Save as or load **07 - Part 2 Imported.dwg**.

17. Synchronize other changes from Revit since the last import by going to **Revit – Synchronize**.

18. Load **08 - Part 2 Revised.smlx**.

19. Scroll to the bottom of the list to identify any beams that will be added (Shown in Green).

20. Check the box then click **Apply All Actions** to incorporate the changes into the model without affecting any change made since the last import.

21. Notice how a new beam appears that had been added in Revit separately.
Exercise 3: Complete the Detailing in Advance Steel

In this exercise, we will work with connections in Advance Steel. We will start by editing the properties of existing connections previously created in Revit or Advance Steel. We will then add new connections. We will create our own custom connections through the additions of plates, holes, and welds.

Exercise 3: Edit Existing Connection

1. Save the model as 08 - Part 2 Revised.dwg or load it from datasets.
2. Identify the Clip Angle Connection Shown.
Exercise 3 (continued): Edit Existing Connection

3. Right-click on any connection object and choose **Advance Joint Properties**.

4. Choose the **Horizontal Bolts** Tab and Change the **Back Mark** to 2 ½”.

5. Save it to the Standard Connection Library.
Exercise 3 (continued): Add Connections

6. Add a Shear Plate Connection by finding it in the Connection Vault.

7. Click the Column first. Then right-click to progress, then click the Beam to be connected, then right-click to end the command.

8. A Parametric Dialog should also appear. Go to Joint Design then click Check.
9. Click **Report** to see the Calculation.
10. Create a Unique Connection from Connection Vault Connections by adding a Stiffener to the Column.

11. Select the Column, then right-click, then select the lower edge of the beam bottom flange.

12. Change the Plate Thickness to 3/16" to match the beam flange thickness and set the Plate Alignment to ‘bottom’.
Exercise 3 (continued): Custom Connection (Plate)

13. Add a Custom **Cap Plate** next by setting the UCS to the Top of the column.

14. Use the Plate by 2 Points tool on the Objects Page of the Home tab to define the plate size.

15. Snap to diagonally opposite points.
Exercise 3 (continued): Custom Connection (Plate)
Exercise 3 (continued): Custom Connection (Holes)

16. Change the plate thickness to 3/16”.

17. Add a Galvanizing Drain Hole using the Bolts Command.
18. Switch the **Bolt Type to Hole** on the Objects Tab, Switch Page.

19. Then **Select Rectangular, 2 Points** from the Connection Objects Page.

20. Select the plate, then the diagonally opposite 2 points.
Exercise 3 (continued): Custom Connection (Holes)

21. Change the hole diameter to \( \frac{3}{16}'' \) then set the Intermediate Distance X to \( \frac{1}{2}'' \) and Intermediate Distance Y as \( 7'' \).
Exercise 3 (continued): Custom Connection (Welds)

22. Finally, add a **Point Weld** to create the Assembly.

23. Select the **Column** first, then the **Plate** then locate the point weld at the center of the connection.

24. Check that the Plate is Shop welded by using the **Display Objects Connected In Shop** Command on the Selection Toolbar.

25. Objects that show highlighted in red will appear on the shop drawing for the assembly selected.
Exercise 3 (continued): Custom Connection (Welds)
Exercise 4: Create and Update Deliverables in Advance Steel

In this exercise, we will produce shop drawings from the information we’ve authored in Revit and Advance Steel. We will start by numbering all of the parts and choosing the format for the drawings to be generated. We will review the assembly drawings and make corrections as needed. Finally, we’ll utilize Advance Steel’s revisions management tools to track revisions and update drawings automatically.

Exercise 4: Fabrication Deliverables

1. Open 09 - Part 2 Connected.dwg to catch up if required.
2. Select Numbering from the Home Tab.
3. Check Process Single Parts and Process Assemblies then click OK.
Exercise 4 (continued): Fabrication Deliverables

4. Using the traditional method, numbers are marked as \textit{Prefix#Internalxx} until elements are assigned to drawings.

5. Go to \textbf{Drawing Processes} and select ‘All Assemblies with Parts Each (ANSI B to ANSI E)’.

6. Press \textbf{OK} to accept the settings on the next dialog.
7. Wait for processing to finish, then open the **Document Manager** from the Home tab and Update all the labels by right-clicking on **Update Required**.

![Document Manager](image1)

8. **Close** Document Manager and return to the column with the custom cap plate in the model.

![Assembly Drawing](image2)

9. Select it, then right-click on it and choose **“Show Assembly Detail”** to open its Assembly Drawing.

10. Clean up the drawing by moving Views (Green Bordered Areas) or managing dimension placement using their grips.

![Assembly Detail](image3)
Exercise 4 (continued): Revisions

11. To manage revisions after the drawing has been created, close the drawings and go back to the model to make a change.

12. Open 10 - Part 2 Drawings.dwg to catch up.

13. Change the thickness of the Column Stiffener to 1/4” by right-clicking on the stiffener and selecting **Advance Joint Properties**.

14. Go back to the Document Manager and right-click on the Column Drawing that shows as ‘**Update Required**’ - **Note**: The Drawing Number may be different from the one shown here.
Exercise 4 (continued): Revisions

15. Right-click on the Assembly Drawing and Select Update Revision.
16. Click Add and enter an Author and Description in the fields shown.

17. Click OK and OK again in the next dialog. The new drawing will now show the Revision Suffix and red clouds will highlight where changes were applied.