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Introduction 
 For all simulation projects where geometry has been imported from some cad source, a 

required step will be to apply a surface mesh and (presuming a solid/volume object) 

subsequently, a solid mesh.  Other than appropriate sizing of the mesh, all is wonderful when 

that meshing process goes smoothly.  Realistically, for larger assemblies or even more complex 

single part geometries, that meshing process can sometimes be interrupted by a variety of 

issues that lead to a non-successful mesh.  This will then require some interaction on our part in 

order to obtain an appropriate mesh so that one can continue with the setup processes (loads, 

constraints, material definition) and move along to the analysis and results reviewing phases. 

I am sure that most of us from time to time – either due to wanting to find the easiest path or 

perhaps simply due to not taking a moment to observe what the program is telling us, try to 

tackle the issue with some brute force approach, hoping that if we re-mesh and re-mesh the 

model that eventually we’ll “find something that works.”  While it is accurate that sometimes all 

the program is requiring for a successful mesh is a finer mesh on the geometry (and we’ll see 

that with our first example), what I am proposing is that the program provides a fair amount of 

feedback and if we use that, along with some knowledge about those issues, we can hopefully 

more quickly arrive at an appropriate and successful mesh. 

In thinking about the course, I had to outline a workflow or process that could be utilized as a 

guide overcoming these meshing issues, so, I thought about my own experience in meshing 

many models over the last 15 years.  Yes, I have used (and still will utilize) the “mesh it finer” 

approach, but in those cases where that ultimately fails to produce a usable mesh, then what?  I 

step back and attempt to overcome the issue in an intelligent manner, what is that process that I 

utilize?  I believe that this can be framed in 5 categories, or steps, to use.   

The first step is to identify the issue or meshing problem.  Generally the program will identify 

what that is in the meshing results with some warning or error that the geometry is not watertight 

or that there are multi-matched lines, for example.  Of course, if you have no idea what those 

things mean, that is not of much help, so, the second phase would be knowing (or learning) 

what the issue means and the types of things that lead to that problem.  Third, it would be 

helpful to look at the issue (find it on the geometry) which might help indicate why we have the 

issue in the first place (a location where parts are inserted, where parts should meet, a complex 

surface…), as well as give us the opportunity to see the extent of the issue.  Now that we see 

issue, the fourth step would be to consider the options that we have, e.g. is the issue at a 

complex surface where I could possibly simplify the geometry, is it a repeating pattern type of 

issue where if I fix one item/dimension I then clear up the entire model or is it something small 

enough I can consider manually repairing the mesh?  Then, fifth step, we attempt the remedy or 

repair once we have considered our options and decided on the best one and apply that 

approach.  At that point, the model either then works smoothly or we start this cycle again. 
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Example 1:  Tapered Panel.ipt – Input surface does not enclose a watertight 

solid – Learning Objective 1 – How to identify problem cad geometry 
 

The issue observed with the following model is one that is pretty simple to remedy, but also one 

that is fairly common (particularly among new users), so it is worthwhile taking a look at and 

explaining how one can potentially arrive at the issue and how to take care of it. 

Opening the geometry we see a long, thin and tapered panel.  This panel is one of many 

segments that would be utilized in a circular array to make a roof structure, as may be seen on 

a silo type of structure. 

 

An inexperienced user might think that they just want a quick analysis and fewer elements 

equals a faster solution, so let’s move the slider on the Model Mesh Settings all the way to the 

coarse end (190%) and attempt to mesh the model. 
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The meshing process will ultimately fail at this mesh size.  Note that there is a button that we 

can press to review the mesh results and this is where we will begin to apply our 5 step process 

for examining and fixing our meshing issues. 

 

Step 1: Identify the issue.   

By pressing the View Mesh Results button shown in the above image, we can see from the next 

image that the problem is identified as a non-watertight mesh, or – precisely, that the “Input 

surface mesh does not enclose a watertight solid”. 

 

Step 2:  Know the cause.   

Watertight means that the mesh on all of the surfaces is complete, the lines of the mesh create 

valid elements, and the mesh properly connects to adjacent surfaces so that the volume is fully 

enclosed.  If the model error indicates that it is not watertight, there are some areas of the mesh 

where the lines of the surface mesh are not comprised of 3 or 4 sided regions, making up valid 

elements.  Typical reasons may include the mesh being too coarse, sliver surfaces, tolerances 

too loose, unmatched or multi-matched edges and interfering geometry. 
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Step 3:  Review on geometry.   

There are multiple ways to see the surface that is problematic, causing the model to not be 

watertight.  One of those ways is to click on the surface (#) link on the Problems tab of the 

Meshing Results.  This will highlight that surface on the model. 

 

Additionally, you can go to the View tab and access the Color by drop down menu on the 

Appearance panel and select Layer to have the mesh lines colored by their layer number.  Next, 

go to the Draw tab and select Layer Control on the Design panel.   

 

Layer 0 is the internal mesh (if solid meshed already) and is displayed in black.  Layer 0 

(displayed in green) is the vast majority of the surface mesh.  Layers 14 (orange) are the edges 

or wireframe of your geometry.  You may also see layer 3 (yellow) where quad elements have 

been split to triangles and layer 15 (typically I describe as a salmon color) is mesh that has been 

matched between two parts for bonding or contact.  Other layers, which would be problems if 

you see them are layers 2 (red) and 6.  It is possible to turn off those valid layers to just display 

the problematic layers (2 or 6, whichever is showing) and get an idea of where it happens and 
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how big the problem area is.  It can also be helpful to go the View tab, access the Visual Style 

pull-down menu and choose to display the style simply as Mesh vs. Shaded with Mesh so that 

the shading of the model does not obscure the problem area.  Once located and zoomed in on 

it, you can turn back on the layers and begin to use your mouse wheel to zoom out slowly so 

you can keep perspective of where on the model the issue occurs.   

Step 4:  Consider the options.  

 If the problem happened at the interface of 2 parts, I might consider looking for interference 

(could also be a tolerance issue).  In this case, it is a single part.  If the issue happened on a 

complex surface, I might consider whether I could simplify it.  In this case, at this point, we don’t 

believe it to be a complex surface… but worth investigating in detail if the issue persists to see if 

there is some accidentally small feature or complexity.  Is it possibly due to unmatched or 

multimatched edges?  We didn’t get any indication of that from the mesh results, but it is easy 

enough to double check.  If we go to the menu tree on the left hand side, we can right mouse 

click on CAD Mesh Options (found under the Material heading for the part) and choose Feature 

Matching.  A quick check of this shows we have 0 of either unmatched or multimatched edges.   

 

These are typical considerations and questions you’d want to ask yourself about the geometry.  

The only obvious thing we know about the model is that the user (or I) chose to mesh 

(attempted to) at a coarser than default mesh size, so we still have plenty of room to move the 

slider toward the finer end of the spectrum. 

Example 1 (continued):  Tapered Panel.ipt – Fixing the mesh issue – Learning 

Objective 4 – Learn about mesh size controls 
 

Step 5:  Attempt the remedy or repair.  

 If we move the mesh slider back to the middle between Coarse and Fine (the middle position 

known as 100% on the slider – coarse is 190%, fine is 10%), the model will successfully mesh.  

So, in this case, the issue was just a function of the mesh size chosen being too coarse initially 

to suit our geometry.  It is probably one of, if not the simplest, changes you can try and, if you 
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have the room in your element count, it is probably worthwhile attempting a few finer mesh 

sizes. 

If you are concerned about the element count, since this issue happened in a very localized 

area, I selected the surfaces where the problem was, selected the sub-entities of vertices and 

then added refinement to the selected nodes, using a radius of 1 and divide factor of 6.  This 

produces a successful mesh. 

 

Bonus Tips and Observations 

I.  When the mesh size slider is right in the center position (100%) between coarse and 

fine, the size of the mesh that is applied is 70% of 1/6th of the cube root of the 

volume.  It is important to note that this is volume based.  This means that as the 

volume increases, so does the size of the mesh associated with the center position.  

When you have long slender items (such as this panel or 3d cad models of long 

structural beams), the high volume (from length and width) typically leads to a large 

mesh size that can lead to issues in relation to the thickness of the part, such as the 

case here.  (Supports Learning Objective 4 – Learn about mesh size controls). 

II. New functionality for 2015!  You may have observed in meshing this model at 

coarser mesh size that is goes through 1 or 2 surface mesh size reductions until it 

shows a green progress bar.  However, when it gets to the mesh verification stage, it 

fails and then attempts the surface mesh again (at a smaller size) and iterates this 

process several times.  In the 2015 product release, you can observe this by going to 

the Mesh tab and selecting 3D Mesh Settings from the Mesh panel.  When the Model 

Mesh Settings dialogue box opens, click on Options… and look at the Model settings 

to see that there are 6 retries and a reduction factor of .75 by default, as shown in 

the image below.  Without these automatic retries (version 2014 and prior), this 

would likely lead the user to spend more time manually attempting mesh size 

reductions.  (Supports Learning Objective 4 – Learn about mesh size controls). 



Advanced Meshing Techniques in Simulation Mechanical 

10 
 

 

III.  The geometry is very thin is comparison to the length and width, which is what leads 

to the meshing issue in the first place.  This part should ideally be made out of plate 

geometry.  I would propose that the best meshing of this part would be to utilize the 

midplane mesh setting, which will produce plate elements.  Midplane meshing the 

part that has had the refinement points added produces a successful plate mesh with 

approximately 11,000 elements. 

 

Example 2:  Edge Guard.ipt – Multi-matched edges – Learning Objective 1 – 

How to identify problem cad geometry 
 

In the following cad geometry, there is a location in this model where a multi-matched edge will 

appear.  This is a model that I generated on my own.  This vision is something like a foam edge 

guard that someone might purchase in order to put around the edges of a table if there is a 

toddler in the house. 
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We will take a look at the steps of identifying the issue, knowing the cause, reviewing the issue 

on the geometry, considering our options and then applying the repair.  Without even meshing 

the model, we can be aware that we have some issue with the geometry, however, we’ll go 

ahead and assign a mesh to the geometry and then begin our investigation.  The model mesh 

settings I am using are to set the Mesh type to Solid (brick) and I’ll move the slider to 50% (in 

bias towards the fine settings).   

 

Let’s begin now with our process we are using for our meshing issues. 

Step 1:  Identify the issue.   

Having meshed the model now we can see an indication of an issue by looking at the menu 

tree, in fact it was also visible (program identified an issue) as soon as the geometry was 

opened.  After having meshed the geometry, my typical next step would be to go over to the 

menu tree and continue with defining the geometry, e.g. set up the element definition (if needed) 

and assign the material.  As we look toward the part there, we can see that it has had a change 

in state.  Instead of showing a typical blue cube, the cube icon next to the part name Part 1 

<Edge Guard.ipt> (in this case) now has a red outline.  In addition, the icon has been badged 

with an x, indicating that there is some issue.  Perhaps more importantly, if you look a couple 

items lower under that part, you will notice that the icon next to CAD Mesh Options has a red 

outline as well and badged with a small letter “i”, indicating that it has some information to share. 
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So, our next step will be to right mouse click on CAD Mesh Options and we will select the option 

of Feature Matching….   

 

This clearly identified that we have a multi-matched edge within our geometry.  Note that the 

slider here can be utilized to try and remedy either unmatched or multi-matched edge issues.  

Generally, moving this slider towards the Coarse end of the spectrum will eliminate unmatched 

edges and moving it toward the Fine end will help to eliminate multi-matched edges.  We will 

discuss this more in the Bonus Tips and Observations section at the end of this exercise.  For 

the origin of the multi-matched edge in this geometry, the slider will not have any bearing, but at 

least we now have identified what type of meshing issue we are dealing with. 

Step 2:  Know the cause.   

A multi-matched feature line occurs when more than two surfaces on one part share an edge.  

To enclose a continuous volume, only two surfaces can meet at an edge (note – volume, 

surface geometry can have different rules).  This particular geometry contains an edge which 

does not allow a continuous volume throughout the part.   
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Multi-matched edges can also arise when there is a sliver surface.  Imagine that, for instance, 

you have a simple cube; this cube would have 16 edges (4 around top, 4 on the vertical edges 

and 4 at the bottom).  Envision that you see any one of those edges show up as a multi-

matched edge and there is no reason it should be, since any one of those edges should only be 

shared by 2 surfaces (the top surface and a side surface, a side surface and another side 

surface or a side surface and the bottom surface).  This would be indicative of a cad modeling 

issue where there is likely a sliver surface, where someone maybe unintentionally made an 

extremely small radius to one edge… so small that the simulation mechanical package does not 

handle that surface well and considers the edge that defines the start of that fillet (or chamfer) 

as a duplicate to the edge that is at the end of the feature and that line (though really 2 lines) 

shares more than 2 surfaces, the fillet surface plus the surface to either side of the fillet.  This 

(the cube) is, of course, a very simplified example to help envision easily how the issue might 

occur.  In actuality, the sliver is more likely a result of some complex modeling which leaves a 

sliver surface or small cuts or extrusions.  I have also seen it happen when someone has 

geometry that is a mirror on the top to the bottom or left to right, so they built one half of the 

geometry and used the mirror command, but – in doing so, one half of the geometry got shifted 

along the symmetry plane by some small amount… this leads to sliver surfaces along the 

symmetry plane.  Additionally, modeling tolerances can come in play here, where, if the 

tolerance of the exported geometry (e.g. it is saved out as a step) is not as good (tight) as the 

native cad model, the features may get mistranslated resulting in multi-matched lines. 

Step 3:  Review on geometry.   

Investigating a multi-matched line issue is a simpler task to perform in that it is typically very 

readily seen where the issue is occurring.  I would propose that you would go to the View tab 

and then select the Visual Style pull-down menu on the Appearance pane and change from the 

default of Shaded with Mesh to Edges.  As soon as that is done, we can see where the multi-

matched line or edge is, as it appears in a dark blue color. 
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Step 4:  Consider the options.   

If we turn back on the Shaded with Mesh type of visual style and then go to the View tab’s Color 

by option, also found on the Appearance panel, we can choose to set the display of the color of 

the lines on the model to color by Surface.  What we can see is that in the area of the 2 half 

round extrusions (what might grip on to the table surface) we have, in fact, 4 surfaces (2 from 

the upper halves of the rounds and 2 on the lower side), all being shared by the one coincident 

edge (or feature line) that runs down the length of the part. 

 

For our geometry, the multi-matched line does not present a roadblock to completing the 

surface mesh or a successful solid mesh, so an analysis could be performed.  So, in some 

cases, this issue could be ignored altogether.  However, since there is a line of contact, the 

nodes are matched between the half round on one side of the model and the half round of the 

other side of the model.  If you envision that the goal of the analysis is to hold one side of this 

geometry and pull the other side, to simulate what the stress might be as we insert the guard 

over the edge of the table, the matched nodes will be bonded and will prevent the two halves 

from separating the way we might want them to. 
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What I would propose as the fix for this one would be to perhaps change the radius of the half 

rounds some very small amount (such that it has a negligible impact on the model 

approximation), but gives us the small gap between the half rounds so that the 4 surfaces are 

no longer touching at 1 edge.  This should eliminate the multi-matched edge, as well as stop the 

nodes from bonding one side of the model to the other.  In other situations, if the multi-matched 

line prevents a successful solid mesh, I would propose first attempting to adjust the Feature 

Matching mentioned earlier to see if it can be remedied.  If the range of adjustment does not 

remedy the issue, a change to the cad model may be necessary.  Sticking within the simulation 

environment, it might also be worthwhile attempting refinement points to see if that will allow the 

program to capture and mesh a sliver surface.  If the issue is one of tolerance, particularly if you 

have used a universal file format, it might be wise to see if file save options allow changing of 

the tolerance or whether it may be possible to use a native cad file. 

Example 2 (continued):  Edge Guard.ipt – Fixing the mesh issue – Learning 

Objective 2 – Learn how to fix modeling issues 
 

Step 5:  Attempt the remedy or repair.   

Given the goal of our analysis on this geometry, we decide the best route might be to make 

some small change to the radii of the half rounds.  In this particular case, the as modeled radius 

is 0.25 inch.  You could go back to the cad package the model originated in, or – if you had 

chosen to install it, you can access Fusion by going to the Tools tab, and then clicking on CAD 

with Fusion on the Edit panel. 
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As this model was constructed in Inventor and I have Inventor loaded, I can simply return to the 

cad package, select the dimension and edit.  Editing the radius by just .001 in. (Edge Guard 

Revised.ipt) allows the model to import without any red outline on the Part 1 icon or CAD Mesh 

Options icon.  There is no longer any multi-matched edge as these surfaces no longer touch 

along a single edge.  The red x badge indicates that information still needs to be defined (like 

material, after meshing) and then will go away.  Meshing the model at 50%, assigning material 

Plastic- Nylon Type 6/6, fixing one side of the model and assigning a surface prescribed 

displacement at the bottom radius of the other side of the model, we can now see a reasonable 

deflection, where the half rounds are no longer stuck together. 

 

Bonus Tips and Observations 

I.  The use of the Feature Matching utility will be most successful when the origin of the 

multi-matched line is a function of some small sliver surfaces or tolerance issues.  By 

moving the slider towards the finer end, we are asking the program to render the 

geometry with greater resolution.  In some cases however, it is also possible that a 

multi-matched issue can be remedied by going to the coarser end.  It takes only a few 

moments to adjust the slider and click apply and see if the number of reported 

unmatched or multi-matched edges changes in your favor… it is worth taking a few 

moments to move the slider around and test. 

II. I have, prior, mentioned that it would also be worth attempting to refine the mesh.  If the 

source of the multi-match issue is due to a sliver surface, or multiple sliver surfaces, you 



Advanced Meshing Techniques in Simulation Mechanical 

17 
 

can access the Mesh tab and then Automatic from the Refinement panel.  

  When the Automatic Refinement Points dialogue opens, press the Generate button.  

  The utility is 

likely to find those small regions where refinement is required and it is very possible that 

if the mesh is executed again then, once those refinement points are added, that the 

mesh will also be successful.  This might lead to a more than desired element count in 

the model, however, if that is a better option in your situation vs. attempting some 

geometry corrections, this could be a path. (Supports Learning Objective 4 – Learn 

about mesh size controls). 

III. As this particular exercise illustrates, it bears repeating that if the multi-matched feature 

lines do not prevent a successful solid mesh and if it will have no negative impact on the 

function of the model, it may also be a consideration to simply ignore this meshing 

issue… once you have observed where it occurs and assessed what impact it may 

have. 

Example 3:  Bicycle Frame 1.igs – Unmatched edges – Learning Objective 1 – 

How to identify problem cad geometry 
 

In the following cad geometry, there is a location in this model where unmatched edges will be 

found.  This is a model of a bicycle frame that was publicly available on a community cad file 

sharing site. 
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We will take a look at the steps of identifying the issue, knowing the cause, reviewing the issue 

on the geometry, considering our options and then applying the repair.  Without even meshing 

the model, we can be aware that we have some issue with the geometry, however, we’ll go 

ahead and assign a mesh to the geometry and then begin our investigation.  The model mesh 

settings I am using are the defaults, so, we can go to the Mesh tab and just select Generate 3D 

Mesh from the Mesh panel, or, we can select the option 3D Mesh Settings from the same tab 

and panel.  If we elect to click on 3D Mesh Settings, you will note that the Model Mesh Settings 

dialogue has the Mesh type changed to Plate/shell, even though we thought (or were attempting 

to) import a solid volume.  As of release 2014, the software is able to detect on opening the 

model whether the part is a complete volume (setting the Mesh type then to solid) or whether it 

is surface geometry, in which case it sets the Mesh type, as seen below, to Plate/shell.   

 

The same issue that is causing the unmatched edges in this geometry is causing the volume to 

not be interpreted as a solid volume.  Once we fix the issue, the model will able to be meshed 

as a solid volume.  For now, we will go ahead and press the Mesh model button on the Model 

Mesh Settings window to generate the mesh on the geometry. 

Let’s begin now with our process we are using for our meshing issues. 
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Step 1:  Identify the issue.   

Having meshed the model now we can see the indications of an issue looking at the menu tree, 

in fact it was also visible (program identified an issue) as soon as the geometry was opened.  

After having meshed the geometry, my typical next step would be to go over to the menu tree 

and continue with defining the geometry, e.g. set up the element definition (if needed) and 

assign the material.  As we look toward the part there, we can see that it has had a change in 

state.  Instead of showing a typical blue cube, the cube icon next to the part name Part 1 

<Bicycle Frame 1> (in this case) now has a red outline.  In addition, the icon has been badged 

with an x, indicating that there is some issue.  Perhaps more importantly, if you look a couple 

items lower under that part, you will notice that the icon next to CAD Mesh Options has a red 

outline as well and badged with a small letter “i”, indicating that it has some information to share. 

 

So, our next step will be to right mouse click on CAD Mesh Options and we will select the option 

of Feature Matching….   
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This clearly identified that we have unmatched edges within our geometry.  Note that the slider 

here can be utilized to try and remedy either unmatched or multi-matched edge issues.  

Generally, moving this slider towards the Coarse end of the spectrum will eliminate unmatched 

edges and moving it toward the Fine end will help to eliminate multi-matched edges.  We will 

discuss this more in the Bonus Tips and Observations section at the end of this exercise.  For 

the origin of the unmatched edges in this geometry, the slider will not have any bearing, but at 

least we now have identified what type of meshing issue we are dealing with. 

Step 2:  Know the cause.   

An unmatched feature line is one that is not shared by two surfaces.  It means that one surface 

ends in the middle of space and does not connect with another surface.  This configuration does 

not enclose a volume and therefore will not allow the solid mesh engine to create a solid mesh.  

Note that we are specifically speaking about volumetric geometry in this instance.  Surface 

geometry, by definition, always will have unmatched edges around the perimeter of the 

geometry.  This particular geometry contains at least one edge which does not allow a 

continuous volume throughout the part.   

So, unmatched edges can happen when there are missing surfaces.  I suppose that this could 

happen from a modeling oversight, however, I would imagine that it is most likely the result of an 

improper file translation or when the data for that model was saved, the information written for 

that surface was incorrect.  From what I have seen, the missing surface that gives rise to the 

unmatched edges is not necessarily complicated, you can imagine the patch of surface that 

belongs there, but the surfaces that exists around the perimeter of that surface might be more 

complex, such as a bunch of small radii surfaces, so the connection between those and the now 

missing surface may have been improper.  As a simple example of how this might happen in a 

model, imagine that, for instance, you have a simple cube, this cube would have 16 edges (4 

around top, 4 on the vertical edges and 4 at the bottom) and – of course – the 6 surfaces (top, 

bottom, and 4 sides).  Now, imagine that you were to remove the top surface, but the 4 side 

surfaces remain.  The top edge of each one of those 4 sides surface would appear as an 

unmatched edge as each individual one is associated to the side surface but no other second 

surface, so you would have 4 unmatched edges total.   

Step 3:  Review on geometry.   

Investigating an unmatched line issue is a simpler task to perform in that it is typically very 

readily seen where the issue is occurring.  I would propose that you would go to the View tab 

and then select the Visual Style pull-down menu on the Appearance pane and change from the 

default of Shaded with Mesh to Edges.  As soon as that is done, we can see where the 

unmatched line or edges are, as it appears in an orange color. 
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Step 4:  Consider the options.   

If we turn on the Shaded with Edges type of visual style and then rotate the model around to 

investigate the area where the unmatched edges appeared, we can get a pretty good picture of 

what the issue is with this model.  What we can see is that the bottom surface of the head tube 

is missing, so, the circular bottom edges of the head tube are unmatched as the cylindrical 

surfaces that make up the outer and inner walls of the head tube are not connected to any 

second surface. 

 

For our geometry, the unmatched line does present a roadblock to completing a successful solid 

mesh, so an analysis cannot be performed and we will need to correct it.  For the typical 

options, as mentioned earlier, you may be able to adjust the slider for the feature matching, but 

this has already been investigated for our model and will not remedy the issue.  Another option, 

if the region isn’t overly complex, which it isn’t here, and the mesh around the boundary of the 

missing surface looks decent, you might be able to just draw lines in to cap off the surface.  So 

long as the lines that you add over this void result in valid surface elements (3 and 4 sided 

regions) you should be able to get a successful solid mesh.  The drawback to that method is 

that the lines that you are adding manually are based on (connected to) this particular surface 
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mesh.  If you wanted to re-mesh the surfaces, then you would need to manually patch the 

surface again.  It is a valid option; I would just propose that you make certain that you have the 

mesh on the rest of the model where you would like it to be first, prior to making the manual 

mesh repair so that you don’t have to do the manual repair once.   

What I would propose as the fix for this one would be to perhaps simply go back to our cad 

modeling package and see if we can repair that surface.  If we can fix the surface and send the 

model back in to Autodesk Simulation Mechanical, then we should have a problem free model 

that we can work with in a more efficient manner since we then wouldn’t need to worry about 

any mesh related issues once this one is remedied.  Or, if there are a number of unmatched 

edges, it could be an iterative process or fixing one or several surfaces, re-open in Autodesk 

Simulation Mechanical to test and then identify next issues and so on.  In any event, presuming 

that you had chosen to install it, you can also patch surfaces with Autodesk Inventor Fusion.  

Example 3 (continued):  Bicycle Frame 1.igs – Fixing the mesh issue – Learning 

Objective 2 – Learn how to fix modeling issues 
 

Step 5:  Attempt the remedy or repair.   

Given the goal of our analysis on this geometry, we decide the best route might be to try and 

repair that surface in the cad package.  You could go back to the cad package the model 

originated in, or – if you had chosen to install it, you can access Fusion by going to the Tools 

tab, and then clicking on CAD with Fusion on the Edit panel. 

 

With the model in Autodesk Inventor Fusion, I’ll save the model with a new name to identify it as 

something different than my original model so if I look at this file again at some time in the 

future, I’ll know that this is one that I repaired or at least attempted repair on, so I’ll name this 

one Bicycle Frame Fusion Repaired, in the native .dwg format.  Having saved the file to a new 

name, what we want to do is get in to the surface modeling tools of Fusion.  On the far left hand 

side of the ribbon, I see a panel titled Modeling and it reads Solid, with a drop-down option.  If I 

access the drop-down, I can change from Solid to Surface, which then gives me access to all 

the surface modeling utilities from the panel labeled as Surfaces in Fusion as shown in the 

image below.  
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First, we can select the 2 circular edges that bound the space that we need to repair.  Select 

one of the circular edges and then, holding the shift key on your keyboard down, select the 

second circular edge.  Once you have them both selected, select the Patch/Merge command.   

 

The ribbon bar should indicate that the Creation Options is equal to New Surface and then you 

can press the OK button to generate this new surface. 
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Now that the surface has been created, from Autodesk Inventor Fusion, we can save the model 

back to the .igs format that it was, so I’ll save the model out as Bicycle Frame Fusion 

Repaired.igs.  We then open this file in Autodesk Simulation Mechanical and test the meshing.  

With that surface now capped and the sum of the surfaces enclosing a volume, the program will 

have detected that and the mesh type is set to solid and the element type in the menu tree after 

meshing should be identified as a brick type of element. 

 

We can apply some material, constraints and loads and ensure that we have a successful 

analysis. 
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Bonus Tips and Observations 

I.  The use of the Feature Matching utility with unmatched edges will be most successful 

when the origin of the unmatched line is a function of Autodesk Simulation Mechanical’s 

interpretation of the geometry, but no actual missing surface data.  For instance, note 

that our meshing of the model (and the cad rendering of the geometry) is a function of 

the volume of the geometry.  So, if you have some very large volume, the scale used to 

render that geometry also becomes larger.  It is then possible that this scale is then too 

large to accurately represent the geometry and the feature is misrepresented and the 

program does not appropriately associate the edges to the features that they should 

describe.  By moving the slider towards the finer end, we are asking the program to 

render the geometry with greater resolution.  In some cases however, it is also possible 

that an unmatched issue can be remedied by going to the coarser end.  It takes only a 

few moments to adjust the slider and click apply and see if the number of reported 

unmatched or multi-matched edges changes in your favor… it is worth taking a few 

moments to move the slider around and test when unmatched or multi-matched edges 

occur in the model.  If changes to the slider have an impact, find where on the slider you 

have the least number of unmatched or multi-matched edges and then you can use an 

alternative method, such as manual mesh repair or cad repair to fix the few remaining 

issues. 

II. In our repair of the geometry in Autodesk Inventor Fusion, we added a surface to the 

model.  We did not go through the process of tying all the surfaces back together to 

create a singular solid volume in that package.  For Autodesk Simulation Mechanical, 

there are file opening, or import, options of iges wireframe and iges solid.  With respect 

to the iges solid, the data format that is typically exported is trimmed surface data.  So 

long as the sum of the surface data encloses a solid, such as it does after this repair, 

the volume should then be able to be surface meshed and solid meshed.  With some 

cad modelers, adding this surface may have resulted in creating a second part, that is, 



Advanced Meshing Techniques in Simulation Mechanical 

26 
 

that new annular surface at the bottom of the head tube could have become part 2.  In 

that situation, it would be advised to either try the iges export option from the cad to see 

if it is then interpreted as a single volume, or, you may need to go through the process 

of knitting your surfaces in to a single volume. 

Example 4:  BeamsAsm.iam – Imprinting and unmatched vertices/nodes – 

Learning Objective 3 – Learn about imprinting between solids and surfaces 
 

In the following image, if we take a look at the mesh between the s-shaped surface and the flat 

(square) plate, just by visual inspection, it appears that the mesh has matched well between the 

two parts. 

 

Further, knowing what we’ve learned in the previous examples, we can take a look at layer 15 to 

see what mesh has been matched and it looks good as well (referencing image below).   
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That is the type of mesh behavior that we’d expect and certainly what we’d like to see.  We are, 

of course, instead interested in learning about meshing issues however and so we will now take 

a look at the model we are going to use for this discussion.  This next model is an example that I 

built from scratch.  It is a surface based geometry with a large beam (W27x146) with two 

smaller channels (metric C130x11) which pass through the larger beam.  We typically see this 

type of construction (surface modeling of beams) in applications such as shipbuilding or some 

civil applications.  The model would, of course, contain much more structure in a “real world” 

type of application, but we’ll focus on this small section of the model to illustrate the issue.  The 

w section, as a function of how I constructed it is comprised of 4 parts, where the web is 1 part, 

one of the flanges is a second part, the other flange is comprised of 2 additional parts (one to 

either side of the web) and then we have two additional parts (the c shaped channels), for a 

total of 6 parts. 

 

 We will take a look at the steps of identifying the issue, knowing the cause, reviewing the issue 

on the geometry, considering our options and then applying the repair.  Without even meshing 

the model, it appears we have some issue with the geometry, however, we’ll go ahead and 

assign a mesh to the geometry and then begin our investigation.  The model mesh settings I am 

using are the defaults, so, we can go to the Mesh tab and just select Generate 3D Mesh from 

the Mesh panel, or, we can select the option 3D Mesh Settings from the same tab and panel.  If 

we elect to click on 3D Mesh Settings, you will note that the Model Mesh Settings dialogue has 

the Mesh type changed to Plate/shell.  As of release 2014, the software is able to detect on 

opening the model whether the part is a complete volume (setting the Mesh type then to solid) 

or whether it is surface geometry, (this model has been created as cad surface geometry) in 

which case it sets the Mesh type, as seen below, to Plate/shell.   
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For now, we will go ahead and press the Mesh model button on the Model Mesh Settings 

window to generate the mesh on the geometry.   

Let’s begin now with our process we are using for our meshing issues. 

Step 1:  Identify the issue.   

Having meshed the model now we can see the indications of an issue looking at the menu tree, 

in fact it was also visible (program identified an issue) as soon as the geometry was opened.  

After having meshed the geometry, my typical next step would be to go over to the menu tree 

and continue with defining the geometry, e.g. set up the element definition (if needed) and 

assign the material.  As we look toward the part there, we can see that it has had a change in 

state.  Instead of showing a typical blue cube, the cube icon next to the part name Part 1 

<W27x146:1> (in this case) now has a red outline.  In addition, the icon has been badged with 

an x, indicating that there is some issue.  Perhaps more importantly, if you look a couple items 

lower under that part, you will notice that the icon next to CAD Mesh Options has a red outline 

as well and badged with a small letter “i”, indicating that it has some information to share. 

 

So, our next step will be to right mouse click on CAD Mesh Options and we will select the option 

of Feature Matching….   
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This clearly identified that we have unmatched edges within our geometry.  This is ok however 

(in fact, expected) with surface models.  The planar geometry does not enclose a volume, so 

the edges of the part do not match with other surfaces to enclose a volume.  We’ll close the 

feature matching window.  The real concern in this model, looking at the mesh that we 

generated, is that we have unconnected mesh between the w section and the c shaped 

channels as can be seen in the image below. 

 

Step 2:  Know the cause.   

There are imprinting options within the mesh settings.  If you navigate to the Mesh tab and 

choose 3D Mesh Settings, that will bring up the Model Mesh Settings dialogue.  When the 

Model Mesh Settings dialogue opens, press the Options… button.  Along the left hand panel of 

the options, click on the icon for Model and you will see the screen below. 
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Things to know about imprinting; 

(A.)  The Use virtual imprinting should be used to have the faces of different CAD parts be split 

in memory where they intersect each other, without creating additional surface numbers 

(that is, it is a virtual imprinting of one surface on another).  The virtual model is used as the 

basis for the surface mesh generation.  Since the matching virtual surfaces are meshed only 

once, this will result in a better quality mesh.  When this option is unchecked, mesh 

matching is accomplished by meshing both surfaces of the parts and then adjusting the 

mesh on one part to conform to the mesh on the other part. 

(B.)   The Perform imprinting within parts option will create virtual intersections where different 

surfaces within a single part meet each other.  This action is similar to that of the imprinting 

between parts.  This is useful for CAD surface models used as the basis of plate/shell FEA 

models when the model is comprised of a single part comprised of several different surfaces 

but without feature lines present along surfaces where an intersection with an adjacent 

surface occurs. 

(C.) What is important to know with either of these options is that the program is looking for 

the feature lines or the edges of a part to be coincident with the surface of a second part (or 

a feature line with a surface on the same part in the case of imprinting with the part). 

Step 3:  Review on geometry.   

As we saw a little bit earlier, the mesh does not match well between the W27x146 and C130x11 

parts.  If you rotate the geometry around, you’ll see that the C130x11 parts are single parts that 

begin to one side of the W, pass through the web and continue on out on the other side.  In 

other words, we have violated one of the important notes that were provided shortly above in, 

item c, in things to know about imprinting.  The C130x11 geometry does not have feature lines 

that terminate on the surface of the web of the W part. 
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We have also, prior, learned that matched mesh is placed on layer 15.  We can go to the Draw 

tab and access the Layer Control option from the Design tab and turn off all but Layer 15.  That 

is, uncheck Layer 1 and Layer 14.  The model will now look like the image below. 

 

Next, turn off the shading so that we can see just the lines of the mesh that are on layer 15.  For 

this, go to the View tab and access the Visual Style pull-down menu from the Appearance tab 

and change from Shaded with Mesh to just Mesh.  We can see in the image below that the web 

has matched with flanges on the W section.  Why?  The edges of the part that represents the 

web do terminate at the surface(s) of the flange. 
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Also note in the image above that the color of the lines is green.  We were not displaying the 

color of the lines based on the layer number.  If you wanted to, you could also go to the View 

tab and then access the Color by pull down menu and choose to display them based on their 

layer number.  The two diagonal green lines from above should display in a dark orange-ish/red 

coloration.  So, from a visual inspection of the nodes (vertices) on the model when looking at the 

Shaded with Mesh and reviewing the layer 15, we can see that we have no matched nodes 

between the C shapes and the W’s web (the C shapes did not imprint).  Had this not have been 

noticed on the assembly, you probably would have noticed peculiar results since the different 

beams would have acted independently from one another with no nodes matched.  I will then go 

to the Visual Style pull down and turn the model back to Shaded with Mesh and go to the Draw 

tab and access Layer Control and bring back (check) all of the layers.   

Step 4:  Consider the options.   

For our geometry, the unmatched line do present a potential roadblock to having an 

appropriately behaving model depending on the options that we utilize in our analysis, so, it 

would be wise to take some type of corrective action.   

(I.) Turn the imprinting option off.  The default option is that imprinting is on.  If we turn 

that option off, then the program will mesh the parts and, as a subsequent step, then 

try and match up the nodes between the parts.  This is certainly a valid path to 

explore.  The degree of success will depend on the mesh itself and matching 

tolerance.  You can increase the chance of this being a successful option by having 

similar meshes on the parts. 

(II.) Manually repair the mesh.  If the region where the issue exists is relatively small and 

could readily be repaired by moving a few nodes to align with one another or by 

adding a few additional lines, it would certainly be a valid approach to make such 

changes.  This can be labor intensive and I would suggest is reserved, again, for 

smaller region problems. 
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(III.) Repair the cad.  We could leave the imprinting option on and then return to our cad 

package and make the changes to the geometry such that the cad geometry does 

terminate at a surface of another part.  While this requires then a small step 

backward to go repair the geometry, it then helps in the meshing stage by eliminating 

the problematic unmatched nodes altogether.   

What I would propose as the fix for this one would be to perhaps simply go back to our cad 

modeling package and see if we can repair (or, perhaps I should say properly prepare for FEA) 

those cad parts.  If we can fix the parts and send the model back in to Autodesk Simulation 

Mechanical, then we should have a problem free model that we can work with in a more efficient 

manner since we then wouldn’t need to worry about any mesh related issues once this one is 

remedied.  Or, if there are a number of problem areas in the model, it may be an iterative 

process or fixing one or several parts, re-open in Autodesk Simulation Mechanical to test and 

then identify next issues and so on.  In any event, presuming that you had chosen to install it, 

you can also intersect parts with Autodesk Inventor Fusion.  

Example 4 (continued):  BeamsAsm.iam – Fixing the mesh issue – Learning 

Objective 2 – Learn how to fix modeling issues 
 

Step 5:  Attempt the remedy or repair.  

Given the goal of our analysis on this geometry, we decide the best route might be to try and 

repair those parts in the cad package.  You could go back to the cad package the model 

originated in, or – if you had chosen to install it, you can access Fusion by going to the Tools 

tab, and then clicking on CAD with Fusion on the Edit panel. 

 

With the model in Autodesk Inventor Fusion, I’ll save the model with a new name to identify it as 

something different than my original model so if I look at this file again at some time in the 

future, I’ll know that this is one that I repaired or at least attempted repair on, so I’ll name this 

one BeamsAsm Fusion Repaired, in the native .dwg format.  Having saved the file to a new 

name, what we want to do is get in to the surface modeling tools of Fusion.  On the far left hand 

side of the ribbon, I see a panel titled Modeling and it reads Solid, with a drop-down option.  If I 

access the drop-down, I can change from Solid to Surface, which then gives me access to all 

the surface modeling utilities from the panel labeled as Surfaces in Fusion as shown in the 

image below.  
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We will use the Split command as shown below. 

 

Once we access the Split tool, the first step will be for us to identify the Split Target, you will 

choose all the surfaces of the C shape sections.  These are the surfaces that we want to have 

split such that the surfaces terminate and start at the surface that represents the web of the W 

shape. 
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Next, select the command for Split Tool, select the web of the W section and press the OK 

button.  We are using the web to split all the surfaces of the channels. 

 

Now that the surfaces have all been split, from Autodesk Inventor Fusion, we can save the 

model once again (to save the work we did) and then push the model back in to Autodesk 

Simulation Mechanical. 
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Back in Autodesk Simulation Mechanical we can mesh the newly split model and, via visual 

inspection, can see that the mesh matches up much more nicely. 

 

We can also check for the presence of layer 15 (matched mesh) and we observe the following, 

indicating that the geometry is matched at the web and flange interface, as well as where the C 

shape interfaces with the W shape. 
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Finally, we can apply some material, constraints and loads and ensure that we have a 

successful analysis. 

 

 

Bonus Tips and Observations 

I.  Imprinting and matched mesh is likely your best option, that is, path of least meshing 

resistance.  If you choose to turn it off, keep in mind that the program will still try and 

match the mesh, but – in order to do so, nodes on the two parts must be within mesh 

matching tolerance to have the nodes matched.  Having a great disparity in mesh sizes 

can make this take more difficult.   

II. In our next exercise, we will explore how to solve an analysis where the meshes are not 

matched.  It is possible to do, but one should enable the smart bonded contact option 

from the analysis parameters. 
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Example 5:  Bow Riser.iam – Single Part Meshing in Assemblies – Learning 

Objective 1 – Learn how to identify problem CAD geometry. 
 

The following model is a five part assembly that represents the main body of a hunting bow.  

The model originates from a cad file sharing site, some parts have been removed, such as the 

string, cams and so on such that we can work efficiently with the geometry, yet still illustrate the 

techniques.  The model has been opened prior and we have attempted to mesh the model 

several times and we are aware that the model has meshing difficulty, specifically that part 3 

(the yellow part) has issues meshing.   

 

 We will take a look at the steps of identifying the issue, knowing the cause, reviewing the issue 

on the geometry, considering our options and then applying the repair.  This model, since we 

know it has difficulty, we will add an initial mesh to, but change some of the settings so that it 

“fails fast”.  That is to say, since we know that part 3 is going to have difficulty, we can change 

settings so that the program will make one mesh attempt and stop, rather than waiting for the 

program to go through a number of mesh attempts. We can go to the Mesh tab and then press 

3D Mesh Settings.  When the Model Mesh Settings box opens, press the Options… button.  On 

the first screen of options (for the surface mesh), we’ll change the size from the default of 100% 

to slightly finer 50% and we’ll change the number of surface mesh retries from the default of 6 to 

0. 
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Next, we will go to the Model options in this same Model Mesh Settings options dialogue and 

change the number of solid mesh retries from 6 to 0. 

   

Having made these two mesh options changes, the program will then attempt to mesh the 

assembly with the specific mesh sizes that we dictate and will not go through any automatic 

retries then due to either the surface meshing or solid mesh verification.  Press the OK button 

and then press the Mesh Model button to have the model attempt to mesh and you should find 

that part number 3 fails. 

Let’s begin now with our process we are using for our meshing issues. 

Step 1: Identify the issue.   

By pressing the View Mesh Results button shown at the end of the meshing attempt, we can 

see from the next image that the problem is identified as a non-watertight mesh, or – precisely, 

that the “Input surface mesh does not enclose a watertight solid”. 
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Step 2:  Know the cause.   

As discussed prior, in example 1, watertight means that the mesh on all of the surfaces is 

complete, the lines of the mesh create valid elements, and the mesh properly connects to 

adjacent surfaces so that the volume is fully enclosed.  If the model error indicates that it is not 

watertight, there are some areas of the mesh where the lines of the surface mesh are not 

comprised of 3 or 4 sided regions, making up valid elements.  Typical reasons may include the 

mesh being too coarse, sliver surfaces, tolerances too loose, unmatched or multi-matched 

edges and interfering geometry. 

You are welcome to use the techniques illustrated in example 1 to review the model and 

observer where the issues arise.  If you click on the surfaces shown in the Problems Summary 

of the Meshing results, you can isolate and investigate those surfaces.  Also, if you display the 

model (or at least the problem part) based on layers and you’ll see that there is a problem 

identified by layer 2, which shows in a red color on the model when you are displaying the mesh 

by layer number. 

Step 3:  Review on geometry.   

As we saw earlier, in example 1, one of the ways to investigate the issue is to click on the 

various surfaces displayed in the Problems Summary of the Meshing results.  This allows us to 

isolate and investigate those surfaces.  If you have already closed the Meshing Results, make 

sure that you are on the Mesh tab and then access View Mesh Results from the mesh panel. If 

we click on one of the problem surfaces, such as Surface 64, you will see the model displayed 

something like the below image. 



Advanced Meshing Techniques in Simulation Mechanical 

41 
 

 

This surface is essentially the entire bottom surface of the riser where it should mate with 

another.  To examine another, we just click the next surface in the list, in this case it is Surface 

86 and a very small surface, as shown in the below image. 

 

Continuing to investigate the surface identified in the list, we’ll find that all those surface make 

up this small corner of the model.   

We have also, prior, learned that mesh is placed on different layers (0 for internal mesh, 1 is 

surface mesh, 2 & 6 are problems, 14 are the edges of the model and 15 is mesh that has been 

matched between parts).  We can go to the Draw tab and access the Layer Control option from 

the Design tab and turn off all but Layer 2, which is a problem layer.  That is, uncheck Layer 1 

and Layer 14 and Layer 15 in this case.  It would also maybe be helpful to display the lines by 

their layer number.  From the View tab, access the Color by drop down menu on the 

Appearance panel and change to Layer.  The model will now look like the image below, with the 

problematic mesh showing in a red color. 
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Note that the this review of the layer numbers also indicates that there is an issue in this small 

corner of this riser part, which is also what was indicated when we reviewed the various 

identified surfaces from the meshing results. 

Step 4:  Consider the options.   

If the problem happens at the interface of 2 parts, I might consider looking for interference 

(could also be a tolerance issue or a mesh matching issue).  It does happen at the interface of 2 

parts, so these are all possible considerations.  If the issue happened on a complex surface, I 

might consider whether I could simplify it.  In this case, it isn’t necessarily a complex surface but 

the geometry isn’t a simple edge either, there are some small rounds and the geometry tapers 

to something very thin.  Is it possibly due to unmatched or multimatched edges?  We didn’t get 

any indication of that from the mesh results, but we have illustrated in earlier examples 

(example 2 and example 3) how to double check.  If we go to the menu tree on the left hand 

side, we can right mouse click on CAD Mesh Options (found under the Material heading for the 

part) and choose Feature Matching.  A quick check of this shows we have 0 of either 

unmatched or multi-matched edges, as shown in the image below.   
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These are typical considerations and questions you’d want to ask yourself about the geometry.  

Since the part is not meshed too coarsely, and we can rule out multi-matched or unmatched 

edges contributing to the problem, and we know it is a somewhat complex surface and the issue 

comes up at the interface of the two parts, the question is then which do we think it is?  A simple 

test that we can do is to run the mesh on that part alone.  If that part will mesh all by itself, we 

know that it isn’t a part surface geometry issue since it meshes, but then likely has something to 

do with the relation to the other part (interference or difficulties matching the mesh between the 

two).  On the other hand, if we mesh that part all by itself and it were still to fail, then we know 

the issue is not related to the assembly of parts, but that there is some cad modeling issue 

(sliver surface, overly complex surface) that we need to remedy with that specific part.   

What I would propose we do with this one (and what ultimately will be the fix) would be to take 

advantage of a new workflow, introduced in version 2015 of the software, which allows us to 

deactivate (suppress) parts we don’t want to remesh and then mesh only the active part.  

Presuming that part meshes, we can suppress it and move on to the next problem part.  Once 

all the problem parts are (hopefully) meshed, then we can activate all of the parts and perform 

the analysis.  Note that prior to V2015 you were not able to surface mesh an individual part and 

then reactivate parts and have them all run within the same analysis, in V2014 and prior, all 

parts that were going to be included in the analysis needed to be surface meshed in the same 

pass.  There is a specific workflow and we will cover that in the following section when we 

employ the methodology.    

Example 5 (continued):  Bow Riser.iam – Fixing the mesh issue – Learning 

Objective 4 – Learn about mesh size controls 
 

Step 5:  Attempt the remedy or repair.   

I will undo all the settings that we did within step 3 so that we can get the model back to the 

default rendered state.  We can go to the Draw tab and access Layer Control from the Design 

panel and turn back on (check) layers 1, 14 and 15 back on.  From the View tab, go to Color by 

on the Appearance panel and set the color by option back to Part (vs. the current of Layer) and 

the model should now appear as it did once our initial meshing attempt was done. 
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What we want to do is to attempt to successfully mesh part 3 on its own.  To do this, we are 

going to suppress the other parts.  To facilitate selection of all the parts but part 3, so we can 

suppress them, we will collapse the menu tree down.  Go over to the menu tree and right click 

on the heading of Parts, found above Part 1 in the menu tree, and then choose the option 

Collapse Part Details. 

 

Next, single left mouse button click on Part 1 (one of the parts to be suppressed) and then, 

holding down the control key on your keyboard, also single left mouse button select parts 2, 4 

and 5 (leaving Part 3 un-selected).  When they are all highlighted in blue, right mouse click on 

any one of the selected ones and choose the option to Suppress, as seen in the image below. 



Advanced Meshing Techniques in Simulation Mechanical 

45 
 

  

With those part suppressed and Part 3 un-suppressed, when we go to mesh, the program will 

only then attempt to mesh Part 3 and the mesh of that part will not be influenced by any of the 

parts around it that it may touch in an un-suppressed state.  So, next step is to go ahead and try 

and mesh that part.  Note that you can try and change meshing parameters, size or other mesh 

options, on that part before we re-execute the mesh, however, I’m just going to go ahead and 

try it with the same parameters used prior.  We will go to the Mesh tab, access 3D Mesh 

Settings from the Mesh panel and then click on Mesh model from the Model Mesh Settings 

dialogue window. 

 

Doing so, we find that the part successfully meshes as seen in the image below.   
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So, the question then becomes whether we can then utilize the most recent mesh of this part 

with the successful meshes that we had prior obtained for parts 1, 2, 4 and 5 and the answer 

(with version 2015) is yes!  Our next step would be to un-suppress those parts we had 

successfully meshed earlier, so, I will single left mouse button click on Part 1 and then, holding 

the control key of my keyboard, also then single left click on parts 2, 4 and 5.  Right mouse click 

on one of the selected parts and click on Suppress again to now un-suppress these parts.   

 

Now that all the parts are back and all of them are successfully meshed, all of these parts can 

be active in the solution.  There is, however, one final consideration or step that needs to be 

utilized when you employ this workflow.  Because we independently meshed Part 3 from the 

other parts, the mesh (vertices to be precise) of that part does not necessarily align with that of 

the mating part as you can see by looking at the interface of Part 2 (red) and Part 3 (yellow) in 

the image below. 
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So, the final piece in this workflow is for us to turn on, or, enable the smart bonding so that the 

program will know to utilize multi-point constraints (MPCs) in lieu of being dependent on 

matched nodes in order to transfer load from one part to an adjacent part.  This is done by going 

to the Setup tab and accessing the Parameters from the Model Setup tab.  Once the Analysis 

Parameters window has opened, go to the tab labeled Contact and there you will find that the 

default for Enable smart bonded/welded contact is set to None.  This will need to be changed to 

either the option Coarse bonded to fine mesh or Fine bonded to coarse mesh.  There is a lot 

that could be said about enabling smart bonded contact, but we’ll note just a couple of items 

here and we’ll have to rely on some self-education via the documentation or some further 

technical support assistance to completely fill in.  What I would note is as follows; 

A.)  The program interrogates the mating surfaces and compares node count on those two 

surfaces.  The surface which has more nodes is dictated by the program then as “finer” 

and the surface that has fewer nodes then becomes the part that is noted as “coarse”. 

B.) Your options to set (other than none) include Coarse bonded to fine.  What that means is 

that the coarse mesh is forced to follow the displacement of the fine mesh.  This would 

be most appropriate in a situation where the model is in a state of pure bending. 

C.) Your other option is Fine bonded coarse, which implies that the nodes on the fine mesh 

will be forced to follow the displacement of the coarse mesh.  This would be most 

appropriate in a situation of pure compression. 

D.) I would encourage you to explore the many more details of the smart bonding function 

that is found in the documentation here 

http://help.autodesk.com/view/ASMECH/2015/ENU/?guid=GUID-CDC0ADD8-95E6-

4E95-84D9-AFE71B45D7FE 

After we have turned on the smart contact (I am applying Fine bonded to coarse), we can 

continue with defining some material (I chose Aluminum 6061-T6), some constraints (fixed on 

either side of handle) and loading (40lbf each to a top and bottom surface) and perform the 

simulation.  The model successfully analyzes with this workflow outlined and, with my given 

http://help.autodesk.com/view/ASMECH/2015/ENU/?guid=GUID-CDC0ADD8-95E6-4E95-84D9-AFE71B45D7FE
http://help.autodesk.com/view/ASMECH/2015/ENU/?guid=GUID-CDC0ADD8-95E6-4E95-84D9-AFE71B45D7FE
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loads and constraints, looks like the image below.  You can see the graph behind the image 

where the reaction force in the area of the handle, in the z direction, matches the applied total of 

80lbf; 

 

Bonus Tips and Observations 

I.  As mentioned a couple of times during this exercise, this workflow is specific to 

version 2015 and beyond (or until some new(er) process is implemented), but will not 

function in version 2014 and earlier.  This is a huge advantage with very large 

models.  Envision that you have a 200+ part assembly that takes, perhaps, an hour 

to go through the surface mesh.  If at the end of the surface meshing you were to 

find that (hypothetically) parts 7 and 57 failed to mesh, it would be much faster to just 

see if you can get those two parts meshed (even if that takes a half hour) rather than 

waiting another hour (or more) with iterating on changing to a finer mesh over the 

model as a whole. 

II. We worked around the issue in this particular example to demonstrate the specific 

workflow that we wanted to demonstrate.  The source of the issue with this model 

can be eliminated simply by going in to the mesh settings and turning off the 

imprinting.  Much more detail was explained about imprinting in the 4th example that 

was done earlier.  This too is really working around the issue.  The source of the 

problem is due to the complex contact patch and slightly overlapping features in the 

problem area.  Ideally, I would simplify the geometry in the region, but either work 

around is a viable option. 
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Example 6:  Plastic Cover.dwg – Manual Mesh Repair – Learning Objective 1 – 

Learn how to identify problem CAD geometry. 
 

The following model is a single part model.  More specifically, what we are going to focus on is 

just a single plastic part of a much larger assembly.  The model has been opened prior and we 

know that this particular part has meshing difficulty, so we’ll focus on that part and see if we can 

apply manual mesh repair techniques to fix the surface mesh and ultimately get a proper solid 

mesh on the piece.   

 

 We will take a look at the steps of identifying the issue, knowing the cause, reviewing the issue 

on the geometry, considering our options and then applying the repair.  This model, since we 

know it has difficulty, we will add an initial mesh to, but first change some of the settings so that 

it “fails fast”.  That is to say, since we know that it is going to have difficulty, we can change 

settings so that the program will make one mesh attempt and stop, rather than waiting for the 

program to go through a number of mesh attempts. We can go to the Mesh tab and then press 

3D Mesh Settings.  When the Model Mesh Settings box opens, press the Options… button.  On 

the first screen of options (for the surface mesh), we’ll leave the mesh size at the default of 

100%, but we will change the number of surface mesh retries from the default of 6 to 0. 
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Next, we will go to the Model options in this same Model Mesh Settings options dialogue and 

change the number of solid mesh retries from 6 to 0. 

   

Having made these two mesh options changes, the program will then attempt to mesh the part 

with the specific mesh size that we dictate and will not go through any automatic retries then 

due to either the surface meshing or solid mesh verification.  Press the OK button and then 

press the Mesh Model button to have the model attempt to mesh and you should find that the 

part fails. 

Let’s begin now with our process we are using for our meshing issues. 

Step 1: Identify the issue.   

By pressing the View Mesh Results button shown at the end of the meshing attempt, we can 

see from the next image that the problem is identified as a non-watertight mesh, or – precisely, 

that the “Input surface mesh does not enclose a watertight solid”. 
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Step 2:  Know the cause.   

As discussed in some prior examples, including the focus of example 1, watertight means that 

the mesh on all of the surfaces is complete, the lines of the mesh create valid elements, and the 

mesh properly connects to adjacent surfaces so that the volume is fully enclosed.  If the model 

error indicates that it is not watertight, there are some areas of the mesh where the lines of the 

surface mesh are not comprised of 3 or 4 sided regions, making up valid elements.  Typical 

reasons may include the mesh being too coarse, sliver surfaces, tolerances too loose, 

unmatched or multi-matched edges and interfering geometry. 

You are welcome to use the techniques illustrated in example 1 to review the model and 

observe where the issues arise.  If you click on the surfaces shown in the Problems Summary of 

the Meshing results, you can isolate and investigate those surfaces.  Also, you can display the 

problem part based on layers and you’ll see that there is a problem identified by layer 2, which 

shows in a red color on the model when you are displaying the mesh by layer number. 

Step 3:  Review on geometry.   

As we saw earlier, in example 1, one of the ways to investigate the issue is to click on the 

various surfaces displayed in the Problems Summary of the Meshing results.  This allows us to 

isolate and investigate those surfaces.  If you have already closed the Meshing Results, make 

sure that you are on the Mesh tab and then access View Mesh Results from the mesh panel. If 

we click on one of the problem surfaces, such as Surface 17, you will see the model displayed 

something like the below image and we can get an idea of where in the model where are having 

some issue. 
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This surface is along the exterior of the part, on one of the surfaces I would consider to be the 

side of the part, in the YZ plane on the –X side of the model.  One thing that we might notice is 

the top edge of that surface does not seem to be collinear with the edge from the surface 

adjacent. 

To examine another, we just click the next surface in the list, in this case it is Surface 18 and we 

can see this is a little sliver of a surface that is just above the problem surface that we had just 

looked at prior. 

 

Continuing to investigate the surfaces identified in the list, finally we’ll look at surface number 19 

and we find that is the surface that is just above the prior 2 surfaces that we just had looked at. 
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So, now we have a pretty good idea of where the issue is happening, where these 3 surfaces 

meet.  One of those surfaces (Surface 18) seems pretty small 

We have also, prior, learned that mesh is placed on different layers.  Layer 0 for internal mesh, 

1 is surface mesh, 2 & 6 are problems, 14 are the edges of the model and 15 is mesh that has 

been matched between parts.  With this one, we can observe an additional layer that isn’t 

observed too often and that is layer 3.  Layer 3 is not an issue, it is where the program has split 

a quadrilateral element in to triangles, the split line being placed on layer 3.  Layers 2 and 6 are 

still problems when seen.  We can go to the Draw tab and access the Layer Control option from 

the Design tab and turn off all but Layer 2, which is a problem layer.  That is, uncheck Layer 1, 

Layer 3 and Layer 14 in this case.  It would also maybe be helpful to display the lines by their 

layer number.  From the View tab, access the Color by drop down menu on the Appearance 

panel and change to Layer.  The model will now look like the image below, with the problematic 

mesh showing in a red color. 
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Note that the this review of the layer numbers also indicates that there is an issue in this area of 

the model, which is also what was indicated when we reviewed the various identified surfaces 

from the meshing results. 

Step 4:  Consider the options.   

As prior mentioned, if the non-watertight problem happens at the interface of 2 parts, I might 

consider looking for interference (could also be a tolerance issue or a mesh matching issue).  It 

certainly does not happen at the interface of 2 parts, given the single part, so these are ruled out 

as possible considerations.  If the issue happened on a complex surface, I might consider 

whether I could simplify it.  In this case, having briefly explored those surfaces from the meshing 

results, it isn’t necessarily what we might envision as a complex surface,  but then, the mesh in 

that area (particularly around surface 18) isn’t as simple and straight forward as we might 

expect either, so that is something to consider there.  Is it possibly due to unmatched or multi-

matched edges?  We didn’t get any indication of that from the mesh results, but we have 

illustrated in earlier examples (example 2 and example 3) how to double check.  If we go to the 

menu tree on the left hand side, we can right mouse click on CAD Mesh Options (found under 

the Material heading for the part) and choose Feature Matching.  A quick check of this shows 

we have 0 of either unmatched or multi-matched edges, as shown in the image below.   

 

These are typical considerations and questions you’d want to ask yourself about the geometry.  

Since the part is not meshed too coarsely, and we can rule out multi-matched or unmatched 

edges contributing to the problem, and we know it is a somewhat complex surface (or so the 

mesh seems to indicate) and the issue comes up at the interface of those particular surfaces, it 

might be good to look there to decide what we are going to do with it.  If the we study those 

surfaces and decide that the geometry is (perhaps unexpectedly) more difficult in that area, one 

option is certainly to go back to the CAD program and see if we can simplify it.  If the problem 

mesh is not too complicated, perhaps we can use the tools provided in the software to move 

nodes, delete and add lines as necessary.   
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What I would propose we do with this one (and what ultimately will be the fix) would be to take 

advantage of the functionality that is available within Autodesk Simulation Mechanical for us to 

repair the surfaces.      

Example 6 (continued):  Plastic Cover.dwg – Fixing the mesh issue – Learning 

Objective 2 – Learn how to fix modeling issues 
 

Step 5:  Attempt the remedy or repair. 

  I will undo all the settings that we did within step 3 so that we can get the model back to the 

default rendered state.  We can go to the Draw tab and access Layer Control from the Design 

panel and turn back on (check) layers 1, 3 and 14 back on.  From the View tab, go to Color by 

on the Appearance panel and set the color by option back to Part (vs. the current of Layer) and 

the model should now appear as it did once our initial meshing attempt was done. 

 

What we want to do is to just first take a good look at the area where the issue occurs and then 

decide our approach.  If we go over the menu tree and expand the list of surfaces that comprise 

the model, by clicking the plus symbol to the left of the Surfaces heading, we can then single left 

click on surfaces 17, 18 and 19 again to have them highlight on the model.  When we do this for 

Surface 18, it looks like the image below.  
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This little sliver of a surface, I think we can get rid of it.  Ignoring a surface within the geometry 

when we mesh the model would frequently leave a gap in the volume (resulting in non-

watertight geometry), however, we know that we are going to be repairing the mesh anyway, so, 

what we can do is right mouse button click on Surface 18<Unnamed> in the menu tree, then go 

to CAD Mesh Options and, then, choose Suppress for Meshing. 

  

With that surface suppressed, we will go ahead and execute the mesh again without changing 

any of the parameters that we had set before.  So, we want to mesh the model still at 100% and 

we’ll leave the retries set to 0 still, so that it fails fast when it fails, but – what we should end up 

with, is now a surface mesh that is un-influenced by that sliver surface.  So, we’ll go to the Mesh 

tab and just click on Generate 3D Mesh from the Mesh panel. 
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Having re-executed the mesh and taking a quick look at our meshing results, we can see that 

we still have issues with surfaces 17 and 19. 

 

It helps to have excluded surface 18, that gives us one less surface to have to worry about and 

a little less mesh that we have to clean up, but we do need to repair surfaces 17 and 19 yet prior 

to us solid meshing the model.  In order to facilitate the mesh repair, we’ll select those two 

surfaces, along with a neighbor surface or two and (to help define our boundaries) and display 

only those surfaces.  You can go to the Selection tab and then ensure that you are set to 

Surfaces on the Select panel so that the program knows what to select (a surface vs. the entire 

part or lines…) and then select one of the surfaces on the part, hold the control key down on 

your keyboard and select some neighbors, or, we can select them in the menu tree, which I will 

do.  So, I will go over to the menu tree and single left click on Surface 17, hold the control key 

down and single left click also on Surface 8 and Surface 19.  Once you have them selected, 

single right mouse button click on one of the selected surfaces and choose the option Isolate. 

 



Advanced Meshing Techniques in Simulation Mechanical 

58 
 

 

Having isolated these 3 surfaces, all other surfaces should now be hidden.  To help with the 

work we are about to do, it would be better to view the model also in a wireframe, instead of 

shaded, model  We can go to View tab and the Visual Style pull down and change from Shaded 

with Mesh to Mesh.  Click off to the side of the model to de-select all the lines and then rotate 

the model and zoom in so that you can see the intersection of surfaces 17 and 19.  The model 

should now look as follows. 

 

We are going to begin fixing this interface by moving 3 nodes.  The method is that we go to the 

Selection tab, make sure that you are on the option Point or Rectangle in the Shape panel and 

that you are on the option of Vertices on the Select panel.  We will select a node we want to 

move, right mouse click and choose the Move command, referencing the image below. 
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Once the Point Move command window comes up, first click on the node you want to move 

(your cursor should show a lock symbol indicating it can “lock on” to that node) and then 

secondly, click on the node you want to move it to.  This sets the direction and distance for 

moving the node you had selected. 

 

You will get a pop-up dialogue that indicates, in essence, that you are making manual changes 

to what was an automatically generated mesh.  It is telling us that we (ultimately) will need to 

manually execute the solid mesh.  That is ok, press the Yes button on this window. 
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The mesh should now look as follows in the interface between those two surfaces. 

 

We will now repeat that process 2 additional times to get all of the nodes along that edge to line 

up.  Select the next “peak” node to the right of where we just fixed and then right mouse click 

again and choose Move and then move it to the next node to the right, as shown in the below 

image. 
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After having moved that node, the model now looks like the following image. 

 

Lastly for the moving of nodes, we’ll take that node that is sticking up a bit to the right of where 

we just fixed and move that to the left, joining it with the nodes that we had just snapped 

together. 
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Finally, after that has been done, our edge should be nice and straight, with the nodes aligned 

between the two surfaces as shown in the image below; 

 

Now, I think that edge looks pretty good, but – in moving those nodes, we were also changing 

the shape of elements that they were connected to and we can see an element (circled in the 

image below) that has a pretty large internal angle. 
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Since that is a 4 sided element, we could add a line across the diagonal to split it in to two 

smaller triangular elements.  When we add that line, we’ll need to specify the part number, 

surface number and layer number of the line we are adding.  We know we want to add it to part 

number 1 since that is the number of our part.  The layer number, well, the vast majority of 

surface mesh is layer 1 so we could use that as well.  Technically, avoiding the special layers 

(0, 2, 3, 6, 14 & 15) we could add the line on some other layer (like layer 100) just in case we 

need to readily find the lines that we added on our own at some point later, but I’ll put it on layer 

1 to match the rest of the surface mesh.  We want to match the surface number of the lines 

around it, in case we want to apply a pressure or constraint (for example) to that surface of the 

model later, we would also want our yet to be added line to be included.  So, let’s select one of 

the lines around this element and then you can right mouse click and choose Inquire.  On the 

Selection tab, make sure you are selecting Lines (vs. surfaces or vertices), left click on a line 

and then right mouse click to inquire it. 
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The Inquire command tells us the properties of the selected line, which in this case equals Part 

1, Surface 17, Layer 1.  So now we know what properties to set the line to when we draw a new 

line across the diagonal of the element. 

 

To draw the line, go to Draw tab and access the Line command from Draw panel.  When the 

Define Geometry window opens, set the Part to 1, the Surface to 17 and Layer to 1.  If it is 

checked, also uncheck the box next to Use as Construction. 

 

Now, we just move over to the node where we want to start our line.  The cursor will show a lock 

symbol, left click on the node where you want to start the line, then move to the node where you 

want to end the line and left click again. 
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You can then hit the Esc key on your keyboard once to stop the line from “rubber-banding” and 

then hit Esc again to close the Define Geometry window.  Single left clicking off to the side of 

the model to deselect all lines, our repaired mesh now looks as follows; 

 

Finally, if you recall – a while back in our workflow (when we went to move that first node) we 

were presented with a message that indicated (basically) that we had interfered with the mesh 

given to us by the surface mesh generation process.  That is ok, but, in order for it to solid 

mesh, we need to execute the solid mesh process manually.  First, before we do that, I’ll re-

display all the surfaces on the model.  If we right mouse click on the Surfaces heading in the 

menu tree, we can toggle the visibility of the surfaces off and then all on by clicking Visibility of 

All Surfaces twice.  Next, I will turn the model shading back on (just personal viewing 

preference) via View->Visual Style->Shaded with Mesh.  Next, we’ll kick off the solid mesh 

process (manually) by going to Part 1 in the menu tree, right mouse clicking on it and choosing 

CAD Mesh Options and then Create Solid Mesh… 
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When the Part Mesh dialogue opens, just press the OK button to start the solid meshing. 

 

Presuming we did a good job with our mesh repair, the solid mesh should complete without 

error and we can then proceed to constrain the model and add loading to it.  My final analyzed 

model looks like the image below. 
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Bonus Tips and Observations 

 

I.  What we just did in this example, to some extent, was create our own surface mesh 

that was ultimately accepted by the program as its foundation for a solid mesh.  You 

are more than welcome to (and I would encourage you to keep it in mind as a 

technique) interact with the mesh by adding or deleting lines, moving nodes, 

intersecting lines and so on.  One major thing to keep in mind when doing so is to 

preserve the valid definition of the element.  For surface mesh, all elements must be 

3 sided or 4 sided regions (no two lines collinear) that enclose an area.  So long as 

you follow that guide as you modify the mesh, you should be ok. 

II. As noted during the exercise, when you do start with a cad model, use an 

automatically generated surface mesh and then intervening by modifying that surface 

mesh, you must manually create that solid mesh by selecting the part, right mouse 

clicking and choosing cad mesh options and then create solid mesh.  You must do 

that for all of the cad solid parts, even if you just modified the mesh of, say 1 out of 5 

cad originated parts in an assembly. 

III. When the model originates as a cad model, your manual changes (successfully 

done) can help the model with a successful analysis.  Note however that if you 

choose to go back and perform a new or different automatically generated surface 

mesh, the program takes no special steps to preserve or incorporate the mesh that 

you had manually repaired.  Considering this, you may want to (a.) make the manual 

repairs only after you are certain you have the rest of the surface mesh where you 

want it to be or (b.) return to the cad package to repair the surfaces if you anticipate 

that you may go through many surface mesh iterations. 


