60 Inventor Tips in 60 Minutes
Timothy Harrison
i GET IT - Tata Technologies

Learning Objectives
- Discover 60 tips in Inventor
- Learn where these items are in the Inventor environment
- Learn about how these tips might help your daily activities
- Have fun

Description
- Whether new to Inventor software or a seasoned pro, you'll learn something from this fast-paced course that will highlight 60 Inventor tips in 60 minutes.
- We'll showcase some of the less obvious commands or features and their location within the Inventor environment.
- Along the way, we'll look at how some of the tips work and how they might help you in your daily designing. So, buckle up—we've got a lot to cover and only 60 minutes to get it done.

Speaker
Based in Novi, Michigan, Timothy Harrison works as the content manager and technical consultant for i GET IT Online Training For Engineers from Tata Technologies. Focusing on online e-training for engineers using Autodesk, Inc., software, Timothy has created numerous online training courses for i GET IT in both text and video format. Courses he has created include the programs Inventor software, AutoCAD software, Revit software, Inventor Fusion software, and Fusion 360 software. Prior to working for Tata Technologies, Timothy worked in manufacturing as a designer and engineer in the tooling and special-machine field for 15 years. Most of that time was in automotive manufacturing and assembly using Inventor software.
Sketching

#1 Sketch Zero Origin
- If not on by default, turn on under Applications Options
  Autoproject part origin on sketch create

#2 Click Hold Arc / Slot
- Start Line command
- Draw line segment
- Click and Hold on the end of the line segment
- Use Point Alignment to create fully constrained slot sketch
#3 Click Hold Tangent Constraint
- Start Line command
- Click and Hold on arc or circle
- Drag line out, **Tangent** constraint inferred

#4 Scrub Geometry for Inferred Constraint
- Inferred Constraint not currently the correct one desired
- “Scrub” cursor over geometry you want constraint referenced to
- New inferred constraint now shown
#5 Temporarily Disable Inferred Constraint
- Hold Ctrl while sketch command is active

#6 Close Sketch
- While Line command is active Right-click
- Select Close from the Marking Menu Overflow Menu
- Closed profile created

#7 Restart, Line Command
- While Line command is active Right-click
- Select Restart from the Marking Menu Overflow Menu
- Line command restarts without ending and restarting the command.
#8 Inferred Trim
- **Trim** command infers trim section based on the sketch geometry even if the segments don’t intersect

**TIP:** Hold **Ctrl** to specify the trim segment

#9 Shift Trim/Extend
- Start either the **Trim** or **Extend** command
- Hold **Shift** on the key on the keyboard
- The opposite command is used when **Shift** key is held
- No need to exit the command

#10 Offset Work Plane on Sketch Creation
- Start 2D Sketch tool
- Select and hold on a face or existing plan
- Drag away from face or existing plane required distance or enter a view
#11 Auto Dimension
- Sketch tab > Constrain panel > Automatic Dimensions & Constraints
- Recommended – Place locating dimensions first
- Select Curves to dimension
- No select will apply to entire sketch

#12 Driven Dimension
- Right-click dimensional constraint
- Select Driven Dimension from Marking Menu
- Dimension does not control sketch
  Can be referenced by other dimensions or Parameters
System & Settings

#13 Configure Default Templates

- **Inventor Home** screen > **New** > **Advanced** > **Configure Default Templates** (gear icon)

Set Measurement Units & Drawing Standards

**NOTE:** Just for Default Templates – Does Not Effect or templates

#14 Mini-Toolbars OFF by Default (2018)

- **View** tab > **Windows** panel > **Mini-Toolbar**
- Check to turn them on
#15 Search Browser (2018)

- Click Magnifying Glass icon on Browser
- Enter text for search. Name or iProperties

#16 Old Versions

- Open file from the OldVersions fold
- Options to Open old version (Save not allowed), Restore old version to current version, or Open Current Version

**NOTE:** If file is copied out of the OldVersions folder, file is treated as its own file
#17 Old Versions Save Option
- Control the number of **Old Versions** saved in the project file
- **Options > Old Version To Keep On Save**
  - Default = 1
  - -1 = All Old Versions Saved

#18 Select Other
- Hover over part or assembly
- Item selection from dropdown list
- OR
- Right click on part or assembly
  - **Select Other** from **Marking Menu**
#19 Select Other – Timing

- Tools tab > Option panel > Application Options
- General tab > Selection
- “Select Other” delay (sec)

**TIP:** Enter value OFF
To turn off Select Other function
Viewing

#20 Ambient Shadows Always On
- Open the Application Options Tool > Options > Application Option
- On the Application Options dialog box on the Display tab:
  Select Use application settings
  Then click the Settings... button
- On the Display Appearance dialog box check the box for Ambient Shadows. Then click OK.

#21 Ortho/Perspective View from View Cube
- Right-Click on View Cube
  Orthographic / Perspective / Perspective with Ortho Faces
- Also available from the Navigation Bar More Options drop down list / Projection
#22 View Cube Predefined View Indicator

- **Predefined Views**
  View Cube has solid edge lines

- **Not Predefined View**
  View Cube has dashed edge lines

#23 Reorient Lighting

- Orient model view to look at desired “Front” of model
- Right-Click View Cube > Set Current View As > Front
#24 Appearance Override Indicator

- Asterisk * next to Appearance name in Appearance dropdown list indicates the this appearance color is Overriding the Material Appearance

#25 Appearance Override Not In Library Indicator

- In the Appearance Browser, appearance names that are shown in Italic text indicates that the Appearance does not exist in the current project appearance libraries.

NOTE:
Similar Indicator in the Material Browser
#26 Add Appearance To Library
- Right-click appearance in the Appearance Browser
- Click Add to in the short cut menu
- Select required Library

NOTE:
Library must be a part of the current project

#27 Remove All Appearance Overrides
- Right-click on View Representation in Browser
- Select Remove Appearance Overrides from the shortcut menu
- Works on both Parts and Assemblies
#28 Continuous Obbit

- Start the **Obbit** command
- Hold down **Shift** on the keyboard
- Which the mouse click and drag the obit and then release.
- The speed in which you click, drag, release controls how fast the continuous obit spins

#29 Zoom / Adjust Perspective View

- Start the **Zoom** command (with Perspective View active)
- Hold down **Shift** and **Ctrl** on the keyboard
- Zoom with the mouse  
  Perspective view is zoomed / adjusted
#30 Clean Screen

- Ctrl + 0 (zero), Toggle on & off
- Ribbon Bar, Browser, View Cube & Navigation Bar hidden
- View Cube & Navigation Panel still available
- Clean Screen also available from ribbon View tab > Windows panel > Clean Screen
Modeling

#31 Sweep Using Edge
- Sweeps need a **Profile** and a **Path**
- Single Profile sketch
- Use existing edge for the Path instead of a second sketch
- 3D Sketch is created for the sweep path

#32 In-Line Work Features
- Start main required **Work Feature** (i.e. **Work Plane**)
- Right-click **Graphics Window**, Select in-line work feature from Marking Menu
- Select geometry for in-line work feature > then select geometry for main work feature > then select **OK**
- In-line work feature is shown nested under the main work feature in the **Browser**
#33 Sheetmetal – Multi Thickness (2018)

- Create new Flange Feature
- Select **New Solid** from dialog box
- Uncheck **Follow Defaults**, select a different **Sheet Metal Rule** from the dropdown list
- After creation: Right-click on **Solid Body** in the **Browser**, select **Set Sheet Metal Rule** from the short cut menu

#34 One Dimension Hole Location

- Start sketch on desired face
- Start the **Offset** command
- Select projected edge profile – Enter in value for offset
- Place hole locations on sketch. Offset will update with model changes
#35 Slice Graphics
- Sketches in the middle of a part or assembly
- F7
- Menu Bar

#36 Extrude Interfering Sketch Profiles
- Two closed sketch profiles
  Extrude will want to extrude the profiles, not the interference area
- Edit Sketch, add a sketch Point at each intersecting line segments
- Extrude the interference area
#37 Extend Start (2018)
- Material above **Hole** start location
- Check on **Extend Start** option on **Hole** dialog box
- Material removed up to open space

#38 0 Value Spotface (2018)
- Create **Spotface** type hole
- Enter 0 (zero) value for **Spotface** depth
- Check on **Extend Start** option on **Hole** dialog box
- Material removed up to open space
#39 Extrude Distance From Face (2018)
- **Extrude** dialog > **Extents** > **Distance From Face**
- Select existing face or work plane

- If profile extents beyond existing face select **Extend Faces**

---

#40 Extrude More Option (2018)
- **Extrude** dialog > **More** tab
- **Alternate Solution** / **Minimum Solution**
#41 Delete Face – Heal

- **3D Model** tab > Create panel > Delete Face
- Select face in area to delete, check on Heal option
- Recommended for imported components where features cannot be edited

#42 Direct Edit

- **3D Model** tab > Create panel > Direct Edit
- Select faces or solids to edit
- Move, Size, Scale, Rotate, or Delete
  
  **All Edits are recorded Parametrically**
Assembly

#43 Assembly Zero Origin
- Constrain (when possible) assembly components to the origin planes of the assembly
- Allows for easier location of constrains
- Less chance for errors when modifying components

#44 Drag & Drop Duplicate Component
- Click and Drag existing component from the Browser into the Graphics Window
- New instance of component placed in assembly
#45 Place Multiple Components At Once
- Ctrl select the components required
- Click Open
- Place the components in the assembly

#46 Free Rotate Multiple Components
- Ctrl select the components required in the Graphics Window
- Assemble tab > Position panel > Free Rotate
- Rotate components
#47 Alt-Drag Constraint
- Hold down Alt key on keyboard
- Click and Hold on a component in the Graphics Window near where constraint should be placed
- Drag to where component should be constrained in assembly
- Constraint is created

**NOTE:** When there are options for constraint placement press the Spacebar to cycle thru options

#48 Pattern Component – Feature Pattern
- **Assemble** tab > **Pattern** panel > **Pattern**
- Select component to pattern
- **Feature Pattern Select**
  Select an existing feature pattern

Component Pattern is updated if the feature pattern is changed
#49 Save & Replace Component

- **Assemble** tab > **Productivity** panel > **Save and Replace Component**
- Select component to replace
- Save new component
- New component replaces existing component with all constraints and features intact
Drawings

#50 Create New Empty Drawing

- Hold down the Ctrl + Shift keys while selecting New on the Application Menu

- Select Drawing on the New dialog box

- Click OK

#51 Copy Drawing Resources Between Drawings

- Right Click the Drawing Resources folder in Browser
- Then select Copy from the Right-Click short cut menu
- In new drawing, Right-Click on the Drawing Resources folding in the browser and select Paste.
- If there are any resources in the new drawing that are named the same as the items you are copying in you are prompted to either Replace the existing resource, or create it as a New resource.
#52 Change Drawing Sheet Background Color

- The sheet background color is stored in the **individual documents** and is accessed in the **Document Settings**
- On the **Document Settings** dialog back, on the **Sheet** tab, under **Colors** select the color button for **Sheet**
- On the **Color** dialog box select the desired background color or define a custom color.

**Note:** Layers with a color set to Black will display as White on a black background, and layers with a color set to White will display as Black on a white background.

#53 Reset Default Drawing Sheet Background Color

- The sheet background color is stored in the **individual documents** and is accessed in the **Document Settings**
- On the **Document Settings** dialog back, on the **Sheet** tab, under **Colors** select the color button for **Sheet**
- On the **Color** dialog box, set the following **RGB** values under **Define Custom Colors >>**
  - Red: 237  Green: 237  Blue: 214
- Select **Add to Custom Colors**
- Select the new color from the **Custom colors** pallet
- Click **OK**
#54 Automated Centerlines

- Right-Clicking on any existing drawing view, **Automated Centerlines**...
- **Automated Centerlines** dialog box allows you to select the features and pattern types on which Automated Centerlines will be applied to the drawing views. Also, the view projection type can be selected.
- **Tip:** Holding Ctrl or Shift will allow you to select multiple drawing views there by allowing you to apply **Automated Centerlines** to all the selected views.

#55 Linear Diameter in Detail View

- Right-Clicking on detail view, Select **Automated Centerlines**... , Place Centerline
- Start **Dimension** command, select Centerline and edge line
- Right-click, selection **Dimension Type** > **Linear Diameter**
- Place dimension
#56 Intersection Dimension

- Start the Dimension Tool
- Select first and second line, then right-click, select Intersection from shortcut menu
- Select first line again and then third line, then right-click, select Intersection from shortcut menu
- Select second line again
- Place dimension

#57 Break Section View Alignment on Creation

- While creating a Section view
- Hold down Ctrl to break the alignment on creation
#58 Detail View Attachment
- Right-Click on Detail View arrow
- Select Attach from shortcut menu
- Select geometry in the drawing view to attach
- Detail view will move with geometry if change is made
- Right-click Detail View arrow
- Select Detach from shortcut menu to remove attachment

#59 Display Center of Gravity in Drawing View
- Expand drawing view, Right-Click on model in Browser
- Click Center of Gravity from Shortcut Menu
- Center Mark is displayed in the drawing view
#60 Text Boarder (2018)

- **Annotate** tab > **Text** panel > **Text**  OR  **Leader Text**
- **Format Text** dialog box
- **Boarder Option** dropdown list
- Detail view will move with geometry if change is made

**NOTE:** Text box grips can resize the boarder

NO controls for size  i.e. No Dimensional Constraints
If specific boarder size is required then a sketch symbol should be used
Additional Information

REALIZING DESIGN POTENTIAL

IGET IT

Sign up for a free account.

www.myigetit.com