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Learning Objectives
•
•
•
•

Work much more quickly during early design stages
Create early design drawings quickly using Revit
Use the best tool for the job in early design stages
Help your team not become limited by their tools of choice

Description
This class will cover the interoperability workflows that enable teams to use tools appropriate to
each phase of design and each team member’s expertise and skill sets, enabling their imagination
to be the limit of their designs rather than the required toolsets. We will cover 2 different methods
for importing geometry into Revit as native content to produce drawings. With the first method
attendees will learn how to use FormIt 360 software to translate SketchUp models into native
Revit content. In the second, attendees will be provided with and instructed on how to apply a
premade, easy-to-use Dynamo script that will enable importing Rhino-generated geometry into
Revit native content. The techniques in this class have been developed and tested on a range of
project scales, from large transit projects to residential high-rises to small tenant improvement
projects with overwhelming success and quantifiable increases in team productivity and
efficiency. This session features Revit Architecture, Dynamo Studio, and FormIt 360.
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Meet Your AU Expert
Luc Deckinga is a Digital Practice Manager for Perkins+Will, leading the firm’s computational
design efforts from their San Francisco office. He is an architect by training and a programmer
by practice, using his skills in the intersection of these areas to develop workflows that enable
more sophisticated design processes and fabrication methods. When not torturing his brain trying
to solve whatever puzzle is too enticing to leave alone he can be found torturing the rest of himself
rock climbing and biking. He earned a BFA in Design from the University of Texas in his hometown
of Austin and his M.Arch from Columbia University before moving to the Bay Area, from which he
may never leave unless he wants to live somewhere that he can afford to buy a house.
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Download Class Files:
https://perkinswill.box.com/v/AU2016-AR21124 or http://bit.ly/2dYgyUZ

Introduction: Understanding Why We Need To Import Anything In The First
Place…
Why do we need to import anything? Revit is
great at documentation coordination and
management, but truthfully, it is not so great at
quick and agile design iteration. We all know
that we need both in order to deliver a project,
which is ok. It is important to remember that
there is a tool for every task. Not every tool can
do every task. Revit is good for some things;
other tools are good for other things. We should
be using all the tools available to us. Just as you
would never use a hammer to screw in a screw
or a screw driver to pound in a nail, so too it is
important to use the right tools in design.

Native Revit Geometry
Imported Geometry

Ideally, every design platform would talk to every
other, but unfortunately this is not always the
case. One of the largest hurdles with bringing
geometry into Revit form another design software
is that we forget the “I” in BIM. We have the
Building Modeling part of the process down pretty
well, but we neglect the Information that makes
BIM so powerful. In this process one of the keys
to getting geometry into Revit in a way that
creates native content is to add a little bit of data
to each piece of geometry.
In this class we will cover three ways of bringing
geometry into Revit from two different design platforms so that the design can be documented.
First we will look at bringing SketchUp geometry into Revit through IFC, then we will look at
bringing SketchUp geometry into Revit through FormIt, and finally, we will bring Rhino geometry
into Revit using Dynamo.
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Bringing SketchUp Geometry Into Revit Through IFC
Exporting SketchUp to IFC
Setting IFC Categories for SketchUp Components
SketchUp has had a little well-kept secret built into it since 2014. In the “Type” settings of the
Component dialog boxes, you can set an IFC category for each component.

1
2
For additional information on this process
refer to:
•

https://help.sketchup.com/en/article/3000128

•

http://plusspec.com/2015/11/13/sketchup-torevit/

•

http://whatrevitwants.blogspot.com/2014/03/sk
etchup-2014-now-with-ifc-export.html

Exporting IFC from SketchUp
Once you have set the category for any geometry you want to bring into Revit and are ready to
export the model, simply go up to File > Export > 3D Model and select “IFC File (*.ifc)” from the
Export Type drop down. Keep in mind that this requires SketchUp Pro in order to have the 3D
Model export option available.

3

4
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Bringing IFC Into Revit
Importing IFC
Once your IFC file has been exported, either open your existing Revit model or start a new Revit
model. Navigate to the Insert Tab > Link IFC, or go to the big 'R' in the top left corner > Open >
IFC, and open or insert the IFC file you exported for SketchUp.

5

Managing IFC Content In Revit
Once you have imported the IFC file from SketchUp into
your Revit model, it will show up in the links manager as
an IFC file, in your Visibility/Graphics as a linked Revit
model with all the over-ride capabilities of a linked Revit
model, and you will be able to control the visibility of
each IFC category together with the same category of
your Revit file.
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Bringing SketchUp Geometry Into Revit Through FormIt
Importing SketchUp Into FormIt
Importing SketchUp Files
SketchUp files can be imported into FormIt through File > Import > Import 3D Model (Ctrl
+ I), select the SketchUp file format and navigate to your model.

1

Setting Categories For Groups
FormIt will import all the geometry,
textures, views, etc. from your
SketchUp model. Similar to setting the
Type for a SketchUp Component,
FormIt allows you to set the Category
for
Groups.
These
Categories
correspond to some of the Revit
categories. Currently there are only a
limited number of loadable family
categories supported, but keep in mind
that if you have imported your
geometry as a Generic Model
Category, you can change it to most
other loadable family categories later
from within Revit.

2

Finally, save your FormIt file.

Import FormIt to Revit
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Convert FormIt to Revit
In Revit, navigate to the Manage tab and use the “Convert RFA to FormIt 360” in the
FormIt 360 Converter section.

Make sure you have the FormIt RFA converter
for your version of Revit installed:
•

http://formit360.autodesk.com/page/download

Managing Imported FormIt Content In Revit
Geometry imported in this method will be treated identically to all other geometry of the
family category you set for the imported group. This means that the geometry will be no
different than if you had created it directly in Revit with one exception; imported content
cannot be edited in Revit.
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Importing Rhino Geometry Into Revit Using Dynamo
Exporting Geometry From Rhino
Exporting SAT
Once your geometry has been cleaned up and there are only closed polysurfaces left (i.e.
valid solids), it is time to export the geometry to .SAT format. But before we do, keep in
mind that simpler geometry is better so don’t Boolean union all your geometry together.
Instead keep them as separate, simple solids. We can join them later.
To export your geometry to .SAT, go to File > Export, and select “ACIS (*.sat)”. Just use
the Default profile when the .SAT Export Options window pops up.
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Processing SAT Geometry In Dynamo
How this Works: FreeForm Objects in Revit
There are many hints throughout the Revit interface that Revit really likes something it calls
“Form”. So logically, we want to give Revit “forms”, but how do we do that?...

Spring Nodes in Dynamo
The Spring Nodes Package in Dynamo allows us to create Freeform
geometry both inside a family and inside a project by using the
Form.ByGeometry and FamilyInstance.ByGeometry nodes.
You can get the Spring Nodes Package through the Dynamo Package
Manager. Simply go to Packages > Search for Packages, and search for
“Spring Nodes”. Download the latest version of the package.

Special Thanks
None of this would be
possible without the
tireless effort, patience
and lightning-speedresponsivness of
Dimitar Venkov

http://badmonkeys.net/
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The Script…
Before we dive into the script, keep in mind that this is a
basic, simple to use version of this workflow. This is by no
means the only version of this workflow. There is basic
instruction at the beginning of the script which should give
you everything you need to use this workflow
successfully. There is also support and version
information included.

Importing An SAT File Into Dynamo
The first three nodes of the script simply allow you to
import the SAT file you exported earlier, and to read the
geometry in that file in Dynamo.

1

Scaling Adjustments
The next portion of the script is two nodes that fix an issue with how Dynamo reads SAT files. At
some point this will go away.

2
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Creating A Unique Name For Each Solid
Next, once every solid in the SAT file has been processed, we need to create unique names for
each one. At this point, you can add your own prefix which will be used to name all the families in
the next step.

3

Adding Everything Together
Once we have each solid and a name for each solid, we can begin to add everything together.
There are four pieces of data that need to be added to every piece of geometry to create native
content in Revit using the Springs.FamilyInstance.ByGeometry node:
•
•

•
•
•

Add the solids to the “geometry”
input
Add the file path to a family
template for the version of Revit
you
are
using
to
the
“familyTemplatePath” input. Most
of the time a Generic Model.rft will
work just fine. You can find the
location of this file when you create
a new family in Revit or at:

4

5

C:\ProgramData\Autodesk\[version of revit]\Family Templates\English_I\Generic Model.rft
Add the names we created in the earlier step to the “familyName” input.
Add a Category from a Categories node to the “category” input. This will determine the
category of your new Revit families. Note that only loadable family types currently work
and there is a correlation to the Family Template file you used in input #2.
Finally, add a material to the “materialName” input. Note that the material used here must
be already in the Family Template file you use. Generally, “Default Form” is the best
choice. You can change the material later through category and visibility settings.
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Putting It All Into Revit
Once you have added all this information, the Springs.FamilyInstance.ByGeometry node will
begin to execute and you should see a sporadic spinning, or some other indication that something
is being processed, along with a sporadic progress bar at the bottom of the Revit screen. This
indicates that the python script inside the node is running once for every solid in the SAT file, then
creating a new family using the name and information given, and finally placing it in the correct
spot in your project.
Generally, we like to keep our FamilyInstance.ByGeometry node frozen or the script in manual
mode until we are ready to run this script. Otherwise, you might run into some issues with previous
families being over-written or families not being properly created. Also, if you are using the same
names as you did in a previous run, it may be useful to delete these families from the project
browser before we run the script.
IMPORTANT:
Once you have “baked” the geometry in by running the script, you'll need to close the dynamo
window. This is very important, as dynamo has no “bake” function, so the geometry will not stay
in your Revit project unless you do this.
Finally, after the geometry is in your project, you should be able to see the “Edit Family” button
under the “Modify” tab on the ribbon. If you open any of the families you just created, you should
see the blue arrows on selected geometry within the family environment. This indicates that the
geometry is “native Revit content,” also known as a FreeForm element. Depending on how simple
your geometry is you might be able to modify some of the forms you created using this method,
but it is not a guarantee and generally just functions well enough to make most people who will
dig into your Revit file think you are an amazing Revit master.
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Cleaning Up Your SketchUp Geometry
Keeping a clean and robust model is an important step in any interoperability workflow. It not only
allows you to get your model from one program into another more easily, but the effort also starts
to pay off when you want to 3D print a physical model, render an image or even perform clash
detections.

Download the Sketchup Cleanup
Extensions here:
•

Solid Inspector2
https://extensions.sketchup.com/e
n/content/solid-inspector%C2%B2

•

Edge Tools2
https://extensions.sketchup.com/en/co
ntent/edge-tools%C2%B2

•

CleanUp3
https://extensions.sketchup.com/e
n/content/cleanup%C2%B3
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Checking FormIt Geometry

In all of these workflows it is important to check your geometry. SketchUp has built-in features to
show you flipped faces (back faces) and geometry that is not solid (watertight issues). Simply
navigate to the Setting Icon (Gear) > Visual Styles > Diagnostics. This will show you edges that
need to be closed to make solids, and faces that need to be flipped in order to make valid
solids.
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Checking Geometry In Rhino
Rhino’s geometry checking capabilities exceed those of both SketchUp and FormIt, both in terms
of visualization and well as fixing. This makes it my favorite option for bringing design geometry
into Revit.
You can select any polysurface and check the properties tab and it will show you whether or not
it is a closed or open polysurface.
The command “Show edges” will allow you to see all the issues that make geometry not a valid
solid.
You can use the command “SelClosedPolysrf” to grab everything that is already a valid solid and
then either hide, lock or move this geometry to another layer.
You can conversely, use the “SelOpenPolysrf” to grab everything that needs to be fixed and get
a quick count of how much needs fixing.
Keep in mind that it is well worth your time to both maintain good geometry for the purposes of
exporting to other programs such as Revit, Inventor, Fusion, FormIt, etc., but it will also allow you
to quickly make physical models using 3D printing.
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Revit 2017.1 SAT and Rhino Importer
With the release of Revit 2017.1, Revit now has the ability to import Rhino and SAT files and apply
a category to the file without using Dynamo. We discovered that this feature did not completely
replace the Dynamo workflow for the reasons listed in the table below. Instead, the two options
work well together as each one covers some aspects that are weak points in the other.

Dynamo vs 2017.1 CAD Import

A Few Tips For Success…
•
•
•
•
•

Try this out before you needed it. Give yourself some extra time the first time. Don’t wait
until an hour before you need to submit a drawing set to try this.
Troubleshoot the script with a Cuboid / Box in Dynamo.
Break your geometry up into simpler parts. Revit will like it better.
Add more control points if the surface is inaccurate.
Any time you are starting with an existing Revit model and want to import something, start
by first exporting a portion of your Revit model to the software you are designing the
geometry to be imported from.
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Does It Really Work?...
Real Benefits to Real Projects And Teams…
File Health And Project Benefits
•
•
•
•
•

Complex forms tend to be lighter when imported, due to absence of construction geometry
in family file.
Allows team members who do not know advanced modeling in Revit to contribute to some
of the most complex parts of the model.
Allows rapid design iteration to be added to the drawing set before it is fully modeled.
Reduces remodeling required in early design phases to produce a drawing set.
Allows for fabrication-level models to be imported back into Revit.

Real Examples From Real Projects
•
•
•
•
•

What previously took a team of 4, 3-5 days to do, can be done by 1 person in 1-3 hours.
20% of a 2.8 M sq ft. project imported by end of DD phase.
Revit model 50% imported during SD phase, 20-30% during DD phase.
Small infrastructure project, 98% imported in 8-10 hours. No Revit model at 50% SD, full
Revit model at 100% SD 2 weeks later.
SD Revit model driven entirely by Grasshopper…
CD project with custom fabricated parts imported, after fabrication analysis.

Final Words Of Advice and Support….
Keep in mind that these workflows are experimental, so give yourself and your team extra time
when implementing them, and always have a plan B, especially when attempting any of these for
the first time.
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