ES17657-L: Integrating Structural Design, Analysis, and Detailing: Advance Steel and Robot

Aaron Vorwerk, AIA, EIT, LEED AP BD+C
Sr. Technical Sales Specialist, AEC, Autodesk
@AaronVorwerk

Stephen Bessette
Technical Sales Support, MEP & Fabrication, Autodesk
In this hands-on lab, we will explore the new interoperability between Advance Steel 2017 software and Robot Structural Analysis Professional 2017 software. We will begin by exploring a simple structural model in Advance Steel software. We will push that model into Robot Structural Analysis Professional software and perform a basic analysis and code group-based design. Once the design is correct, we will update the Advance Steel model geometry from Robot Structural Analysis Professional and continue the steel-detailing process.
Key learning objectives

At the end of this class, you will be able to:

- Create and manipulate model geometry in **Advance Steel**
- Send **Advance Steel** models to **Robot Structural Analysis Pro (RSA)** and back for analysis
- Perform code group-based design in **Robot Structural Analysis Pro**
- Add connections, number parts, and generate drawings in **Advance Steel**
Today's Agenda
Integrating Structural Design, Analysis, & Detailing

- Tools and Workflows
  - What, Where, and Why
- Advance Steel
  - E1: Modeling in Advance Steel
- Robot Structural Analysis Pro (RSA)
  - Key Features
  - E2: Analyzing the Model
- Advance Steel
  - E3: Detailing the Model
# Tools by Phase
The Autodesk Structural Toolbox

<table>
<thead>
<tr>
<th>Design</th>
<th>Fabrication</th>
<th>Construction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conceptual Design</td>
<td>Fabrication Model</td>
<td>Installation</td>
</tr>
<tr>
<td>Structural Design</td>
<td>Shop Drawings</td>
<td></td>
</tr>
<tr>
<td>Coordination, Simulation</td>
<td>Prefabrication and Production</td>
<td></td>
</tr>
<tr>
<td>Code Checking</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Tools by Phase**
- **Design**
  - Conceptual Design
  - Structural Design
  - Coordination, Simulation
  - Code Checking
  - Structural Analysis for Revit
  - Robot Structural Analysis Professional
  - Dynamo
  - Revit
  - Advance Steel

- **Fabrication**
  - Fabrication Model
  - Shop Drawings
  - Prefabrication and Production
  - Partner Add-ins, e.g. SOFiSTiK

- **Construction**
  - BIM 360 Team, BIM 360 Docs, Navisworks, BIM 360 Glue
  - BIM 360 Field, BIM 360 Plan

**Advance Steel**

**BIM 360 Team, BIM 360 Docs, Navisworks, BIM 360 Glue**

**BIM 360 Field, BIM 360 Plan**

**Robot Structural Analysis Professional**

**Structural Analysis for Revit**

**Partner Add-ins, e.g. SOFiSTiK**

**Dynamo**

**Revit**

**Advance Steel**

**BIM 360 Team, BIM 360 Docs, Navisworks, BIM 360 Glue**

**BIM 360 Field, BIM 360 Plan**
Steel Design and Detailing Workflow
Autodesk Revit, Robot, and Advance Steel
Key features
Advance Steel 2017

- Smooth workflow from design to fabrication
- Based on the familiar AutoCAD® technology
- Minimize errors and omissions with deliverables
- Direct interface with CNC machines
- Integration with other Autodesk design and analysis software
Tools for automating the 3D modeling phase
Advance Steel 2017

Steel Connection Design Engine
Comprehensive library of parametric steel connections; tools to create your own connections; built-in steel connection design engine

Miscellaneous Steel: Stairs, Railings, Cage Ladders
Macros for stairs, railings and cage ladders; large library of stair tread types

Plate Works: Folded Plates, Transitions, Unfolding
Folded plates of any shape; transitions such as round-square; automatic unfolding
Tools to meet project documentation needs
Advance Steel 2017

General Arrangement Drawings: Templates and Automation
Ready-to-use templates for elevation view, top view, anchor plan, isometric view; automatically labeled & dimensioned

Fabrication Deliverables: Shop Drawings, BOMs, CNC Data
Single part and assembly drawings; bills of materials (BOMs); DSTV & DXF & KISS files

Document Manager: Automatic Updates, Revisions, Approvals
Automatic update of drawings, BOMs and CN data; revision clouds on drawings; drawing approval-based workflow
New and enhanced features
Advance Steel 2017 and 2017.1

- Bridging connection for cold rolled elements
- Beam offset information in labels
- Structural member representation
- Custom clipping symbols
- Snap points on anchors
- Grid balloon placement control
- New templates for lists on drawings
- User-defined formulas in BOMs
- Enhancements to the BOM editor
- Enhanced drawing styles for the US market
- View native drawings in AutoCAD®
- IFC export enhancements

- Advance Steel 2017 Extension for Revit®
- Autodesk® Steel Connections for Revit®
- Dynamo Extension for Advance Steel
- Code checking steel connections with latest AISC codes
- Connection libraries with DASt values
- Simplified way to create drawings
- Background mask behind dimension & label texts
- Special parts visibility on drawings
- IFC 2x3 export enhancements
- Model information exported to FabTrol Pro
- Higher precision for angle values in NC-file
# Customer Projects

<table>
<thead>
<tr>
<th>Sector</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oil &amp; Gas</td>
<td>Delivering challenging and complex projects</td>
</tr>
<tr>
<td>Nuclear</td>
<td>Expertise spanning the entire lifecycle of complex nuclear assets</td>
</tr>
<tr>
<td>Transmission &amp; Distribution</td>
<td>Innovative and high value added solutions</td>
</tr>
<tr>
<td>Government Services</td>
<td>Comprehensive engineering services and solutions</td>
</tr>
<tr>
<td>Unconventional Oil &amp; Gas</td>
<td>Provider of services to the industry</td>
</tr>
<tr>
<td>Renewables / Bioprocess</td>
<td>Experience supporting today’s renewable energy</td>
</tr>
<tr>
<td>Water</td>
<td>Global expertise in every aspect of water, from source to ocean</td>
</tr>
<tr>
<td>Mining</td>
<td>Expertise and delivery from concept to closure</td>
</tr>
<tr>
<td>Power</td>
<td>Shaping the future of clean energy</td>
</tr>
<tr>
<td>Transportation &amp; Infrastructure</td>
<td>Innovative solutions for complex transportation needs</td>
</tr>
</tbody>
</table>
Ex 1: Modeling
Exercise 1
Modeling Beams and Columns

2. Select File > Open.
4. In the Home ribbon, choose Project > Project Explorer.
5. In the Project Explorer, turn off Level 1, Level 2.
6. In the Home ribbon, select Objects > Column and create 3 columns.
Exercise 1
Modeling Beams and Columns

7. In the **Advance Properties** dialog box, change the column size to **W8x10**.

8. In the **Home** ribbon, select **Objects > Rolled I section** to draw the main beams. Connect these from node to node at the top of the columns.

9. In the **Advance Properties** dialog box, change the beam positioning to **top flange**.

10. In the **Home** ribbon, select **Project > Project Explorer** and turn off **Level 3**.
Exercise 1
Modeling Beams and Columns

11. In the **Advance Steel Tool Palette > Tools** Menu > select **Advance Copy**.

12. In the **Transform Elements** dialog box, enter **18’** for the Y component and click **Select Objects**.

13. Select the existing beams (see image).
Exercise 1
Modeling Beams and Columns

14. In the Home ribbon, select Project > Project Explorer and turn on all of the levels.

15. Save the Model.

16. In the Export & Import ribbon, select Exchange Formats > Advance Export to export the model to the .SMLX file format (01 – AS Model 1.smlx).
Autodesk Robot Structural Analysis Pro 2017
(aka Robot, RSA)
Top features
Robot Structural Analysis Professional 2017

**Collaboration**
- Supports efficient BIM workflows
- Interoperability with Advance Steel, Revit, etc.

**Speed**
- Auto-meshing (FEA)
- Robust nonlinear and dynamic algorithms
- Over 70 design codes

**Versatility**
- Flexible, open API
- Covers a broad range of structures
- Localized for global markets
Typical customers
Robot Structural Analysis Professional 2017

- Spans multiple industries
  - Structural Engineers
  - Multidisciplinary Engineering Teams
  - Building Product Manufacturers and Fabricators
  - Large Industrial Machinery Providers
  - Oil and Gas / Mining Firms
Analysis of concrete, steel, and timber designs
Robot Structural Analysis Professional 2017

- **Design versatility**
  - Reinforced concrete design module
  - Steel design module
  - Timber design module
Modeling flexibility
Robot Structural Analysis Professional 2017

- Shells, solids, and more
  - 2D and 3D frames and trusses
  - Plates
  - Shells
  - Grillages
  - Plane stress structures
  - Plane deformation structures
  - Axisymmetric structures
  - Volumetric structures
  - Composite beams
Advanced analytical capabilities
Robot Structural Analysis Professional 2017

- Flexibility to meet your needs
  - Advanced finite element auto-meshing
  - Wide range of analysis capabilities
  - Powerful analysis solvers
Advanced analytical capabilities
Robot Structural Analysis Professional 2017

- Linear and non-linear analysis
  - Compression / tension elements
  - Cable elements
  - Non-linear constraints
  - Material plasticity
  - Non-linear hinges
  - 2nd-order effects (non-linear)
  - 3rd-order effects (P-delta)
Advanced analytical capabilities
Robot Structural Analysis Professional 2017

- **Dynamic analysis**
  - Modal
  - Seismic
  - Spectral
  - Harmonic and FRF
  - Time history (linear and non-linear)
  - Elasto-plastic
  - Pushover
  - Footfall
Wind load simulation

- Simulates the wind flow around a structure
- Generates wind loads on all surfaces automatically
- Adjustable wind profile and velocity factor
- Graphic representation of the virtual wind tunnel
Extensibility
Robot Structural Analysis Professional 2017

- **Open, flexible API**
  - Custom macros creation
  - Extraction of analysis results
  - Parametric structure creation

- **Results Connect**
  - Seamlessly access RSA data and results using Microsoft Excel, even without API knowledge

- **Dynamo**
  - Access the API with powerful visual programming tools
Customer Examples
Robot Structural Analysis Professional 2017
Ex 2: Analysis
Exercise 2
Import Advance Steel into RSA

1. Open RSA and start a new Building Design project.
2. Select Add-ins tab > Integration > Autodesk Advance Steel.
3. Select Import and then OK.
4. Select 02 – AS Export.smlx and then Open.
5. RSA will open and begin importing the Advance Steel model data.
Exercise 2
Map Sections and Materials

6. In this example, a few materials need to be mapped.
7. In the **Mapping of elements** dialog, Select **Materials** at left, then click the buttons to the right of each material and set to the values shown.
8. Click **OK** when finished to view the imported geometry.
Exercise 2
Add Supports, Panels, and Loads

9. Open **04 – Analysis Start.rtd.** To save time, much of the prep work on the imported model has been completed for you.

10. Note that grids, levels, supports, panels (i.e. slabs and walls), and loads are visible in this model.
Exercise 2
Generate Load Case Combinations

11. Select **Loads** tab > **Automatic Combinations** to open the Load Case Code Combinations dialog.
12. Select **Full automatic combinations**, then click **More** to view the combinations in more detail.
13. Select **Generate** to build out the load combinations list.
Exercise 2
Create Finite Element Mesh

14. Click the **Options of FE Mesh Generation** icon to open this toolbar, then choose **Meshing Options** (select **Yes** to the pop-up message).

15. Select **Complex mesh generation (Delaunay)** and set the **Element size** to 2 feet. Select **OK**.

16. Select **Generation of calculation model** to create the FE mesh.

17. Select **Mesh Freeze** to store this mesh; then close the toolbar.
Exercise 2
Perform Analysis

18. Time for analysis! If you’re behind, open 05 – Analysis Ready.rtd to catch up.

19. Go to Analysis tab > Analysis Types to open this menu. Observe additional capabilities under the New and Parameters buttons.

20. Select Calculations to run the analysis. A green light at the bottom of the screen indicates that current results are available.
21. Select **Results** tab > **Maps** to open this dialog.

22. Select the **z** direction for **Displacements – u,w** and select **Apply**.

23. Note the color mapping in RSA is similar to the results previously explored in Revit.

24. Deselect the **z** checkbox and select **Apply** again to remove the map.
Exercise 2  
Configure Code Group for Design

25. For this step, let’s change our RSA layout. Locate the **Layouts** toolbar and change from **Geometry** to **Steel/Aluminum Design**.

26. Proceed to the **Groups** tab of the **Definitions** dialog. Click **New** to create a new code group and enter members **104 to 123** in the **Member list**.

27. Select **Save**.
Exercise 2
Perform Code Group Design with Optimization

28. Proceed to the Calculations dialog and select the Code group design option. Enter 1 or use the List button to find and select group 1.

29. Select Optimization and check the Weight option. Select OK to close this dialog. If you’re behind, open 06 – Design.rtd to catch up.

30. Select Calculations to perform code group design for the selected settings.
Exercise 2
Select Optimal Sections

31. The Code Group Design module highlights the optimal section for the group (W 8x24 here). Click on the icon next to this section to view results; select OK to return.

32. In the Code Group Design dialog, select Change all to resize the sections. Close the dialog and Cancel saving the calculation results.
Exercise 2
Export Updated Geometry

33. Return to **Add-ins** tab > **Integration** > **Autodesk Advance Steel**.
34. Select **Export** and click **OK**.
35. Save the file as **07 – RSA Export.smlx**.
Ex 3: Syncing
Exercise 3
Synchronize Model Changes

1. In Advance Steel 2017, on the Export & Import ribbon, select Exchange Formats > Advance Export pulldown > Advance Synchronization.

2. In the Synchronization dialog box, click Load and select the SMLX file exported from Robot.

3. In the Synchronization dialog box, click the box next to Status and select Apply All Actions.
Ex 4: Connections
Exercise 4
Add Connections to the Model

1. Open 03 – AS Model2.dwg.
2. Set the view to Southwest Isometric using the View Cube.
3. Zoom into the northeast corner of the top floor.
4. In the Connection Vault Tool Palette (Home > Extended Modeling > Connection Vault), Platform Beams menu, select Clip Angle.
Exercise 4
Add Connections to the Model

5. Select the column and press Enter. Then select the exterior beam intersecting the web and press Enter.
6. Zoom out to see the next column beam intersection.
7. In the Advance Tool Palette, Tools menu, select Create Joint in Joint Group.
8. Select any portion of the clip angle connection previously created (e.g. bolts) and press Enter.
Exercise 4
Add Connections to the Model

9. Select the column and press **Enter**. Then select the beam intersecting the column web and press **Enter**.

10. Select any portion of the joint created (e.g. bolts), right-click and select **Advance Joint Properties**.

11. In the dialog box, check **Upgrade to master**.

12. Select the clip angle header and change the profile size to **AISC 14.1 Angle Not Identical L 4x3x3/8**.
Ex 5: Detailing
1. In Advance Steel, open 08 – AS Model 3.dwg.
2. Zoom into the northwest corner of the top level in the model.
3. In the **Advance Tool Palette > Tools**, select **Camera(s) at Node**.
4. Select the bounding box for the clip angle connections.
Exercise 5
Detailing the Model

5. Select the top plane and press Enter.
6. Select the camera, right-click and select Advance Properties.
7. In the Properties menu, change Type to Overview, and type “Roof Framing Plan” under the Description.
Exercise 5  
Detailing the Model

8. In the **Detail Box** menu, change the following:
   a. z-Viewport to 1’ (Front and Rear)
   b. xy-Viewport to Automatic
   c. Style: 3 – Plan View – Full
   d. Scale: 3/16” = 1’ – 0”

9. In the **Home ribbon > Documents panel > Select Numbering.**

10. In the **Numbering** dialog box, select the boxes next to Process Preliminary mark, Process single parts, and Process assemblies then press **OK.**
Exercise 5
Detailing the Model

11. In the Drawing Process Tool Palette, select Cameras > All Cameras PageFull ANSI-D.

12. In the Process Properties dialog box, select OK.


You did it!
ES17657-L: Integrating Structural Design, Analysis, and Detailing: Advance Steel and Robot

Aaron Vorwerk, AIA, EIT, LEED AP BD+C
Sr. Technical Sales Specialist, AEC, Autodesk
@AaronVorwerk

Stephen Bessette
Technical Sales Support, MEP & Fabrication, Autodesk