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Get Real: Using AutoCAD Civil 3D & Storm and 
Sanitary Analysis to Prepare EPA SWMM Models  
Robert Ward 
Hyphae Design Lab 
 

 

Description 

The Stormwater Management Model (SWMM) is a powerful analysis engine inside Autodesk 
Storm and Sanitary Analysis.  SWMM empowers both Landscape Architects and Urban 
Planners analyze sites and create sustainable stormwater solutions.  This class uses the Esalen 
Institute in Big Sur, CA as a case study on how to build a complete SWMM analysis from the 
ground up including techniques for open channels, bioswales, infiltration trenches, as well as a 
deep dive into the extended functions of SWWM.  By the end of this class users will have a solid 
foundation of workflows between Autodesk Civil3D and Autodesk Storm and Sanitary Analysis. 

 

Your AU Expert 

Robert is an Environmental Designer in the San Francisco Bay Area. He has worked in various 
design roles at the meeting point of Civil Engineering, Urban Design, and Computer Science for 
10+ years, 8 of which were with multinational planning-engineering companies, AECOM 
(Guangzhou) and Parsons Brinkerhoff (Shanghai) as a BIM/CAD manager and GIS analyst. His 
passion for Hydrology lead him to a co-teaching position at Tongji University Planning 
Department; Applications of Civil Engineering Hydrology for Urban Planners. He was a key 
speaker at Wuhan Sustainability in Urban Planning Conference; GIS Based Simulations of 
Energy and Water, as well as a selected speaker for World Architecture Day Shanghai; BIM 
Techniques for Multimodal Mass Transit Station Design.   He has taught at AU2012; CI4820-V: 
Feeling the Lay of the Land: Civil 3D + Civil View for Landscape Architects.  He was a key 
technical consultant for Roundabout and LID tools in Infraworks360. He is a certified 
professional in AutoCAD, Civil3D, Revit Architecture, RevitMEP, Revit Structure, Autodesk 
Building Performance Analysis, and ArcGIS 10.3, as well as being a LEED accredited 
professional. He was trained as a landscape architect in the rigorous curriculum of North 
Carolina State University College of Design, and currently works at Hyphae Design Lab an 
environmental engineering consultancy. 
 

Learning Objectives 

 Organize and manage GIS to CAD to SWMM data workflows 

 Draft and model open channel networks 

 Draft, calculate, and model SWMM subbasins 

 Design, calculate, and model BMPs 
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1.0 Overall Workflow  
 

“Why is this so hard?”, was a question I asked myself over and over throughout my self-taught 
learning path in both hydrology theory and hydrology software.  In short, there is a perfect storm 
of inconsistent documentation, missing or hidden data, buggy software, pay-to-play access to 
both data and software.  Taken together it turns real hands-on learning of sustainable 
stormwater solutions into a nightmare that would cause all but the most dedicated throw up their 
hands in despair and run away. 
 
To succeed at this challenging task you need to be: 
1. Well organized with data from the beginning 
2. Have presets to make-up for the missing functionality in the software 
3. Have workarounds for the flawed functionality in the software 
4. Expect to spend 80% of the time preparing input and only 20% in SWMM 
 
What follows is a suggested process and lots of little hacks to avoid all the little hidden pitfalls, 
so that you can spend less time troubleshooting and more time on actual design!  This for 
Landscape Architects and Urban Planners with some background, but may have felt too 
intimidated to dive into hydrology.  The deep dive sections are optional more detailed 
discussions. 
 
There is an assumption of basic GIS knowledge in this class, if you are not familiar with GIS 
lookup some Map3D classes on AU.  On the topic of GIS it is imperative that you keep all your 
files in the same projected coordinate system, and that you use only SDF type files.  SDF files 
were developed by Autodesk and are inherently more stable than any other choice.  The only 
exceptions are exporting/importing SQLite files between Civil3D and QGIS, and 
exporting/importing shapefiles between Civil3D and SSA. 
 

1.1 Hydrology 
In short, Hydrology studies how water moves through the world.  The purpose of most hydrology 
studies is to compare pre-development to post-development sites with the goal of mimicking 
pre-development hydrologic response to rainfall.  Often these studies are mandatory and must 
be specifically formatted to meet legal requirements for a development permit. 
 
Hydrology tracks three properties of water space, mass, and time.  When only space and mass 
need to be calculated, volumetric calculations, a spreadsheet is the most efficient tool.  When 
time is included, flow calculation, purpose-built hydrology software must be used. 
 
Computer based models of hydrologic system work by taking rainfall (input) and running it 
through a flowchart of math instructions (transform) and converting it into a runoff (output).  
Keep this in mind when looking at the SSA screen, it is just a flow chart of points and lines (one 
dimensional analysis), it may seem to have geometric properties, but it doesn’t.  Everything SSA 
needs to calculate flow is written in tables attached to each point. 
 
The typical study is usually defined in time and space as “the watershed area of all the water 
that passes through the site and lasts 24 hours.”  A rainfall input, the 24-hour design storm, is 
typically used.  Design storms are created from historic rainfall statistics and have a recurrence 
(return period).  Return periods, are the, “once in ___ year size storm”.  For example, the “10 
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year 24 hour NRCS Type II” rainfall is a 24-hour long design storm that happens only once 
every 10 years with a rainfall pattern using a NRCS Type II curve 
 

 
FIGURE 1.1 LOCATION OF NRCS CURVE TYPES 

 
The “10 year 24 hour NRCS Type II” storm is a good default input setting for establishing a 
baseline of performance on most projects in the United States.  What will the results of such a 
simulation tell you? If your design can handle a once in a decade storm without flooding, and 
what the peak flow of site runoff will be.  Is such a peak flow acceptable to stewardship of the 
environment? 

1.1.1 Deep dive: Rainfall Statistics 
You may wonder how are these rainfall curves made anyway?  Each design storm has a 
rain depth that gets dropped on the land.  Is that rain dropped all once, more in the 
beginning, or the end?  No two storms are alike, but they are all similar enough to make 
a curve.  This curve takes a single number, depth, and distributes it out across 24 hours.  
It’s worth knowing how, so you can make your own rainfall curves for any location in the 
world.  You can download the raw data from the Global Historic Climatology Network 
(GHCN).  Once you have the data, load it into a spreadsheet and create a Pearson Type 
III probability density function.  Then pull out the rainfall depths for different probabilities.  
Remember, the return period in years is the inverse of probability (1/P). 
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FIGURE 1.2 TYPICAL RAINFALL CURVES 

 
These graphs show rainfall as either a speed, called intensity, (in/hr) or as the total 
depth (in) adding up across the day. Notice the rainfall begins with a trickle, a very low 
speed on the left graph and has a very low depth on the right graph, then in the middle 
of the day it speeds up (left) and most of the depth is added (right). 
 
The NRCS Curve, I, IA, II, III take this basic curve and push the central high 
speed/sudden depth zone slightly one way or the other to match regional rainfall 
patterns. 
 

1.2 Hydrographs + Routing 
The output of running a SWMM model is time to mass graph called a hydrograph.  Each 
component in the system has its own unique signature time-mass curve and in SSA they can be 
examined alone or as an overall master hydrograph of the entire system. 
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FIGURE 1.3 EXAMPLE OF A HYDROGRAPH 

 
The hydrographs are where you may look to see the impact of your design on the environment 
or to see how well your proposed stormwater treatments will function.  You can find peak flow 
as the highest point on the graph, and the volume is the area under the curve.  Rain depth is 
shown as a depth on top (Input), and runoff is on the bottom (output).  Notice how the peak 
rainfall happens before the peak runoff.  This delay, called lag, is an important concept.  The 
subbasin section explains why. 
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FIGURE 1.4 EXAMPLE OF HYDROGRAPHS ROUTING 

 
Routing is the way the different hydrographs of each element are passed to the next, merged 
together, or split apart.  In SSA this is routing can be done by either the Kinematic Wave method 
or the Hydrodynamic Method.  What’s the difference you may ask?  Kinematic Wave is an 
approximation, whereas Hydrodynamic is more exact because it solves a famous system of 
partial differential equations called St-Venant Equations. 
 

1.2.1 Deep dive: EPA SWMM 
Why SWMM? Out of all the analysis options in SSA the SWMM engine is the most 
advanced.  Many of the other methods pre-date computers and were designed with 
large margins of error and more complex time of concentration requirements. 
 
SWMM is the only analysis option for modeling water quality. 
SWMM is the only analysis option to model snowmelt 
SWMM is the only analysis option with hydrodynamic routing 
   
The Environmental Protection Agency Storm Water Model (SWMM) was written in 1971. 
As a response to the need for a better tool to study the effects of urbanization on 
watersheds.  Prior to SWMM the most popular method was called TR-55, which stands 
for Technical Release 55 of the Soil Conservation Surface 
 

 
 

2.0 Open Channels  
 

The secret to open channels is the ability of SSA to merge both GIS data and exported Civil3D 
pipe networks in a single SSA file.  I like to use a What-You-See-Is-What-You-Get (WYSIWYG) 
approach because it keeps everything clear when all the data is bouncing back and forth 
between applications and that allows us to easily flag errors.  As long as the data is formatted 
with an eye toward a merged network it should come in painlessly. The data is exported to SSA 
in three separate files.  If you don’t know how to export pipe networks to SSA see Appendix C 
for the AU class. 
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Purpose Export File Object 

Closed Pipes Hydroflow STM file Civil3D Pipe 

Open Channel Horizontal Design GIS line shapefile Polyline 

Open Channel Vertical Design GIS point shapefile Block 

 
. 

2.1 Theory of Open Channels 
Although SSA is a 1D analysis it can model simple open channels.  It sweeps typical cross 
sections between junctions.  The typical open channel cross sections have parabolic for swales 
and trapezoidal for almost everything else.  To take it to the next level of complexity you can 
create irregular user defined cross sections in a dedicated section editor.  For example, this is a 
great tool for 8-point stream sections. Beyond simple small streams, you are much better off 
using the HEC-RAS engine in Autodesk River Analysis for Civil3D.  Autodesk River Analysis 
(HEC-RAS) is a better tool for unique stream sections from survey data, larger scale streams, 
rivers, and river systems. 
 

 
FIGURE 2.1 TYPICAL 8-POINT SECTION 

 
In Civil 3D draft polylines on a dedicated layer to represent SSA open channel links and place 
special blocks called “node blocks” to represent SSA junctions.  Together the polylines and 
blocks are the horizontal and vertical control of your channel design.  A dedicated file (C-SITE-
PIPE.dwg) with a finished grade daylight surface will hold both pipe networks and open 
channels. 
 
The additional data necessary for open channels is added with attached tables, these are 
Map3D function within Civil3D.  This table of extended custom properties is available in the 
property manager for you to populate with values.  Open channels have three properties, 
Length, Depth, and Manning’s n value, which is a number between 0 and 1. 
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If the Manning's value or channel depth varies in some parts of the network, use the property 
manager to alter those segments.  The additional data necessary for junctions is added with 
attributes to the node block, also accessible via property manager. 

2.1.1 Deep dive: Manning’s n value 
What is Manning’s n-value anyway?  It is a number used to describe the roughness and 
therefore friction of a material.  It is used as part of part of Manning’s Equation to 
calculate flow.  This equation is very famous especially in the days before computers 
because it was a simple way to calculate flow.  The equation was written in 1890 by 
Robert Manning, an accountant with no formal training in Civil Engineering. 
 

 
FIGURE 2.1.1 ROBERT MANNING 

 

2.2 Open Channel Step by Step 
 

 

 
This step MUST happen in every Civil3D file you create for 
the project.  In Toolspace > Settings Tab > Click on the 
filename to open the drawing setting dialog 
 

 
 

 
In Edit Drawing Settings Dialog > Units and Zone tab 
pick out the correct projected coordinate system for your 
project from the two drop down menus 
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Draft the drainage network on C-STRM-SWLE-CNTR layer 
by sketching out the centerline of the swales with polylines.  
Keep elevations polyline elevations at zero.  Be sure to 
draw the polylines in the direction of flow.  Use the linetype 
arrows as a guide. 
 

 

 
Very important; at places where the surface flow enters or 
leaves a pipe network be sure to snap the polyline to the 
insertion point of the structure.  The surface flow lines DO 
NOT pass through the structures in Civil3D.  (Just like in 
the real world a surface flow is no longer a surface flow 
when it’s under a culvert, remember WYSISYG). 
   

 

 
Mark all the places where you will want or need an SSA 
junction object with the node block.  These are places like 
the top and bottom of weir, the begin/end of a culvert, 
channel junctions, inlet/outlets of storage areas, start/end of 
swales, changes in channel width and depth.  Important, 
never have node blocks closer than center-to-center (see 
4.1) 
   

 

 
Use the command MOVEBLOCKSTOSURFACE to elevate 
node blocks to the surface.  Very Important; update the 
fields twice.  The reason why is explained in the 2.2.1 
 

 

 
Use ADEDEFDATA to create a new table.  This is the table 
of extra properties. 
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Name the table “SSA-LINK” 
 

 

 

In the table create an attribute “N_VALUE” 
Assign the attribute default value 0.025 
Set the attribute type as “Real” 
 

 

 

In the table create an attributes “DEPTH” 
Assign the attribute default value 1 
Set the attribute type as “Real” 
 

 

 

 

Use the command ADEATTACHDATA to attach the table to 
all polylines.  Tip isolate the C-STRM-SWLE-CNTR layer 
first to select all at once. 
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Use the Property Manager to alter the DEPTH or N_VALUE 
as needed.  Remember if you add new polylines you will 
need to attach tables to them. 

 

 

 

Use the command MAPEXPORT to create a shapefile 
called “SSA-LINK.shp” in the folder: 02_SHP > 01_ToSSA 

Set the object type to “line” 

 

 

 

Select only the open channel centerlines using the select 
by layer option to find C-STRM-SWLE-CNTR layer.  This is 
why it is important to use a dedicated layer for attached 
data. 
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Select the Data tab and “Select Attributes…” button to open 
the dialog 

 

 

 

In the attribute tree expand Properties and select the 
LENGTH property then expand Object Data > SSA-LINK 
and N_VALUE and DEPTH properties.  Finish the export 

 

 

 

 

 

Use the same procedure to create a new shapefile called 
“SSA-NODE.shp” in the same location.  This time set the 
object type to Point. Select only the node blocks using the 
C-STRM-SWLE-NODE layer.  This time in the Select 
Attributes dialog select only the block attributes. Finish the 
Export 

 

2.2.1 Deep dive: Node Blocks 
Let’s drill into the block design more deeply, a good way to think of the node block is a 
1D representation of a typical cross section of an open channel.  Within this cross 
section are 4 levels each one corresponds to a block attribute which in turn match an 
SSA junction parameter. 
 
RIM 
DEPTH 
INVERT 
INITAL_WSEL 
SURCHARGE 
PONDED_AREA 
 
RIM is essentially the bankfull elevation of the channel, and the INVERT is the thalweg 
elevation.  Confusingly, the DEPTH is measured upward from the INVERT in positive 
units.  The Initial Water Surface Elevation (WSEL) parameter is equal to INVERT in dry 
channels. SURCHARGE is an abstraction for sealed systems where there might be an 
air gap that can be filled with water before the system becomes pressurized, this should 
always be equal to RIM.  Finally, PONDED_AREA is an abstraction of an imaginary 
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cylinder sitting above the RIM which can hold water flowing over the RIM and then 
release it back into the system as water levels drop.  Leave this as 0 unless the design 
required this specialized options for flood storage 
 

 

 
FIGURE 1.2  JUNCTIONS FROM THE SSA MANUAL 

 
Within the block all the values are entered by the user except RIM and INVERT which are 
automatically created.  The RIM attribute uses an object field type to read out the Z-Position of 
the block in decimal units.  The INVERT attribute uses a formula field with the expression “RIM - 
DEPTH”.  This is why you must update the blocks twice after elevating them. To update RIM 
and then to update INVERT.  If you were to alter the DEPTH attribute you would need to update 
to recalculate the invert. 
 

3.0 Subbasins  
 

Subbasins are the primary collectors of rainwater that feed the entire drainage system. In 
SWMM, all the complexity of terrain is abstracted into rectangular blocks of similar hydrologic 
properties.  Each one of these subbasin objects is a conceptual rectangle bisected by a flow 
path which has three physical and four material parameters to describe it.  Similar to a roof with 
all kinds of intricate shapes and multiple levels that fall into gutters.  Runoff volume of a 
subbasin is directly proportional to its area. 
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FIGURE 2.3 FROM THE SSA MANUAL 

 

Physical Property Parameter 

Area The 2D area of the subbasin 

Length The length of the flow path from pour point to farthest point 

Width The equivalent width for asymmetrically divided subbasins 

Material Property Parameter 

Curve Number A value (2-99) which measures water absorbed by the subbasin 

Impervious Manning’s Value The friction by material type of water sliding across the surface 

Pervious Manning’s Value The friction by material type of water sliding across the surface 

Percent of Impervious Area A value (0-100) which measures the impervious fraction of area 

 
Like a roof draining into gutters, in SSA the subbasins pour into a junction of the drainage 
network.  This junction is sometimes called the pour point or spill point it represents the lowest 
point of the subbasins.  The flow path is drawn along the most efficient route from the pour point 
to most distant point in the subbasin.  You can imagine it as the path a drop of water will take 
from the most distant point to the pour point. 
 
Water can be absorbed by the subbasin and never exit.  The material parameters model this 
behavior. This depends on the type of soil, on the type of landcover, and the number of 
depressions in the microtopography that can form puddles The loss of water by plants 
(interception) and by soil (infiltration) is combined into an abstract number analogous to 
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percentage called Curve Number.  The loss of water by puddles (storage) is based on user 
defined settings in SSA for typical pit depth. 
 

3.1 Theory of Subbasins 
As you can see subbasins are more complicated objects than channels and preparing 
subbasins requires GIS operations to merge landcover, soils, and flow path data.  These GIS 
operations, in turn, rely heavily on the Map3D functions in Civil3D. It is good practice to have at 
least three files for processing subbasins. 
 

C-SITE-HYDR.dwg The hydrology file with subbasins and flow paths diagrammed out 

C-SITE-MTRL.dwg The landcover file typically an extension of site materials QTO file 

C-SITE-GISS.dwg A scratch space for working with GIS data 

 
Guess what? Your client probably will not give all the information you need to prepare 
subbasins.  So be prepared to search out the missing information on the internet.  Appendix A 
contains information about last resort data sources for soils, landcover, topography, and rainfall.  
It is very likely that the GIS data you do find may need to be formatted in some way such as 
clipped or reprojected.  Appendix B has information about a free GIS software to help prepare 
data. 
 
GIS operations in Civil3D will generate a tsunami of files. In order to avoid drowning in data use 
a life preserver called Document Object Model (DOM).  Below, you can see examples of DOMs 
in Civil3D prospector and SSA Plan View panel.  Notice how objects of the same type 
accumulate under an icon in the Civil3D prospector (DOM)?  Likewise, in our custom DOM, GIS 
files of the same file type will accumulate in the correct folder.  In addition to the DOM, a 
standard naming system helps track variations as the site design progresses toward completion. 
 

 
FIGURE 3.1 DOCUMENT OBJECT MODEL EXAMPLES 

 
The GIS operations while seemingly complex have a simple underlying theme; generate a 
unique ID for each subbasin, then tag all the elements inside that subbasins with the ID.  This ID 
called HID for Hydrologic ID is already present in the parcel names.  After every geometric 
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overlay is finished, all the GIS tables are exported to finish the data operations in a spreadsheet.  
Note: if you are already skilled at GIS there is another non-spreadsheet way to get to the same 
result faster using SQL operations. 
 
It may seem faster to just manually enter the data but the appeal will soon wear off as the site 
area increases in size and complexity.  The value of using the GIS process is that it scales up. 
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FIGURE 3.2 THE SUBBASIN GIS WORKFLOW 
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3.2 Subbasin Step by Step 

 

 
Open C-SITE-HYDR.dwg In the Prospector Click on the 
Sites branch and create sites called “Subbasin”, 
“SubbasinHalf”, and “TimeConc” 

 

 
Import parcel styles “_Subbasin_HID” and _” 
Subbasin_Half”, and parcel label styles “_Subbasin_HID” 
and “Subbasin_Half” 

 

 
Diagram out subbasin boundaries (shown in red).  Try to be 
as precise as possible, even small gaps and overhangs 
may result in inaccurate areas.  Diagram flow paths (shown 
in green) It is essential that the line begins at the most 
distant point and ends at the pour point.  The arrows should 
point in the flow direction. 

 

 
Use the command MAPCLEAN and select the boundary 
linework by layer on the layer C-STRM-WHSD 
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Use the order of operations EXTEND UNDERSHOOT, 
BREAK CROSSING, ERASE DANGLING, DELETE 
DUPLICATES, ERASE SHORT, ZERO LENGTH, 
DISSOLVE PSEUDO NODES 
 
Be careful, in Map Clean the order of operations can create 
wildly different results. 

 

 
Use the command OVERKILL Do Not Optimize Segments 
Within Polylines because it will distort the lines. 

 

 
Use the command CREATEPARCELSFROMOBJECTS 
Choose the site “Subbasin”  
Choose the parcel style “_Subbasin _HID” 
Choose the parcel label style “_Subbasin_Half” 
Do not delete the linework 
 
These prepared styles will help you visually flag errors. 
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Examine the parcels look for leaks where two parcels are 
one and fix the undershoot as needed. On the Prospector > 
Parcels, in the tabular editor sort by area. If any parcels are 
listed as “NaN” it indicates an error.  Click on the that row to 
open the menu, zoom to each one and correct as 
necessary. 

 

 
Use the command CREATEPARCELSFROMOBJECTS 
and select the boundary and flowpath polylines 
Choose the site “SubbasinHalf” 
Choose the label style “_Subbasin_Half” 
Choose the parcel style “_Subbasin_Half” 
Do not delete linework 
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Use the command CREATEFEAURELINES 
Choose the site “TimeConc” 
Use the name style “<[Style_Name]>_<[Next_Counter]>” 
Choose the layer C-STRM-TOCL  
Choose assign elevations  
Do not delete linework 
 
 

 

In the following dialog choose “elevations from surface” and 
pick your hydrology reference surface from the drop down 
 
Explode the lines to 3Dpolylines 

 

 
Use the command MAPEXPORT to create an SDF file 
named “TimeConcLine.sdf” in the folder 03_GIS_SDF 
 
Select the 3Dpolylines by layer in the Selection tab, then in 
the Feature Class tab set the geometry type in the drop 
down as “Line” 
 
In select attributes dialogs choose the properties LENGTH, 
Z1, Z2 

 

 
Use the command EXPORTTOSDF and save the entire 
DWG file as “HydrologyExport.sdf” in the folder 
03_GIS_SDF 
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Close C-SITE-HYDR.dwg and open C-SITE-MTRL.dwg 
Import Landcover parcel styles and label styles.  Create a 
new site called landcover Copy over site material parcels 
and diagram additional off-site landcovers. Convert off-site 
linework to parcels. Check the parcels for errors and 
correctness.  Use the command EXPORTTOSDF and save 
the file as “landcover.sdf” in the 03_SDF 

 

 
Close C-SITE-MTRL.dwg and open C-SITE-GISS.dwg Use 
the command MAPWSPACE to activate the task pane.  
Click the manage data content icon and in the pop-up menu 
select “Connect to Data…” 

 

 
In the Connect to Data dialog Highlight “Add SDF 
Connection” and browse to the files “TimeConc.sdf” 
“HydrologyExport.sdf, Landcover.sdf” adding each to the 
map.  In the SQLite Connection add “Soil.sqlite”: as a layer 

 

 
Check the Landcover layer for missing rings if a ring is 
missing you will need to create it and recalculate the 
geometry.  Use the command MAPFEATURESPLIT to cut 
the ring into the feature polygon. Use the command 
MAPMULTIPOLYGONEDIT to remove the unwanted 
polygon inside the ring.  Use the command 
MAPCHECKINALL to finish the edit operation. 
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Copy HydrologyExport layer and paste twice 
Name one copy “Subbasin” 
Name one copy “SubbasinHalf” 
 

 

 
In “Subbasin” layer Click to open the menu and create a 
query.  If you are new to GIS a query is a way to filter data. 

 

 
Use the expression “Name LIKE 'HID%' ” 
This will filter out the subbasins from the subbasin halves.  
The percent “% “is the wildcard character. 

 

 
Create a calculation called “HID” 
Use the expression “ToInt64 (  Substr (  Name, 5, 3)   )” this 
will pull the number out of the parcel name.  
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Create another query of the layer “SubbasinHalf”.   
Use the expression “Name LIKE '%half%' “ to filter.   
Click on each layer to open the menu and export SDFs 
named “Basin.sdf” and “HalfBasin.sdf” to the folder 
“03_GIS_SDF” 

 

 
Use the command MAPGISOVERLAY 

 

 
Set the operation as intersect 
Source: BasinHalf.sdf 
Overlay; Basin_HID.sdf 
Save the output as BasinHalf_HID.sdf 
 
If you are new to GIS this will write the HID number, you 
just created to each basin half inside each subbasins all 
once. 
 

  
Use the command MAPGISOVERLAY 
Set the operation as Identity 
Source: TimeConc.sdf 
Overlay: Basin_HID.sdf 
Save the output as TimeConc_HID.sdf 
 
This will tag each flow path with the HID 
 

  
Use the command MAPGISOVERLAY 
Set the operation as Intersect 
Source: Landcover.sdf 
Overlay: Soil.sqlite 
Save as preCN.sdf 
 
This adds soil types to each landcover type and creates 
essentially, an uncalculated CN 
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Use the command MAPGISOVERLAY 
Set the operation as Intersect 
Source: preCN.sdf 
Overlay: Basin.sdf 
Save as preCN_HID.sdf 
 
This adds HID to each landcover polygon 
 

 

 
On the layer preCN.sdf 
Create a calculation called “AreaByHID” 
Use the expression “Area2D(Geometry)” 
 
This is necessary to write out the area of the new polygons 
created in the intersect operations. 

 

 

Open the table for each layer and click on the corner to 
open the menu.  Export the tables for BasinHID.sdf, 
BasinHalf.sdf, TimeConcHID, and preCn_HID.sdf. Save the 
exported tables to folder “04_GIS_Table” 

 

3.3 Tables Theory 
Once the GIS operations are finished in Civil3D all the data that can be extracted from geometry 
has been.  From this moment onward finishing the preparation of the subbasins is purely a data 
operation.  At this point the user has two options either use a spreadsheet or use a fully 
functional GIS.  In the spreadsheet approach it is useful to have a template with all the formulas 
I have preloaded.  The main goal of the spreadsheet is to assign Manning’s numbers to 
landcover types, combine areas by HID, and weight averages of combined areas.   
 
These tasks rely on table lookup functions INDEX, MATCH, VLOOKUP, and hacking the power 
of the SUMPRODUCT function.  At the end of table calculations, the data will be joined back to 
the subbasins in a GIS operation called JOIN.  The join key number will match each row in the 
final table with its corresponding subbasin’s HID number. 
 
The BasinHalf sheet is calculated in two steps the two half areas are sorted into lesser and 
greater.  Next they are evaluated.  Are they equal?  If so they are given a skew factor of 1, if 
they are not they are given a skew factor between 1 and 0 based on the SWMM skew factor 
formula (page 341 SSA Manual) Skews are then copied into the Basin sheet to calculate 
Equivalent Width based on the SWMM formula (page 341 SSA Manual) 
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FIGURE 2 EXAMPLE OF A LOOKUP TABLE FUNCTION 

 
The Material properties are a much more involved task.  In the preCN sheet, there are three 
lookup tables as defined by the user.  For example, in the “Lookup Mngs” table, the first column 
(I) is a list of every user defined surface material, and the second (J) is the Manning’s value.  
The spreadsheet will check each landcover row and look up the corresponding Manning’s value 
from this table.  The Curve Number lookup table is a little more complex in that it has two criteria 
to lookup, and the Impervious Flag table writes a true/false answer when the landcover is 
looked up. 
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FIGURE 3 EXAMPLE OF A MANY:ONE WEIGHTED AVERAGE 

 
The preCN_HID sheet contains formulas to sum up weighted averages by subbasins HID.  The 
formulas look more complicated then they actually are when written out in spreadsheet syntax.  
In short, each row uses a Key number (L) to search the entire array of data and pull out those 
rows which with matching HID values (A), sums up areas and weights (I/J), then divides.  In the 
case of Impervious Percent, however, the formula compares rows flagged as impervious (F) 
against all rows for that HID to find a percentage.  Note SUMPRODUCT is an array function so 
always use SHIFT+CTRL+ENTER when editing the formula and the “{ }” will appear.  Be sure to 
use the lock symbol “$” on rows and columns as necessary to keep everything in the right place 
when dragging! 
 
Typically, and unfortunately, the final steps for creating SSA input, the Join table operation and 
the bulk copy operations in Civil3D will result in inexplicable null fields, missing data, corrupted 
data, unreadable shapefiles.  This is where you will need to go to your backup GIS and properly 
join and export the final shapefiles for SSA.  The Autodesk Forums have not offered or even 
addressed any solutions to these issues as of this publication. 
 

3.4 Tables Step by Step 

 

 
In the folder 04_GIS_Table, open each CSV you just exported 
and delete and sort columns to match the organization in the 
template “CalcSubbasin_Template.xls” 
Frustratingly, there is no header in Map3D exports so you’ll 
have to count columns. 
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In “preCN_HID.csv” select the name column and use the “Text 
to Column” command, using “_” as the delimiting character. 
Delete the column of numbers that was separated from the 
name.  

 

 
Copy and Paste each column from CSV to its corresponding 
column under “Input” in the template. Drag the cursor in 
“Output” to apply the formulas to each array.  Don’t forget to 
Save As in this step of you will lose your template! 
 

 

 
Write lookup tables for Manning’s, Curve Number, and 
Imperviousness.  Use the tables included in the class materials 
to find these values.  The Landtype text strings must match 
exactly the spelling in “preCN_HID.csv” and include the 
complete range of values. 

 

 
Modify extents of the arrays in sheet “preCN”.  The arrays 
should include the complete list of values you have just defined 
in your lookup tables. 
Drag the cursor in “Output” to apply the formula 

 

 
In the “PreCN_HID” sheet under “Output > Join_Key” Generate 
the join keys by dragging the first cell and choosing “Fill Series” 
This list should be Equal to the number of HIDs in the “Basin” 
sheet. 
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Modify extents of the input array by dragging the colored boxes 
for each output column. Then drag the cursor in each tab to 
apply the formulas to each array. 

 

 
Copy the cells as Value Only of each output column in each 
sheet into the matching column on the “composite” sheet.  It 
should look similar to this. 

 

 
Open the ODBC manager by typing “ODBC” on the windows 
search line 
In the ODBC manager choose the tab “User DSN” 
Highlight “Excel Files” and use Add button to open the dialog 

 

 
Highlight MS “Excel Driver” and press the Finish button.  If the 
Excel file is not an option install the driver included with the 
class materials. 

 

 
In the pop-up dialog use the Select Workbook button to select 
the Excel file and write a name in the field “Data Source Name” 

 

 
In Civil3D open the Task Pane, navigate to Data Connections 
dialog and create an ODBC connection.  Press the ellipses 
button and select the name of the DSN you just created and 
add it. 
 

 

 
Select the “Basin_HID.sdf” layer and create a Join 
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Choose one-one cardinality Choose “HID” as the target key 
and “Join_Key” as the join key.  If the join fails, or if the data is 
missing in the joined layer’s table then do this step in another 
GIS software.  Export the layer as “BasinFinal.sdf”. 

 

 
Use the command _MECommand followed by the command 
IDM_METASK_CREATESHP to create a new shapefile in the 
folder 02_GIS_SHP > 01_ToSSA and name it “SSA-POLY.shp”  
 

 

 
In the pop-up set the coordinate system to match Civil3D 
 

 
 

 
Expand the shapefile schema and highlight feature the “New 
Property” button will become active 
 

 

 
Use New Property define a new property for each column in the 
attribute table from “BasinFinal.sdf” 
 
Be sure to set the correct data type and name in the table 
below 
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In Task Pane . Map Explorer > Tools select the BULK COPY 
tool.  Bulk Copy will transfer all the data in one GIS file format 
like SDF to another file format like SHP.   

 

 
In Bulk Copy set the input “BasinFinal.sdf” to “SSA-POLY.shp” 
Match each attribute including the geometry 
Select Ignore errors for  
Insert Error 
Coordinate System 
Unmatched Geometry 
 

 

3.4.1 Deep dive: SUMPRODUCT 
A deeper look at the logic behind the SUMPRODUCT operation.  Remember splitting up 
the landcover and soils by subbasin?  This tagged a HID to each polygon (One to 
Many). Sumproduct does the reverse and puts all those fragments back together by HID 
(Many to One).  How? It searches an array of cells for only those that match a criterion 
(key) then sums them up.   
 
When the spreadsheet formula syntax is stripped away to create a human-readable 
format we get this basic expression: 
 
= { SUMPRODUCT ((key=HID)*Weight) / SUMPRODUCT ((key=HID)*AreaByHID) } 
 
Notice the search criterion (Key=HID) this will evaluate to 1 if true and 0 if false.  This is 
the secret lookup function buried within the SUMPRODUCT function.  You can add as 
many of these logical truth tests as necessary to filter the data.  As is shown in the two 
criteria test for imperviousness by HID: 
 
= { SUMPRODUCT ((key=HID)*(1=I_Flag)*AreaByHID) /  SUMPRODUCT 
((key=HID)*AreaByHID) } 
 

 

4.0 SSA Model  
 

My workflow aims to minimize this tedious and error-prone style of data entry.  Beginning with a 
template that has preset defaults and then using a very narrow path in the GIS data import 
wizard, it can be done.  After analysis has been run, one of the most useful ways to use the data 
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is to roundtrip it back to Civil3D with the GIS data export wizard.  Note, SSA has no undo so you 
MUST save backups at critical points. 
 

 
FIGURE 4.1 SECRET LOCATION OF SSA REVEALED! 

 
Fun fact!  Have you ever wondered about the graphic on the left-hand side of the SSA GIS 
Import Wizard?  It’s actually a cropped map of the West Portal area of San Francisco (The 
green line is Ocean Avenue, the deep orange line is Highway 1, and black railroad line is the 
MUNI light rail line N). 
 

4.1 Importing Step by Step 

 

 
Open “SWMM_Template.spf” and Save As to create a new file.  
Choose Project Options and in the Prototypes > Conveyance 
Links select the default open channel geometry for your 
imports.  Usually this will be either trapezoidal or parabolic 

 

 
Choose File > Import > Import Hydraflow to import the pipe 
STM file from the 05_SSA > 01_HydroFlowToSSA folder 
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Convert all outfall nodes to Junctions (except the actual 
outfalls) 
Convert any inlets to junctions as needed 

 

 
Choose import File > Import > GIS data. To launch the GIS 
import wizard. In the Pipes tab browse to the “SSA-LINK.shp” 
Assign fields 
3-Length to LENGTH 
8-Manning’s Roughness to N_VALUE 
9-Diameter to DEPTH 
Check that all the units are in feet.  
Append Existing Network.  Set Snap Pipes Tolerance to “1” 
never more never less.   
 

 

 
In the Nodes browse to “SSA-NODE.shp”  Fields should match 
automatically. Check that all the units are in feet.   
Append Existing Network 
Finish the import. 
 

 

 
Examine the import, is should resemble what you drafted in 
Civil3D. Choose lock coordinates from the menu. 

 

 
Open the Conveyance Links dialog.  Each channel should now 
connect to a pipe link at the junctions. If any links have zero 
elevations press the “< “ button beside In/Out fields to read 
inverts out of the junction the invert elevations, or press the 
“Inverts…” button to assign elevations all at once.  Save as 
“ImportRaw.spf” 
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A common error is for conveyance links to attach to the wrong 
junction in closely spaced junctions.  Correct this problem by 
reattaching the link to the correct junction, and then delete 
orphan nodes. 

 

 
Perform a design check for negative slopes or misconnected 
pipes. Go to Output > Custom Report Options clear everything 
except Links Summary Tab. Check only Link ID and In/Out 
Elevations. Then go to Output > Excel Table Reports.  Use this 
table to check slopes.  After correcting these errors, Save as 
“Import.spf” 
 

 

 
In GIS import Wizard under subbasins tab browse to “SSA-
POLY.shp”  Match the fields 
1-Subbasin ID to HID 
3-Area to Area 
4-Average Slope to Slope 
5-Impervious Area to Prnt_Imp 
6-Impervious Manning’s to Mngs_Imp 
7-Pervious Manning’s to Mngs_Per 
8-Curve Number to CN 
9-Equivalent Width to Width 
 

 

 
Go to Input > Rain Gauge open the rain gauges dialog.  In the 
dialog box click “Add” to create a new rain gauge, then click the 
ellipses button beside the blank “Time Series:” drop down. 
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A dialog for time series opens, again click Add and press the 
now active Rainfall Designer button to open the rainfall dialog. 
 

 

 
In this dialog select a rainfall location close to your site.  Then 
select a rainfall curve that matches that location. 
 
Back in the rain gauges dialog press “Assign…” to connect the 
rain gauge to every subbasin 
 

 

 
Connect each subbasin one by one to its pour point junction. 
Save as “FullModelRaw.spf”  

 

 
Change the link routing method to “Kinematic Wave” and run 
the analysis.  Do any errors occur?  If no errors are present is 
the Continuity error less than 3%?  Fix either or both of the 
issues. Save as “FullModel.spf” 
Kinematic Wave does not allow negative drainage so it’s a fast 
way to flag errors. 

 

 
Change the link routing method back to “Hydrodynamic”. Run 
the analysis again.  Was the continuity error less than 3%?  If 
so then this is a working and valid model 
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4.2 Open Channel Widths Step by Step (optional) 
 
In addition to the properties of Depth and Manning’s open channels also have a width and in the 
case of a trapezoidal channel, side slopes.  Frustratingly enough, it is not possible to either read 
these in from GIS data or to set a default in the element prototypes tab of the Project Options.  
This forces you to set through the form for each SSA link and repetitively enter the data over 
and over.  There is a workaround, but it will cause the SSA links representing channel 
centerlines to de-curve.  While this is purely an aesthetic effect, some users may prefer to do 
the work and keep SSA links that match a background. If you are interested this technique is 
best done AFTER a clean network has been built but BEFORE adding subbasins. 
 

 

 
In SSA go to File > Export > export to LandXML 
Open the LandXML file in Notepad++ or a tabular XML editor if 
you have one is even better 

 

 
Expand the XML tree until you find the properties <Channel 
height="0.5" widthTop="2" widthBottom="1" mannings="0.025" 
/> 
 

 

 
Carefully edit each value or use REPLACE function to batch 
overwrite.  Save As in the 05_SSA folder as 
“LandXML_Formatted.xml” 

 

 
Save the file. In SSA go to File > Import > Import LandXML and 
browse to “LandXML_Formatted.xml”. Notice all the curve data 
is lost. De-curved arcs can be re-curved by adding nodes to the 
links as needed.  Click on a link and choose Edit Vertices > 
Add Vertex 

 
 

4.2 Theory of Visualizing Results in Civil3D 
When you see the status bar reach 100% on a successful analysis it may seem like mission 
accomplished, but to a client or manager who can’t see all your hard work, not so much.  The 
project isn’t finished until you have some slick output graphics. The graphical outputs in SSA are 
quite limited, but the data can be richly visualized in Civil3D.  Having SWMM results as native 
CAD objects in a Xref background under the design file is a huge asset.  To return the results 
from SSA to Civil3D uses a GIS shapefile.  These shapefiles are stored in the DOM under their 
own node.   
 
You have two options in Civil3D to bring in SSA exports, Feature Data and Object Data. Feature 
Data is native GIS data read into Civil3D, whereas, Object Data is GIS data converted into 
native CAD objects with attached tables.  Feature Data is the quickest way to push out CAD 
exports, however it is unstable, very limited graphically, and not dynamic.  Object Data takes a 
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little longer to produce, but it is more useful and stable.  Especially useful in Object Data is the 
ability to batch generate custom label blocks from the attached data tables.  A third graphics 
option is supplementing the plan views by exporting hydrographs and hydraulic profiles as CAD 
linework directly from SSA. 
 

4.3 Results to Civil3D Feature Data Step by Step 

 

 
In SSA after running the model, go to File > Export > GIS 
Export 
In the GIS Export Wizard Options tab set the output location to 
the folder 02_GIS_SHP > 02_FromSSA 
Check all the options 

 

 
In the element types tab clear everything except Subbasins and 
Junctions. 
 
Your export will vary according but these two elements will 
describe most of the analysis results 

 

 
In the field definitions tab you can trim down the data.  
Typically, you may only want the element ID and the peak flow. 
 
Finish the export 

 

 
In Civil3D open C-HYDR-GISS in the Task Pane > Data 
Connections > Shapefiles and browse to 02_GIS_GIS > 
02_FromSSA select the entire folder icon to load all the exports 
at once 
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In the load dialog select only those elements you exported from 
the GIS export wizard 
 
Ignore the <unknown> coordinate system, Civil3D will solve 
this on import. 

 

 
In the Task Pane > Layers click on the subbasins layer and 
choose edit style 
 
 

 

 
In the Edit Style dialog click in the first cell of the style column 

 

 
In the pop-up dialog delete the fill and alter the outline as 
desired. 
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In the Edit Style Dialog click in the Feature Label Cell to open 
the dialog. 
Set the Unit to inches, this is like annotation scaling to 
paperspace 
In Select Symbol choose “text” 
In text Content drop down select Use Expression to open the 
expression builder 

 

 
In the Expression Builder use the expression 
“Concat (ToString(AREA*640), ‘ sqft’, ‘\n’, 
ToString(TOT_RUNF),  ‘ cfs’)” 
 
This will create a label for the Area in square feet and the 
Runoff Flow rate in cubic feet per a second 

 

 
The result will place text inside each subbasins with the result 
of the SWMM model. 
Experiment building your own more elaborate expressions.  
Refer to Appendix C 

 

 
Repeat the steps to access the edit style dialog for the Junc 
layer.  Click the “New Theme…” button to open the Theme 
dialog 
Set the property to P_INFLOW 
Equal Distribution 
Number of rules 3 
 
Click on the ellipses beside style range 
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In the Style tab of the pop-up dialog 
Select a circle symbol 
Set a green to red fill range 
Turn up the transparency on the border 
 
This will color code the flow rates at junctions from low to high 
so you can visually see where high flow rates are located. 

 

 
In the Feature Text Label tab 
Set the Units to Inches 
In Text field click the expression builder button beside the field 

 

 
In the Expression Builder use the expression 
“Concat(ToString(P_INFLOW), ‘ cfs’))” 
 
This will put the flow rate beside each junction 

 

 
Notice back in the style editor the rules have been 
automatically populated in the table.  By adjusting the ranges in 
the Thematic Rules column you can define High, Mid, Low 
classes for the junction symbols.  Experiment with building 
elaborate symbols and labels 
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Use the command MAPEXPORTCURRENTMAPTODWG to 
create a DWG version of the map 
 
Name the file “ACAD-filename.dwg” 
 
Now you have a vanilla CAD drawing of the SSA output 
 

 

  
In SSA under the profiles tab > System check “Runoff” to 
create the output hydrograph. 
 
Click to open a menu > export > export to CAD 
Insert as a block into the “ACAD-filename.dwg” export from the 
previous step. 

 

4.4 Results to Civil3D Object Data 

 

Beginning with same shapefiles exported from SSA in 4.3 
Use the command MAPIMPORT 
 
Check Import polygons as polylines 
 
In the pop-up dialog click the ellipses beside drawing layer cell 
and choose the correct Civil3D layer 
Click the ellipses beside Input Coordinates cell and select 
Click the ellipses beside Data cell 

 

 
In the pop-up dialog select “Create Object Data”.  Select the 
Object Data Table and click on “Select Fields…” button 
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In the pop-up dialog you can choose which fields to read into 
the drawing and even modify the names to something more 
readable than the standard SSA output. 

 

 
The properties are now linked to the polylines in the drawing. 

 

 
To read out those embedded properties into labels.  In Task 
Pane > Data > Add Drawing Data > Query Current Drawing 

 

 
In the pop-up dialog select the “Data” button 
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In the pop-up dialog select Object Data.  Choose the table from 
the drop down and in the Object Data Fields choose, for 
example, “Area” and in the Expression at the bottom of the 
dialog box write “> 0” to read in every subbasin. 

 

 
Click on the new layer in Task Pane and choose Add Style > 
Text 

 

 
In the task pane highlight the SubLayer Text Style 
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Next pull up the Property Manager by using the command CH.  
Then in Display > Style Traits > Value click the small icon next 
to the field 

 

 
In the pop-up dialog choose Object Data > Subbasin > 
TOT_RUN_FLOW 

 

 
You can alter the properties of these text objects, and build 
more elaborate expressions. 
Note the syntax of these labels is different than the expression 
builder syntax from the previous section 

 

 
Use the command MAPANNTEMPLATE to create an 
annotation block 
In the pop-up dialog choose “New…” button 
 

 

 
Name the label block after naming Civil3D will automatically 
switch into Block Editor mode 



 

 

Page 45 

 

 
In the Block Editor use the command MAPANNTEXT to create 
a new attribute 
In the pop-up dialog set the layer to “0” and everything to 
“ByBlock” 
Set a font and a justification that makes sense for your design 
In “Tag” enter the attribute name 
In “Value” click the button beside the field 
 

 

 
In the pop-up dialog expand the tree Object Data > Subbasin 
and highlight the attribute 
 
Then “Ok” in each dialog. You will be prompted to pick an 
insertion point. Type “0,0” 

 

 
Repeat the process and add additional linework to make a nice 
looked label block 
When you are finished close the block editor 

 

 
Back in the annotation template dialog, set the layer and 
insertion point “.Center” is a good choice as it will force the 
label to always be inside the polygon 
 

 

 
Use the command MAPANNINSERT 
In the pop-up dialog check the Annotation Template “Subbasin” 
This is a chance to override any default properties 
Press “Insert” button and select all the subbasin polygons 
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Notice in the result the objects are blocks so you can affect the 
scale color and layer as needed. 
 
The best part is the potential to create a user-defined library of 
label blocks as needed by project. 

 

4.5 Theory of Advanced Visualization to Civil3D 
Advanced visualization takes more setup and organization, but it works better in situations 
where there is data being constantly updated, or when most of your workflow is running SWMM 
models. 

 
FIGURE 4.2 ADVANCED RESULTS WORKFLOW 

 
Advanced visualization works on a more complicated way of accessing drawing Object Data 
called “Query Attached Drawings” And what is an attached drawing you may ask?  Attached 
drawings are simply a deeper and more powerful Xref base.  If you are already familiar with Xref 
management it’s only a short step to master Attached Drawings.  Whereas, a Xref appears as a 
passive background, when Object Data is read-in through an Attached Drawing it can be styled.  
For example, flow rates below 10cfs can be colored red and flow rates above 10cfs colored 
green.  The graphics possibilities are infinite!  The act of reading-in the attached drawing and 
styling the Object Data is called “Query”.  The best part about queries is they can be saved and 
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reused, so if you put together something complicated with a result you like, you can use it every 
project afterward. 
 

4.6 Theory of Advanced Simulations 
So far we have looked at simulating and reporting a peak event which is typically one day long. 
A more advanced type of simulation called, continuous simulation looks at how the site will 
behave across a typical year.  In this simulation we look beyond a single heavy rainfall into more 
parts of the hydrologic cycle such as, evaporation, groundwater, and snow melt.  The results of 
this analysis tell us a lot about long-term performance, water balance, and especially the 
hydroperiods of different elements. 
 
These simulations rely on two external files a climate file and precipitation file. Both files are 
created NOAA downloads (Appendix A).  The files will come as CSVs and must be formatted 
before you can load them into SWMM.  It is important when running a continuous simulation that 
the analysis period in SSA analysis options matches the dates in the external files. 
 

4.7 Advanced Simulations Step By Step 

 

 
In SSA Analysis Options > Reporting set the time period from 
Jan 01 to Dec31 of the same year as the two downloaded 
CSVs 
Set all of the time steps to 1 day 

 

 
Open the Climate file CSV Save As “filename_formatted.xls”  
in 04_GIS_Table > 01_Climatology then delete column B 
“STATION_NAME” 

 

 
Create two new columns to the right of “DATE” columns 
 

 

 
Select the “DATE” column and go to Data > Text to Columns 
In the pop-up dialog select “fixed width” and click “Next >” 
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drag two dividers to separate year, month, and day click “Next 
>” 

 

 
Select each column and choose “text” and click “Finish” 

 

 
Delete the header row 

 

 
In the two columns to the right add an asterisk if there is no 
wind speed or evaporation data and copy to the final row Save 
As a plain text file tab delimited 
 

 

 
In SSA input > climatology set Temperature to external files 
and browse to “filename.txt” This will automatically set the 
evaporation and wind speed too. 
 

 

 
Open the Precipitation file CSV and use the same technique 
as the climate file to create a file with columns for station ID, 
year, month, day, hour, minute, precipitation depth. 
Save as a tab delimited plain text file “filename.txt” in 
04_GIS_Table > 01_Climatology then change the file 
extension from “txt” to “dat” 
 



 

 

Page 49 

 

 
In SSA rain gauges create a new rain gauge.  In the type drop 
down choose “external file” and browse to “filename.dat” copy 
paste the station name from column A into the station name 
field and set the Rain Units to “Inches” Assign this rain gauge 
to all subbasins 
 

 

 
Run the simulation.  Notice in the results you can now access 
options for temperature and losses will include evaporation 
 

 
 
 

5.0 Best Management Practices (BMP)  
 

Now that the grind of putting together a model is finished you can get to the fun part of SSA, 
adding Best Management Practices (BMP) to keep stormwater quality and quantity within the 
limits.  Much of BMP design is in the layout and the volumes which can be done brilliantly with 
Civil3D and spreadsheets.  When the time comes to link those BMPs up and see how they 
perform in a storm, then is the time for SWMM. 
There is no consensus on naming or classifying BMPs which leads to confusing duplications 
and murky schemes of categorization.  When it comes to SWMM, there is only one key question 
that defines two distinct categories of BMP, “Does this BMP require one storage node or 
multiple storage nodes?” 

5.1 Theory of Storage Nodes 
Like everything in SWMM the BMPs are compressed to 1D points with all the complexity 
compressed to three properties storage volume, exfiltration loss, and outlet control.  The real 
workhorse of BMP simulation in SWMM/SSA is the storage node.  It is useful to add node 
blocks in Civil3D where you will want storage nodes to be placed in SSA such as in the center 
of bioretention cells. Note, you can convert any junction into a storage node. 
 
Inside the storage node the main settings beyond the basic invert/rim settings are evaporation, 
exfiltration, and storage volumes.   

No Exfiltration Tanks, Lined Pond, UG Vaults 

Above Elevation Partially Lined Ponds 

At all Elevations Unlined Ponds, UG storage 
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The storage volume can be either functional (used for tanks) or a storage curve.  The storage 
curve is the key to BMP.  So what is a storage curve? In short, a table of depth vs volume.  For 
example, in the classic detention pond each depth contour has area/volume associated with it.  
 
Storage curves can be generated from contours in Civil3D or manually entered as a table in the 
curve editor.  Often, the fastest way is to make up a simple storage curve table in the editor so 
you can rough out the area volume depth relationship that works for the water volume and then 
try to fit it into the site. 
 
Most of the BMPs are modeled with a single storage node and single storage curve.  I term 
these as simple BMPs.  In contrast to simple BMPs, complex BMPs require 2 or more storage 
nodes with storage curves linked together. 
 

5.2 Simple Storage Nodes Step by Step 

 

 
Set Project Options > Infiltration to “Constant Rate Wetted 
Area”  
 
This is a great default setting if you are unsure or don’t care.  In 
short, it instructs SSA to let soil absorb water at a steady rate  
only on the surface area that the water is actually touching 
 
Enable overflow ponding at nodes 
 
This means everything that overflows from channels will 
eventually drain back into them 
 
If you are curious to know how much was overflowing into 
ponding, SSA will tell you in the very unhelpful volume units of  
acre-inches. (1 acre-inch = 53 1/3 cubic feet) 
 

 

 
Click on each Junction to convert to storage nodes 
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In the pop-up dialog define the storage parameters, in this case 
for a bioretention cell (rain garden). 
 
The ponded area is the footprint of the bio cell 
The evaporation is zero 
The Exfiltration is at all elevations 
The Exfiltration rate is for USDA Soil C (0.27 in/hr) 
The Storage type is a user-defined curve 

 

 
Assuming that the storage node has been set up as a simple 
infiltration cell (5.1) In the storage node dialog pick the storage 
curve button 

 

 
In the storage curve dialog press Add 
For this example, assume 10’ x 20’ infiltration cell has 1’ of 
storage volume with 3:1 side slopes and 3’ of underground 
gravel wrapped in geotextile.  What is the curve to describe 
that? 
 

 

 
Set the Storage Curve to Depth vs. Area 
Row 1 is the bottom of the BMP and the Depth counts upward 
in positive units. 
 

 

 
Set the depth for Row 1 to 1’ set the use the area formula 
Length x Width x Void Factor. For example, 4*14*0.6 = 33.6 for 
Row 1 
 

 

 
Copy and Paste to Row 2 and Row 3.  On Row 4 use 
10*20*1=200 
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On the curve you can, in a sense, “read” the vertical drop of the 
3’ block of underground gravel and 3:1 tapered volume on top 
of it (green line) and the storage volume increasing rapidly in 
the underground gravel block and then more slowly in the 3:1 
tapered volume on top (red) 
 

 
 

5.3 Theory of Complex BMPs 
Unlike the classic detention pond, the newer and more complex BMPs, like bioretention cells, 
infiltration trenches, and bioswales, have components of surface storage, underground storage, 
channels, and pipes all in the same element.  There is no purpose-built element in SSA for 
them.  How best to approach modeling them?  Using the principle of functional equivalence, you 
can break a BMP of any complexity into simpler elements and model them.  A great example of 
functional equivalence is a discussion of breaking down a complex weir in the SSA manual 
(pg333). 
 

 
FIGURE 5.1 BIORETENTION CELL 

 
In a bioretention cell (rain garden, flow through planter) two storage node for surface pool and 
subsurface gravel are linked together with a very small orfice called a water quality orifice 
(WQO) which simulation the infiltration through the soil or mulch mix. 
 

 
FIGURE 5.2 INFILTRATION TRENCH 

 
In the infiltration trench, a long channel with a pervious bottom and several feet of gravel 
underground is functionally equivalent to water that fills up an underground storage chamber 
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which then pours into the channel and flows over weir as long as the trench into an open 
channel. 
 

5.4 Theory of Water Quality 
In my experience water quality calculations are primarily volumetric in nature and therefore, can 
be done in a spreadsheet.  Remember SWMM is used for time-mass calculations.  Using 
SWMM does not seem to add much additional information.  For example, do you really need to 
know when peak rate of TSS entering a bio cell or just the total first-flush volume? 
 
Nevertheless, no discussing of storage nodes would be complete with discussing water quality. 
Water quality modeling in SWMM has two parts, generation and removal.  Generation tells you 
how much pollution your site design will generate. Removal is, obviously, how much you can 
treat in BMPs.  SWMM water quality treatments can be added anywhere, but its best to add 
them only at storage nodes because they conceptually represent the BMPs.  In general, 
treatment lets user-defined pollutants hitchhike on the water as it is routed through the system.  
As it passes from BMP to BMP more and more pollutants are removed. 
 
Just like in the real world, in the simulated world of SWMM pollution can have either point or 
non-point sources.  The non-point is generated in the subbasin objects based on the land types 
in each subbasin, which brings us back to GIS.  Using a similar technique to creating landcover 
area split by subbasin ID, we can create pollution landtypes split by subbasin ID. 
 

Appendix  
 

These are meant to supplement the text on an as-needed basis to deal with issues that may 
arise during GIS operation and SSA model creation.  

Appendix Purpose 

A Where to find GIS data to fill in missing information 

B How to use QGIS for common tasks 

C Whitepapers, website, and other technical resources for further reading 

D Files for download on the AU site 

 

Appendix A: GIS Data 
If you are lucky you will have the data delivered from a survey.  That is exceedingly rare.  If you 
do not have soil data, landcover, and topography for the ENTIRE watershed(s) that your site 
occupies, getting it is the first step.  In the worst case even with no survey, no free data on the 
county/city website you always have the USDA and NOAA.  Often the scale is not as precise as 
the site design, but don't worry it gives a good enough baseline, and it can only get more 
accurate! 
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FIGURE A.1YOUR ONE STOP SHOP FOR MISSING INFORMATION 

 
Within the USDA is the Natural Resource Conservation Service (NRCS) formerly called the Soil 
Conservation Service (SCS).  You may recognize SCS from many menus in SSA.  They were 
responsible for developing the popular TR-55 method and Curve Number.  Although this data 
can be found on the USGS National Map as well the NRCS website is better because the data 
is delivered with a projected coordinate system. 
 

Data America International 

Soils Soil UN Food and Agriculture Organization 

Landcover National Landcover Database USGS Landsat 

Hydrology National Hydrology Database USGS Hydrosheds 

Topography National Elevation Database USGS Hydrosheds 

Climate Climate Data Online Global Historic Climate Network 

 

Data Acronym PCS GCS WKID 

Soils SSURGO - WGS84 4326 

Landcover NLCD UTM NAD83 26911 

Hydrology NHD UTM NAD83 26910 

Topography NED UTM NAD83 4269 

 
Soils come in the SSURGO format which is a zip file with shapefiles and tables in TXT format.  
Use the shapefile “soilmu.shp” to load into GIS.  The suffix “mu” stands for MAP UNIT, as in a 
polygon of soil. “soilmu.shp” has the columns MUKEY and MUSYMB.  MUKEY links to a vast 
table of soil properties.  You will need to create this table and join it to “soilmu.shp” to find the 
Hydrologic Soil Group for each soil polygon.  There are two possible workflows for this, the 
preferred method is to use MS Access, but there is an alternate method if you don’t have MS 
Access using QGIS addressed in Appendix B. 
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A.1 Preparing SSURGO soils step by step 
 

 

 
Extract the ZIP folder to a temporary location. Copy the 
shapefile “soilmu.shp” the folder 01_GIS_SHP 

 

 
Open the MS Access MDB file a macro screen should appear 
copy and paste the location of the folder “tabular” 

 

 
After Access builds the table base go to Table and open 
“muaggatt” table then click to Export to Excel.    
 
Create an ODBC connection to the exported table and use the 
join procedure to connect it to soil shapefile using MUSYM as 
the target key and join key 
 
In Civil3D Bulk Copy to SDF only “Name”, “Key”,” HSG” 
properties 
 

 
Note, any <NULL> fields which will show as blank in a spreadsheet are converted to “C” per the 
procedure outlined by Purdue Civil Engineering Department. 
 

USDA Hydrologic  Composition Infiltration Rate 

A sand, loamy sand or sandy loam 5.27 in/hr 

B silt loam or loam 1.02 in/hr 

C sandy clay loam 0.27 in/hr 

D clay loam, silty clay loam, sandy clay, silty clay or clay 0.02 in/hr 
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FIGURE A.2 USDA SOIL TRIANGLE 

 
Landcovers come from the National Landcover Database (NLCD) They use a numeric code to 
represent landtypes.  For many sites, it is often more accurate to digitize an aerial image of the 
site context and draw off-site landcover polygons in Civil3D. 
 

NLCD92 Description NLCD92 Code 

Open Water 11 

Perennial Ice/Snow 12 

Low Intensity Residential 21 

High Intensity Residential 22 

Commercial 23 

Bare Rock 31 

Gravel Pit 32 

Transitional 33 

Deciduous Forest 41 

Evergreen Forest 42 

Mixed Forest 43 

Shrubland 51 

Orchards 61 

Grasslands 71 

Pasture 81 

Row Crops 82 

Small Grains 83 

Fallow 84 

Urban  85 

Woody Wetlands 91 

Wetlands 92 
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Sometimes depending on the scale its useful to have information from the National Hydrology 
Dataset (NHD) which can help locate watershed boundaries and streams as you try to define 
your study area and discharge points. 
 
Also useful for finding watershed and subbasins boundaries is the National Elevation Dataset 
(NED).  The NED is a set of DEM raster files which can be used to generate contours for terrain 
outside your survey area necessary to find the edges of some subbasins. 
 
SSA already has the NOAA-14 table for rainfall hardcoded.  For climate data inputs use the 
National Atmospheric and Oceanic Administration (NOAA). Climate data comes in the form of 
CSV tables. 
 

 
FIGURE A.3 YOUR ONE-STOP SHOP FOR CLIMATE DATA 
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Appendix B: Working with Quantum GIS 
Quantum GIS (QGIS) is a free and open source GIS platform which is useful to format GIS data 
to feed into Map3D.  It is also useful as a backup when Civil3D fails, such as during a table join.  
Other than Join, the most common tasks you may need do to prepare data in QGIS are clipping 
and reprojection.  Clipping is for datasets that are too large and crash Civil3D.  Reprojection is 
for datasets that land in the wrong place.  Note reprojection must take place before clipping to 
ensure proper output.  This is especially important for raster that have no projections. 
 

B.1 Prepare SSUGRO data in QGIS 
 

 

 
In QGIS set the model coordinate system to match the Civil3D 
file.  A good way to check this is the with the Well Known ID 
(WKID) number.  WKID are generated by different 
organizations called authorities the most common is the 
ESPG, and for this reason ESPG code is often used to mean 
WKID 

 

 
In Civil3D > Prospector > Settings > Units and Zone copy the 
coordinate system code 

 

 
Create a new SDF file “DummyCoord.sdf” in 03_GIS_SDF 
In the pop-up dialog press the ellipses button. 

 

 
In the dialog paste the coordinate system code into the search 
box 
The result will show you the WKID in the seventh column 
(ESPG code) 
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In QGIS click the project coordinate system and in the pop-up 
dialog enter the WKID from Civil3D 

 

 
In layer > add layer > add vector layer load “soilsmu.shp” 

 

 
Click on the layer and choose properties. 
Change the name to “Soil” 
Set the coordinate system to match the project WKID 
 

 

 
Extract “muaggatt.txt” from the SSURGO ZIP file > tabular 
data into 05_GIS_Table 
 

 

 
In Layer > Add Layer > Add Delimited Text Layer load 
“muaggatt.txt” 
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In the pop-up dialog 
Set the geometry definition to no geometry 
use the pipe symbol ” | “ as the delimiting character. 
 

 

 
Click on the Soil layer > properties > joins 
Create a join to layer muaggatt using MUSYM as the target 
key and column 1 as the join key.  Only add the field column 
18 this is the Hydrologic soil group 
 

 

 
Click on the Soil layer> Save As and save an SQLite file 
named “Soil.sqlite” in 03_GIS_SQLite 
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B.2 Joining Subbasin Tables to Subbasins 

 

 
In C-HYDR-GISS.dwg > Task Pane Click on the layer 
“Basin_HID” and choose export to SQlite 
Save the file as Basin_HID.sqlite in the folder 03_GIS_SQLite 
 
In QGIS Layer > Add Layer > Add Vector Layer browse to 
“Basin_HID.sqlite” 
 
 
 

 

 
Click on layer “Basin_HID” in properties > and set the layer 
CRS to match the Civil3D file 
 

 

 
In QGIS Layer > Add Layer > Add Delimited Text 
 
In the pop-up dialog choose file format CSV 
First row has field names 
No Geometry 
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Click on layer “Basin_HID” in properties > Joins click on the 
plus to create a new join 
 
In the Join dialog choose “CalcSubbasin_Jointable” 
Join Field “HID” or “Key” 
Target Field “HID” 
Don’t select Area or HID these already exist in the target 
Choose “_” as the prefix for joined columns 
 
 

 

 
Save the layer as a shapefile “SSA-POLY.shp” in the folder 
02_GIS_SHP > 01_ToSSA 
 
Be sure the CRS is correct 

 
 

B.3 Reprojecting DEMs for Clipping 

 

In QGIS Layer > Add Layer > Add Raster Layer browse to the 
DEM file 
 
Name the layer USGS and note the coordinate system 
 

 

 
Go to Raster > Projection > Warp (Reproject) 
In the Dialog choose the input as “USGS” layer and 
“USGS_rpjt.tif” in folder 01_GIS_Raster as the output 
 
Then select the Target SRS as the same WKID as the 
Civil3D/QGIS project projected coordinate system 
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B.4 Clipping DEMs for Offsite Topography 

 

 
In C-HYDR-GISS.dwg sketch out a rectangle around the 
approximate extents of the watershed containing the site 
It is helpful to have the rectangle in integer dimensions and 
have a Lower Left corner at an integer position. Use the 
MAPEXPORT function to create an SQLite file “Extents.sqlite” 
in the folder 03_GIS_SQLite 
 

 

 
In QGIS Layer > Add Layer > Add Vector Layer Browse to 
“Extents.sqlite” 

 

 
In QGIS Raster > Extraction > Clipper… 
In the dialog choose extent from layer “Extents” 
Save the output as USGS_clip in folder 01_GIS_RasterGrid 
 
 
 

 

 
In Civil3D C-HYDR-GISS.dwg Task P”ne > Data > Data 
Connections > Raster and load the file ‘USGS_Clip.tif” 
 

 

 
Click the layer “USGS_Clip” and Edit Stye.  In the edit style 
dialog choose Theme > Palette > USGS DEM 
 
This background can help define watershed boundary 
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Click on the layer ‘USGS_Clip” and choose create contours 
In the dialog choose settings that match the contour density 
you may need for the project. 

 

 

Appendix C: Resources 
Resource Location 

My original open channels post https://forums.autodesk.com/t5/autocad-civil-3d-forum/how-to-
model-open-channels-in-ssa-v1-0/td-p/5882884 

Purdue missing soils technique http://web.ics.purdue.edu/~vmerwade/tutorial.html 

SSA pipes import class http://au.autodesk.com/au-online/classes-on-demand/class-
catalog/2014/autocad-civil-3d/cv5486-p#chapter=0 

QGIS official page http://www.qgis.org/en/site/ 

Map3D expression syntax http://help.autodesk.com/view/MAP/2016/ENU/?guid=GUID-
59701A39-6FA5-41AE-9619-1B5B5FB53990 

Map3D Multipolygon Help files https://knowledge.autodesk.com/support/autocad-map-
3d/learn-
explore/caas/CloudHelp/cloudhelp/2016/ENU/MAP3D-
Use/files/GUID-68B6FCC8-F4EB-4EC0-8C34-
EA0C7F36E4E0-htm.html 

Notepad++ https://notepad-plus-plus.org/ 

Classic TR-55 manual http://www.nrcs.usda.gov/Internet/FSE_DOCUMENTS/stelprd
b1044171.pdf 

Classic EPA BMP design 
manual 

https://www3.epa.gov/region1/npdes/stormwater/assets/pdfs/B
MP-Performance-Analysis-Report.pdf 

CI2416-L River Analysis http://au.autodesk.com/au-online/classes-on-demand/class-
catalog/2013/infrastructure-design-suite/ci2416-l 

CI2170 http://au.autodesk.com/au-online/classes-on-demand/class-
catalog/2013/infrastructure-design-suite/ci2170#chapter=0 

CI2413 http://au.autodesk.com/au-online/classes-on-demand/class-
catalog/2013/infrastructure-design-suite/ci2413#chapter=0 

 

Appendix D: AU Additional Files Manifest 
Filename Description 

AccessDatabaseEngine_X64.exe Missing excel driver of ODBC connections 

SSA_DOM.zip The document object model for data roundtrips 

SWMM_Civil3D_Styles.dwg Civil3D parcel and feature line styles 
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SWMM_Layers.dwg CAD layers 

SWMM_Node_Block.dwg CAD block for open channel design 

SSA_Basins. A QGIS layer style for SSA subbasin polygons 

CalcSubbasinTemplate.xlsx Template for table calculations 

 


