Using the New Geometry and Meshing Tools in Autodesk CFD

Heath Houghton
Autodesk

Learning Objectives

- Learn how to use the Model Assessment Toolkit in Autodesk CFD 2016
- Learn key functionality in SimStudio Tools that will help you be more productive
- Understand when and how to use surface wrapping with Autodesk CFD 2016
- Understand what is in the CFD 2017 Beta for surface wrapping

Description

One of the main development efforts regarding Autodesk CFD software has been to reduce time that users spend on the tasks of altering geometry and meshing. There have been several new major features and tools added to the product as part of this focus. The aim of this class is to inform and teach about how to gain productivity and greatly reduce your model-preparation time using these new tools. This class will include instructional demonstrations on how to use the new Surface Wrap tools, Model Assessment Toolkit, and SimStudio Tools for Autodesk CFD software. We will show a live demonstration of these tools in action. There will also be some demonstration of further enhancements for geometry and meshing available in the Autodesk CFD 2017 Beta software scheduled to be available at the time of Autodesk University 2015.

Your AU Experts

Heath Houghton is the product Manager for Autodesk CFD. Heath joined Autodesk with the acquisition of Blue Ridge Numerics (CFdesign). Heath was in a Technical role with Blue Ridge Numerics for 4 years, and continued that role with Autodesk. As a technical specialist, Heath supported technical sales through customer-facing engagements, worked with the Autodesk partner network, and provided development feedback and guidance for Autodesk’s suite of simulation tools. Heath has 18 years of experience using advanced simulation tools.

Heath’s prior experience includes being a Special Projects Engineer at a manufacturing company in San Marcos, TX. Heath used simulation tools to manage the thermal and structural challenges for projects in the petrochemical, power, water management, and transportation industries. Heath has his B.S. in Engineering Science from Trinity University.
Using the New Geometry and Meshing Tools in Autodesk CFD

CFD 2016 Model Assessment Toolkit

Model Assessments Toolkit: What is it for?
The model assessment toolkit is a new set of functionality added to CFD 2016. How many times have you imported a model into a simulation package, only to have the mesher fail in meshing the model or create a poor mesh? How many times have you made it through the mesh process only to end up with poor simulation performance or results? Autodesk® has added the Model Assessment Toolkit (MAT) to our CFD product to help you avoid some of these costly inefficiencies. The MAT provides you with tools to assist you in getting the fluid volumes you want before moving on to the other steps. Using the tools in conjunction with your engineering judgment and knowledge of your application can help make your simulations more effective and efficient.

**Edge Lengths**
Small part edges require fine mesh seeding which can significantly increase mesh counts. Small edges can also introduce local discontinuous behavior in the mesh length scales which negatively impacts solution accuracy. Use the **Edge Lengths** tool to assess your model for potential small edge issues.

The following image shows our frame assembly model with the **Edge Lengths** tool active. Given the initial edge length filter setting of 2 mm, you see 780 potential edge length issues.

However, a quick scan of the issues table shows all but eight edge lengths are at, or above, 1 mm. So, by adjusting the Edge length slider to less than 1 mm, we eliminate all but eight issues from the table.
When you select the table entries and select **Auto zoom** and **Emphasis**, you see four of the potential edge length issues on the corner bracket.
By rotating and zooming the view, we see 2 of the potential edge issues on the corner bracket where the bend and chamfer occur.

Most likely, the short edge length is not important relative to the simulation. As a result, we can return to Inventor and remove these edges to avoid high mesh density.
**Surface Slivers**

Similar to short edges, small surfaces on parts can also result in mesh length scale issues. Use the Surface Slivers tool to assess your model for small surfaces that may challenge the CFD mesher.

Returning to our model and using the Surface Slivers tool with a filter size just over 0.4 mm, we find eight surface issues on the corner brackets.

When we manipulate the view to find those surfaces, it is no coincidence that the surfaces correspond to the short edge lengths we previously located.
As with the short edges, modeling these small surfaces is, most likely, not important relative to the simulation. As a result, we can return to Inventor and remove these surfaces to avoid high mesh density.
**Part Gaps**

Similar to short edges and small surfaces, small gaps between surfaces on a part can result in mesh length scale issues. Use the **Part Gaps** tool to assess your model for small gaps that may challenge the CFD mesher.

Returning to our frame assembly model and using the **Part Gaps** tool we find sixteen gap issues on the two corner brackets.

When we manipulate the view to find the gaps, we see they occur where edges of the brackets nearly touch.
Modeling these small gaps is, most likely, not important relative to the simulation. As a result, we can return to Inventor and eliminate the gaps to avoid high mesh density.

**Model Slivers**
Assembly parts can interface such that surfaces with large aspect ratios, also known as sliver surfaces, are created. Sliver surfaces require fine mesh seeding which can significantly increase
mesh counts. Sliver surfaces can also introduce local discontinuous behavior in the mesh length scales which negatively impacts solution accuracy. Use the **Model Slivers** tool to assess your model for potential sliver surface issues.

The following image shows our electronics enclosure assembly model with the **Model Slivers** tool active. The initial sliver size filter setting defaults to 0.2032 mm, resulting in 4 potential sliver issues.

When you select the table entries and **Auto zoom** and **Emphasis**, you see the potential sliver issues at the interfaces of the chips and heat sinks.
By rotating and zooming the view, we see a small offset between the edges of the heat sinks and chips. If you transferred this model into CFD in the current configuration, these offset edges would result in the creation of small sliver surfaces.
Most likely, this small offset is the result of improper applications of assembly constraints. As a result, we can return to Inventor and apply the proper constraints to eliminate the small offset at the interfaces.

**Model Gaps**

Similar to model slivers, small gaps between assembly parts can also result in mesh length scale issues. Use the **Model Gaps** tool to assess your model for small gaps that may challenge the CFD mesher.

Returning to our model and using the **Model Gaps** tool, the initial filter size setting defaults to 0.127 mm resulting in 4 potential gap issues.

Rotating and zooming the view, we see small gaps between the capacitors and board.
Clearly, these gaps are not reflective of our physical design and should be eliminated before the model is transferred to CFD. Therefore, we return to Inventor and apply proper constraints to eliminate the gaps between the capacitors and board.

SimStudio Tools 2016

SimStudio Tools: What makes it different than my CAD package?
Use Autodesk® SimStudio to prepare geometry for your simulation applications. Once your model is complete, export the geometry to a file or push to one of your simulation applications. What makes SimStudio Tools unique is that there is functionality that is specific to building effective simulation models. There are too many features to cover in one 60 minute class, let alone one segment of a 60 minute class, so we will concentrate on some items that have been most beneficial for CFD analyses.

Quickly change view styles to understand the assembly

Component Color Cycling Toggle
This command is very helpful to differentiate different components in the assembly.
Use **INSPECT** ➤ **Component Color Cycling Toggle** to apply a different color to each component.

**Transparent Surfaces Toggle**
Sometimes models look like they are made up of solids, but instead are surface parts. This toggle helps you quickly see which is surfaces versus solids.

Use **INSPECT** ➤ **Transparent Surfaces Toggle** to make all surfaces transparent.

**Select by Size**
Often times there are many components in an assembly that we just simply want to eliminate or suppress because they are too small to have an effect on our simulation other than to increase complexity and solve-times due to dramatically increasing the mesh count.

Use **SELECT** ➤ **Selection Tools** ➤ **Select By Size** to select objects based on size.

**Command Highlights:**
- Drag the Size sliders, or enter values in the dialog box fields, to set the minimum and maximum object sizes.

Use **SIMPLIFY** ➤ **Replace with Primitives** to replace selected objects with primitive shapes.

**Command highlights:**
- Cursor-based tooltips guide you through the process.
- Use the manipulators and dialog entry fields to set the **Length** and **Radius** values, as appropriate.
- To set dimensions, you can also click the dialog drop-down arrows and select **dimensions**, **Measure**, or **Re-anchor**.

**Scripts**
SimStudio tools has an API that can be used to execute commands that might be tedious to do manually or to give additional streamlined functionality. There are several scripts that are included with the installation. One sample script that has been found to be useful when deleting bodies from the model is the **DeleteEmptyComponents** script.

Use **Application Menu** ➤ **Scripts** ➤ **Run DeleteEmptyComponents**

The script will look at all the components in the assembly and delete the components that don’t have any bodies in them.

**Replace with Primitives**
Use **SIMPLIFY** ➤ **Replace with Primitives** to replace selected objects with primitive shapes.

**Command highlights:**
• Cursor-based tooltips guide you through the process.
• Use the manipulators and dialog entry fields to set the Length and Radius values, as appropriate.
• To set dimensions, you can also click the dialog drop-down arrows and select dimensions, Measure, or Re-anchor.

SimStudio Tools 2016 and Model Assessment Toolkit combo

Use these two tools together to quickly idealize your simulation model
Using some of the analytics from the model assessment toolkit to understand where a model may not be ideal for simulation and then using SimStudio Tools to quickly change that status is why these tools were introduced.

Part Gaps
In the live demonstration, there is a rip in the sheet metal that is not desirable. It causes a very small part gap (self-gap). We fix the part gap shown by using the direct modeling capability in SimStudio Tools.
**Model Gaps**
In the live demonstration, we fix the model gaps shown on this electronics assembly (Autodesk Ember). There are three components not mated properly to the PCB as shown below and we use SimStudio Tools to quickly fix that situation.

![Model Gaps](image)

**Surface Wrap for Autodesk CFD 2016**

**When does it make sense to just surface wrap the model?**
Use Autodesk® Surface Wrap to surface wrap a model, add an external volume, and generate a quality mesh for import into Autodesk® CFD. You can easily generate a mesh for CAD models that might otherwise be difficult or impossible to mesh without extensive CAD cleanup. Currently, Surface Wrap meshes are appropriate for external flow analyses or wind tunnel type models. The workflow steps are provided in this handout, but this will be shown live in class.
General Workflow

1. Use Home ➤ File ➤ Open to read in your model.

2. Set up your model in the wind tunnel bounding-box.
   - Click Home ➤ Setup ➤ Bounds to activate the box.
   - Size the box using the manipulators, or enter values in the browser entry fields.
   - To skew the model relative to the box, click Home ➤ Setup ➤ Orient and drag the smaller box.

3. Use Home ➤ Surface ➤ Surface Mesh to wrap your model. Notable highlights:
   - High values for Model surface automatic repair precision gives you a mesh that closely represents the physical model.
   - Larger values for Surface mesh gradation proximity bias give you a finer mesh for parts close to one another.

   **Note:** View and modify your surface mesh before volume meshing as the latter tends to be resource-intensive.

4. If appropriate, use Home ➤ Refinement ➤ Refinement to add volume refinement regions.
   - Use the checkboxes in the browser to view the refinement region and other objects.
Using the New Geometry and Meshing Tools in Autodesk CFD

- Specify the target mesh size within the refinement region with the **Refinement factor**.
- As with the bounding-box, you control the refinement region size with manipulators and browser entry fields.
- To modify or remove a refinement region, right-click the region in the browser tree and select the appropriate command.

5. Create your volume mesh with **Home ➤ Volume ➤ Volume Mesh**.
- Use **View ➤ Clipping ➤ Clipping** to view the internal mesh.

6. Click **Home ➤ File ➤ Save As** to export your mesh for use with CFD.
- Save to Universal (*.unv) or Nastran (*.nas) CAD mesh file formats.
- You can also save to Surface Wrap (*.cdfw) format for future modification.

7. In CFD, **create a new design study** and import your mesh.

**Surface Wrap for Autodesk CFD 2017 Beta**

**A sneak preview at the workflow improvements for surface wrapping**

The same basic premise of when and why you might surface wrap a model are true in CFD 2017 Beta, but the workflow is no longer a stand-alone application. We have integrated the surface wrapping into the Model Assessment Toolkit interface. If you are doing external flow and think it will take way too long to fix the model, surface wrap it and save a ton of effort. We now treat the surface wrap as if it is geometry and mesh it inside of CFD very similarly to a CAD model. We think this will make a quicker and more intuitive workflow. There will be live demonstration of this in the class along with discussion of where we are headed with this technology.