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GEN20664  

Data Mining in AutoCAD with Data Extraction 
Ben Rand 
Job Industrial Services, Inc. 
 

 

Description 

Your drawings are a potential gold mine of information. Learn how to get the most out of your 
AutoCAD drawings using the powerful Data Extraction tool. Learn how to build automated bills 
of material, drawing title sheets, coordinate tables and more. Learn how to extract data to 
AutoCAD software tables or Microsoft Excel files. This session features AutoCAD. 
 
Your AU Expert(s) 

Ben began his career in AutoCAD as a part time job while studying English at Brigham Young 
University. After a year of teaching 6th and 7th grade, he returned to architecture and AutoCAD. 
He taught himself to program first in AutoLISP, then VBA to speed up repetitive drafting tasks. 
He taught as an Autodesk Certified Instructor at Salt Lake Community College, covering 
AutoCAD, LISP and VBA programming for AutoCAD, and 3DS Viz and Max. In 2002, he took a 
job as CAD Manager for an industrial engineering firm, and has worked in that industry ever 
since. Ben now spends most of his professional time developing in C#. At AU 2013, he won the 
overall AUGI Top DAUG prize, not bad for someone who hasn’t done production drafting in 
many years. He is currently an AutoCAD Mentor All-Star, helping AutoCAD and AutoCAD LT 
newbies during their software trial. Ben was a speaker at AU2015, is an avid reader, and also 
enjoys tennis, racquetball, volleyball, and pickleball.

Learning Objectives 

 Learn how to use Data Extraction to create tables based on drawing data 
 Learn how to use Data Extraction to extract data across multiple drawings 
 Learn how to link Excel spreadsheets with extracted data 
 Learn how to customize data extraction using sorting, filtering, formulas, and totals 
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Introduction  

We all know that our drawings are valuable tools used to convey information about our design to 
other people so that what we design can be built. Some of this information is easy enough to 
read by looking at dimensions and other annotations on the drawing. 
 
But did you realize that there’s a potential gold mine of other information lurking in your 
drawings? Unfortunately, designers often don’t realize they have some very powerful tools for 
digging out this valuable ore, and putting it to work for them. 
 
In this class, we’ll be exploring the powerful Data Extraction tool and how you can put it to good 
use in your drawings. Along the way, we’ll also look into some other related tools that can help 
boost your productivity. 
 
Data Set 

The sample data set provided with the class materials includes several drawings and a sheet 
set named AU2016.dst which I’ll be using throughout the presentation. The sheet set isn’t 
important for working through the examples, but does it make it easier to open the referenced 
files as you follow along. The sample data set includes: 
 Floor Plan Sample.dwg—an architectural floor plan 
 MH-1115-FC-109.dwg—a structural foundation location plan 
 Landscaping.dwg—a landscaping site plan 
 Arch Drawings\A-00 Index to Drawings.dwg—part of an architectural set of drawings 
 Arch Drawings\A-01.dwg—part of an architectural set of drawings 
 Arch Drawings\A-02.dwg—part of an architectural set of drawings 
 Arch Drawings\A-03.dwg—part of an architectural set of drawings 
 Arch Drawings\A-04.dwg—part of an architectural set of drawings 
 Mechanical - Data Links.dwg—a Piping and Instrumentation diagram 
 Mass-balance.xls—an Excel file 
 104.dwg—an instrument mounting detail 
 301.dwg—an instrument mounting detail 
 403.dwg—an instrument mounting detail 
 D01.dwg—a drawing with a border to be used to create a details drawing 
 Keynote Sample.dwg—a sample to demonstrate architectural keynoting 
 CSI.xlsx—an Excel file 
 
Use Data Extraction to Create Tables Based on Drawing Data 

Let’s start with an architectural example Floor Plan Sample.dwg. In this drawing we have a floor 
plan of one floor of an office building. The plan includes offices, cubicles, and other rooms, and 
identifies where major furniture (desks, chairs, etc) are located along with standard office 
equipment such as phones and computers. 
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FIGURE 1 FLOOR PLAN SAMPLE 

 
Suppose you are given the task of counting how many desks, chairs, phones and computers 
are in the layout. How would you proceed? Would you zoom into one corner of the building, 
make a count of all the phones in that area? Then pan around the drawing until you had them all 
counted, and write it down? Then start over to count the desks and so on? If that sounds 
tedious and error-prone, good. It is. Surely there are better ways. 
 

Recommended Drafting Practices 
Before we get into Data Extraction, let’s look at some recommended drafting practices that help 
facilitate good results from Data Extraction. 
 
First, notice that each desk, chair, phone, computer, door, etc. in the sample drawing is a block. 
Blocks allow us to compose common geometry such as lines, circles, etc., into reusable 
symbols. Blocks can also have attributes which are a special type of text that can be changed 
with each instance, or insertion, of a block. For example, a door block might have a 
DoorNumber attribute which can be changed to a unique number for each “door” symbol 
inserted into the drawing. 
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FIGURE 2 BLOCKS COMBINE SIMPLE GEOMETRY TO FORM REUSABLE SYMBOLS 

 
 
Second, notice that items have been placed on layers which help separate drawing elements by 
their function, not their appearance. Open the Layer Property Manager and you’ll see layer 
names like Phones, Chairs, Furniture, and CPU. 
 

 
FIGURE 3 GOOD LAYERING SEPARATES GEOMETRY BY THE FUNCTION IT REPRESENTS 

 
 
To summarize: use blocks to represent symbolic geometry as much as possible, and use layers 
to separate items by function or type rather than by appearance. 
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Layer Isolate / Layer Unisolate 
Isolating layers is a good way to see what content is on them. Let’s try using this command to 
find how many phones are in the design. 

 
Exercise: 
 
1. Select Home tab > Layers panel > Isolate (the LAYISO command). 
 

 
FIGURE 4 LAYER ISOLATE COMMAND 

 
2. Select the Settings option, then choose Off twice. 
3. Select any one of the phone blocks and press Enter. 
4. Zoom to Extents (Z <space> E <space> at the command prompt) and draw a 

selection window around all the phones. 
5. Right-click and choose Properties to see a count of the phones. 
 

 
FIGURE 5 SELECTED OBJECT COUNT IN PROPERTIES 

 
Did you find 51 objects? If so, that’s great. However, that answer really only tells you that 51 
objects were placed on that layer. You can’t be sure that these are blocks of the exact type 
(FNPHONE) you’re looking for. 

 
6. Select Home tab > Layers panel > Unisolate (the LAYUNISO command) to undo 

the layer isolation. 
 

 
FIGURE 6 LAYER UNISOLATE COMMAND 

 

Quick Select 
Quick Select is a handy tool to use when you need a quick answer. For example, what if you 
need a quick count of how many “DESK3” blocks there are in the drawing? Isolating the 
FURNITURE layer as we did previously would be less helpful because there are many different 
furniture symbols on this layer. Let’s try using Quick Select for this answer. 
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Exercise: 
 
1. On the ribbon, go to Home > Utilities, then click Quick Select (the QSELECT 

command). 
 

 
Figure 7 Quick Select 

 
2. Change Apply to to Entire drawing. 
3. Change the Object type to Block Reference. 
4. Change the Properties to Name. 
5. Verify the Operator is set to Equals. 
6. Change the Value to DESK3. 
 

 
FIGURE 8 QUICK SELECT SETTINGS 

 
7. Click OK. 
 

All the DESK3 blocks are selected in the drawing, and a count is displayed—8 in our sample. 
 

While both of these techniques have value, especially for quick answers, the output is not 
exactly reusable or updateable in a meaningful way. What if we need to have this information 
show up in a report or a table on the drawing? What if the design is still evolving and we later 
need to recount? We’d have to repeat all these steps to get an updated count. Too much work. 
 

Create tables using Data Extraction 
Continuing with our architectural example Floor Plan Sample.dwg, let’s do something more 
practical: build a room schedule which will appear as a table in our drawing. 
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Exercise: 

 
1. Create a layer named Schedules and make it the active layer. 
2. On the ribbon, go to Insert > Linking & Extraction, then click Extract Data. 

 

 
FIGURE 9 EXTRACT DATA COMMAND 

 
3. Select Create a new data extraction, then click Next. 

 

 
FIGURE 10 DATA EXTRACTION, STEP 1 

 
4. Select a folder and file name for your DXE file, I’ll name mine RoomSchedule.dxe1. 

Click Save to move to the next step. 
5. By default, Autocad includes the current drawing as the Data source, but you can 

also include other drawings, which we’ll look at later. 
 

                                                
1 Typically I like to keep my DXE files in the same directory as the source drawing(s), but this is not strictly 
required. 
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FIGURE 11 DATA EXTRACTION, STEP 2 

  
6. Click Next. 
7. Right-click the list of objects and choose Uncheck all. 
8. Locate the RMNUM block and check it, then click Next. 

 

 
FIGURE 12 DATA EXTRACTION, STEP 3 

 
9. Scroll through the list of available properties to see what is available. When you’re 

done, uncheck all properties except for the NUMBER attribute, then click Next. 
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FIGURE 13 DATA EXTRACTION, STEP 4 

 
10. Uncheck the Show count and Show name column boxes. 
11. Click on the NUMBER column to apply sorting, then click Next. 

 

 
FIGURE 14 DATA EXTRACTION, STEP 5 

 
12. Check the Insert data extraction table into drawing box, then click Next. 
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FIGURE 15 DATA EXTRACTION, STEP 6 

 

13. Select the Standard table style, then enter ROOM SCHEDULE for the title, then click 
Next. 

 

 
FIGURE 16 DATA EXTRACTION, STEP 7 

 
14. Click Finish and place the table somewhere in your drawing.  
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Don’t worry for now if the table is quite small. While functional, our room schedule leaves a bit to 
be desired. First, it’s a very lengthy table that will be hard to fit on paper when we print this out. 
Let’s take advantage of table breaking to help us out. 
 

15. Select the table. 
16. Using the grip at the very bottom middle of the table, drag up until you’ve created 

three roughly equal columns. 
 

 
FIGURE 17 RESIZING THE TABLE 

 
17. Select the table, right-click and choose Properties, then set the Repeat top labels 

property to Yes. 
 

 
FIGURE 18 REPEATING COLUMN LABELS 

 
The second problem with our Room Schedule is that there just isn’t very much information 
available. Seems like it would be more useful if we could see who is assigned to each room. 
However, that attribute was not available on the RMNUM block. Let’s update the block definition 
to carry more useful data. 

 

Find Command 
Find is a very helpful command that lets us search any text in our drawing, be it in DText or 
MText, dimensions, attributes, or buried in xreferences. 
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Exercise: 
 
1. On the ribbon go to Annotate > Text, then enter “6050” in the Find box, then press 

Enter. 
 

 
FIGURE 19 FIND COMMAND 

 
2. You should zoom right to a RMNUM block with the text “6050” in its attribute. If you 

happen to zoom to the table we just created, click Find Next and you should zoom to 
the correct location. Click Done when you get to the block shown below. 

 

 
FIGURE 20 LOCATING A BLOCK VIA ATTRIBUTE TEXT 

 

Block Edit 
Block Edit is a great tool that helps you edit block definitions for blocks defined in the drawing 
you are working in. 

 
Exercise: 
 
1. Select the block, then right-click and choose Block Editor. 
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2. Copy the NUMBER attribute and paste a copy below the rectangle. 
3. Double-click the new attribute and set the Tag to “Occupant”, Prompt to “Name of 

Occupant” and Default to “-”, then click OK. 
4. Select the attribute, right-click and choose Properties. 
5. Set the Invisible property to Yes. 
 

 
FIGURE 21 ADDING AN ATTRIBUTE TO A BLOCK DEFINITION 

 
Of course, it may be useful to have the Occupant attribute displayed on the drawing. This would 
make having the “extra” text version on the drawing obsolete, and the approach I would likely 
use myself. Here though, I want to demonstrate that attributes don’t have to be visible on the 
drawing to be extractable. 

 
6. Click the Close Block Editor button then choose Save changes. 
7. Double-click one of the RMNUM blocks to edit the attributes. 
 

 
FIGURE 22 WHERE'S THE NEW ATTRIBUTE? 

 
Wait. Shouldn’t there be two attributes now? Whenever you add or remove attributes from a 
block which has already been inserted into the drawing, you need to use the ATTSYNC 
command to synchronize any existing block references with the attributes in the block’s 
definition. 

 



 

 

GEN20664-Rand-AU2016.docx AU 2016 Page 14 

  

8. Click Cancel to exit the Attribute Editor, then go to Insert > Block Definition, then 
click the Block Definition drop-down, then choose Synchronize (or type 
ATTSYNC). 

 

 
FIGURE 23 SYNCHRONIZE AFTER ADDING NEW ATTRIBUTES TO EXISTING BLOCKS! 

 
9. Choose Select, then select a RMNUM block, then select Yes. 
10. Double-click one of the RMNUM blocks again and you should see the new attribute 

available for editing. 
 

 
FIGURE 24 NEW ATTRIBUTE APPEARS AFTER SYNCHRONIZE 

 
Take a few minutes and add the occupant name (red text in the room) to the Occupant attribute 
of several RMNUM blocks. You don’t need to do them all, but do several so we can see them on 
the Room Schedule table. 

 
We now need to update our Data Extraction (dxe) file to include the new attribute we just added.  
 

Exercise: 
 

1. Select the ROOM SCHEDULE table, then select one of the cells within the table.  
 
For some reason, this allows the Data Extraction submenu to appear when we right-click, 
whereas it does NOT appear if the whole table is selected.  
 

2. Right-click and choose Data Extraction > Edit Data Extraction Settings…. 
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FIGURE 25 EDIT DATA EXTRACTION SETTINGS 

 
3. In Step 1, verify that your drawing is listed, then click Next. 
4. In Step 2, verify that RMNUM is still selected, then click Next. 
5. In Step 3, check the Number and Occupant attributes, then click Next. 
6. Click the Full Preview button to see a preview of your table. Close the preview when 

you’re finished. 
 

 
FIGURE 26 DATA EXTRACTION PREVIEW 

 
7. Right-click the NUMBER column and choose Rename Column, then change the 

column name to ROOM #. 
 

 
FIGURE 27 CHANGING COLUMN NAMES 
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8. Click Next three times, then click Finish. 
9. Select the table (not a cell within the table!), then right-click and choose Update 

Table Data Links. 
10. Resize the columns to fit the data using the grips as before. 
11. To resize the row heights, select the rows, right-click and choose Properties, then 

set the Cell height to something very small (like 0.1”). Autocad will set the height as 
small as possible while still fitting the text + the specified cell margin. You may need 
to do this a few times to “reset” any affected rows. 

 

 
FIGURE 28 TRICKING AUTOCAD INTO AN ACCEPTABLE ROW HEIGHT 

 
Let’s create another data extraction table to get some quantity take-offs. We’d like to report on 
how many computers, phones, chairs, desks and filing cabinets are on the plan. 
 

Exercise: 
 

1. Use the Data Extraction command, this time starting a new data extraction. I’ll name 
mine FurnitureTakeOff.dxe. 

2. In step 3, check Chair7, Computer, Desk2, Desk3, FC15X27A, FC42X18D and 
FNPHONE. 

3. In step 4, uncheck all properties except Layer. We don’t really want this in our 
output, but the wizard forces us to choose something. We’ll hide this in the next step. 

4. In step 5, right-click the Layer column and choose Hide column.  
5. Drag the Name column to the left of the Count column.  
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FIGURE 29 REARRANGE COLUMNS USING DRAG AND DROP 

 
6. Click on the Name column to sort on that column. 
7. Be sure that Combine identical rows, Show count column and Show name 

column are all checked. 
8. In Step 6, check the Insert data extraction table into drawing check box. 
9. In Step 7, enter the title FURNITURE TAKE-OFF. 
10. Finally, select an insertion point somewhere in the drawing. 

 
One of the terrific benefits of using data extraction to create tables is that as your design 
evolves, your tables are easy to update.  
 

11. Try copying some of the furniture a few times somewhere else in the drawing.  
12. Select the take-off table, right-click and choose Update Table Data Links. 

 

“Scaling” tables for output 
I promised earlier we’d discuss the table text size issue. When we draw in model space, we 
should ALWAYS draw the design to full scale. We then use Layouts (aka paper space) to setup 
our paper for plotting, using Viewports which are like windows through which we can see our 
(model space) design. Viewports can be scaled to a precise scale so that our design fits on the 
piece of paper we intend to print to. 

 
If we put annotations in model space, we have several options. One is to change the size of the 
annotations to match the intended viewport scale. Another is to use Annotative scaling to 
accomplish this for us. Personally, I find both of these options more difficult than they’re worth. 
In general, I recommend putting most annotations, such as text, dimensions and tables on the 
Layout. However, since we started the Data Extraction command from model space, the 
workflow we used here didn’t really give us an option to put the table on a Layout, and because 
we didn’t change our text style height, we wound up with tiny tables.  
 
Still another option available is to create a separate viewport through which to view the 
schedules, and set the schedule viewport scale to 1:1. Then if we wish, we can simply use the 
CHSPACE command to change the tables from model space to paperspace. The Data 
Extraction links will still work, even though the table lives on a layout and our data source lives 
in model space. Let’s see how this last option works. 
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Exercise: 
 
1. Activate Layout1, then right-click the Layout tab and choose Page Setup Manager. 
2. Modify the default page setup to a paper size of Arch D (36.00x24.00 Inches). 
3. Change the existing viewport scale to 1/16”=1’-0” and resize the viewport as 

necessary so you can see the entire floor plan. 
4. From the ribbon, go to Layout > Layout Viewports, then click Rectangular to 

create a new viewport. 
 

 
FIGURE 30 CREATING A VIEWPORT 

 
5. Activate the viewport and zoom in on one of the schedules, then set the viewport 

scale to 1:1.  
 

 
FIGURE 31 SETTING VIEWPORT SCALE 

 
6. You’ll probably need to resize the viewport and move the viewports around a bit to 

get everything to fit. 
7. Repeat this process to add the Furniture Take-Off table in its own separate viewport. 
 

Use CHSPACE to move tables to Paperspace 
Because I prefer my annotations (including tables) to generally reside on a Layout to keep 
modelspace focused on my design, let’s “move” the tables from modelspace to paperspace. 
 
The key to making this command work is scaling the viewport to the correct size first, then using 
CHSPACE. We’ve already set the scale of the viewports so we’re ready to proceed. 

 
Exercise: 
 



 

 

GEN20664-Rand-AU2016.docx AU 2016 Page 19 

  

1. Double-click inside either viewport where your tables are visible. 
2. On the ribbon, go to Home, click the Modify drop-down, and then choose Change 

Space (or type CHSPACE). 
 

 
FIGURE 32 USE CHANGE SPACE TO TRANSFER OBJECTS BETWEEN "SPACES" 

 
 
3. Select the table, then press Enter twice (once to end selection, the second to accept 

the viewport you’re already in). 
4. Autocad puts you back in paperspace at which point you can erase the viewport. 

Repeat for the other table. 
 

At this point your tables are in paperspace, but are still linked for data extraction.  
 

Overriding extracted values  
Let’s work through another example from another discipline, this time from a structural footing 
drawing. This example is interesting because in addition to attribute data, we’ll also include 
geometric data (the X, Y and Z values) in our data extraction. We also want to override some of 
the extracted values with some manually entered data. 
 

Exercise: 
 

1. Open the MH-1115-FC-109.dwg file. 
2. Use the Data Extraction command to start a new dxe file, and name it the same as 

the sample drawing. 
3. In step 3, select the FootingPoint block. 
4. In step 4, select the FTG and POINT attributes, as well as the Position X, Position 

Y, and Position Z geometry properties. 
5. In step 5, uncheck the Combine identical rows, Show count column and Show 

name column check boxes. 
6. Rearrange the columns in the following order: Point, Position X, Position Y, 

Position Z and FTG. 
7. Rename the columns as follows: 

a. Point Number 
b. Northing 
c. Easting 
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d. Elevation 
e. FTG 

8. Click on the Point Number column header to sort by the point numbers. 
 

 
FIGURE 33 REARRANGED AND RENAMED COLUMNS 

 
9. In step 6, select Insert data extraction table into drawing. 
10. In step 7, enter the table title Misc Pipe Supports. 

 
After the table is inserted, you’ll notice that points 05 and 06 indicate that the FTG is 
“DELETED.” In these cases, it does not make sense to report the X, Y and Z values, so we’ll 
override the extracted values. In order to do this, we must unlock the cells we want to override. 
 

11. Select cells B7:D8, then right-click and choose Locking > Unlocked. 
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Figure 34 Unlocking cells to override extracted values 

 
12. Select one of the cells you just unlocked and notice the change in the cursor badge. 

 

 
FIGURE 35 UNLOCKED (TOP LEFT) VS LOCKED (LOWER RIGHT) CURSOR BADGES 

 
13. Double-click cell B7 and replace the value with “-”. 
14. Repeat step 13 for cells B7:D8. 

 
So, what happens when we later need to update our table? Autocad detects the overridden cells 
and gives you the option of updating the contents (i.e. back to extracted data) or to retain the 
overwritten contents. 
 

15. Select the table, right-click and choose Update Table Data Links. 
16. When prompted, select Retain the overwritten contents. 
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FIGURE 36 OVERWRITTEN DATA-LINKED CELLS 

 
 
Learn how to customize data extraction using sorting, filtering, formulas, 
and totals 

When we use data extraction, we frequently need to do additional things with that data, such as 
sorting or filtering the data, or adding formulas and totals. 

 
Exercise: 
 
1. Open the Lanscaping.dwg file. This sample has a site plan from which we want to get 

the square footage of various elements. 
2. Use the Data Extraction command to start a new dxe file, and name it the same as 

the sample drawing. 
3. In step 3, select Hatch as the type of objects to extract data from. 
4. In step 4, select Area and Layer as the properties to extract. 
 

Step 5 of the wizard we’ve seen before, but this time we want to have our table display the 
summed total of the area of “like” hatch objects (“like” being hatches on the same layer should 
all be summed together). We also need to convert the area from square inches to square feet, 
and format the output appropriately. 
 

5. In step 5, uncheck Show count and Show name.  
6. Rearrange the columns so Layer is first. 
7. Click on the Layer column header once to sort in ascending order. 
8. Verify that Combine identical rows is checked. 
9. Right-click in the Area column and choose Combine record mode > Sum values. 
10. Right-click in the Area column and choose Set column data format.  
11. Select Decimal and set the precision to 0.  
12. Click on Additional Format, then set the Conversion factor to 0.0069, Suffix to “ 

s.f.”, and set the Thousands separator to ‘,’ (Comma). 
 



 

 

GEN20664-Rand-AU2016.docx AU 2016 Page 23 

  

 
FIGURE 37 CONVERTING AREA TO SQUARE FEET 

13. Click OK twice to return to the Data Extraction wizard. 
 
We’re pretty close, but what if we wanted to exclude hatches on certain layers? For example, 
maybe we don’t want to report the Building footprint. We can accomplish this using Filter 
Options. 
 

14. Right-click the Layer column and choose Filter Options. 
15. Uncheck Building and click OK. 
 



 

 

GEN20664-Rand-AU2016.docx AU 2016 Page 24 

  

 
FIGURE 38 FILTERING A COLUMN 

 
To see a total of the “landscaped” areas, we need to add a footer row with a formula to sum the 
Area column values. 
 

16. Right-click the Area column and choose Insert totals footer > Sum. 
 

 
FIGURE 39 INSERTING A TOTAL FOOTER 

 
17. Click Next to proceed to the next steps, and insert a data extraction table into the 

drawing. 
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Integrating Fields with Text Objects 
While we’re working with the Landscaping example, it’s worth pointing out another option for 
reporting information. Frequently we add annotations to our drawings to call out information, for 
example we might add callout labels to identify the square footage of each area. Far too often, 
we create these labels using static text. So each time there’s a design change, we have to go 
back and update the labels. It’s tedious, error prone, and easy to forget to update. 
 
Fields allow us to link annotation text to properties of objects in our drawings, or even to 
properties of the drawing file itself. We’ll just work through a quick example here so you can see 
the power of fields. 

 
Example: 

1. While still in the Landscaping.dwg, verify that you’re on the 36x24 layout tab, 
working in paperspace (not inside the viewport). 

2. Go to Annotate > Text > Multiline Text2. 
 

 
FIGURE 40 CREATING MTEXT ANNOTATION 

 
3. Draw a small bounding box for the MText over the pond in the lower left corner of 

the property. 
4. Type “POND: ” in the MText box (do not include the quotation marks), then click 

the Field button on the Text Editor tab. 
 

 
FIGURE 41 ADDING A FIELD TO AN ANNOTATION 

 
5. Under Field Category, select Objects. 
6. Under Field Names, select Object. 
7. Under Object type, pick the Select Object button, then pick the pond. And yes, 

Autocad correctly identifies the hatch object within the viewport, even though it isn’t 
active! 

8. Under Property, select Area. 

                                                
2 Single Line Text (aka DTEXT) is also OK, though there may be slight differences to the steps described 
here. 
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9. Under Format, select Architectural. 
10. Under Precision, select 0.00. 
11. Click Additional Format. 
12. The Conversion factor is retained from our previous use of this dialog box. If not, 

set it to 0.006944. 
13. Under Suffix, set it to “ SQ. FT.” (again, not the quotation marks). 
14. Under Thousands, set it to ‘,’ (Comma) if it’s not already. 
15. Click OK once to return to the Field dialog box. 

 

 
FIGURE 42 USING A FIELD TO REPORT HATCH AREA 

 
16. Click OK to return to the drawing. 
17. Adjust the MText box size if necessary. 
18. On the Text Editor tab, click Mask to set masking options for this text object. 

 

 
FIGURE 43 SETTING A BACKGROUND MASK 
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19. Check Use background mask, and Use drawing background color, then click 
OK. 

20. Click Close Text Editor on the Text Editor tab to finish editing. 
 

 
FIGURE 44 FIELDS UPDATE WHEN YOUR DESIGN CHANGES! 

 
Now that the field is linked to our “pond” hatch object, any change to the pond’s shape will 
automatically3 and accurately update in our drawing. 

 
Learn how to use Data Extraction to extract data across multiple drawings 

Data Extraction is a very powerful tool, and can be used across multiple drawings. In this 
section, we’ll build a drawing index by extracting title block information. 
 
NOTE: Yes, I’m aware that you can generate a Sheet List Table using sheet sets. I wanted to 
demonstrate how to duplicate this functionality for those who may not use sheet sets. And, there 
are plenty of other things we might want to report on across multiple drawings that sheet sets 
don’t track. 
 

Exercise: 
 

1. Open A-00 Index to Drawings.dwg. This drawing contains an empty title block. 
2. Start the Data Extraction command and create a new data extraction file. I’ll name 

mine Index to Drawings.dxe. 
3. In step 2 of the wizard, we can click Add Drawings to select additional drawings to 

act as data sources. This is relatively straightforward, so I won’t demonstrate this. 
Instead, click on Add Folder. 

 
The Add Folder button allows you to add one or more folders as the data source. There are 
some powerful options when you add folders as the data source. Let’s peek at the options. 
 

4. Click on Add Folder. 
5. Click the … button next to the Folder box. Browse to the Sample Files\Arch 

Drawings folder and click Open. 
6. Check Automatically include new drawings…. Any new drawings you add to the 

target folder will be added to the data extraction. 
                                                
3 Automatically meaning each time you use the REGEN, SAVE or PLOT commands. Note that the 
REGEN command only updates objects in the current “space” so you either need to regen on the specific 
layout tab, or use the REGENALL command to regen all “spaces”. 
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If you were to look in the Sample Files\Arch Drawings folder, you’d find several drawings 
starting with A-nn, as well as drawings named Exterior Elevations, Grid Plan, and Wall Base. 
These last three all serve as xreferences for the other drawings and should not be included in 
our Index to Drawings. Fortunately, we can easily filter these out with wild-cards. 
 

7. Check the Utilize wild-card characters to select drawings, then enter A*.dwg in 
the box. 

 

 
FIGURE 45 ADD FOLDER OPTIONS 

 
8. Click OK. 

 

 
FIGURE 46 USING A FOLDER AS A DATA SOURCE 

 



 

 

GEN20664-Rand-AU2016.docx AU 2016 Page 29 

  

As you can see above, all drawings starting with A are included. Notice that we can still uncheck 
individual drawings to exclude a particular drawing if needed. While we’re here, we should 
probably check the Setttings options. 
 

9. Click on Settings. 
 

 
FIGURE 47 ADDITIONAL SETTINGS 

 
Here, we can include or exclude blocks, xrefs, or choose to target only model space. We don’t 
need to change the default settings, but it’s nice to know they are available. 
 

10. Click OK, then in step 3 of the wizard, select Title and title4 as the objects to 
extract data from. 

11. In step 4 of the wizard, select X, Sheet_Content1, and Sheet_Content2 
(attributes) as well as File Name (drawing). 

12. In Step 5 of the wizard, uncheck Show count and Show name.  
13. Rearrange the columns in order: File Name, X, Sheet_Content1, 

Sheet_Content2. 
14. Rename column X to “Drawing #”. 
15. Rename column Sheet_Content1 to “Title 1”. 
16. Rename column Sheet_Content2 to “Title 2”. 
17. Sort on the File Name column so A-00 appears first. 

 

                                                
4 One of the drawings in our data set (A-04) had the name of the block capitalized. Both blocks have all 
the same attributes, so I thought it would be interesting to see how Data Extraction handles this 
somewhat odd scenario. 
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FIGURE 48 STEP 5 OF DATA EXTRACTION 

 
18. In step 6 of the wizard, select Insert data extraction table. 
19. In step 7 of the wizard, enter the table title “Index to Drawings”. 
20. Select an insertion point in your drawing. 
21. Open drawing A-04.dwg and do a Save As to create drawing A-05.dwg in the same 

folder.  
22. Close the newly created A-05 drawing. 
23. Select your Index to Drawings table, right-click and choose Update Data Table 

Links. 
 

 
FIGURE 49 NEW DRAWINGS ADDED TO THE FOLDER APPEAR WITH AN UPDATE 

 
Thanks to the Add Folder options we selected earlier, your new drawing appears on the list. 
Awesome! 
 
Learn how to link Excel spreadsheets with extracted data 

We’ll switch gears a bit now to discuss how to get data into our drawings by linking to Excel 
spreadsheets. A common workflow in many offices is to input some data into a spreadsheet, 
then look for ways to link or insert the spreadsheet into a drawing. 
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The drawing we’ll use in this section is called Mechanical – Data Links. This drawing is a 
process flow diagram, commonly used in the oil and gas industry to describe a process and the 
major equipment involved.  
 

Exercise: 
 

1. Open Mechanical – Data Links.dwg.  
2. On the ribbon, go to Insert > Linking & Extraction > Data Link. 

 

 
Figure 50 Creating a Data Link 

 
3. Select Create a new Excel Data Link, then enter the name Mass Balance and click 

OK. 
4. Click the … button next to Browse for a file, then select the mass-balance.xls file. 
5. Under Link options, verify that Sheet1 is selected, then choose Link to range and 

enter “A1:W18”. 
6. Click the More Options button at the bottom of the dialog to view the Cell contents 

and Cell formatting options. 
7. Check the Allow writing to source file check box, then click OK. 
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Figure 51 Excel Data Link options 

8. Click OK to dismiss the Data Link Manager. 
 
At this point…nothing new appears in your drawing. All we’ve done so far is create a data link, 
but we haven’t linked it to anything. Next, we need to create a table and associate it with the 
data link. 
 

9. From the Annotate tab, Tables panel, click Table. 
 

 
FIGURE 52 INSERTING A TABLE 

 
10. In the Insert Table dialog, select From a data link. 
11. Select Mass Balance from the drop-down list, then click OK. 
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FIGURE 53 LINKING A TABLE TO A DATA LINK 

 
12. After a brief pause while Autocad retrieves the data from the Excel file, pick an 

insertion point in the drawing. 
 

Formatting a linked table 
The default column widths and row heights leave a lot to be desired, so we’ll have to adjust 
these. This is a little tricky, so follow along carefully. 
 

1. Select the table, then double-click the upper left-hand corner. 
 

 
FIGURE 54 CLICK THE UPPER LEFT CORNER OF THE TABLE 

 
2. Click on the row header for row 2, on the left edge of the table. 

 

 
FIGURE 55 CLICK THE ROW HEADER TO SELECT THE ENTIRE ROW 

 
3. In the Properties panel, enter a cell height of 355. 

                                                
5 There are a bunch of “magic” numbers in this section for column and cell widths and heights. Really it 
was just a bunch of trial and error to get this to work right. Sadly, no magic. 
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4. Click off the table to deselect it. 
5. Zoom out so you can see the entire table. Don’t worry if you can’t actually read the 

table, you just need to be able to see it. 
6. Reselect the table as you did in step 1. 
7. Draw a crossing select that encompasses columns C:W. 
8. In the Properties panel, enter a cell width of 20, which is wide enough to avoid 

wrapping the data in rows 3 to 18. 
9. Select column B and set the cell width to 25. 
10. Select column A and set the cell width to 75. 
11. Now select rows 3 to 18 and set the cell height to 0.1. Autocad won’t really size it 

this small, but it will shrink the row heights as small as possible, while still displaying 
the content. 

 

 
FIGURE 56 TABLE CREATED VIA DATA LINK 

 
We’ve now created an Autocad table, data linked to an Excel spreadsheet. If the contents of the 
Excel workbook change, we can update the Autocad table with a couple of clicks. Let’s see how 
this works. 
 

12. Select the table in Autocad, then double-click the upper-left corner again. 
13. Right-click and choose Data Links > Open Data Link File… to open the file in 

Excel. 
14. Change the value in cells W17 and W18 to a “-”, then save the Excel file. 
15. Switch over to Autocad, and you should see a balloon notification indicating that a 

data link has changed. Click the hyperlink to update your table. 
 

 
FIGURE 57 DATA LINK HAS CHANGED NOTIFICATION 

 
We now have one-way communication from the Excel file to Autocad. And in certain scenarios, 
this may be exactly what you want. For example, in the scenario we’re working through, it may 
be a process engineer’s job to maintain the mass balance spreadsheet, while it is the process 
designer’s job simply to link the spreadsheet into the drawing, but should not edit the content. 
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In other scenarios, you may want two-way communication, allowing a designer to make 
changes in the Autocad table and push those back to the Excel workbook. To enable this two-
way communication, we need to “unlock” the table in Autocad. 
 

16. Select the table in Autocad, then double-click the upper-left corner again. 
17. Right-click and choose Locking > Unlocked. 
18. Change cells W17 and W18 in the Autocad table back to “TBA”. 
19. Right-click the table and choose Write Data Links to External Source. If you do this 

without closing the Excel workbook, the command prompt will inform you that 1 data 
link(s) could not be written out. 

 

 
FIGURE 58 SOURCE EXCEL FILE OPEN, DATA LINK COULD NOT BE WRITTEN OUT 

 
20. Close the Excel workbook and repeat step 29. This time you should see a message 

indicating that 1 data link(s) written out successfully. 
 

 
FIGURE 59 SUCCESS! 

 
One and two-way data exchange with Excel, very nice. 
 
Additional Examples 

We’ve covered many different ways of extracting and displaying information in and from our 
drawings. If we have additional time in class, I wanted to share some other examples to help get 
you thinking of other ways they might be of benefit. 
 

Creating a Detail Bill of Materials 
In my business (industrial engineering) we frequently use standard instrument details that 
explain how instruments are to be mounted. To keep the drawings clean, we use numbered 
callout bubbles which are referenced by a Bill of Materials table. Each detail drawing is 
maintained in its own separate DWG file that we typically print out on letter-size paper for our 
internal standards manual, and these pages frequently are submitted as-is with other project 
deliverables. 
 
Sometimes, though, we prefer to copy and paste several of these detail drawings onto a D-Size 
sheet as the deliverable, with one combined table of contents on the new sheet displaying the 
Bill of Materials for whichever details were hand-picked to appear on that sheet. We struggled 
with various ways to do this, until we realized that Data Extraction could help us in this situation 
with a little bit of outside-the-box thinking. 
 

Example: 
 
1. Open sample drawings 104.dwg, 301.dwg and 403.dwg.  
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Each drawing contains a different detail, with callout bubbles and a table. Note that the bubbles 
are all in modelspace along with the actual detail drawing. Also, each bubble consists of 
additional invisible attributes (you know, the kind you can’t see) containing the Description, Size, 
Material, Quantity and Comments for each item the bubble points to.  
 
You might think having the bubbles in modelspace rather than paperspace contradicts what I 
said earlier about putting annotations in paperspace (it does). But we made an exception in this 
case to make it easier to copy and paste these details into a custom detail sheet, as I’m about to 
demonstrate. The tables were created using standard Data Extraction techniques we’ve already 
seen. 
 

2. In the 104.dwg activate the viewport and select everything you can see, the detail, 
the bubbles and the callout block. 

 

 
FIGURE 60 SELECT THE MODEL SPACE CONTENT TO COPY 

 
3. Right-click and choose Clipboard > Copy. 
4. Open D01.dwg and activate the viewport. 
5. Right-click and choose Clipboard > Paste, then select an insertion point in the 

upper left corner of the viewport. 
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6. Repeat steps 2-5 for the detail in the 403.dwg. Place this detail close to the lower left 
corner of the viewport. 

7. Repeat steps 2-5 for the detail in the 301.dwg. This is a rather large detail, so fit it in 
the viewport where you can, but try to preserve the upper right corner of the drawing 
as much as possible. 

 
The bubble numbers copied in from each detail overlap, but the attributes of each bubble are 
not identifying the same components. We need to renumber the overlapping bubble numbers so 
they’re unique to each detail. We’ll use the detail in the upper-left corner as our starting point, 
but leave those numbers the same. 
 
For the detail in the lower right corner, change the bubble numbers as follows: 
 

8. Change 01 to 04 (one of these). 
9. Change 02 to 05 (two of these). 
10. Change 03 to 06 (two of these). 

 

 
FIGURE 61 CHANGES TO DETAIL 403 (LOWER LEFT CORNER) 

 
For the large detail, we’ll again make several bubble number changes. But this time, let’s use 
Find and Replace.  
 

11. On the Annotate tab > Text panel, click the Find text button. 
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FIGURE 62 FIND BUTTON 

 
12. Enter 01 in the Find what box, then enter 09 in the Replace with box. 
13. Click the Select objects button next to the Find where drop-down box. 

 

 
FIGURE 63 FIND AND REPLACE 

 
14. Select a window encompassing the entire 301 detail (right side of the drawing). You 

don’t need to be overly precise here, just be sure to include all the detail bubbles in 
your selection. 

15. Click Replace All. You should get a notification that 1 item was changed. 
16. With the Find and Replace dialog still open, change Find to 02 and Replace to 10 

and click Replace All. 
17. Change 03 to 11 (one of these). 
18. Change 04 to 12 (one of these). 
19. Change 05 to 13 (one of these). 
20. Change 06 to 14 (one of these). 
21. Leave 07 and 08 unchanged. 
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FIGURE 64 CHANGES TO DETAIL 301 (RIGHT SIDE) 

 
Now, let’s run through the Data Extraction wizard. 
 

22. On the D01 Custom Details tab, activate paperspace (double-click outside the 
viewport), then start the Data Extraction command. 

23. In step 1, create a new data extraction, and save the file as D01 Data Extraction.dxe. 
24. In step 2, verify that the current drawing is selected. 
25. In step 3, select the InstrumentCalloutTag to extract data from. 
26. In step 4, select all the Attribute category items (6 total attributes). 
27. In step 5, uncheck Show count column and Show name column. 
28. Rearrange the columns in the following order: Item, Qty, Description, Matl, Size, 

Comments. 
29. Sort on the Item column. 
30. In step 6, check Insert data extraction table into drawing. 
31. In step 7, enter the title Bill of Materials. 
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32. Insert the table in the upper left corner of the drawing area. You may need to make 
some adjustments to get everything to fit properly. 

 

 
FIGURE 65 COMPLETED BILL OF MATERIALS TABLE 

 
This is, admittedly, a strange way to go about this. But it allows us the flexibility of creating 
customized detail sheets with some easy copy and paste and a little bit of bubble renumbering. 
Far better than having to retype the Bill of Materials table by hand each time. 

Potential “Gotchas” Using Data Extraction 
In this class we’ve created several data extraction files. When you create a data extraction link, 
Autocad maintains a reference to the DXE file, kind of like an xreference. In fact, DXE links 
show up right on the Reference Manager palette. 
 

 
FIGURE 66 DATA EXTRACTION CREATES A REFERENCE! 

 
One thing you need to watch out for when using data extraction is renaming or moving your 
drawing files. If you rename or move a drawing file, you may need to update the Saved Path. A 
really good trick is to change the Saved Path from a full path to a relative path by replacing the 
entire path (except the file name) with .\ as shown below. 
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FIGURE 67 USING A RELATIVE PATH REFERENCE 

 
When Autocad sees this, it looks in the same folder as the drawing for the DXE file, and 
resolves itself. This is particularly important to keep in mind when you transmit drawings (and 
the DXE files!) to a client or collaborator. 
 
Unfortunately, this is not all you need to do. Remember that the DXE file also contains a link to 
one or more drawings that act as data sources. Renaming or moving files invalidates these 
links. Fortunately, it’s fairly easy to fix. 
 
Select any cell in a data linked table, then right-click and choose Data Extraction > Edit Data 
Extraction Settings. In Step 1, verify the drawing names and locations. Most likely you’ll need 
to replace the old drawing path(s) with new ones. I’ve found that it works best to add the new 
drawing paths in first before removing the old drawing paths. Sadly, there is no way to do the 
relative path trick here as we did with the link in the DWG file. Once you’ve updated the file 
path(s), you should be able to click Next through the rest of the wizard. 
 
And speaking of transmitting drawings, you may be wondering if Etransmit picks up the Data 
Link Files. By default, it does, although this can be turned off in the Modify Transmittal Setup 
dialog. I recommend always using Etransmit when transmitting drawings from one office to 
another. 
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FIGURE 68 ETRANSMIT DETECTS DATA LINK FILES 

 

Combining Autocad and Excel Data 
One final example. In some cases, we may want to “merge” data from our drawing with data in 
Excel. A good example of this would be architectural keynotes. Suppose you have an Excel file 
with CSI keys and descriptions as shown below: 
 

 
FIGURE 69 SAMPLE CSI KEYNOTES IN EXCEL 

 
In your Autocad file, you use a “Keynote” block with an attribute to identify the key, as shown 
below: 

 

 
FIGURE 70 A "KEYNOTE" BLOCK WITH ATTRIBUTE 

 
The trick is to combine two things we’ve already seen, data extraction and data link. 

1. Open the Keynote Sample.dwg file from the sample data set. 
2. A few keynote blocks have been inserted on Layout 1. 
3. Start the Data Extraction command and create a new DXE file named Keynotes.dxe. 
4. In step 3, select the Keynote block. 
5. In step 4, select the Keynote attribute. 
6. In step 5, uncheck the Show Count and Show name columns. 
7. Click Link External Data. 
8. Click Launch Data Link Manager. 
9. Click Create a new Excel Data Link and enter the name CSI. 
10. Browse to the sample files directory and select CSI.xlsx. 
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11. Verify that Sheet1 is selected and Link entire sheet then click OK twice. 
12. Select KEYNOTE in the Drawing data column and ID in the External data column, 

then click Check Match. 
 

 
FIGURE 71 DATA MATCHING 

 
Identifying these “keys” is crucial for getting the external data to link up. Your Excel file must 
contain unique values in the external data column (“ID” in the example used here). Autocad 
matches this up with the value you identify as the drawing data column (“KEYNOTE” in the 
example shown here). 
 

13. You can select any additional columns from your Excel file to add to any data you’re 
extracting from Autocad itself. 

14. Click OK to return to step 5. 
 

 
FIGURE 72 LINKED COLUMNS 
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15. Rename the ID column to “KEY” and sort on that column. 
16. In step 6, select Insert data extraction table. 
17. In step 7, enter KEYNOTES for the table title and proceed to insert the table. 
 

 
FIGURE 73 FINISHED KEYNOTE LEGEND 

 


