Fusion 360 Strategies for Bridging Between Digital and Physical Models

Alex Lobos
Rochester Institute of Technology

Learning Objectives

• Learn how to use Fusion 360 for early concept development and well as for design definition.
• Learn how to combine tools in the A360 and 123D product families, taking advantage of their intuitive and effective workflows.
• Learn how to quickly move from conceptualization to testing and refinement by using CAD, model making, 3D printing, and 3D scanning.
• Learn powerful tools in Fusion 360, including Edit Form, Import Mesh, Pull, and Crease.

Description

This class will show the use of Fusion 360 CAD software and captured reality programs such as Memento and ReCap to create and refine models by moving between computer and physical environments in an easy and efficient way. By combining computer software with model making, capture-reality imaging and 3D printing, designers can easily navigate between physical and CAD models. This class will show examples of models that are quickly generated in Fusion 360 software and then 3D printed so that they can be tested and adjusted in the physical world. Once the models have been improved physically, they are captured by programs such as Memento and ReCap and brought back to Fusion 360 software, where they can be updated and finalized. The workflow covered in his class is dynamic, fun, and perfect for product development!

Your AU Expert

Alex explores use of CAD in product design and has collaborated with Autodesk since 2012 on sponsored projects, development of new CAD programs and use of hybrid ideation and fabrication in CAD education. He is an Expert Elite for Fusion 360, recipient of Fusion 360 Education Award and featured Speaker at Autodesk University 2013. Alex Lobos is an Associate Professor of Industrial Design, Miller Professor for International Education, and extended program faculty at Golisano Institute for Sustainability, at Rochester Institute of Technology, New York. His research focuses in sustainable design, emotional attachment and user-centered design. He lectures and directs workshops throughout North and Latin America and Asia. His research has been sponsored by companies, such as Autodesk, AT&T, Colgate-Palmolive, General Electric, Kraft, Staples and Unilever. Prior to RIT, he was faculty at University of Illinois Urbana-Champaign and Universidad Rafael Landivar in Guatemala, as well as Industrial Designer for General Electric and Whirlpool.
1. Introduction
Visualization and fabrication tools in design and engineering are evolving at a dramatic pace and producing more intuitive and affordable technologies. These technologies open up many opportunities for tinkering, exploring and developing solutions for key challenges faced in today’s society. The tools available today successfully integrate digital and physical methods for the generation of 2D, 3D and 4D concepts, all in continuous and effective ways.

This class explores the integration of analog and digital tools in new product development in order to maximize the designers’ ability to understand, test and refine their ideas. It also addresses issues around how the use of digital visualization processes such as Computer Aided Design (CAD) and digital illustration compromises the exploration of three-dimensional forms and empathic user understanding.

2. Integrating physical and digital visualization methods
CAD has become a key tool for designers. Its ability to develop concepts that are easily communicated across the business and that maintain intent throughout product development phases make it a key component for understanding, visualizing and fabricating tangible solutions. Despite all the benefits that CAD offers, a major concern is the risk of bypassing physical exploration of design concepts and jumping directly from sketches into digital models and prototypes. This process leads to assumptions and oversights that can only be detected with physical testing and exploration. CAD also challenges users with a steep learning curve, which makes for frustrating sessions and limited results before a person can model the geometries that he or she has in mind. There is a common pattern where novice CAD users have no choice but to let the software drive many of the decisions and make various compromises along the way, accepting whatever shapes the software generates. It is only after a lot of practice and knowledge that a CAD user can drive the process and obtain the exact design intent at a high-quality level that will produce good parts in manufacturing.

Another common challenge is importing physical geometry into CAD. Many designers and engineers take pictures of physical models and place them in the CAD workspace as background canvas for visual reference but this is limiting in terms of translating accurately all the details that the physical model contains (See Figure 1). 3D scanning is a good way of capturing 3D input and convert it into CAD data but these tools are not owned by a large number of designers either because of their complexity or high cost.
Another issue with integrating CAD and traditional analog modeling processes is that while it is technically easy to move downstream, meaning from digital models into physical output, it is much harder to move upstream. 3D scanners offer adequate ways of importing physical models into CAD environments, but this takes time and practice. Additionally, most imported models are almost impossible to edit directly in the computer, and designers generally use them only as reference objects, having to create new models around them.

3. A proposed workflow that navigates between analog and digital models.
This class presents a workflow that integrates physical and digital models in a way that is easy, intuitive, inexpensive and reliable (See Figure 2). It is important to note that this workflow is designed to be flexible and iterative. Steps can be repeated or skipped as needed in order to facilitate different processes and objectives for concept development.
This workflow shows continuous transitions between physical and digital models, where insights acquired at any given step can define the direction of the next one. Details of each level include:

**3.1 Modelmaking**
This step includes analog inputs commonly used in modelmaking techniques. Materials for this step include modeling foam, clay, foamcore, cardboard, etc. Processes include manual cutting, sanding, sculpting, etc. Modelmaking techniques can also be used to modify and improve 3D printed models.

**3.2 Image capture**
This step takes advantage of programs such as Autodesk Memento, ReCap and 123D Catch. These programs use a series of photographs of a model in order to “stitch” together a digital model. Memento offers the important advantage of exporting both Tri and Quad OBJ meshes (most programs only export tri-OBJ). Quad meshes are necessary for importing files into Fusion 360 and convert them to T-Splines bodies.

**3.3 3D printing**
This stage allows for CAD models to be printed quickly and be tested to make sure that the design works in the real world. Based on this testing, adjustments can be made to the model so that it’s captured and brought back to CAD for further refinement.

**3.4 CAD**
This step takes advantage of Fusion 360’s simple, intuitive and powerful features. Fusion 360 is an excellent choice for creating models in an organic way and it allows for OBJ mesh files to be imported and even converted into models that are fully editable in the program.
This workflow is designed to be flexible and iterative (See Figure 3). Depending on the type of project at hand, several repetitions of digital and/or analog models might be necessary before a final model is achieved. Some of the key benefits of this workflow include:

- Physical mockups can be captured as digital data with the use of pictures and cloud-based image capture software. This eliminates the need of a 3D scanner and also makes the process easier and more practical.
- The captured data can be imported into Fusion 360 either as static models (mesh geometry) or it can be converted into a T-Spline model (if saved as OBJ with quad faces). This means that the imported bodies are completely editable in Fusion 360 and they can also be merged with bodies created in the software.
- The largest benefit of this workflow is the ability to translate forms and objects accurately between analog and digital formats. When designers use this methodology they know that whatever improvement they make to their model will be captured accurately and carried on for as long as they need it. This eliminates what can be called as a “lost in translation” issue with traditional transitions between physical and digital models.

4. Rotary tool as example of proposed workflow
In order to better understand how the proposed workflow works as well as to become more familiar in Fusion 360 and Memento, this class focuses on the development of a handheld rotary tool (See Figure 3). This device is similar to a power drill but with a smaller scale and the ability to use bits common in other rotary tools. This device is a good example of the potential of bringing physical and digital tools since it combines a top portion that requires geometric precision to include the rotary motor with a handle that benefits from an organic shape with strong input from ergonomics testing.

Figure 3: Rendering of the final design of the rotary tool.
Figure 4 below illustrates the development process for the rotary tool discussed in this class. The steps in the process are the following:

1- Crude mockup made out of PVC tube and clay to get initial shape and proportions.
2- Image capture of PVC model captured in Memento and imported into Fusion360.
3- Fusion 360 model that used as reference the mesh of the PVC mockup.
4- 3D print of the basic model.
5- Model with clay additions identified after holding the model.
6- Image capture of refined model captured in Memento and imported into Fusion360.
7- Refined Fusion 360 model that uses an exact copy of the mockup’s undated handle.
8- 3D print of the final model.

5. Step-by-step tutorial
Below are the steps for creating each of the digital iterations of the rotary tool, as well as for digitizing physical mockups and importing them into CAD software. Each section has been separated intentionally so that it’s easier to focus on individual tasks. This organization provides more flexibility for using the tutorials, depending on the specific needs of any given project. The key objective of this process is to be able to merge the data collected from physical interaction with the handle of the device with the shell previously designed in Fusion 360 (Figure 5).
5.1 Converting a physical model into digital data using Autodesk Memento

| Take pictures of mockup | • Use a bright but diffuse environment. Hard shadows won’t allow for a good model.  
|                        | • Avoid shiny and/or dark models. Matte and light-colored surfaces are easier to read by the software.  
|                        | • Take pictures every 5-10 degrees, all around the object, at different heights.  
|                        | • You should end up with at least 75 pictures if you want a good model.  
|                        | • Download the pictures to your computer and put them in a folder.  
|                        | • For more tips on how to capture your model go to: https://memento.autodesk.com/resources |

| Create image Capture models | 1.  Open Memento  
|                            | 2.  Go to Create 3D > Photos |
### 3. Choose the folder where you downloaded your images

### 4. Name the project

### 5. Turn on “smart background” and “smart texture”

### 6. Set resolution to Best

### 7. Click “Start” and wait for the model to be processed (normally takes about one hour).

### 8. When the image capture is ready go to the dashboard and look for the file in the A360 Drive list.

### 9. Hover over the file and you will see a blue arrow. Click on it to download the file to your computer.
### Fusion 360 strategies for bridging between digital and physical models

<table>
<thead>
<tr>
<th>Step</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.</td>
<td>Go to Open and browse for the file. You should see the file opening in the Memento workspace.</td>
</tr>
<tr>
<td>11.</td>
<td>Most times the file will show the object along with some of the background. This is normal.</td>
</tr>
<tr>
<td>12.</td>
<td>Make windows with your mouse/trackpad to select the excess portions of the model. Hit “delete” key to delete them.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td><strong>13.</strong></td>
<td>In the toolbar in the left, go to Edit &gt; Slice &amp; Fill</td>
</tr>
<tr>
<td><strong>14.</strong></td>
<td>Move the cursor down so that you leave only your model visible. Click “Apply”</td>
</tr>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td></td>
</tr>
<tr>
<td><strong>15.</strong></td>
<td>Your model is now cropped and filled (you shouldn’t have holes/open edges in the geometry. This is necessary for saving it as OBJ).</td>
</tr>
<tr>
<td><strong>Save file</strong></td>
<td><strong>16.</strong> In the toolbar in the left, go to Export Model &gt; Export 3D model.</td>
</tr>
<tr>
<td></td>
<td><strong>17.</strong> Choose format “OBJ QUADS” (Fusion360 only imports OBJ with quad geometry; tri-mesh won’t work).</td>
</tr>
<tr>
<td></td>
<td><strong>18.</strong> Keep the face count to under 2000. Otherwise the model will be too large and will affect performance.</td>
</tr>
<tr>
<td></td>
<td><strong>19.</strong> Click “Export” and give the file a name and location.</td>
</tr>
</tbody>
</table>
5.2 Model a body in Fusion 360 by referencing an OBJ mesh

<table>
<thead>
<tr>
<th>Insert Mesh</th>
<th>1. Open Fusion 360 and enter “Sculpt” mode</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>2. Go to Insert&gt;Insert mesh</td>
</tr>
<tr>
<td></td>
<td>3. Select OBJ file</td>
</tr>
<tr>
<td></td>
<td>4. Use Modify&gt;Move to reposition</td>
</tr>
</tbody>
</table>
Fusion 360 strategies for bridging between digital and physical models

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>5.</td>
<td>If you want the model to be fully editable in Fusion360, go to the Menu tree on the left side, look for the object under “bodies”, right-click on it and select “Convert” to turn it into a T-Spline.</td>
</tr>
<tr>
<td></td>
<td>![Image of Fusion 360 interface showing Menu tree and Convert option]</td>
</tr>
<tr>
<td>6.</td>
<td>Go to the tree menu (left side), find the body, right-click on it and choose “Selectable/Unselectable”</td>
</tr>
<tr>
<td></td>
<td>![Image of Fusion 360 interface showing body selection options]</td>
</tr>
<tr>
<td>7.</td>
<td>Go to Create&gt;Quadball, using the parameters shown in the image.</td>
</tr>
<tr>
<td></td>
<td>![Image of Fusion 360 interface showing Quadball creation]</td>
</tr>
</tbody>
</table>
| 8. | Use Modify>Edit Form to turn the ball into a cylinder.  
   TIP: Holding ALT key when pulling faces will create new faces. |
|   | ![Image of Fusion 360 interface showing Modify>Edit Form] |
9. Selecting the ‘center donut’ in the XXXX allows to scale down/up uniformly.

10. After exiting Edit Form, selecting edges and deleting them can help to smooth the shape.

<table>
<thead>
<tr>
<th>Create handle of object</th>
<th>11. Create the handle using similar workflow to the horizontal section.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>12.</td>
<td>Use Edit Form to scale up the top of the handle. This will help with a smoother transition.</td>
</tr>
<tr>
<td>13.</td>
<td>Delete edges if needed to make a smoother transition.</td>
</tr>
<tr>
<td>14.</td>
<td>Use Modify&gt;Bridge to connect both sections together.</td>
</tr>
</tbody>
</table>
Create a new file for printing

15. This step is very important if you want to use this T-Spline object down the road. Save the file and then save a second version using “Save As”

Create a new file for printing

16. Using the second version of the file, go to “Finish Form” to turn the file into a solid model

17. In the left-side menu tree, select the body, right click and choose “Save as STL”.

Use the STL file for 3D printing using your printer’s software.
5.3 Model a body in Fusion 360 by pulling surfaces into an OBJ mesh

1. Open the T-Spline file of the rotary tool that you saved previously.

2. Go to Insert > Insert Mesh and select the OBJ file of the refined mockup.

3. Use Modify > Move to align the Mesh object with the T-Splines one.
| Bring the mesh’s form into your model. | **4.** Make a copy of the T-Spline. You will use one to match the handle and the other one to keep the upper cylinder.  
5. In order to make a copy, go to the menu tree on the left side and expand “Bodies“.  
6. Look for the T-Splines body, right click and select “Copy“.  
7. Go to the top of the menu tree, right click the name of the file and select “Paste“.  
8. Turn off that copy for now.  
9. Select the original T-Spline object and delete the faces that are not part of the handle. For deleting faces simply select them and hit the Delete key. |
10. Go to Modify > Edit Form and adjust the Tspline handle so that it comes close to the shape of the Mesh.

   Tip: You don’t need to be exact in matching the shape; just bring them close enough so that the next step is successful.

11. Go to Modify > Pull to select a selection window with your mouse that includes all the control points in the left side of the Tspline, including the center line.
12. Set the pull type to Surface Points and hit Ok.
13. The geometry of the T-Splines with adjust to match the Mesh.

Important Notes About Pull:
-Pull only works when a T-Spline wants to be matched to a Mesh. If you have two t-spline objects, the tool won’t work.
-Each T-Spline point looks for the closest point in the mesh. That’s why it’s important to tweak the T-Spline first to come close to the mesh.
-It is very hard to obtain a symmetrical mesh when tweaking a model by hand and then capturing via Memento. This is why it’s important to have a T-Splines file with mirror symmetry AND to select points only on one side when performing the Pull, as these two steps will result in a symmetrical result.
<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>14.</td>
<td>Turn back on the copy of the Tspline and delete the handle portion</td>
</tr>
</tbody>
</table>
| 15.  | Adjust the edges of both objects so that it is easier to connect them together.  
**COMMON ADJUSTMENTS:**  
- Eliminating surface overlaps.  
- Maintaining separation consistent.  
- Keeping the same number of faces without loosing the original shape. |
| 16.  | Go to Modify > Bridge and select the open edge of the handle as Side One and the open edge of the upper section as Side two.  
17.  | Click Ok that the two edges will be joined. |
18. Go to Modify > Crease and select the loop of the area that you just connected. This will add a sharp transition to it which will make it look more interesting.

19. Use Modify > Edit Form to adjust the object as needed but make sure that you don’t depart too much for the original shape, otherwise you will lose its accuracy in relationship to the physical mockup.

20. When done, click on “Finish Form” to convert the file into a Solid and bring it to the “Model” mode.

21. Once in Model mode you can add details as needed for finalizing your design.